zorphnog

Member
  • Content count

    427
  • Joined

  • Last visited

Community Reputation

0 Neutral

About zorphnog

  • Birthday 01/24/1983

Contact Methods

  • Website URL
    http://
  1. What does the script do? Is it an .exe file or an .au3? If its an .au3 file then you will need to download AutoIt3 and compile the script. Its impossible to tell you how to use it if we can't actually see the script. So post it if you have it.
  2. It depends on what kind of installer the application uses, and how it was written. Many of the common installers will allow you to define the install location through and answer file or command line input. For more information about specific application installers, search the Application Installs forum.
  3. Post your config file.
  4. WPI does not evaluate internal function calls with cmd entries. You would need 3 separate entries that have a gcond entry, i.e.: gcond[pn]=['getOSlang().substr(0,2)!="EN"'] cmd1[pn]=['"%wpipath%\\Install\\OFFICE\\Acrobat Reader\\8\\ar812lite_US.exe"'];
  5. This could all be avoided if you just integrate the drivers into your baseline. Any reason you are not doing that?
  6. More info: http://www.msfn.org/board/index.php?s=&amp...st&p=669411
  7. This has been covered many times. Search: +diskpart +script
  8. Kel is talking about the machine you are trying to run WPI on not what you are trying to install via WPI. Was that machine built using nlite or xplite? Does that machine already have nero installed? Both of these are known to cause issues with WPI.
  9. Every application is different. Sometimes you can add it as a command line parameter; sometimes a registry entry. It just depends on the program and the type of installer being used. The good news is that most of the more common commercial applications have already been figured out for you. Do a search for your applications in the Application Installs forum.
  10. Good job Kel. I like the new themes. Simple. Clean.
  11. Ah Vista! Sorry, I somehow missed that part. I see what the problem is now, as that key no longer exists under Vista. The problem exists in the core.js file in the section that determines the %CDROM% variable (lines 87 - 91): if (cddrv=="") { cddrv = WshShell.RegRead("HKLM\\Software\\Microsoft\\Windows\\CurrentVersion\\Setup\\SourcePath") + "\\"; cddrv = cddrv.substr(0,3); } The If statement should be changed to this to accommodate Vista: if (cddrv=="" && getOSver()!="Vista") @Kel This is really not a good way to be determining the CD-Rom drive letter as the SourcePath value can be a CD-Rom drive, a network drive, a UNC path or an external drive that is no longer connected. I know you probably didn't write it, but I would suggest removing it all together.
  12. Hmm. Never seen this one before. The line numbers are hardly ever correct. As soon as you started loading .js files they get messed up. I don't know of any specific calls to the setup key within WPI, but Kel would have to confirm that. How did you build your OS? nLite? I'm thinking this is related to your baseline OS and not WPI. Why exactly are you adding the config and options files to the registry? You know you can add them via command line options right?
  13. What program are you attempting to install? You may need to add 'start /wait' to the beginning of your command or launch the install from a .cmd/.bat.
  14. Thanks much.............John VMware Server is basically a stripped down version of ESX Server. Its basically a teaser product to get companies interested in ESX server, which is all about managing VM resources, high availability, disaster recovery, etc. As Kel said, it is not for you. You need VMware workstation, and you have to host it on a x64 machine if you want x64 guests.
  15. Seems like you don't have a file association with .hta files. Try opening with mshta.exe, you probably just need to change the way WPI is launched.