morgancroft

Member
  • Content count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About morgancroft

  1. Music5_5, Dont take this post the wrong way, but why did you change the variables that were in the guide? I will show you how mine looks, and it works fine. (My apps install from the Vista DVD which sounds like what you are trying to accomplish). This is from the Specialize Pass... <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <RunSynchronous> <RunSynchronousCommand wcm:action="add"> <Order>1</Order> <Path>cmd /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\AppsRoot.txt SETX AppsRoot %i: -m"</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>2</Order> <Path>%WINDIR%\system32\sysprep\sysprep.exe /quiet /audit</Path> </RunSynchronousCommand> </RunSynchronous> </component> Here si the AuditUser pass where the apps are being installed... <settings pass="auditUser"> <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <RunSynchronous> <RunSynchronousCommand wcm:action="add"> <Order>1</Order> <Path>cmd /c start /wait %AppsRoot%\Install\Flash9\install_flash_player.msi /qn</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>2</Order> <Path>cmd /c start /wait %AppsRoot%\Install\Reader8\AdbeRdr811_en_US.exe /sAll</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>3</Order> <Path>cmd /c %AppsRoot%\Install\Office2007\setup.exe</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>4</Order> <Path>%WINDIR%\system32\sysprep\sysprep.exe /quiet /oobe /reboot</Path> </RunSynchronousCommand> </RunSynchronous> </component> </settings> And of course, make sure AppsRoot.txt exists in the root of the DVD... Hopefully this will help you...
  2. Hello, I have tried to search for the answer, but have been unable to find anythign after sifting through pages of search results... My unattended install works great except for one thing.. I have it set to enter the product key, but on first log on, it is prompting me to enter the product key again... Here is my autounattend.xml file... Let me know if you need more information. <?xml version="1.0" encoding="utf-8"?> <unattend xmlns="urn:schemas-microsoft-com:unattend"> <settings pass="windowsPE"> <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <SetupUILanguage> <UILanguage>en-US</UILanguage> </SetupUILanguage> <InputLocale>0409:00000409</InputLocale> <SystemLocale>en-US</SystemLocale> <UILanguage>en-US</UILanguage> <UserLocale>en-US</UserLocale> </component> <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <UserData> <ProductKey> <WillShowUI>OnError</WillShowUI> <Key>PRODUCT KEY IS HERE</Key> </ProductKey> <AcceptEula>true</AcceptEula> <FullName>Morgan Croft</FullName> <Organization>Morgan Croft</Organization> </UserData> <Display> <ColorDepth>32</ColorDepth> <HorizontalResolution>1920</HorizontalResolution> <VerticalResolution>1200</VerticalResolution> </Display> <ImageInstall> <OSImage> <InstallFrom> <MetaData wcm:action="add"> <Key>/IMAGE/NAME</Key> <Value>Windows Vista ULTIMATE</Value> </MetaData> </InstallFrom> <InstallToAvailablePartition>false</InstallToAvailablePartition> <WillShowUI>OnError</WillShowUI> <InstallTo> <DiskID>0</DiskID> <PartitionID>1</PartitionID> </InstallTo> </OSImage> </ImageInstall> <DiskConfiguration> <Disk wcm:action="add"> <CreatePartitions> <CreatePartition wcm:action="add"> <Order>1</Order> <Extend>true</Extend> <Type>Primary</Type> </CreatePartition> </CreatePartitions> <ModifyPartitions> <ModifyPartition wcm:action="add"> <Active>true</Active> <Extend>false</Extend> <Format>NTFS</Format> <Letter>C</Letter> <Order>1</Order> <PartitionID>1</PartitionID> </ModifyPartition> </ModifyPartitions> <DiskID>0</DiskID> <WillWipeDisk>true</WillWipeDisk> </Disk> <WillShowUI>OnError</WillShowUI> </DiskConfiguration> </component> </settings> <settings pass="specialize"> <component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <SkipAutoActivation>false</SkipAutoActivation> </component> <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <RunSynchronous> <RunSynchronousCommand wcm:action="add"> <Order>1</Order> <Path>cmd /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\AppsRoot.txt SETX AppsRoot %i: -m"</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>2</Order> <Path>%WINDIR%\system32\sysprep\sysprep.exe /quiet /audit</Path> </RunSynchronousCommand> </RunSynchronous> </component> <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <ComputerName>MorganLaptop</ComputerName> <RegisteredOrganization>Morgan Croft</RegisteredOrganization> <RegisteredOwner>Morgan Croft</RegisteredOwner> <TimeZone>Pacific Standard Time</TimeZone> </component> </settings> <settings pass="oobeSystem"> <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <AutoLogon> <Enabled>true</Enabled> <LogonCount>2</LogonCount> <Username>Administrator</Username> </AutoLogon> <Display> <ColorDepth>32</ColorDepth> <HorizontalResolution>1920</HorizontalResolution> <VerticalResolution>1200</VerticalResolution> </Display> <OOBE> <HideEULAPage>true</HideEULAPage> <NetworkLocation>Home</NetworkLocation> <ProtectYourPC>1</ProtectYourPC> <SkipUserOOBE>true</SkipUserOOBE> </OOBE> <TimeZone>Pacific Standard Time</TimeZone> <UserAccounts> <LocalAccounts> <LocalAccount wcm:action="add"> <Password> <Value>ZABkADIAMwBuADQAMwBtAGkAdABjAGgAUABhAHMAcwB3AG8AcgBkAA==</Value> <PlainText>false</PlainText> </Password> <Description>Morgan</Description> <DisplayName>Morgan</DisplayName> <Group>Administrators</Group> <Name>Morgan</Name> </LocalAccount> <LocalAccount wcm:action="add"> <Password> <Value>NwA1ADAANAA1ADQAMABQAGEAcwBzAHcAbwByAGQA</Value> <PlainText>false</PlainText> </Password> <Description>Tamara</Description> <DisplayName>Tamara</DisplayName> <Group>Administrators</Group> <Name>Tamara</Name> </LocalAccount> </LocalAccounts> </UserAccounts> </component> <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <InputLocale>0409:00000409</InputLocale> <SystemLocale>en-US</SystemLocale> <UILanguage>en-US</UILanguage> <UserLocale>en-US</UserLocale> </component> </settings> <settings pass="auditSystem"> <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <AutoLogon> <Enabled>true</Enabled> <LogonCount>5</LogonCount> <Username>Administrator</Username> </AutoLogon> </component> </settings> <settings pass="auditUser"> <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <RunSynchronous> <RunSynchronousCommand wcm:action="add"> <Order>1</Order> <Path>cmd /c start /wait %AppsRoot%\Install\Flash9\install_flash_player.msi /qn</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>2</Order> <Path>cmd /c start /wait %AppsRoot%\Install\Reader8\AdbeRdr811_en_US.exe /sAll</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>3</Order> <Path>cmd /c %AppsRoot%\Install\Office2007\setup.exe</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>4</Order> <Path>cmd /c %AppsRoot%\Install\Winrar\winrar.exe /s</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>5</Order> <Path>cmd /c %AppsRoot%\Install\Quickset\quickset.msi /qn</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>6</Order> <Path>cmd /c %AppsRoot%\Install\xvid\xvid.exe /VERYSILENT</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>7</Order> <Path>cmd /c %AppsRoot%\Install\TagRename\tagrename.exe /VERYSILENT</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>8</Order> <Path>cmd /c %AppsRoot%\Install\IDUMP\iDump_Setup.exe /S</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>9</Order> <Path>cmd /c %AppsRoot%\Install\DVDDECRYPTER\SetupDVDDecrypter.exe /S</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>10</Order> <Path>cmd /c %AppsRoot%\Install\DVDPRINT\dvdsetup.exe /S</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>11</Order> <Path>cmd /c D:\Install\Ricoh\dpinst.exe /sw /lm /f</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>12</Order> <Path>cmd /c D:\Install\Acronis\AcronisTrueImage.msi PIDKEY=K9E9V-RPHF3-RRKZG-EF6WC-J9NBE /qn /norestart</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>13</Order> <Path>cmd /c cscript //nologo %AppsRoot%\Install\PASSWORD\nopwdexp.vbs /domain:%ComputerName% /user:Morgan</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>14</Order> <Path>cmd /c cscript //nologo %AppsRoot%\Install\PASSWORD\nopwdexp.vbs /domain:%ComputerName% /user:Tamara</Path> </RunSynchronousCommand> <RunSynchronousCommand wcm:action="add"> <Order>15</Order> <Path>%WINDIR%\system32\sysprep\sysprep.exe /quiet /oobe /reboot</Path> </RunSynchronousCommand> </RunSynchronous> </component> </settings> <cpi:offlineImage cpi:source="wim:c:/vistawork/dvd/sources/install.wim#Windows Vista ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" /> </unattend>
  3. Does anything in this guide change now that SP1 has been released for Vista... I know that there is the new version of WAIK. I have downloaded the Vista DVD with SP1 integrated from Microsoft, so is it just the same process for recreating the unattended install? Thanks in advance.