• Content count

  • Joined

  • Last visited

Community Reputation

0 Neutral

About Twisten

  1. will do, keep in mind that if you do find out there's a new need for none unc path then runonceex.bat in wpi tools will need to be updated.
  2. not sure if this is a bug yet, i have wpi launched from svcpack and runonceex at each instance with its own seperate config and options files (the usual setup when using ryan's integator to include wpi once for each option, config and options file set in registry) still launched using config.js which was very much unexpected. i'm using wpi with windows xp sp3. attempted workaround by giving command line options: (filenames respective for runonceex and svcpack) failed: WPI.hta options=./WPIScripts/runonceex_options.js config=./WPIScripts/runonceex.js failed: WPI.hta options="./WPIScripts/runonceex_options.js" config="./WPIScripts/runonceex.js" failed: WPI.hta options="runonceex_options.js" config="runonceex.js" worked: WPI.hta options=runonceex_options.js config=runonceex.js
  3. been playing with it a bit, when i try compiled the installer package i get an error because InitializeWizard is defined both in clihelp iss and the uniextract iss , could you tell me the proper way to handle this error ? btw, i haven't searched hard to see if it was mentioned, but thought it worth mentioning just in case innounp.exe in 1.6 beta isn't the latest version (i.e. it has problems extracting uniextract16beta.exe which 0.2 final handles fine)
  4. hi rick *cough descritly* -> in my case install finished fine, so maybe its a problem with the particular installers onenettle? i still got the 'OSLanguage' error, which is the reason i've tried to run from commandlines.txt before that it was launched from svcpack where i've first ran into that error.
  5. could be a bug, i'm runing wpi from svcpack using ryanvm's integrator wpi plugin, when wpi launches it complains that about 'OSLanguage' being null or not an object. it seems to trace to Enum = sLang.OSLanguage; in core.js if i recall correctly i also saw a different error message once for the same problem with less information but i still traced it to Enum = sLang.OSLanguage; in core.js could be it happens because regional options settings are skipped (i'm providing them in winnt.sif), still it should pick a default not throw an error. this happens when installing from a cd of windows xp sp3 vl english source on vmware. lots of hugs thank you for all the great work
  6. kel, did you get a chance to look at it yet? its not urgent since uids not starting with numbers seem to suppress the error, but it would be nice to know if its going to be fixed or perhapse there should be a note about it in the manual ?
  7. kel? if i'm getting this right it's meant to launch wpi at first login, does it do anything else i've missed ?
  8. thanks mate, that'd be great , as i'm sure you'd notice there's no manual exludes/includes only dependencies when DisableOnDepsNotMet=true i get this error. i reckoned by trial and error that having a UID starting with numbers will definetly cause it to happen, to me it looks like an error parsing the UID. i should mention that those uid's were first generated by wpibee which simply used the file name a a basis to program name, description and UID and were imported during integration with ryanvm's integrator.
  9. the comments ? it made no impact on whether or not the error showed, i've taken them out to make it easier on myself combing through it trying to find some sort of error. edit: on a side note, if it makes a difference the comments are actualy present in the file i use, i've only striped them from this copy
  10. well, *ponders* the files in my wpiscript dir are exact matches to the ones bundled with wpi 6.5.1, i'll attach my config file could be something there that i'm too inexperianced to catch ? thats the only file changed/added to the original atm. edit: it seems wpi takes exception to usage of #_ (where # is a number) in the UID, prog, or possibly both when DisableOnDepsNotMet=true , seems some sort of parsing bug. i realy realy hope you can help narrow this down mritter config.js
  11. edit: moved to bug tracker to make things neater.
  12. hi there hug to all the dev's. i'm a new to using wpi, please be kind. first ran into this problem after adding dependencies, when wpi launches i get an error message about it expecting a ';' from function parseAreChecked in check.js on the line it mentioned there's the code: var elem = eval("document.all." +deps[j]); you end with only the first program checked then after that the error pops up when you try to check/uncheck anything. couldn't see anything wrong with the code, the function is parentsAreChecked but parseAreChecked is just a typo in the variable used to report what function caused an error and has been there a looong time. after some code diving forum searching a few reruns of reading the manual and looking up some javascript refrences i'm realy stumped, the only positive outcome was finding out setting DisableOnDepsNotMet to false bypassed this error.
  13. ooo boy, been a while since the last post. still for those looking for the answer to that question: put on a line of its own ascii code 0x1A which is the SUB (Substitute) control character. Edit: About being able to use /s with winrar sfx, actualy you can't its passed along to the uninstall.exe file that said, simply change Setup=uninstall.exe /setup to Setup=uninstall.exe /setup /s voila no more popup for the configuration options and if you add Silent=1 you've got a totaly silent installer. . use winrar to export your settings.reg and add Setup=regedit.exe /s settings.reg and there you go a registered (assuming you archived rarreg.key) configured installation of winrar.
  14. iSiloX 4.37 Notes: Save as a .au3 file in the same folder as the original installer and compile to have a working passive installer. Read the script at least once to see if you want to change the customizations options, this script changes the default options for components, install location and shortcut creation. #cs ---------------------------------------------------------------------------- AutoIt Version: Author: JC Script Function: Automate iSiloX 4.3.7 Install. #ce ---------------------------------------------------------------------------- #NoTrayIcon Opt("TrayIconHide", 1) Dim $aOptTxt[3] = ['&Create a shortcut to iSiloX on the desktop','Install iSiloX Clipper for Internet &Explorer 5.0 or later','Make iSiloX available for &all users on this computer'] Dim $aOptCID[3] = [1006, 1013, 1012] Dim $aOpt[3] = [False,False,True] Dim $aOrgOpt[3] = [True,True,False] Dim $aOptC[3] For $i = 0 To 2 If $aOpt[$i] <> $aOrgOpt[$i] Then $aOptC[$i] = True Else $aOptC[$i] = False EndIf Next $ParentPrgGrp = 'Palm' $InstallDir = @ProgramFilesDir & '\Utilities\Palm\iSiloX' FileInstall("iSiloX437Setup.exe", @TempDir & "\") Run(@TempDir & "\" & "iSiloX437Setup.exe") $WinTitle = 'iSiloX Setup: Welcome' $WinText = 'Welcome to iSiloX Setup.' WinWait($WinTitle, $WinText) WinActivate($WinTitle, $WinText) ControlClick($WinTitle, $WinText, 1) $WinTitle = 'iSiloX Setup: Software License Agreement' $WinText = 'Please read the following license agrement. Scroll to see the rest of the agreement.' WinWait($WinTitle, $WinText) WinActivate($WinTitle, $WinText) ControlClick($WinTitle, $WinText, 1) $WinTitle = 'iSiloX Setup: Options' $WinText = 'Destination Folder' WinWaitActive($WinTitle, $WinText) WinActivate($WinTitle, $WinText) ControlSetText($WinTitle, $WinText, 1004, $InstallDir) For $i = 0 To 2 If $aOptC[$i] == True Then ControlClick($WinTitle,$WinText,$aOptCID[$i]) EndIf Next ControlClick($WinTitle, $WinText, 1) $WinTitle = 'iSiloX Setup: Complete' $WinText = 'Congratulations! Setup successfully installed iSiloX onto your computer.' WinWait($WinTitle, $WinText) WinActivate($WinTitle, $WinText) ControlClick($WinTitle, $WinText, 1) ProcessWaitClose("iSiloX437Setup.exe", 180) If FileExists (@ProgramsCommonDir & "\" & "\iSiloX") Then If Not FileExists (@ProgramsCommonDir & "\" & $ParentPrgGrp) Then DirCreate (@ProgramsCommonDir & "\" & $ParentPrgGrp) EndIf DirMove (@ProgramsCommonDir & "\iSiloX", @ProgramsCommonDir & "\" & $ParentPrgGrp, 1) EndIf If FileExists (@ProgramsDir & "\" & "\iSiloX") Then If Not FileExists (@ProgramsDir & "\" & $ParentPrgGrp) Then DirCreate (@ProgramsDir & "\" & $ParentPrgGrp) EndIf DirMove (@ProgramsDir & "\iSiloX", @ProgramsDir & "\" & $ParentPrgGrp, 1) EndIf If FileExists (@TempDir & "\" & "iSiloX437Setup.exe") Then FileDelete (@TempDir & "\" & "iSiloX437Setup.exe") Edit: attached script file. iSiloX437Setup.AU.au3