Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



r0sWell

Member
  • Content count

    189
  • Donations

    $0.00 
  • Joined

  • Last visited

Community Reputation

0 Neutral

About r0sWell

Profile Information

  • OS
    Windows 7 x64
  1. @ bensam56 : do you plan to add a "winsetup.dll" patch option in your next version, adding the possibility to 'remove' the 100 Mb Win7 partition ? (patching it should transfert the 100 Mb partition files into a recovery folder instead) more info Here. if it is planned, when do you plan to release your next version ? thx
  2. yes, it worked without adding any driver (with the updates integrated). i'll continue to test it
  3. hello there B) i tried to make an unattended DVD with the 2.4.0 version of RT 7 Lite, the operation ran fine, but the build created won't install at all (using Virtualbox - last version). if needed, please find the lastsession.inf attached below. for the details, i integrated 352 hotfixes (from Windows Hotfix repository) and 453 drivers (from Driverpacks.net), and after 5 hours of processing (yes, 5 hours :o ), RT 7 Lite operation terminated successfully. Here is a screenshot of the Virtualbox error : Do you have more information about my error ? What could cause this fatal error ? What shouldn't i remove from the source (looking at my lastsession.inf) ? Thx a lot ! Lastsession.inf
  4. Mr Jinje DISM Tool™

    Thanks a lot for your tool ! I wanted to test it yesterday to rebuild my Win 7 ISO (for a new HDD). It worked perfectly, no error during the process (tested on Windows 7 x64 Ultimate) : Drivers & Hotfixes integrated (verified) Maybe an idea to complete the DISM Tool a little more : What about adding a 'Help' button to describe all the functionalities ?
  5. i'm 99% sure that a lot of people are waiting for a vlite replacement if with your tool it's possible to easily slim down the size of the Win7 source (or parts of it), i'm very interested in too B)
  6. i didn't want to "hide" information, i wanted to simplify my explanations in English using basic paths & needs. and because paths was not the big deal i suppose. below is the final script i think i'll use. my goal is to change the Windows 7 "User Account Picture" randomly, picking one from the folder and set it to user.bmp which is the user account picture file, so it can be used by other people too . (btw i was completely wrong earlier, i said i'll need the %username% variable but in fact it's %programdata% - to make it independant from the drive letter -, shame on me i didn't check) thx again for your help, very appreciated !
  7. Was this line required?There's no way of us telling whether it correlates to the C: provided in the original question. it's required because in the real script, i must point to the %username% directory (which vary), so i used %systemdrive% to test variables paths. @geezery : thx for your script, it's working i'll try to adapt it to my needs Edit : Now fully working with variable paths :-) thx again !
  8. i'm pretty sure that a VBS script can do that, but i'm not sure concerning a Batch (?). for the folders, they're examples here (but i'm sure they're OK in the real most recent script). if you have any solutions, i thank you in advance thanks
  9. Hi guys, 1st, my apologies if my English is not perfect But i have troubles to create a working VBS script. To be honest i'm a 99% noob concerning VBS, and i'd like to make a script that will do 2 things : - in a folder C:\test\Default Pictures\ which contains many *.BMP files, i need to randomly select one of these. - then, copy this file as USER.BMP, in the Parent folder : C:\test\ I googled many things & did some tests, but i'm not good enough to make it work. my most recent script is: THX in advance for your help. i'm blocked for now
  10. Everything seems to be OK now (concerning the account problem). (Here's my Autounattend.xml) PS: for now, I only use the Administrator account, plus a limited user account. I'll do more tests on that point later, by adding another Admin account. PS2: I'm not sure, but I think the Administrator account is not automaticaly disabled (nor hidden) after the Windows install (?) Now I'm trying to import REG modifications for "CURRENT_USER" but it's not working atm (i tried during the specialize pass which replace the old cmdlines.txt). Thanks for your answers :thumbup Autounattend.xml
  11. update : By lowering the Autologon number, and add it to the OOBE step too, it's now OK for the accounts to appear, but there's more : any idea ? Autounattend.xml
  12. I only used the Windows 7 WAIK I'll try that & I'll post the results
  13. Hi, I have problems in my tests to build a 'Windows 7 x64 unattended' DVD. Please note I never used Vista (I'm still using XP SP3) and it my 1st tries with WAIK & Autounattend.xml method. I would love some help if you know how to solve this : (thx in advance for reading ) PS: I've only done the tests in a Virtual machine using SUN Virtualbox 3.0.4 After the Windows installation (which is OK), and the post-op APPS installation (OK too), the computer reboots and when I arrive to the logon screen, it tells me that the account is disabled. It concerns the Administrator account here. I'm not sure, but I think it's because in my Autounattend.xml in the last lines I want to re-disable the Administrator account to use only the *new* Test account created in it. PS: after installation, at every reboot it tries to login using the Administrator account (still disabled). And at last after 2-3 reboots, it shows the Test + User account pictures. Here is my complete Autounattend.xml : <?xml version="1.0" encoding="utf-8" ?> - <unattend xmlns="urn:schemas-microsoft-com:unattend"> <servicing /> - <settings pass="specialize"> - <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <BlockPopups>yes</BlockPopups> <FavoritesDelete>true</FavoritesDelete> <DisableDevTools>true</DisableDevTools> <DisableDataExecutionPrevention>true</DisableDataExecutionPrevention> <ShowInformationBar>true</ShowInformationBar> <Home_Page>http://www.google.com</Home_Page> <PlaySound>false</PlaySound> <Help_Page>http://www.google.com</Help_Page> </component> - <component name="Microsoft-Windows-RemoteAssistance-Exe" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <fAllowFullControl>false</fAllowFullControl> <fAllowToGetHelp>false</fAllowToGetHelp> </component> - <component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <SkipAutoActivation>true</SkipAutoActivation> </component> - <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> - <AutoLogon> - <Password> <Value>test</Value> <PlainText>false</PlainText> </Password> <Enabled>true</Enabled> <LogonCount>5</LogonCount> <Username>Administrator</Username> </AutoLogon> - <Display> <ColorDepth>32</ColorDepth> <HorizontalResolution>1280</HorizontalResolution> <VerticalResolution>1024</VerticalResolution> </Display> - <Themes> <DefaultThemesOff>false</DefaultThemesOff> </Themes> - <WindowsFeatures> <ShowInternetExplorer>true</ShowInternetExplorer> <ShowMediaCenter>true</ShowMediaCenter> <ShowWindowsMail>true</ShowWindowsMail> <ShowWindowsMediaPlayer>true</ShowWindowsMediaPlayer> </WindowsFeatures> <TimeZone>Romance Standard Time</TimeZone> <BluetoothTaskbarIconEnabled>false</BluetoothTaskbarIconEnabled> <CopyProfile>true</CopyProfile> <ComputerName>w7x64</ComputerName> <DoNotCleanTaskBar>true</DoNotCleanTaskBar> <StartPanelOff>false</StartPanelOff> <RegisteredOrganization>testNetwork</RegisteredOrganization> <RegisteredOwner>Test</RegisteredOwner> <ShowWindowsLive>true</ShowWindowsLive> </component> - <component name="Microsoft-Windows-SQMApi" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <CEIPEnabled>0</CEIPEnabled> </component> - <component name="Microsoft-Windows-SystemRestore-Main" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <DisableSR>1</DisableSR> </component> - <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> - <Identification> <JoinWorkgroup>TESTNETWORK</JoinWorkgroup> </Identification> </component> - <component name="Microsoft-Windows-Deployment" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> - <RunSynchronous> - <RunSynchronousCommand wcm:action="add"> <Order>1</Order> <Path>net user Administrator /active:yes</Path> </RunSynchronousCommand> - <RunSynchronousCommand wcm:action="add"> <Order>2</Order> <Path>net user Test /active:yes</Path> </RunSynchronousCommand> - <RunSynchronousCommand wcm:action="add"> <Order>3</Order> <Path>net user User /active:yes</Path> </RunSynchronousCommand> - <RunSynchronousCommand wcm:action="add"> <Order>4</Order> <Path>cmd /c "FOR %i IN (C D E F G H I J K L M N O P Q R S T U V W X Y Z) DO IF EXIST %i:\WIN7DVD SETX SOFT %i:\Softwares -m"</Path> </RunSynchronousCommand> </RunSynchronous> </component> </settings> - <settings pass="oobeSystem"> - <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <InputLocale>040c:0000040c</InputLocale> <UILanguage>en-US</UILanguage> <UserLocale>fr-FR</UserLocale> <UILanguageFallback>en-US</UILanguageFallback> <SystemLocale>fr-FR</SystemLocale> </component> - <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> - <OEMInformation> <Manufacturer>TestUnattended</Manufacturer> <Model>top-of-the-line model</Model> <SupportURL /> <Logo>%SystemRoot%\OEMlogo.bmp</Logo> </OEMInformation> - <OOBE> <HideEULAPage>true</HideEULAPage> <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE> <NetworkLocation>Home</NetworkLocation> <ProtectYourPC>3</ProtectYourPC> <SkipMachineOOBE>true</SkipMachineOOBE> <SkipUserOOBE>true</SkipUserOOBE> </OOBE> - <UserAccounts> - <LocalAccounts> - <LocalAccount wcm:action="add"> <Name>User</Name> <Description>limited use</Description> <Group>Users</Group> <DisplayName>User</DisplayName> - <Password> <Value>test</Value> <PlainText>false</PlainText> </Password> </LocalAccount> - <LocalAccount wcm:action="add"> - <Password> <Value>test</Value> <PlainText>false</PlainText> </Password> <Description>everyday use</Description> <DisplayName>Test</DisplayName> <Group>Administrators</Group> <Name>Test</Name> </LocalAccount> </LocalAccounts> - <AdministratorPassword> <Value>test</Value> <PlainText>false</PlainText> </AdministratorPassword> </UserAccounts> - <VisualEffects> <FontSmoothing>Standard</FontSmoothing> </VisualEffects> - <Display> <ColorDepth>32</ColorDepth> <HorizontalResolution>1280</HorizontalResolution> <VerticalResolution>1024</VerticalResolution> </Display> - <FirstLogonCommands> - <SynchronousCommand wcm:action="add"> <CommandLine>%SOFT%\GUIRunOnce.cmd</CommandLine> <Description>custom settings</Description> <Order>10</Order> </SynchronousCommand> - <SynchronousCommand wcm:action="add"> <Order>100</Order> <CommandLine>net user Administrator /active:no</CommandLine> </SynchronousCommand> </FirstLogonCommands> <RegisteredOrganization>TestNetwork</RegisteredOrganization> <RegisteredOwner>Test</RegisteredOwner> <TimeZone>Romance Standard Time</TimeZone> <StartPanelOff>false</StartPanelOff> <DoNotCleanTaskBar>true</DoNotCleanTaskBar> <ShowWindowsLive>true</ShowWindowsLive> </component> </settings> - <settings pass="generalize"> - <component name="Microsoft-Windows-SharedAccess" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <EnableICS>true</EnableICS> </component> - <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls> <DoNotCleanUpNonPresentDevices>true</DoNotCleanUpNonPresentDevices> </component> </settings> - <settings pass="windowsPE"> - <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> - <SetupUILanguage> <UILanguage>en-US</UILanguage> </SetupUILanguage> <InputLocale>040c:0000040c</InputLocale> <SystemLocale>fr-FR</SystemLocale> <UserLocale>fr-FR</UserLocale> <UILanguage>en-US</UILanguage> </component> - <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> - <ComplianceCheck> <DisplayReport>OnError</DisplayReport> </ComplianceCheck> - <DiskConfiguration> <WillShowUI>Always</WillShowUI> </DiskConfiguration> - <Display> <ColorDepth>32</ColorDepth> <HorizontalResolution>1024</HorizontalResolution> <VerticalResolution>768</VerticalResolution> </Display> - <ImageInstall> - <OSImage> - <InstallFrom> - <MetaData wcm:action="add"> <Value>Windows 7 ULTIMATE</Value> <Key>/IMAGE/NAME</Key> </MetaData> </InstallFrom> <InstallToAvailablePartition>false</InstallToAvailablePartition> <WillShowUI>OnError</WillShowUI> </OSImage> </ImageInstall> - <UserData> - <ProductKey> <Key>*****-*****-*****-*****-*****</Key> <WillShowUI>OnError</WillShowUI> </ProductKey> <AcceptEula>true</AcceptEula> <FullName>Test</FullName> <Organization>TestNetwork</Organization> </UserData> <LogPath>%SystemRoot%\temp</LogPath> <UseConfigurationSet>true</UseConfigurationSet> <EnableFirewall>true</EnableFirewall> <EnableNetwork>true</EnableNetwork> </component> </settings> <cpi:offlineImage cpi:source="wim:e:/unattended/win7/x64/win7_x64/sources/install.wim#Windows 7 ULTIMATE" xmlns:cpi="urn:schemas-microsoft-com:cpi" /> </unattend> I'd like to have your advices for my problem. As you can see, using the strange 'Other User' box, i can type in what I want. If I type in the other 'Test' account I created it logs in. but it's not what I want. Plus, because it's another Admin type account it's OK, but what if I only created a limited user ? then I would be completely blocked (no access to the admins rights anymore : no Administrator account still enabled and no right to enable it with a limited user) What I'm trying to do is : - install Windows 7 x64 100% unattended (except for the partition management) - post-install Applications 100% unattended (using a simple batch for easy access & modification) - autologon with Administrator during the installation, then hide this account and disable the autologon Plus the 2 "bugs" (?) I have : - auto-enable Gadgets (not working in Autounattend.xml) - auto-select "Home" homegroup (not working as a popup is displayed for 'Home / Work / Public' after the 1st logon) Don't hesitate to ask me if you need more info, or if you see things I should do for the Gadgets & homegroup. Thx a lot !
  14. Firefox 3.0.6 AdvancedINF Install

    thx a lot for your .inf method
  15. Firefox 3.0 Released

    @Acheron: ow, i didn't see your post thanks a lot for your .inf file, i'll make a test tomorrow.
×