Madhits45

Member
  • Content count

    361
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Madhits45

  • Rank
    MSFN Indulger

Contact Methods

  • Website URL
    http://
  1. Hi. Me again. I created the file Packages.txt, and I found that it contains packages with 6.1.7601.17514 (SP1 packages) and also 6.1.7600.16385 (non SP1 packages). I presume this is because I upgraded my non SP1 Windows 7 image with SP1 via RT7Lite. Some of the non-SP1 packages have the following state: State : Install Pending and others have the state: State : Uninstall Pending Should I remove both or just ignore the non SP1 packages? Also, do I need to specify both en-us packages and those that do not contain en-us into my dism7x64.bat file for removal, or will dism automatically remove both? Thx. I'm also wondering about the install pending and uninstall pending. Apparently from reading over at technet these are delt with at install time. But does that mean we have extra crap in our image waiting to be deleted? That is what I am not sure about. Dism cleanup does not fix this. That only works for deleting sp1 files from the winsxs directory. Kinda frustrating that those are shown that way. As for the packages with EN-us and ones without. It appears if you remove the EN-us one the regular one will also be removed. If you put both in your remove bat DISM will say the second none language one is not a valid package. So it appears they are tied together. Why they show as different packages is beyond me. Why does MS have a lang part for every packages and not 1 big lang pack. That would make sense. Hope that helps.
  2. I'm looking for this also. Ive got packages.xls but it cant be right. Some of the info is clearly wrong.
  3. I have been trying to understand this also. I have removed from my x86 win7 sp1 source with rt7lite and vlite and gotten the image down quite small but not where i wanted it. There is still more that can be removed and youl find directories within the windows folder of your mounted wim that are massive (winsxs & assembly are 2). There are guides on here of manually deleting files from a mounted wim but the problems are that you can not delete the files without file permission errors because they are protected. Now install_wim_tweak allows you to remove those files without the permission errors but you still have another problem. The problem youl face is durring install. The files you remove are requested by the installer and if there missing you get an error and the install will fail. I am still trying to understand if there is a central install listing of all files like there was in XP or if its all controlled by the hives in the install.wim. If its controlled by the hives how come install_wim_tweak does not work when you remove files and commit the changes? I recently removed a bunch of files from assembly after loading install_wim_tweak and my install failed. What did I do wrong?
  4. IT was a brand new wim saved to a different directory. I cant find whereisit. Can you give me a link to it? I will try to do the rtlite part againa and see if it works ok with vlite. Thanks
  5. aviv00.. I have been trying to get vlite to run with my wim x86 win7 sp1 which has been rebuilt after running rt 7 lite (method 5). I used the apply capture trick with gimagex. This still leads to a problem when using your sp1_2 ini file. Vlite crashes with no error just goes away. I have tried this vlite step on winxp, win7 sp0 and a win7 x64 and its always the same except on the x64 where it says vlite has stopped working and then it asks would you like to close it. I even went back to tried vlite 1.1.6 and its the same. I also tried to remove remove the winsxs from the components removal and no luck either. Is there any way I can do this without vlite? Or do you know why vlite is not letting me progress? It could be because I have a number of updates applied to my win7 sp1. They are security updates but thats all I can think of. Maybe vlite cant handle those. Any thoughts or suggestions you can offer me? Also have you heard of w7t.exe its a nice gui and allows you to remove winsxs but not anymore then rt 7 lite as far as componts. Thanks
  6. I keep having a problem with vlite with windows 7 sp1 and running from host Win7 Sp0. It instantly crashes in the removing componets part. I am still testing to see if some combanation will make this crash stop. I have tried the apply capture and it still crashes. Hope to find an answer but if anyone has some suggestions to that I would be glad to hear.
  7. Ok Ive given up on trying to remove the foundation language. I think its an MSU pack and that has to be why they are not allowed to be removed. Ok so i've started from scratch Win7 SP1 x86 and I am back to using this script to remove some stuff from SP1 to shrink it down. Now I have a few question. First about this command. Dism /Image:D:\mount /Get-Packages >featurelist.txt It spits out a list of all the packages in the image. Now is it always 100% accurate? The reason I ask is the image I have does not include a lot of packages that are in the removal script. I am wondering why this is? Any idea? Are they hidden or actually not there? I might try to run the script on these packages but If this cmd is correctly giving me the packages in the image then its going to error. If anyone knows Id like to find out. Is anyone using RT 7 lite that is also using these scripts? If no why not? Why are you guys still using vlite? Thanks
  8. Ok I got it. Turns out I had the wrong download for the vista version. I had vista_6000.16386.061101-2205-LRMAIK_EN.img which is not WAIK or not the right version not sure. Ive got the correct link now almost done downloading. I hope Ill be able to remove these packages but Im not holding my breath.
  9. How do you install AIK for vista? Its impossible, install is not allowed.
  10. I might have told you wrong. I believe this version of Win 7 Sp1 might be orginal source spanish. I'm not sure. I cant remove the cab as it was never installed that way. However Ive read over at technet that you can remove any langage reguardless if its installed via cab or not. So that is what I am trying to do here. The problem I beleive is because I cant use vista WAIK. I must use WAIK 3.0 and this might be why I cant remove these packages. I am still trying to search for someone who is working on windows 7 (host pc) and has to use WAIK 3.0 to do all of this or if they found a way to install waik for vista on win7. SO far I have not found anyone with a work around or a trick I can use. I keep getting the 800736b3 error the specified image is no longer servicable even with install_wim_tweak.exe working on the mounted wim. I even tried takeown and give admin rights to all files. Same result I can not remove these packages without that error. dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-Client-Features-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-WindowsFoundation-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-Client-Refresh-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-Client-Wired-Network-Drivers-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-GroupPolicy-ClientTools-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-MediaPlayer-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-PhotoPremiumPackage~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 There has to be some sort of trick besides starting from scratch with a new wim and besides going to a different host say winxp to do the work from there. Hope someone can help me. Thanks
  11. Yes my version is win7 ultimate x86 sp1 ES.. I want to remove spanish and put back English. IT was orginally an english version and it was removed and replaced with spanish. So I am just reversing it. Never imagined it would be this hard to do that. I have the general idea here but I cant install vista WAIK as it is not allowed in Win7 (what Im running now win7 ultimate none SP1). Is there a way around that? Once I get that done I will try to remove these packages. These are not packages from the remove bat that your referencing. They are simply language packages, so should be easy to remove.
  12. AIK 1.1 for Vista installed! 1) First mount your image...You need a clean complete copy source, because your image is no more serviciable! Of course it's needed to make some changes inside the batch file. Here is an example for Windows 7 Ultimate es-ES (I've made some changes inside the batch file to give you some help. 5 images are insIde the install.wim image with this example) but adapt to your needs for the Packages you want remove: You can write the Package you want remove inside: %rempacks% *Be carefull with the path inside the batch file! removal.bat Here is the result for mine fr-FR version: I know it's not really easy...But works for me like this! I hope that can help you! *ONLY using the removal.bat (7elite32.rar) and batch7x86sp1.bat (but I need to change many keys manually! )...... I can remove successfully what I want IF I use the two differents batch ! I love MSFN.. Thanks for your help. Ok i've come a ways since i posted this. Now I am just having trouble with a few packages that I want to remove. These are the 8 listed in my last post. The rest actually removed however there the minor updates to the big foundation language pack. I thought my no longer serviceable 800f0830 error had to do with the fact that I did not have windows 7 WAIK 3.0 installed (which I read I did not need since it includes a bunch of extras that are useless if u are just editing wims). I was wrong as those 8 packages still dont remove even with WAIK 3.0 installed. So now I am thinking I need to have the WAIK 2.0 for vista to remove them but that makes no sense to me because these are Win7 SP1 packages (potentially). It is a win7 SP1 x86 image I am trying to remove the spanish language from. Now you have given me a script which works off the same concept as 7elite32 removals bats.. Cool.. Ok now I just need to understand something to get that to work. I need: 1 Windows vista WAIK 2.0 correct 2. install_wim_tweak.exe <-- I cant find a good link to this file and also need to understand how it works. I thought it was outdated and there was something better now. This is not correct? Once I have those all I need to do is uninstall WAIK 3.0 Install Waik 2.0 start with clean install.wim (I Knew that as DISM always corrupts it if it cant remove something) use install_wim_tweak on the mounted wim correct? Not sure how to do that. Run the remove bat unmount and commit with gimagex All done. Hope you can clairify this for me.. I'm so close I think.. THANKS
  13. Hi all, been out of the scene a while, trying to understand win7 imaging & package removal. I have a list of packages I want to remove for a language in windows 7 ultimate x86, These are simular to the list of packages in Dead0 second script. The list is all spanish language updates. When I input it into DISM I get errors after about the second package. I think this has to do with the packages/registery being locked or wrong ver of Wimflr vs Wimount WAIK for vista vs WAIK for WIn7 (correct me if I'm wrong here). Whatever this install_win_tweak.exe does I think I need it or whatever tool is evolutionaryly better. I tried it and nullify which did not work same DISM errors. So either I'm doing something wrong or there is an evolutionary better way I have yet to find. The error I get in DISM is the specified image is no longer serviceable 800f0830 I am trying to remove the following packages: dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-Client-Features-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-WindowsFoundation-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-Client-Refresh-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-Client-Wired-Network-Drivers-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-GroupPolicy-ClientTools-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-MediaPlayer-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 dism.exe /image:C:\Wim /remove-package /packagename:Microsoft-Windows-PhotoPremiumPackage~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 Why do I get this error and what tool will help. Believe me I have searched high and low for an answer on this and I keep finding new tools but nothing that actually works or comes close to working as good as the old Dism command line tool can do. Ive tried them all and removing this language either fails or never starts. I believe this has to do with the servicable error that I see when I do this manually that I dont see when using jim jim dism tool or RT seven lite etc. I hope someone can shed some light or point me in the right direction. Been looking at this same problem for over a week now. I hate posting as usually can find stuff but no such luck with this.
  14. Hi all. Just read about 25 pages here, been out of the scene a while. What I am trying to understand is I have a list of packages I want to remove for a language in windows 7 ultimate x86. The list is complete and when I input it into DISM I get errors after about the second package. I think this has to do with the packages/registery being locked. Whatever this install_win_tweak.exe does I think I need it or whatever tool is evolutionaryly better. I tried it and nullify which did not work same DISM errors. So either I'm doing something wrong or there is an evolutionary better way I have yet to find. Also the link for install_win_tweak.exe is broken here. I got a copy from another site but not sure if its working. The error I get in DISM is the specified image is no longer serviceable 800f0830 I am trying to remove the following packages: /PackageName:Microsoft-Media-Foundation-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Branding-Ultimate-Client-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Client-Drivers-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Client-Features-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Client-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Client-Refresh-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Client-Wired-Network-Drivers-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-ClipsInTheLibrary-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-CodecPack-Basic-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Common-Drivers-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Disk-Diagnosis-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Gadget-Platform-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-GPUPipeline-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-GroupPolicy-ClientExtensions-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-GroupPolicy-ClientTools-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-ICM-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Media-Format-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-MediaPlayback-OC-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-MediaPlayer-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-NetFx3-OC-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-PeerToPeer-Full-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-PhotoPremiumPackage~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Printing-Foundation-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-RemoteAssistance-Package-Client~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-SearchEngine-Client-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-SecureStartup-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-ShareMedia-ControlPanel-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-Shell-HomeGroup-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-SnippingTool-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-TerminalServices-CommandLineTools-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-TerminalServices-MiscRedirection-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-TerminalServices-Publishing-WMIProvider-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-TerminalServices-RemoteApplications-Client-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-TerminalServices-UsbRedirector-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-TerminalServices-WMIProvider-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-WindowsFoundation-LanguagePack-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 /PackageName:Microsoft-Windows-WMPNetworkSharingService-Package~31bf3856ad364e35~x86~es-ES~6.1.7601.17514 Why do I get this error and what tool will help. Believe me I have searched high and low for an answer on this and I keep finding new tools but nothing that actually does what the good old Dism command line tool can do. Ive tried them all and removing this language either fails or never starts. I believe this has to do with the servicable error that I see when I do this manually that I dont see when using jim jim dism tool or RT seven lite etc. I hope someone can shed some light or point me in the right direction. Been looking at this same problem for over a week now. I hate posting as usually can find stuff but no such luck with this.
  15. Mark, Like yourself I have always liked the simple search in old XP. Before MS got index happy. Anyway in Win7 I have removed search but the framework of it is still there. It works in explorer and functions like XP's search did almost. I dont really care about it as long as I can do date and file size searches. I use everything search for the rest as its insanely fast. Anyway outlook 2007 breaks the explorer bar search and completely removes it from the UI. It took me a while to track down what part of Office 2k7 was doing it. I should have known it would be outlook. If you keep outlook the search stays.. If you remove outlook the search goes. Anyway I hate outlook and dont use it. I will keep it for now till I find out a way to re-enable the search in explorer without having outlook installed. It must register a DLL or make a reg entry or something to keep to remove the search. I just dont know what it is. There is no longer outlook express so I'm not sure why this happens. If anyone has a clue. Let me know.