• Content count

  • Joined

  • Last visited

Community Reputation

0 Neutral

About TerryInWales

  • Birthday 07/28/1953

Profile Information

  • OS
    Windows 7 x64
  1. Thanks. Do it! Just send me the contact info in South Wales and I'll arrange it and stick it in the SatNav.
  2. I thought this command would be very useful: Example {OS=Win7,Vista} "%WpiPath%\Install\MyApplication\MyApplicationSetup.exe" will execute the command only on Windows 7 and Vista (no XP, 2000 and previous). I went to config. In commands, went to condition/operating system and it gave me {OS=Win8,Win7,Vista,XP} . Being a bit of a simpleton I just backspaced over the OSes I didn't want. Examples: {OS=XP,Vista} "%root%\Install\AV CoDecs\VistaCodecs_v641.exe" {OS=Win7} "%root%\Install\AV CoDecs\Win7codecs_v390.exe" {OS=Win8} "%root%\Install\AV CoDecs\win8codecs_v132.exe" This did not work as expected. I'm using windows 8 pro x64. WPI version 8.6.3 I can't remember now if it failed or skipped. The first one is not that important to me because I don't have Vista anyway. It would be nice to know if it works though. However: {OS=Win7,} "%root%\Install\AV CoDecs\Win7codecs_v390.exe" {OS=Win8,} "%root%\Install\AV CoDecs\win8codecs_v132.exe" Notice, I left commas in. This does seem to work. From config.js: prog[pn]=['CoDecs etc XP Vista 7 8, 32 and 64 bit']; uid[pn]=['CODECSQUICKTIMEFFDSHOW']; ordr[pn]=[1250]; dflt[pn]=['no']; forc[pn]=['no']; bit64[pn]=['yes']; cat[pn]=['Multimedia']; pfro[pn]=['no']; cmds[pn]=[''{OS=XP%comma%Vista} "%root%\\Install\\AV CoDecs\\VistaCodecs_v641.exe"','{OS=Win7%comma%} "%root%\\Install\\AV CoDecs\\Win7codecs_v390.exe"','{OS=Win8%comma%} "%root%\\Install\\AV CoDecs\\win8codecs_v132.exe"','{x64} "%root%\\Install\\AV CoDecs\\x64Components_v390.exe"','{x86} "%root%\\Install\\AV CoDecs\\MPC-HC." /VERYSILENT /SUPPRESSMSGBOXES /NORESTART /SP-','{x64} "%root%\\Install\\AV CoDecs\\MPC-HC." /VERYSILENT /SUPPRESSMSGBOXES /NORESTART /SP-']; gcond[pn]=['FileExists("%programfiles%\\MPC-HC\\mpc-hc64.exe")']; desc[pn]=['Video Codecs]; pn++; Notice how it has replaced the commas with %comma%. It seems to work OK, but I'm not sure if I have to leave the comma in for multiple OS choices and I can't find any documentation that seems to help. If you were here is SW Wales in the UK I would come round and fix mritters main computer for free. Please continue with the WPI. I really do appreciate it. Terry
  3. Thank you for you quick response and help. I'm looking forward to 8.2.0. I'd never noticed the "Run in Bg" command before. I think it's about time I went back and RTFM. Terry
  4. It looks like things have been quiet for a few months here in the WPI forums. Is development still going on or am I looking in the wrong place? I would like to see an easier to use config editor. Can it be made to remember you ordered it by number order next time you go in to it or which ever field you ordered it by. The highlighting with the mouse and cursor in the editor is poor. You have to drag the mouse with left button down to the extreme right or left then drag it back to highlight the bit you need to delete or edit. Even then it is very inaccurate because it seems to snap in the wrong place. It could do without that. I would also like to see better contrast in the editor between highlighted items and non-highlighted. Is there a way to open a text file and leave the text file open whilst the WPI gets on with installing the next items? I find now if I quit a batch file in the WPI it now says it has failed, it didn't in v7. I used to use this feature for displaying text files, then I would quit the command window. I know you can't predict what idiots like me will do with your program, but I'm sure there are more ingenious idiots than I. I'm not quite sure whats going on with the 64 32 bit installers. I thought I'd got hold of how it worked once, but the birds have flown away. I use Windows 7 x64. I thought that if it was a 32 bit installer it should stick the program in "Program Files (x86)" when it encounters %PROGRAMFILES% and if it's a 64 bit installer "Program Files" when it encounters %PROGRAMFILES% . I think this supports it. msdn library link I'm not a programmer, I was just trying to work with the limitations and features of the WPI. In fact, I think the WPI is an excellent program and have been using it for many years and many more to come I hope. Hopefully with a few more improvements. Terry :-)
  5. I have saved the files under WPI 8.03. It still has the same faults. Here are the full files. Terry config.js useroptions.js
  6. I'm running on Windows 7 x64 and I don't have much in the way of problems with WPI 7.7. I thought I would give WPI 8.03 a go. I have run into a couple of problems. To make sure there were no other errors I renamed my old WPI folder WPI77, copied the downloaded WPI 8.03 WPI folder and only copied the config.js file from my old folder to the new one. As you can see from the .jpg files WPI77 greys out all files that have be checked on load. WPI803 however doesn't. It appears if I use %programfiles% in the new WPI it doesn't recognise it. gcond[pn]=['FileExists("%PROGRAMFILES%\\DisplayFusion\\DisplayFusion.exe")']; I have attached part of my config.js that relates to the part screen capture. Also, when I go into config, I cannot highlight relevant sections to copy and paste. Double clicking highlights a word which can be copied and pasted but drag and highlight no longer works. I have tried versions 8.01 and 8.02 and the faults are still there. I have also tried using a different machine and it is the same. Help! Terry Part of config.js