Godflesh

Member
  • Content count

    18
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Godflesh

Profile Information

  • OS
    none specified
  1. I got this commandline in Windows Post Install Wizard...and it won't install. cmd1[pn]=['msiexec.exe /i "%wpipath%\\Install\\Video Editing\\ISScript8.Msi" /norestart /qb']; <-- what is wrong with it? (it is command 1 of 3 in total)...but I need to install ISScript8.msi first. Please help
  2. I made a standalone installer in AutoIT3.... here is the working script for 2.5.5 ..(adapted 2.4.0 script) Run ("autoGK-setup.exe /S") ; ---------------------------------------------------------------------------- ; VobSub install ; ---------------------------------------------------------------------------- WinWaitActive ( "Installer Language" ) ControlClick ( "Installer Language" , "OK" , "Button1" ) WinWaitActive ( "VobSub 2.23 Setup" ) ControlClick ( "VobSub 2.23 Setup" , "&Next >" , "Button1") WinWaitActive ( "VobSub 2.23 Setup: Installation Options" ) ControlClick ( "VobSub 2.23 Setup: Installation Options" , "&Next >" , "Button1") WinWaitActive ( "VobSub 2.23 Setup: Installation Folder" ) ControlClick ( "VobSub 2.23 Setup: Installation Folder" , "&Install" , "Button1") WinWaitActive ( "VobSub 2.23 Setup: Completed" ) ControlClick ( "VobSub 2.23 Setup: Completed" , "&Close" , "Button1") ; ---------------------------------------------------------------------------- ; AviSynth install ; ---------------------------------------------------------------------------- WinWaitActive ( "Installer Language" ) ControlClick ( "Installer Language" , "OK" , "Button1" ) WinWaitActive ( "AviSynth 2.5.8 " ) ControlClick ( "AviSynth 2.5.8 " , "&Agree" , "Button2" ) ControlClick ( "AviSynth 2.5.8 " , "&Next >" , "Button2" ) ControlClick ( "AviSynth 2.5.8 " , "&Install" , "Button2" ) WinSetTitle ( "AviSynth 2.5.8 ", "", "AviSynth 2.5.8 Install" ) WinWaitNotActive ( "AviSynth 2.5.8 Install" ) ControlClick ( "AviSynth 2.5.8 " , "&Next" , "Button2" ) ControlClick ( "AviSynth 2.5.8 " , "&Finish" , "Button2" ) ; ---------------------------------------------------------------------------- ; Xvid install ; ---------------------------------------------------------------------------- WinWaitActive ( "XviD MPEG4 Video Codec Setup" ) Send("{ENTER}") WinWaitActive ( "XviD MPEG4 Video Codec Setup" ) Send("{ENTER},{ENTER}") ;end Exit
  3. Hi Allen, the VistaInspirate2Ultimate.exe is allready in "%wpipath%\install\Bricopacks\"...so I just removed: "fileinstall("c:\bricopack\VistaInspirate2Ultimate.exe", EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe",1) ....and put the VistaInspirate2Ultimate_silent.exe in the same dir etc....everything works as it should now. my final script: #region --- Au3Recorder generated code Start --- Run(EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe") _WinWaitActivate("Installer Language","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Sleep(2000) Send("{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Sleep(2000) Send("{TAB}{TAB}{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Sleep(4000) Send("{TAB}{DOWN}{SPACE}{DOWN}{DOWN}{DOWN}{SPACE}{DOWN}{RIGHT}{DOWN}{SPACE}{DOWN}{DOWN}{DOWN}{SPACE}{TAB}{TAB}{ENTER}{ENTER}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Sleep(280000) Send("{TAB}{SPACE}{ENTER}") WinClose("Vista Inspirat 2 1.0 Setup","") Exit #region --- Internal functions Au3Recorder Start --- Func _WinWaitActivate($title,$text,$timeout=0) WinWait($title,$text,$timeout) If Not WinActive($title,$text) Then WinActivate($title,$text) WinWaitActive($title,$text,$timeout) EndFunc #endregion --- Internal functions Au3Recorder End --- #endregion --- Au3Recorder generated code End --- #endregion --- Au3Recorder generated code End --- I understand how it works now a little bit better...thnx for answering my questions and your time invested in me....I really appreciate it.
  4. Ok, I got the installer working as it should...FINALLY I only have 1 question...about this line "fileinstall("c:\bricopack\VistaInspirate2Ultimate.exe", EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe",1) I noticed when I test the silent installer it unpacks VistaInspirate2Ultimate.exe in bricopacks dir...but what happens when I burned my "Windows Post installer" on DVD? It obviously can't extract it in that dir anymore...should I change that line to C;//Temp or something..so it can actually EXTRACT it etc? besides that the installer works fine ....still on my hd etc.
  5. Update....the silent installer script blow installs fine, but stil have to figure out the last bit where it gets at the "REBOOT OPTION" screen. Autoit and WPI have finished the "silent bricopack installer", but I am still stuck at the last screen of the Vista Inspirate installer... with the opties "reboot now" & reboot later. I still have do it manually #region --- Au3Recorder generated code Start --- fileinstall("c:\bricopack\VistaInspirate2Ultimate.exe", EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe",1) Run(EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe") _WinWaitActivate("Installer Language","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{TAB}{TAB}{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{TAB}{DOWN}{SPACE}{DOWN}{DOWN}{DOWN}{SPACE}{DOWN}{DOWN}{TAB}{RIGHT}{ENTER}{ENTER}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{TAB}{SPACE}{ENTER}") <-- these are the keyboard keys it should use in the REBOOT screen _WinWaitActivate("Vista Inspirat 2 1.0 Setup","",120) #region --- Internal functions Au3Recorder Start --- Func _WinWaitActivate($title,$text,$timeout=0) WinWait($title,$text,$timeout) If Not WinActive($title,$text) Then WinActivate($title,$text) WinWaitActive($title,$text,$timeout) EndFunc #endregion --- Internal functions Au3Recorder End --- #endregion --- Au3Recorder generated code End --- #endregion --- Au3Recorder generated code End ---
  6. I allmost have the silent installer working only 1 problem remains... the installer has to "WAIT" so it can install all the files...after that is done i get a "REBOOT" screen in the installer, but I can't get the "WAIT" option to work in autoit. Here is my old script (which installs fine, but lacks the 2 minute timeout, so I have to doing the reboot option MANUALLY still): #region --- Au3Recorder generated code Start --- fileinstall("c:\bricopack\VistaInspirate2Ultimate.exe", EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe",1) Run(EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe") _WinWaitActivate("Installer Language","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup ","") Send("{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{TAB}{TAB}{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup ","") Send("{TAB}{DOWN}{SPACE}{DOWN}{DOWN}{DOWN}{SPACE}{DOWN}{DOWN}{TAB}{RIGHT}{ENTER}{ENTER}{ENTER}{TAB}{SPACE}{ENTER}") #region --- Internal functions Au3Recorder Start --- Func _WinWaitActivate($title,$text,$timeout=0) WinWait($title,$text,$timeout) If Not WinActive($title,$text) Then WinActivate($title,$text) WinWaitActive($title,$text,$timeout) EndFunc #endregion --- Internal functions Au3Recorder End --- #endregion --- Au3Recorder generated code End --- #endregion --- Au3Recorder generated code End --- Here is my BETA editted script (trying to get the WAIT option working), but it fails everytime sofar: #region --- Au3Recorder generated code Start --- fileinstall("c:\bricopack\VistaInspirate2Ultimate.exe", EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe",1) Run(EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe") _WinWaitActivate("Installer Language","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{TAB}{TAB}{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{TAB}{DOWN}{SPACE}{DOWN}{DOWN}{DOWN}{SPACE}{DOWN}{DOWN}{TAB}{RIGHT}{ENTER}{ENTER}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","",timeout=120) <--- I also tried just "120" , but that didn't work either Send("{TAB}{SPACE}{ENTER}") WinWaitClose #region --- Internal functions Au3Recorder Start --- Func _WinWaitActivate($title,$text,$timeout=0) WinWait($title,$text,$timeout) If Not WinActive($title,$text) Then WinActivate($title,$text) WinWaitActive($title,$text,$timeout) EndFunc #endregion --- Internal functions Au3Recorder End --- #endregion --- Au3Recorder generated code End --- #endregion --- Au3Recorder generated code End --- ( get errormessages now during install "error parsing function call LINE 14")
  7. I tried to compile the exe....that worked....but I get an error while using WPI to run the "silent installer". ....command line 1 ERROR etc etc. This is gonna be harder than I thought... here is my script: #region --- Au3Recorder generated code Start --- fileinstall("c:\bricopack\VistaInspirate2Ultimate.exe", EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe",1) Run(EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe") _WinWaitActivate("Installer Language","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup ","") Send("{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup","") Send("{TAB}{TAB}{TAB}{SPACE}{ENTER}") _WinWaitActivate("Vista Inspirat 2 1.0 Setup ","") Send("{TAB}{DOWN}{SPACE}{DOWN}{DOWN}{DOWN}{SPACE}{DOWN}{DOWN}{TAB}{RIGHT}{ENTER}{ENTER}{ENTER}{TAB}{SPACE}{ENTER}") #region --- Internal functions Au3Recorder Start --- Func _WinWaitActivate($title,$text,$timeout=0) WinWait($title,$text,$timeout) If Not WinActive($title,$text) Then WinActivate($title,$text) WinWaitActive($title,$text,$timeout) EndFunc #endregion --- Internal functions Au3Recorder End --- #endregion --- Au3Recorder generated code End --- #endregion --- Au3Recorder generated code End ---
  8. Where do I put this line EXACTLY? fileinstall("c:\bricopack\VistaInspirate2Ultimate.exe", EnvGet("wpipath") & "\install\Bricopacks\VistaInspirate2Ultimate.exe",1) Does this line include the original installer to the new compiled SILENT.exe?
  9. Anyone who has succeeded in silent installing these 2 programs through WPI and would like to share their knowledge on how they did it?
  10. A version to use with Firefox 6 would be nice.....
  11. I can't get the silent install working of ...Corel PaintShop Photo Pro X3 v13.2.0.41 I tried: 1. "C:\PSPX\Setup.exe" /a <--(Admin Install) invalid serial ERROR 2. msiexec /a "D:\Corel_Paint_Shop_Pro_X\PSPPro.msi" Serialnumber=XXX /qb <-- it seems to install etc, but it doesn't install anything Could anyone tell me what I am doing wrong???
  12. Could somebody share the knowledge how to silent install Autogordianknot 2.55 with WPI? Would love to add this great tool to my WPI disc. Please keep the explanation simple if possible ...I am a newbie with autoit etc.
  13. I am looking for a way to silent install with WPI: TMPGEnc Authoring Works 4 & TMPGEnc Video Mastering Works 5 Anyone who achieved this and is willing to explain how he did it and maybe share the "commandslines" for WPI etc? I would be most gratefull....
  14. And i'd make a standalone exe and include the source in the compiled script <---abracadabra to me ... lol. No idea how to do that. thanks for your help, but I am really new to autoit and not really a "code wizkid" etc : ) ... I just want a simple way to add the vista inspirate 2 ultimate installer to silent install in WPI....without "rocketdock" and without the "logon screen" and without the "wallpaper" and without rebooting at the end of the installation. Anymore help for this newbie to make it easier for me would be awesome.