ipen

Member
  • Content count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About ipen

Profile Information

  • OS
    XP Pro x86
  1. OK, 1) Why did you decied that " MySetup.msi (NOT WITHIN A FOLDER!!!)" ??? It is in the folder and when checking the zip created after "C:\Program Files\7-Zip\7z.exe" a %zipFileName% %allFromOutputDir%" the MSI is present!!! 2) both msi and exe are created from a simple visual studio .net, C# setup project. Framework 3.5.. No problem with that part at all! More over - and that is the point you keep missing - The self extracting zip works just fine (and run the MSI and all) when i run it on win 7 (extract exe and MSI and execute it all!!!). The same self extracting zip - will not work on win XP. SO ???
  2. Yes - the commad i use is exactlly like yours. I tried installing Windows Installer 4.5. Did not help. Can you please just post the link to what you think is the relevant SFX version - because i am very confused by now...
  3. when using the "7zsd.sfx" from 7zSD 1.5 beta (build 2478) May 10, 2012 Modified 32-bit module (for LZMA compression method that 7-Zip uses by default). (downloaded from 7-zip.info) and trying to run it product - it gives me an error "Could not read SFX configuration or configuration Not found". When using "7zsd.sfx" from 7z920_extra (downloaded from 7-zip.org) it works but only on win7. when using "7zsd.sfx" from 7zSD 1.4.3 Release (build 2367) January 21, 2012 (downloaded from 7-zip.info) it still gives me this "Could not read SFX configuration or configuration Not found" Please help!
  4. Hi, I use "7zsd.sfx" from 7zsd_tools_150_2100.exe Is it the correct version for my needs ? - run self extructed installer - run on win XP and win 7 ??? Thanks
  5. Hi, tried both of the last suggestions.... Still same errors. Could it be because my zip contains more then one file ? See , the zip contains these items : - MySetup.msi - setup.exe - "WindowsInstaller3_1" folder (pre - requisite) -"DotNetFX35" folder (another pre-requisite) Now - when i run my SFX on win XP - it does run the "setup.exe", but after checking for the pre-requisites , it fails to run the MSI !!! Here is the log content : The following properties have been set: Property: [AdminUser] = true {boolean} Property: [ProcessorArchitecture] = Intel {string} Property: [VersionNT] = 5.1.3 {version} Running checks for package 'Windows Installer 3.1', phase BuildList The following properties have been set for package 'Windows Installer 3.1': Running checks for command 'WindowsInstaller3_1\WindowsInstaller-KB893803-v2-x86.exe' Result of running operator 'VersionGreaterThanOrEqualTo' on property 'VersionMsi' and value '3.1': true Result of checks for command 'WindowsInstaller3_1\WindowsInstaller-KB893803-v2-x86.exe' is 'Bypass' 'Windows Installer 3.1' RunCheck result: No Install Needed Running checks for package '.NET Framework 3.5', phase BuildList Reading value 'Install' of registry key 'HKLM\Software\Microsoft\NET Framework Setup\NDP\v3.5\1033' Read integer value 1 Setting value '1 {int}' for property 'DotNet35InstallSuccess' The following properties have been set for package '.NET Framework 3.5': Property: [DotNet35InstallSuccess] = 1 {int} Running checks for command 'DotNetFX35\dotNetFx35setup.exe' Result of running operator 'ValueEqualTo' on property 'DotNet35InstallSuccess' and value '1': true Result of checks for command 'DotNetFX35\dotNetFx35setup.exe' is 'Bypass' '.NET Framework 3.5' RunCheck result: No Install Needed Launching Application. Running command 'C:\WINDOWS\system32\msiexec.exe' with arguments ' -I "C:\DOCUME~1\...\LOCALS~1\Temp\7zS909.tmp\MySetup.msi" ' Any ideas ?
  6. Hi, Well let me better explain : "C:\Program Files\7-Zip\7z.exe" a %zipFileName% %allFromOutputDir% copy /b "C:\Program Files\7-Zip\7zSD_LZMA.sfx" + config.txt + %zipFileName% %outputFile% where : %zipFileName% = "MySetup.7z" %allFromOutputDir% = all of the items that currentlly exists in the output dir of the setup project. (bin\release\...) %outputFile% = "MySFX.exe" thats it... Did not zip only one file but the whole setup dir - since the setup my contain more then just the ".exe". It contains the pre- requisites folders (like the .net version and win intsller etc.). That is not the issue. I will try your format of command : copy /-Y /B
  7. Look, The setup alone does work on both OS... (XP and win 7). Only after creating SFX and using it - it does not work on win XP. And yes - the setup pre-requisite is to install .net frame work. Any other suggestions ? Thanks Iris
  8. Hi, Tried all the above - still same errors. I have a VS.net setup project - creating my setup.exe file. Then i have a post build event - trying to create the SFX like this : "C:\Program Files\7-Zip\7z.exe" a %zipFileName% %allFromOutputDir% copy /b "C:\Program Files\7-Zip\7zS.sfx" + config.txt + %zipFileName% %outputFile% When running its product - it cause this error : "This installation package could not be opened..." or like this "C:\Program Files\7-Zip\7z.exe" a %zipFileName% %allFromOutputDir% copy /b "C:\Program Files\7-Zip\7zSD_LZMA.sfx" + config.txt + %zipFileName% %outputFile% When running its product - it cause this error : "Could not read configuration or configuration not found". config file is saved in UTF-8 encoding. NOTE : both errors only happen on win XP . On win 7 - it works great!!! Any other suggestions ?
  9. Yep - the 'setup.exe' works just fine on both OS. Only when using the SFX - it fails on XP.
  10. Hi, Tried all that - did not work... Thanks Iris
  11. Hello all, I been trying to create a self extracting zip (SFX) to contain my installation folder. I am using 7z modules like "7zs.Sfx" or "7zSD_Lzma.sfx". I created a zip which after extraction run the "setup.exe" . this is the command lines in the batch file : "C:\Program Files\7-Zip\7z.exe" a %zipFileName% %allFromOutputDir% (creating a 7z zip) copy /b "C:\Program Files\7-Zip\7zS.sfx" -y + MCTSFXConfig.txt + %zipFileName% %outputFile% (Creating self extracting zip) this is the config content : ;!@Install@!UTF-8! RunProgram="setup.exe" GUIMode="2" ;!@InstallEnd@! On my comuter which OC is win7 - it works good! But when i try to run it on WinXP pro x86 i get this error after extraction : "This installation package could not be opened..." So i tried different command for SFX : "C:\Program Files\7-Zip\7z.exe" a %zipFileName% %allFromOutputDir% copy /b "C:\Program Files\7-Zip\7zSD_LZMA.sfx" + MCTSFXConfig.txt + %zipFileName% %outputFile% and when i am trying to run its out put - i get this error : "Could not read configuration or configuration not found". NOTE : it is the same configuration... Please help !