Chumbawamba

Member
  • Content count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Chumbawamba

Profile Information

  • OS
    Windows 7 x64
  1. I saw Q&As in this forum about 7zip and the 7zSD sfx module, so i though this a good place to ask. so im making a tool that launches 2 portable apps that have folders with the app data inside. So i have the 2 folders with their programs inside and a Run.cmd file parent of those which is something like this; @echo off start Portable1.exe && start Portable2.exe exit then my exe.cmd is @echo off copy /b 7zsd.sfx + config.txt + Tool.7z Tool.exe echo. pause then my config file is ;!@Install@!UTF-8! Title="Tool" RunProgram="hidcon:Run.cmd" GUIMode="8" ;!@InstallEnd@! this all works fine to a point when it tries to Run the second .exe it says it cannot locate one of its files within the apps folder. when i look in the temporary folder the files haven't been extracted. so for test purposes i try each file separately like so ;!@Install@!UTF-8! Title="Tool" RunProgram="portable1/portable1.exe" GUIMode="8" ;!@InstallEnd@! and ;!@Install@!UTF-8! Title="Tool" RunProgram="portable2/portable2.exe" GUIMode="8" ;!@InstallEnd@! and both run and when i check all files have been extracted. it seems if i use any .bat or .cmd file then all the files do not extract correctly. i think this may have something to do with the cmd executing too fast for the install to finish. ive also tried with pause and nowait: functions without any luck. Any help would be greatly appreciated, thanks.