clsmith

Member
  • Content count

    5
  • Joined

  • Last visited

Community Reputation

0 Neutral

About clsmith

  1. ..every effort I made to slipstream the Promise drivers failed miserably: most of the time it simply didn't work/didn't see the controller, and when it did work I got the BSOD after setup rebooted the second time. The simple answer is: I couldn't get it to work. Following GreenMachine's instructions, as well as other's I found searching the forum, got me to a point where setup would see the controller/drives but after the final reboot I got the BSOD every time. CLS
  2. That will be cool. I'll keep trying but you'll probably get there before I do. CLS
  3. That's what I did. After searching (and finally reading ) all the posts regarding the promise 378. I ended up setting the OemPreinstall=No then hitting F6 and installing the drivers from a floppy. Then right after the first reboot I used a PECD to copy all the $OEM$ directories onto the drive before continuing setup - this worked but was WAY too involved for an "unattended" install. The reason I took this, very indirect, route was that every effort I made to slipstream the Promise drivers failed miserably: most of the time it simply didn't work/didn't see the controller, and when it did work I got the BSOD after setup rebooted the second time. I even tried the MassStorage Driver pack: Created a new directory and put the renamed promise drivers in there (with the edited .inf file.) Then edited the Winnt.sif to point to that dir. And edited the 'add_to_txtsetupsif_v008.txt' to use the new drivers. Again, no luck Does anyone have a working TXTSETUP.SIF for the promise 378 controller (UATA mode not RAID)? CLS
  4. Got it. Thanks. CLS
  5. I recently picked up a Tyan board with a Promise PDC20378 controller on it. I'm using it in SATA mode not RAID. I already had a built (nLite, SP2, custom unattended setup) XP-Pro CD that I've been using for a while but it didn't have the new drivers on it yet. So I started an install hitting the 'F6' button during the initial setup to install the 378 drivers. All seemed to go fine: hit 'F6', setup asked for drivers, hit 'S' and selected the XP SATA drives, hit 'Enter' to continue etc.... Setup then asked me which partition to use (it saw the disk!!) so I selected the partition, formatted it NTFS - then the problem started. Just as the text-mode setup started "generating a list of files to be copied" I got an error message telling me that "Setup cannot copy the file: UlSata.sys"! At first I thought this was an nLite problem as when I used my original XP-Pro SP1 disk I was able to get past that copy point. Upon further testing I found that it wasn't nLite it was the unattended setup! If burned another nLite CD using the same files but removed the WINNT.SIF then setup was able to find/copy the UlSata.sys file - but I lost my unattended settings/scripts. I did try and slipstream the drivers into the CD using GreenMachine's instructions but I got the same 'cannot copy file' error. Any ideas? CLS