Oleg_Sch

7z SFX Modified Module and Tools

511 posts in this topic

Hello,

Hopefully I can get some help. The MiscFlags="4" is not working for me as well. I tried using the 7zsd_All.sfx and 7zsd_LZMA2.sfx. I'm very new to SFX so just to be clear - I would like the sfx executable I'm creating to prompt for administrator.

Config:

;!@Install@!UTF-8!

GUIMode="2"

MiscFlags="4"

RunProgram="x64:%%T\x64\setup.exe"

RunProgram="x86:%%T\x86\setup.exe"

;!@InstallEnd@!

Thanks in advanced!

Can anyone please help me out? This is driving me crazy and I need to resolve it. Thanks you.

0

Share this post


Link to post
Share on other sites

I have one question regarding SFX archives created using WinRAR and I am expecting a very fast reply as it is very urgent for me.

I have to create one SFX file that can be installed in both, 32 or 64 bit machines. But, I want to know if it is possible to give the extraction path dynamically, i mean Can the SFX itself decide in which %ProgramFiles% it should extract contents.? In 32 bit we have Program Files folder and in 64 bit, we have Program files(x86).

Please help me ASAP

0

Share this post


Link to post
Share on other sites

I know you are desperate, but posting the same post in multiple places will not get you a response any faster, you will just p*ss people off and you will be ignored. No one cares how urgent it is for you - that is not our problem. Pick ONE thread to leave your post and delete the other posts. It will be seen and someone will respond if they have anything useful.

Cheers and Regards

0

Share this post


Link to post
Share on other sites

Can you give a beta version of the SuRun for reproduce error? I can't download it now.

It does not seems to occur in the recent beta 6, but happens here in SuRun1211b5.zip

Edited by JFX
0

Share this post


Link to post
Share on other sites

Hello... I have a problem with some 7zsfx files in Windows 8 (other files works perfect)... I got error message : "Non 7z archive." That 7zsfx files works perfect in Win XP, Win 7 x86 and x64... :unsure:

An example of config file:

;!@Install@!UTF-8!
GUIMode="0"
MiscFlags="4"
GUIFlags="2+4+8+16+32+2048"
Title="Mozilla Firefox v19.0 b4 esp Silent..."
BeginPrompt=" Creado por -=cr@ckm@n=-

¿Quieres instalar Mozilla Firefox...?"
ExtractTitle="Extrayendo archivos..."
ExtractDialogText="Mozilla Firefox v19.0 b4 español"
ExtractCancelText="Cancelar la instalación"
RunProgram="setup.exe -ms"
FinishMessage="Instalación finalizada correctamente... ;-)"
;!@InstallEnd@!

Regards... ;-)

post-329917-0-87301000-1359642607_thumb.

Edited by alfreire
0

Share this post


Link to post
Share on other sites

Well.. I auto-answer to myself... :sneaky: I updated sfx module to v1.6 develop (build 2712) and works now... :whistle:

Regards... ;-)

Edited by alfreire
0

Share this post


Link to post
Share on other sites

Hi, friends... One question, how to make work this command...?

Delete="%%T\\*.reg"

*.reg not working... I tried this

Delete="%%T\\\"*.reg\""

and this

Delete="\"%%T\\*.reg\"" 

and this

SetEnvironment="Variable1=*.reg"
Delete="%%T\\%Variable1%"

but not working too... :no:

Regards... ;-)

p.d.: This command works perfect...

RunProgram="hidcon:cmd /c del \"%%T\\*.reg\"" 

Edited by alfreire
0

Share this post


Link to post
Share on other sites

2 alfreire

The module does not support wildcard (*,?)

0

Share this post


Link to post
Share on other sites

2 alfreire

The module does not support wildcard (*,?)

Thank you very much, Gora... appreciate your help... :rolleyes:

Cheers and regards... ;-)

0

Share this post


Link to post
Share on other sites

Hello,

I would like to know If is possible to give the extraction path as a parameter.

i.e In config.txt file I set the InstallPath="%TEMP%" dir for extraction path but I want the user to have the option to choose the extraction path and overwrite the setting in config file.

is that possible?

Cheers,

c0nf

0

Share this post


Link to post
Share on other sites

is that possible?

Yes.

sfx.exe -InstallPath="%ProgramFiles%\\NewFolder"

0

Share this post


Link to post
Share on other sites

thank you very much for your fast reply, it works!

Cheers

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.