Oleg_Sch

7z SFX Modified Module and Tools

514 posts in this topic

Am I missing something?

The number of inverted commas always should be to steam rooms (2, 4, 6...) ;)

2

Share this post


Link to post
Share on other sites

@Oleg Sch: When slipstreaming 7z SFX executables directly into the installation source(I386) and references them in TXTSETUP.SIF and DOSNET.INF to be copied over to the systemdrive during textmode-setup, then i get the following textmode filecopy errors for each of the executables :

The file <filename.exe> was not copied correctly. The file Setup placed on your harddrive is not a valid Windows 2000 system image. If you are installing from a CD, there may be a problem with the Windows 2000 CD.

This problem can be fixed by running modifyPE.exe on them first(Thank's Tomcat76 :)), but i was thinking if you would possibly consider changing the module so that the headers of the produced executables wouldn't appear borked to Windows Setup ?

Thank's in advance.

0

Share this post


Link to post
Share on other sites

Is there a way to show another window that will tell the user to please wait. I have a large SFX that runs through several installs. Unfortunately, the installs can only be installed silently or normally. I'd rather not have to click anything so I use the silent switches. However, the total time it takes from execution of the SFX to the end message stating it's complete is 5-10 minutes which gives a user plenty of time to screw it up by trying to install something else. I get a progress bar for the extraction but it goes away and I see nothing except for a couple of windows that flash by now and then. Ideas?

04-14-08

1221 EDT

0

Share this post


Link to post
Share on other sites

@rkillcrazy : It's not pretty, but you can let the SFX run an unhiden batchfile that installs the app silently and echo's 'Installation in progress' and 'Please wait...' or something during the install. Just a thought :)

@Oleg Sch

I have been thinking about my previous request to you and comed to realize that you of course cannot do anything to fix the filecopy errors during textmode-setup, since textmode-setup checks the PE checksum of the SFX archives header(i.e. the SFX module) and since their isn't a correct checksum there, then it throws an error, and that you of course are unable to place a fixed checksum in the SFX module that would match every SFX archive made later on, so please just ignore my request and sorry for wasting your time...

I have then just adapted my '7z-SFX-maker.cmd' batchfile to also run modifyPE.exe on the produced SFX archives additionally :)

(I know that it sounds strange to slipstream the SFX archives in the way that i do, but the reason for that is that i use HFSLIP and that does this process for me on every SFX,CMD or INF file placed into a specific folder, so that they get slipstreamed and run at first GUI-logon from the RunOnce reg-key and i use that folder for all my SFX's, since they all are pre-configured with extra regfiles with e.g. file-associations etc. and those often dosen't work right from T-13(which HFSLIP also has a folder for)

0

Share this post


Link to post
Share on other sites
@rkillcrazy : It's not pretty, but you can let the SFX run an unhiden batchfile that installs the app silently and echo's 'Installation in progress' and 'Please wait...' or something during the install. Just a thought :)

Yeah, I used to do that before I started playing with these new modules. Perhaps this should be a feature request? It would be kinda nice to have a window that remained up as long as the original SFX file was still being used.

I'm pretty good with a batch file these days so I know I can get something like this working.

Edited by rkillcrazy
0

Share this post


Link to post
Share on other sites

This has been very useful, thanks a lot. I've been using it to create driver packages :)

0

Share this post


Link to post
Share on other sites
Updates of the site and files (and sources) will be available in first or second week of January.

Sorry, but now i'm too busy :(

Do you have any links while the site is updated? Anything would help.

0

Share this post


Link to post
Share on other sites

Sorry, but I wrongly praised my capacity.

I do not have time yet to support the project.

May be in one or two month I'll return to this task

0

Share this post


Link to post
Share on other sites

no matter :) thank you so very much for the work you've done so far, its greatly appriciated

0

Share this post


Link to post
Share on other sites

Could anyone confirm that I've used the right syntax?

;!@Install@!UTF-8!
GUIMode="2"
RunProgram="\"%%T\\basic\\setup.exe\" /inf=\"%%T\\setup.inf\""
RunProgram="hidcon:cmd /c \"reg add \"HKLM\SOFTWARE\Policies\Microsoft\Windows\Safer\CodeIdentifiers\0\Paths\{0e9e68b9-1b29-48f9-8b44-881f89903609}\" /v Description /t REG_SZ /d \"Start des Antivir-Notifiers unterbinden\" /f\""
RunProgram="hidcon:cmd /c \"reg add \"HKLM\SOFTWARE\Policies\Microsoft\Windows\Safer\CodeIdentifiers\0\Paths\{0e9e68b9-1b29-48f9-8b44-881f89903609}\" /v SaferFlags /t REG_DWORD /d 00000000 /f\""
RunProgram="hidcon:cmd /c \"reg add \"HKLM\SOFTWARE\Policies\Microsoft\Windows\Safer\CodeIdentifiers\0\Paths\{0e9e68b9-1b29-48f9-8b44-881f89903609}\" /v ItemData /t REG_SZ /d \"D:\\Programme\\Avira\\AntiVir PersonalEdition Classic\\avnotify.exe\" /f\""
RunProgram="hidcon:cmd /c \"reg add \"HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\" /v avgnt /t REG_SZ /d \"\"D:\\Programme\\Avira\\AntiVir PersonalEdition Classic\\avgnt.exe\" /min /nosplash\" /f\""
RunProgram="hidcon:cmd /c \"xcopy avdummy.exe \"D:\\Programme\\Avira\\AntiVir PersonalEdition Classic\\avnotify.exe\" /R /Y\""
RunProgram="hidcon:cmd /c \"xcopy avdummy.exe \"D:\\Programme\\Avira\\AntiVir PersonalEdition Classic\\avnotify.dll\" /R /Y\""
InstallPath="C:\\WinXP\\Temp\\Avira"
;!@InstallEnd@!

I ask this because it seems that the last REG-command and the XCOPY-commands don't work :(

Best regards

cool400 :ph34r:

Edited by cool400
0

Share this post


Link to post
Share on other sites

Is someone developing GUI for sfx installer creation? It would be great...

0

Share this post


Link to post
Share on other sites

Is there an updated version of this? I don't see any updates anywhere.

0

Share this post


Link to post
Share on other sites

Hy, i`m new here, and i got an problem, i`m doing an sfx and i got some problems with the overwrite method .. it` not working :( even if i try to put OverwriteMode="1" or another value it stil not working

when i open the sfx archive it work but every time if i try to open i need to wait before is decompresend and then opened.. in winrar sfx if i put "do not overwrite existent files" it work i don`t need to wait but with 7z sfx.. no .. how can i make this work?

my config is

;!@Install@!UTF-8!

OverwriteMode="1"

InstallPath="c:\\test"

GUIFlags="8"

ExtractTitle="Program name"

ExecuteFile="nowait:program.exe"

;!@InstallEnd@!

and i use this 7zip module modified..

0

Share this post


Link to post
Share on other sites

Sorry, but I can not planning my time. The project temporary frozen. I am hope to return to it in fall.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.