Oleg_Sch

7z SFX Modified Module and Tools

511 posts in this topic

Q

How do the commands run? Do they run in the order they are shown in the config?

A

There are 4 types of commands of start of programs: ' AutoInstall ', ' AutoInstallX ', ' RunProgram ' and ' ExecuteFile '. At a configuration file there can be any of these of 4 types and even everything, but after start SFX of archive one type of commands of start can be carried out only.

Commands of start of programs in each type (' AutoInstall ', ' AutoInstallX ' and ' RunProgram ') can be a little, are processed they (within each type) in that sequence in which are specified in a configuration file, the termination of the previous command and after that the following is started thus is expected.

Parametre InstallPath is not a command of start of programs. It specifies a place of unpacking of archive. Commands of start of programs are started ONLY after archive unpacking.

In your case it is possible to make so:

RunProgram="batch file to kill my task here"
RunProgram="batch file to clear the destination directory"
; InstallPath="extract to the recently cleared destination directory"
RunProgram="Copying of files from temporary folder to destination directory..."
RunProgram="batch file to do something else..."
RunProgram="batch file to do something else..."

In the absence of parametre InstallPath unpacking will occur in a temporary folder

Edited by gora
0

Share this post


Link to post
Share on other sites
will there be any update given that the base 7-Zip program has now been updated to v4.62?
The program and this tool have nothing to do with each other
0

Share this post


Link to post
Share on other sites

have any1 encountered icon problem when modifying the SFX using XN Resource Editor?

If using XN REsource Editor, the icon won't show on the dialogs. If I use Resource Hacker, the icon shows.

p/s: I like XN Reosource Editor because editing the Version is easier :)

0

Share this post


Link to post
Share on other sites
If all you need is to extract the archive content to a certain folder, you need to specify a value for 'InstallPath' in the config file. In this case you should not specify 'RunProgram' or 'ExecuteFile' in the config file. 'AutoInstall' or 'AutoInstallX' may be specified in the config file, but should not be invoked via the command line or with the [sHIFT] key. If you specify 'RunProgram' or 'ExecuteFile' or invoke 'AutoInstall' and 'AutoInstallX', the specified executable will be launched after the extraction.

I'm getting desperate. It is exactly what I am trying, but I keep getting an error telling me that setup.exe could not be found.

What could be the problem? Thanks!

;!@Install@!UTF-8!

InstallPath="%PROGRAMFILES%\\Teamviewer"

GUIMode="2"

Shortcut="D,{%%T\\Teamviewer\\TeamViewer.exe},{},{},{Get help from IT Spain BB},{Teamviewer},{},{},{}"

;!@InstallEnd@!

0

Share this post


Link to post
Share on other sites

darkpepe

Try this:

;!@Install@!UTF-8!

AutoInstall="ai"

OverwriteMode="0"

InstallPath="%PROGRAMFILES%\\Teamviewer"

GUIMode="2"

Shortcut="D,{%%T\\TeamViewer.exe},{},{TeamViewer},{Get help from IT Spain BB},{%PROGRAMFILES%\\Teamviewer}"

;!@InstallEnd@!

Edited by Geej
0

Share this post


Link to post
Share on other sites

Modules, Help files (Russian), Site (Russian) are updated. Many functions are added. Change of appearance of dialogue windows and use RTF in texts is possible.

sc_large_en.png

To load it is possible here. For studying of new possibilities use online translator.

0

Share this post


Link to post
Share on other sites

Are the configuration options backwards compatible (keep settings from older module)?

0

Share this post


Link to post
Share on other sites
Are the configuration options backwards compatible (keep settings from older module)?
Yes! :thumbup
0

Share this post


Link to post
Share on other sites

I would like to install with a dos Instruction and wondering how it goes:

here the cmd:

copy /y "%WINDIR%\system32\Adobe\Director\np32dsw.dll" "%ProgramFiles%\Mozilla Firefox\plugins\"

and my 7z cmd, is this correct with the DOUBLE backslashes (\\) and the double quotes (\")

especially at the end of my code (...plugins\\\")? :unsure:

RunProgram="hidcon:cmd /c copy \"%WINDIR%\\system32\\Adobe\\Director\\np32dsw.dll\" \"%ProgramFiles%\\Mozilla Firefox\\plugins\\\" /y "

Thanks for input.

0

Share this post


Link to post
Share on other sites

hey thanks a lot Oleg, first post as well :P

im still figuring out how to use it but hopefully it wont be too hard :)

amazing tool btw.

0

Share this post


Link to post
Share on other sites

Hi there, thank you for your module. I have a little cosmetic problem: i cannot make shortcut icon to work. This is my simple config.txt:

;!@Install@!UTF-8!
InstallPath="%ProgramFiles%\\JDownloader"
GUIMode="1"
Shortcut="P, {%%T\\JDownloader.exe}, {}, {JDownloader}, {}, {} {%%T\\} {%%T\\JDownloader.exe} {1}"
;!@InstallEnd@!

shorcut is created but icon is blank. Going to properties -> change icon shows that the %ProgramFiles% variable is not expanded correctly (my case is C:\Programmi\JDownloader).

Am i wrong?

Edited by Gremo
0

Share this post


Link to post
Share on other sites
Am i wrong?

Correct variants of a line for your case:

Shortcut="P, {%%T\\JDownloader.exe}, {}, {JDownloader}, {}, {}, {%%T\\}, {%%T\\JDownloader.exe}, {0}"

Shortcut="P, {%%T\\JDownloader.exe}, {}, {JDownloader}, {}, {}, {%%T\\}, {%%T\\JDownloader.exe}"

Shortcut="P, {%%T\\JDownloader.exe}, {}, {JDownloader}, {}, {}, {%%T\\}"

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.