egorss78

PE 2.0 Boot Screen

60 posts in this topic

Anyone know what happens when I replace bootmgr.exe.mui from ie. PL-pl folder to US-us? This also change "Windows is loading files..." text to ie. PL version?

0

Share this post


Link to post
Share on other sites

I'm guessing you want to change the bootloader to another language? If that is the case, then placing the pl version of the bootmgr.exe.mui file in the ISO\boot\en-US folder should work.

If that doesn't work, then you will have create a folder for pl, ISO\boot\pl-PL, and place the bootmgr.exe.mui file in there. Then you will have to change the bootmgr language to pl-PL by modifying the BCD (ISO\boot\bcd).

0

Share this post


Link to post
Share on other sites
I'm guessing you want to change the bootloader to another language?

Yep. I just try to change this "Windows is loading..." text without change in any file (copyrights)

If that is the case, then placing the pl version of the bootmgr.exe.mui file in the ISO\boot\en-US folder should work.

I try - I have only pl-pl folder: \boot\pl-pl\bootsect.exe.mui - still english text...

If that doesn't work, then you will have create a folder for pl, ISO\boot\pl-PL, and place the bootmgr.exe.mui file in there. Then you will have to change the bootmgr language to pl-PL by modifying the BCD (ISO\boot\bcd).

BCDEdit.exe. also works without Vista? AFAIK bcdedit can change boot option off installed OS...

Best regards

MR

Edited by MaciekMR
0

Share this post


Link to post
Share on other sites
If that is the case, then placing the pl version of the bootmgr.exe.mui file in the ISO\boot\en-US folder should work.

I try - I have only pl-pl folder: \boot\pl-pl\bootsect.exe.mui - still english text...

en-US is the default language. Its always going to be in English if you don't put bootmgr.exe.mui in a en-US folder or change the bcd. Rename the pl-pl folder to en-US: \boot\en-US\bootmgr.exe.mui

BCDEdit.exe. also works without Vista? AFAIK bcdedit can change boot option off installed OS...

Yes you can use bcdedit.exe. WinPE 2.0 is based off of the Vista kernel/architecture. Thats why it uses BCD and bootmgr to boot from rather than boot.ini and ntldr.

0

Share this post


Link to post
Share on other sites
Ok. I've got it to work by replacing the green bars with a picture (no animation).

1. Download and install Vista Boot Logo Generator.

2. Run the generator and add a 800x600 24-bit BMP and 1024x768 24-bit BMP.

3. Save the file as winload.exe.mui.

4. Copy and replace the winload.exe.mui file in the \Windows\System32\Boot\en-US directory of your boot image with the new one.

xcopy /y c:\peimage\winload.exe.mui c:\peimage\mount\Windows\System32\Boot\en-US

5. Capture or unmount your image to ISO\sources\boot.wim

6. Disable the gui option of your bcd entry for WinPE.

bcdedit /store c:\peimage\ISO\boot\bcd /set {default} quietboot yes

Now the green bars will be replaced with your picture!

I must give credit where credit is due, I modified the instructions from this website to work for PE:

http://www.howtogeek.com/howto/windows-vis...-windows-vista/

Kudos, as this works great - my WinPE CD shows my custom boot screen just fine.

The boot.wim that I use on my PXE network doesn't show them, though. I think it's because we aren't changing anything - other than copying the MUI to the mount - before we capture/unmount the WIM.

Any thoughts?

0

Share this post


Link to post
Share on other sites

You have to edit the BCD for your PXE boot as well. Did you perform step 6 for your PXE BCD? It should be located at <pxeroot>\boot\bcd.

Edited by zorphnog
0

Share this post


Link to post
Share on other sites

Does anyone have that PEChecksum tool somewhere? I can't get it from the code project (I keep getting an error) :realmad:

TIA!

0

Share this post


Link to post
Share on other sites
Does anyone have that PEChecksum tool somewhere? I can't get it from the code project (I keep getting an error) :realmad:

TIA!

I've attempted to attach the file here:PEChecksum.zip

0

Share this post


Link to post
Share on other sites

Hi Zorphnog,

Instructions for modifying the "Windows is loading files..." text

is Greate !

And I want to do same setting at "WinPE lanboot from Windows Deployment Service on Windows server 2003 std SP2.

I custumized bootmgr.exe.mui at C:\RemoteInstall\Boot\x86\en-US.

But "Windows is loading files..." message is not changed.

It succesed at boot from DVD.

Please tell me how can i set.

Thank you .

0

Share this post


Link to post
Share on other sites
Try putting it in: C:\RemoteInstall\Boot\en-US

Thank you for your Help !!

I Tried it, but i did not success.

I put custumized bootmgr.exe.mui in C:\RemoteInstall\Boot\en-US & C:\RemoteInstall\Boot\x86\en-US.

I did "bcdedit /store c:\RemoteInstall\Boot\x86\default.bcd /set {bootmgr} locale en-US" .

I did "bcdedit /store c:\RemoteInstall\Boot\x86\test.wim.bcd /set {identifier} locale en-US" .

There is "Windows Deployment Services Role" at Microsot TechNet

Associate a language pack with an install image

You can associate multiple language packs with a single image, reducing the number of images you need to maintain. To use a language pack, create the appropriate folder structure and copy the language pack. Language packs are only supported on Windows Vista and Windows Server 2008 operating systems.

If I want to use bootmgr.exe.mui for "WDS", Do i need Windows 2008 server?

Thank you .

0

Share this post


Link to post
Share on other sites

You don't need Windows 2008. WinPE 2.0 is based off the vista architecture so you should be fine. I don't use WDS so I am not familiar with the folder and file structure. Since you say it works on DVD, then it should just be a matter of putting the bootmgr.exe.mui file in the right location. I can't really tell you where that is without seeing the folder structure. Mainly, where are the 'bootmgr' and 'BCD' files?

0

Share this post


Link to post
Share on other sites
You don't need Windows 2008. WinPE 2.0 is based off the vista architecture so you should be fine. I don't use WDS so I am not familiar with the folder and file structure. Since you say it works on DVD, then it should just be a matter of putting the bootmgr.exe.mui file in the right location. I can't really tell you where that is without seeing the folder structure. Mainly, where are the 'bootmgr' and 'BCD' files?

Thank you zorphnog.

I tried several location to putting the bootmgr.exe.mui file in the WDS(Windows deployment service).

But I can't change Message Text & Color at the plogress bar .

I think WDS put the bootmgr.exe to Taget PC by tftp, but WDS does not put bootmgr.exe.mui file to target PC,though bootmgr.exe doesn't know the bootmgr.exe.mui.

Boot from DVD is OK, and boot from WDS with "BCD : quietboot yes" is OK.

If anybody know how to try with WDS, please teach me it.

Thank you everybody.

Edited by n-ikeda
0

Share this post


Link to post
Share on other sites

Has anybody figured out how to do the background and progress bar? John

0

Share this post


Link to post
Share on other sites

Does anyone knoe how to edit the bootmgr.xml? to put a graphic in the background of windows is loading files?? John

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.