Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Terabyte

Can't move Users Profile, ProgramData Folder

Recommended Posts

Hi,

I've downloaded the windows AIK software.

I've created a Autounattend.xml file which I placed on a stick.

The only reason I have done this is so that I can move my Users and ProgramData folder off the C drive.

This is my Autounattend.xml file.

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<FolderLocations>
<ProfilesDirectory>D:\Users</ProfilesDirectory>
<ProgramData>D:\ProgramData</ProgramData>
</FolderLocations>
</component>
</settings>
<cpi:offlineImage cpi:source="wim:d:/temp/vista/install.wim#Windows Vista BUSINESS" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

I tried installing Vista Buisness with it, and when the installation completed, I checked on the location of Users and ProgramData, and found it was still on the C drive rather than the D drive.

Does anybody know what it is I am doing wrong?

Thank you.

Share this post


Link to post
Share on other sites

We had a longer discussion about the methodology that can be used in this thread, and I emailed MRGCAV for any further developments - last I heart from him (about a month ago) He thought he might have had a solution to make it permanent....

I, too, want it moved to another drive, if not another partition, for simplicity sake.

Share this post


Link to post
Share on other sites

Hey,

I did solve the problem.

I shall post the XML file I used as soon as I find it.

Should note, that this is ALL I wanted the install to do, so it's a very simple xml file.

Should be noted the problems that come with doing this aren't well documented...

First of all, the warning on 'upgrades'.

By upgrades they mean moving from Home Premium to Ultimate for example.

Windows Updates will still work but it also has problems, basically, some updates won't install, the solution is to create a copy of the users directory structure on C:\ (where you windows installation is) (temporary) you then delete this structure when the updates are installed. You only run into problems like this with a couple of windows updates, but they are important updates, and will cause all the other updates that follow to 'apparently' fail. Find the problematic update and try to install the updates one by one until all updates except the problematic one have installed.

Share this post


Link to post
Share on other sites
Hey,

I did solve the problem.

I shall post the XML file I used as soon as I find it.

Should note, that this is ALL I wanted the install to do, so it's a very simple xml file.

Should be noted the problems that come with doing this aren't well documented...

First of all, the warning on 'upgrades'.

By upgrades they mean moving from Home Premium to Ultimate for example.

Windows Updates will still work but it also has problems, basically, some updates won't install, the solution is to create a copy of the users directory structure on C:\ (where you windows installation is) (temporary) you then delete this structure when the updates are installed. You only run into problems like this with a couple of windows updates, but they are important updates, and will cause all the other updates that follow to 'apparently' fail. Find the problematic update and try to install the updates one by one until all updates except the problematic one have installed.

I know this is an old thread, but I am currently experiencing the exact same problem that Terabyte had at the top. If somebody has a solution (or if Terabyte is still around and remembers how to fix this) I would greatly appreciate the .xml !

Thanks

Share this post


Link to post
Share on other sites

From all of the posts about

a. users

b. programdata

c. program files

I'm understanding that only program files is safe to move in vista.

Does anybody knows how to modify the autounatend.xml file in order to mov it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×