Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Office 2003 Slipstream with SP3 problem

- - - - -

  • Please log in to reply
44 replies to this topic

#26
pgdalk

pgdalk
  • Member
  • 2 posts
  • Joined 24-September 07

... or more easily to copy the file from the CD to its location on the disk...

ok I did this and now it still wants the cd to copy the SemiTrust dll.. (exactly the same error as the threadstarter)


OUCH ! Sorry about that, I only saw the problem with the FMU DLL file ...
I didn't have the problem with the SemiTrust DLL, so I don't know really what may be the cause of your problem.

Anyway, it seems that there someone found a far better solution to our problems than mine. :whistle: :thumbup


How to remove advertisement from MSFN

#27
radix

radix

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 740 posts
  • Joined 08-February 07
  • OS:Windows 8 x64
  • Country: Country Flag
I slipstreamed SP3 into Office 2003 with SP1 and I made the ISO with CDImage GUI using these switches:
-l -yd -n -h -x -o -m -d
with label CD_ROM
With label Office2003 I have that error from the first post.

#28
spebph

spebph
  • Member
  • 1 posts
  • Joined 27-July 07
Hi,

Tried all of these and still getting the same issue after burning the cd. My cd keeps asking for the office cd to copy Micorsoft.Office.Interop.InfoPath.Semitrust.dll.

Can anyone else help with this?

#29
TheFlash428

TheFlash428

    Advanced Member

  • Member
  • PipPipPip
  • 456 posts
  • Joined 15-September 05
I read through this quickly, so I'm sorry if someone already mentioned it...

When creating the administrative installation used for the SP3 slipstream process, make sure to use the MSINODISABLEMEDIA=1 switch.

Setup.exe /a MSINODISABLEMEDIA=1

This command allows the adminstrative installation to be installed from removable media, such as a CD.
"There are 3 ways to do things: The right way, the wrong way, and the Max Power way!"
"Isn't that the same as the wrong way?"
"Yes--but faster!"

#30
OuTmAn

OuTmAn

    \ ( ^_^) /

  • Member
  • PipPip
  • 103 posts
  • Joined 11-October 04
Hi TheFlash428, thanks for the tip!

I'd like to add this setting to an already administrative source, I think I have to manually add a row in "Property" table of OWC11.MSI and/or PRO11.MSI

am I right?

#31
TheFlash428

TheFlash428

    Advanced Member

  • Member
  • PipPipPip
  • 456 posts
  • Joined 15-September 05

Hi TheFlash428, thanks for the tip!

I'd like to add this setting to an already administrative source, I think I have to manually add a row in "Property" table of OWC11.MSI and/or PRO11.MSI

am I right?


Probably, although I've never tried--good luck!
"There are 3 ways to do things: The right way, the wrong way, and the Max Power way!"
"Isn't that the same as the wrong way?"
"Yes--but faster!"

#32
jvidal

jvidal

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 719 posts
  • Joined 14-November 05
I have the exact same problem. Installation stops while trying to copy the file FM20ENU.DLL. If I copy the entire CD to ANY folder in the HD, it installs perfectly. It also installs perfectly from the CD in a VM.
My CD is labeled O2K3SP3, no spaces and it still doesn't work.

There's an additional problem, though. If you uninstall office, the uninstaller does NOT delete any files. The software appears uninstalled, shortcuts are removed, msi databases are deleted, but the files are not deleted, this does not happen with SP2.

I will try the MSINODISABLEMEDIA=1 Switch and see what happens.

thanks for the tips!

--- EDIT ---

Well, it didn't work.
I will try with a blank label now.I used O2K3SP3 and it didn't work.

--- EDIT ---

Ok, the blank-labeled-CD did the trick, it installed fine.

But, the uninstallation still doesn't work correctly. what could this be?

bye!

#33
pia

pia
  • Member
  • 1 posts
  • Joined 07-August 07

Ok, the blank-labeled-CD did the trick, it installed fine.

But, the uninstallation still doesn't work correctly. what could this be?

bye!


I do confirm: blank-labeled-CD solution works fine but, would you believe it, same uninstallation problem with Office 2003 SP2! We should try slipstreaming sp3 to an untouched (not previously slipstreamed) Office2003 cd

#34
jvidal

jvidal

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 719 posts
  • Joined 14-November 05
That's what I did... I slipstreamed over the original CD, w/o any SP (Doing an admin installation, of course)

And I didn't have that problem with SP2, installation and Uninstallation worked just fine.

bye!

#35
midi2k6

midi2k6

    Junior

  • Member
  • Pip
  • 64 posts
  • Joined 30-November 04
Well! look like so many had so many difference errors here, try this (i did):

* Covert your MS Office 2003 Pro CD to .ISO (so you can mount it to a virtual CD for better read)
* make sure you slipstream with the original CD(no servicepack)
* Slipstream SP3 it with Admin install (google it Office 2000/XP/2003 Slipstreamer)

#36
jvidal

jvidal

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 719 posts
  • Joined 14-November 05
Any new info on this problem?

#37
Anderton

Anderton

    Newbie

  • Member
  • 32 posts
  • Joined 11-May 07

Any new info on this problem?

Critical Update for Office 2003

SUMMARY
Microsoft has released an update to Microsoft Office 2003. This update fixes the following issues that may occur after you install Office 2003 Service Pack 3 (SP3):

• When you try to uninstall Office 2003, the Office folder is removed from the Start menu. Also, Office 2003 appears to have been uninstalled successfully. However, the Office 2003 files are not removed from the computer.
• If you install an Office 2003 suite to your computer by using a custom transform, and then you install the Office 2003 SP3 update, all Office 2003 suite programs are set to Not Installed. Additionally, you may experience one or more of the following symptoms:

  • After you repair Office 2003 or after you first run an individual Office 2003 program, the feature state is set to Not installed. This is true even though the files are still present on the hard disk.
  • When you start an Office 2003 program, you may receive an error message that resembles the following:
    Microsoft program_name has not been installed for this user.
  • When you try to run a macro or open the VBA editor, you may receive an error that states that the VBA macro support has not been installed or that macro security is set to High. Macros do not run, and VBA editor cannot be started.
  • When you try to configure a new mail profile for Microsoft Office Outlook 2003, the Office installation program repeatedly tries to configure the Office 2003 suite.

Note These issues affect only the following language versions of Office 2003:
• Dutch
• French
• Italian
• German
• Portuguese-Brazil
• Spanish
• Swedish

These issues do not affect the English version of Office 2003 or other language versions of Office 2003. This issue does not affect other Microsoft products.

SOURCE
http://support.microsoft.com/kb/943452/EN-US/
DOWNLOAD
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=022bb910-c191-43f0-bed8-33ae04e9ce93
I didn't test this solution yet.

Best regards,
Chads.

#38
OuTmAn

OuTmAn

    \ ( ^_^) /

  • Member
  • PipPip
  • 103 posts
  • Joined 11-October 04
good new! I'd been affected by that 1st issue (when uninstalling, Office folder in Program Files isn't removed... quite disappointing)

Edited by OuTmAn, 16 November 2007 - 01:36 PM.


#39
jvidal

jvidal

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 719 posts
  • Joined 14-November 05
nice!!!

Now it would be cool if it were possible to slipstream this hotfix to the SP3 installation CD...

edit: I just integrated it using mara's integrator, let's see how it works.

Edited by jvidal, 17 November 2007 - 03:49 PM.


#40
jvidal

jvidal

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 719 posts
  • Joined 14-November 05
Alright, great news!
After SS SP3 and the KB943452 Patch, I installed from a CD labeled "OFFICE11" (something I wasn't able to do before). Then, It uninstalled perfectly, so it's safe to say this update solves BOTH installation AND Uninstallation problems.

bye!

#41
OuTmAn

OuTmAn

    \ ( ^_^) /

  • Member
  • PipPip
  • 103 posts
  • Joined 11-October 04
did you also try with spaces in the label?

#42
jvidal

jvidal

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 719 posts
  • Joined 14-November 05
no, but i don't see the need for that.

#43
Kiroupirou

Kiroupirou
  • Member
  • 1 posts
  • Joined 11-June 09
Hi All,

I am actually creating a redistribuable windows xp cd-rom, which also install Office 2k3, .Net and so on and I found a explanation about the problem with the "Microsoft.Office.Interop.Infopath.SemiTrust.dll".

Actually, you will get prompt to insert the Office CD-ROM if you install Office 2003 after the .Net Framework. To correct this, you just need to install Office first, and only then the .Net Package.

:thumbup

#44
Bilou_Gateux

Bilou_Gateux

    Powered by Windows Embedded

  • Member
  • PipPipPipPipPip
  • 768 posts
  • Joined 03-January 04

So, the only possibilities are to modify the PRO11.msi file with Orca or to copy the FM20ENU.DLL file in the system32 folder before installing Office? :unsure:
I hoped in something better.... :whistle: I made a lot of tests but I didn't find any final solution....


for localized versions of Office 2003, integrate office2003-KB943452-FullFile-xxx.exe.

contains FORMMAN20ENU.msp patch which solves issue with FM20ENU.DLL
OS Version = 5.1.2600 Service Pack 3
Platform ID = 2 (NT)
Service Pack = 3.0
Suite = 0x0140
Product Type = 1
Architecture = x86

#45
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • Joined 06-January 10
  • OS:Windows 7 x64
  • Country: Country Flag
Also some help!

French tutorial:

http://www.mediafire.com/?1kccgk09rc144

http://support.micro...kb/891154/en-us

Regards
For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users