xavier73

Making Nero 8 a silent install

151 posts in this topic

I've used the script posted and it works well installing all the components.

I just needed to add this to make Nero not complain about "Windows Installer Service"

start /wait msiexec /unreg
start /wait msiexec /regserver

before the last line that run "SetupX".

But I have a question, is there any switch to change the target directory?

0

Share this post


Link to post
Share on other sites

hi,

can u help me? this is my config.txt of my self extracting archive .... but i cannot remove "Nero scout" and "Nero control center"

Maybe switch NERO_SCOUT=FALSE doesn't work when ADDLOCAL=ALL. And i cannot find the "component id" for Nero Control Center app.

thanks

;!@Install@!UTF-8!
Title="Nero 8.1.1.4"
BeginPrompt="Avviare l'installazione?"
FinishMessage="Installazione completata."
GUIMode="1"
SetEnvironment="c1=NeroToolbar6231A394"
SetEnvironment="c2=NeroBurnRights72CC518F"
SetEnvironment="c3=NeroImageDriveE38B9E06"
SetEnvironment="c4=NeroCDDVDSpeed82602EE0"
SetEnvironment="c5=NeroDriveSpeed7DFFCC12"
SetEnvironment="c6=NeroInfoToolE72D824A"
SetEnvironment="c7=NeroRescueAgentDE0B9FB0"
SetEnvironment="c8=NeroHome2FF8B816"
SetEnvironment="c9=NeroStartSmartB035464E"
SetEnvironment="c10=NeroBurningRomBCAFF604"
SetEnvironment="c11=NeroSoundTrax716FE146"
SetEnvironment="c12=NeroVision57D52359"
SetEnvironment="c13=NeroBackItUpCB9D5429"
SetEnvironment="c14=NeroCoverDesigner7CE8D626"
SetEnvironment="c15=NeroWaveEditorFA3A3F7B"
SetEnvironment="c16=InCDC9AC4AC7"
SetEnvironment="c17=NeroShowTimeD773A6E2"
SetEnvironment="c18=NeroMediaHome53BEFA20"
SetEnvironment="c19=NeroRecode6035F00C"
SetEnvironment="c20=NeroPhotoSnapED1EAF52"
RunProgram="SetupX.exe /qb! /NORESTART ADDLOCAL=ALL REMOVE=%c1%,%c2%,%c3%,%c4%,%c5%,%c6%,%c7%,%c8%,%c9%,%c11%,%c12%,%c13%,%c14%,%c15%,%c16%,%c17%,%c18%,%c19%,%c20% RebootYesNo=No NERO_SCOUT=FALSE serialnum_userval=XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX AgreeToLicense=Yes EULA_AGREEMENT=1"
RunProgram="hdicon:reg DELETE HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run /v NeroFilterCheck /f"
;!@InstallEnd@!

0

Share this post


Link to post
Share on other sites

Hi yiepinhsu,

I did your way. It's working.

Do we really need VCRedistSetup.msi and neroxml.msi? What are those file do?

0

Share this post


Link to post
Share on other sites

I installed Nero 8.1.1 using the Nero8_2.2.au3 installation script and experienced a problem I hope someone can help me solve.

The script installs automatically and does not open the installation dilog box which is used to choose the installation of the InCD program. This program is not installed with the other programs but is turned "off" by the default set by Nero.

When I attempted to install InCD ,after the initial installation of the Nero 8 software, the installation program will reinstall the entire Nero 8 package rather than only adding the InCD program.

Will this reinstallation of the entire Nero 8 package remove the beneficial functions provided by using the Nero8_2.2.au3 installation script?

If it will does anyone know how to add the InCD installation to the Nero8_2.2.au3 installation script?

I have tried to install the InCD program using a stand alone .exe, available from the Nero.com site, but it will not install unless the entire Nero 8 program is uninstalled first.

I would really appreciate anyones help in solving this problem of how to add the InCD program without removing the functions of the Nero8_2.2.au3 installation script. Please help.

Thanks, Zippa634

Nero8_2.2.au3

0

Share this post


Link to post
Share on other sites
I have tried to install the InCD program using a stand alone .exe, available from the Nero.com site, but it will not install unless the entire Nero 8 program is uninstalled first.

I would really appreciate anyones help in solving this problem of how to add the InCD program without removing the functions of the Nero8_2.2.au3 installation script. Please help.

THere is no need to email me a question which is essentially identical to this post.

I didn't write that AutoIt script. Without searching the forums, memory tells me 'boardbabe' had made a Nero script.

Hopefully someone familiar with AutoIt will assist you here.

I merged your topic with this existing topic to better find you the help you seek

shark

0

Share this post


Link to post
Share on other sites

@Shark007 – Please merge thread to this topic instead. [done. thanks.]

@zippa634 – You don't have to reinstall the entire Nero 8 package. Please read through the FAQ regarding InCD.

It's not possible to make the install of InCD unattended if you don't make use of MST-transforms, as far as I know.

In the "Condition" table using Orca, change the feature "InCDC9AC4AC7" from "1=1" to "CC9AC4AC7=0"

See this post to modify the script to handle transforms. ;)

0

Share this post


Link to post
Share on other sites

Thanks Shark007 for moving my post to the appropriate area.

CEoCEo, I trie to install InCD using the method specified by Nero but the installation program turned itself off after the Nero congiguring process. The only way I was able to install InCD was to uninstall the entire Nero 8 program, Clean the registry with Registry Firat Aid, Install the stand alone InCD program, and then reinstall Nero 8 using the silent install. Everything works finw now. Pass this onto anyone else who has the same problem. I do not know how to write code so I did not folow your suggestion to read the post that described the process of changing the installation script. Thanks a lot for all your help in soving this.

Zippa634

0

Share this post


Link to post
Share on other sites

The msi works fine with a /q switch as long as you install the neroxml.msi and VCredist.msi before that. Run the msi with the 1033.mst transform and change the properties to select which Features to install.

Now...my problem is that I need to make an admin install so I can deploy the app using Radia. Another forum member posted a similar issue with Nero 7.x.x.x. After the admin install is created, the cab files get extracted to [FILELOCATION] folders. When you try to run the msi from the admin point, it faill. The log says it fails on the RunLicenseDialog action but I ahve looked for it and it shouldn't be causing any problems. I think the msi is confused as to what to look for.

Anyone had a similar problem?

I've actually mailed Nero support to ask them to create and admin install and try run it from a test machine of theirs.

0

Share this post


Link to post
Share on other sites

So how do you install InCD with the script? Installing it afterwards with the Nero ControlCenter doesn't work and just gives me this error:

New features have been selected for install. The installer detected that the installer files are not available. You will only be able remove existing features. To install new features, please cacel the installation, make the original media or the downloaded installer available and start the update from there.

nero.png

Edited by gyrfalcon
0

Share this post


Link to post
Share on other sites

i'm trying to install nero 8 on unattended vista but the problem is that it asks for a reboot (e.g windows update) and i use WPI to install nero but after the reboot WPI doesn't run. is there a way to install nero 8 without having to reboot??

i've tried all solutions mentioned above, they work on XP but i want to work on VISTA

Edited by exhaler
0

Share this post


Link to post
Share on other sites

this sometimes happens with xp too. If u are starting with a bunch of installations, choose nero to install first.

0

Share this post


Link to post
Share on other sites
The problem still the same. I follow step by step as you mentioned.

The message :

"A system reboot was requested by previous software installation (e.g. a Windows update). Please reboot your computer to resume the installation of Nero 8 Demo".

Add this line to your script just before invoking nero installer:

reg delete "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager" /v PendingFileRenameOperations /f

This will solve your problem.

0

Share this post


Link to post
Share on other sites

Some suggestions for CEoCEo's Nero AutoIt script. Based on version 2.2

To hide the extracting window, add this to the top of your script:

; Options
AutoItSetOption("WinTitleMatchMode", 2)
AutoItSetOption("WinWaitDelay", 1)

And this right after line 149, before the Else statement:

WinWait("Extracting", "")
WinSetState("Extracting", "", @SW_HIDE)

But this might not work for non english distributions.

Add an option to unregister Nero DirectShow Filters. Something like this:

$UND = 1; UnRegister Nero DirectShow Filters

; UnRegister Nero DirectShow Filters
If $UND = 1 Then
$search = FileFindFirstFile(@CommonFilesDir & "\Nero\DSFilter\*.ax")
While 1
$file = FileFindNextFile($search)
If @error Then ExitLoop
RunWait("regsvr32 /u /s " & $file, @CommonFilesDir & "\Nero\DSFilter", @SW_HIDE)
WEnd
EndIf
FileClose ( $search )

0

Share this post


Link to post
Share on other sites

With CEoCEo script 2.2, and Nero 8.3.2.1 I am still getting this error right after Windows XP unattended finishes:

post-22395-1209997613_thumb.jpg

Install during unattended windows XP at RunOnceEx stage fails with this error:

"Installation of Nero failed by an unknown reason"

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.