Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Making Nero 8 a silent install

- - - - -

  • Please log in to reply
150 replies to this topic

#51
bober101

bober101
  • Member
  • 6 posts
im having problems witht eh script, can u explain how and where does the script look for its self when adding to runonce, as im having trouble ,i get an error that the startup app isisnt found.


How to remove advertisement from MSFN

#52
CEoCEo

CEoCEo

    Junior

  • Member
  • Pip
  • 64 posts

im having problems witht eh script, can u explain how and where does the script look for its self when adding to runonce, as im having trouble ,i get an error that the startup app isisnt found.

Really strange :blink: , it's working here...look at line 118 regarding the RunOnce sequence.
I'm using commands other working scripts are using, simple @AutoItExe to specify where the script is located even if it's compiled or not.
Does this script work for anyone?
* Antec P180B / Antec Neo HE550EC / GA-X38-DQ6 / C2D E6600@3.2GHz
Nero 8 AutoIt script

#53
bober101

bober101
  • Member
  • 6 posts
thing is im running the setup from my dvd drive..i guess thtas why.

#54
SuperDuy

SuperDuy
  • Member
  • 5 posts
I have the same problem I get the error and then restart then nothing comes up.

How do I disbable cleaners?

And where does it extract to?

Mine doesnt have a documents and settings folder.

Edited by SuperDuy, 18 October 2007 - 07:09 PM.


#55
ricktendo

ricktendo

    Group: Banned Members

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,298 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Just want to report that RunOnce worked for me.

#56
bober101

bober101
  • Member
  • 6 posts

Just want to report that RunOnce worked for me.


when is ure installer called,@t12-t13 or at runonceex?

#57
ricktendo

ricktendo

    Group: Banned Members

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,298 posts
  • OS:Windows 7 x64
  • Country: Country Flag

Just want to report that RunOnce worked for me.


when is ure installer called,@t12-t13 or at runonceex?

WPI... I got the RunOnce pop up from the autoit installer (it exited on its own) then WPI continued installing the rest of my programs. On reboot Nero setup restarted, it extracted and installed successfully.

#58
CEoCEo

CEoCEo

    Junior

  • Member
  • Pip
  • 64 posts

How do I disbable cleaners?

Maybe I can implement this… ;)

And where does it extract to?

It’s extracted to the environment variable %TEMP% together with generated folder NERO*

Thanks again ricktendo64, that’s exactly what the script is intended to do. Maybe we all can conclude that this script doesn’t work @t-12 or @t-13? :unsure:
* Antec P180B / Antec Neo HE550EC / GA-X38-DQ6 / C2D E6600@3.2GHz
Nero 8 AutoIt script

#59
Gorki

Gorki

    Junior

  • Member
  • Pip
  • 50 posts
Well I did not manage to install it once again...
On first logon installation fails,after restart (second logon) installation continues,extracts,tries to configure and install than BANG...look at the screenie...

Posted Image



#60
Sanjay

Sanjay

    Member

  • Member
  • PipPip
  • 273 posts
I tried the script in a real unattended install and I am glad to report the installation went of perfectly, except for one small problem:
$UN = ""; UserName
$CN = ""; CompanyName
which seemed to work fine with the Nero 7 scripts, does not work here and I ended up with blanks where there ought to be the User and Company names. I would like to point out that I had simply made the above change to the scipt myself, so in case there are any other required changes that were made by CEoCEo to make this work, then that may be the problem. I compared my script with that of CEoCEo and my simply just making the above change is not enough since the script requires further entries to make it work. Lesson learnt, in future be more careful.

Thanks.

Edited by Sanjay, 19 October 2007 - 07:16 PM.


#61
bober101

bober101
  • Member
  • 6 posts
ill be trying an other way to install nero witht he script, instead of pakign the works in a sfx, ill leave all files ina folder and run the install from there on the disc,my guess is in a sfx,the temp files get deleted..so thtas prolly why teh script wasint finding the required files to finish setup,but ill launch it via a cmd file, i should launch it directly from the autoit script but i have some custom things that i want with my nero install,if it dosent work,ill try directly form the compiled autoit exe.if it still dosent work,i think adding support to search optical drives for the said file to finishup might be required.....

#62
SuperDuy

SuperDuy
  • Member
  • 5 posts
Anyonw figure it out?

#63
radix

radix

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 738 posts
  • OS:Windows 8 x64
  • Country: Country Flag

Anyonw figure it out?

No man. It not works. Nor in a clean Windows installation. I have that error Nero 8 installation failed.

#64
SuperDuy

SuperDuy
  • Member
  • 5 posts
How do i disable clean sofware on vista?

i dont have ccleaner.

#65
bober101

bober101
  • Member
  • 6 posts

How do i disable clean sofware on vista?

i dont have ccleaner.



Lolol what?


edit:ok finaly got nero 8 working via runonceex, at runonceex,i called the autoit script from a folder instaed of an sfx,and its called directly to the .exe not via cmd.and also,all is being installed from the disc.

Edited by bober101, 21 October 2007 - 10:36 AM.


#66
SuperDuy

SuperDuy
  • Member
  • 5 posts
So what exactly did you do?

#67
ricktendo

ricktendo

    Group: Banned Members

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,298 posts
  • OS:Windows 7 x64
  • Country: Country Flag

So what exactly did you do?

Don't pack it with 7zip or WinRAR, because they are extracted to temp files which are deleted and cannot be called from again when you restart.
Just put the autoit installer and the Nero installer in a directory (such as WPI install directory on your disk) and call it from there, you will get a RunOnce box and the installer will fail, then during next boot the nero installer should run and install successfully during second login.

Edited by ricktendo64, 21 October 2007 - 01:04 PM.


#68
SuperDuy

SuperDuy
  • Member
  • 5 posts

So what exactly did you do?

Don't pack it with 7zip or WinRAR, because they are extracted to temp files which are deleted and cannot be called from again when you restart.
Just put the autoit installer and the Nero installer in a directory (such as WPI install directory on your disk) and call it from there, you will get a RunOnce box and the installer will fail, then during next boot the nero installer should run and install successfully during second login.


Yes I dont have it is in a folder to the desktop where does the files extract later though.

#69
CEoCEo

CEoCEo

    Junior

  • Member
  • Pip
  • 64 posts
@SuperDuy – I have already answered your question, please look here.

I have worked further with the script for you users to test... :D

Changelog: 2.2
* Added: Major internal changes and revamped install routine
* Added: Optional fixed location for already extracted files
* Added: Option to delete extracted and temporary files after successful install
* Added: Optional restart procedure and internal support for 'GUIRun'

The big change is that the installer now tries to install anyway, even if file rename operations are pending and the extracted content can be reused after restart.
Please read the FAQ regarding the installation over at NeroAG site if you still have issues.

Script is found in my signature :hello:
* Antec P180B / Antec Neo HE550EC / GA-X38-DQ6 / C2D E6600@3.2GHz
Nero 8 AutoIt script

#70
radigast

radigast

    Junior

  • Member
  • Pip
  • 79 posts
I have 2 questions about the Nero 8.1.1.0b autoit script.

First:
For the variable $ID, what is wrong with my installation directory code? The script generated an error during install saying my installation directory was not valid.

Here is a screenshot-->Attached File  AutoIT_Error.jpg   94.06KB   60 downloads

Below is the code I used in the .au3 file:

$ID = @ProgramFilesDir & "\Nero"


Second:
I don't understand what I need to put for the $EF variable. I have just been leaving it blank, as I am simply running the .exe package I directly downloaded from Nero. Is that what I should be doing?

$EF = ""; Already extracted folder example: $EF = "D:\Apps\Extracted\Nero8"


Any help to these questions would be greatly appreciated! Thanks a lot for the amazing script, btw!

Edited by radigast, 27 October 2007 - 12:43 AM.

Only in America do we have drive up ATM's with braile on them.

#71
CEoCEo

CEoCEo

    Junior

  • Member
  • Pip
  • 64 posts

Any help to these questions would be greatly appreciated! Thanks a lot for the amazing script, btw!

You don't have to specify any path when using this script. Leave these settings blank as it will use the standard directory for your programs anyway. These settings are for more experienced users who want to install in/from a different location and they have to be fixed as it seems it will not work when adding macros like @ProgramFilesDir.
* Antec P180B / Antec Neo HE550EC / GA-X38-DQ6 / C2D E6600@3.2GHz
Nero 8 AutoIt script

#72
yadzil

yadzil

    Junior

  • Member
  • Pip
  • 69 posts
Hi CE0Ceo,

Thanks for the script. But I still cannot install nero 8 with or without the script. The msg said "the wizard was interupted before nero 8 demo before completely installed" keep appear. Can u help me?

#73
CEoCEo

CEoCEo

    Junior

  • Member
  • Pip
  • 64 posts
@Yadzil - This is not an easy problem to solve because there are so many aspects that need to be looked at. I really do hope you don't get this right after an unattended installation, otherwise you are in real trouble finding what is causing this message. :no:
Please look through the installation-FAQ… and if that is not helping, you should try Nero CleanTool. After a quick search on other forums there can be troubles with ASPI-layers and certain configurations, but that one is really rare. Otherwise I'm clueless… :wacko:
* Antec P180B / Antec Neo HE550EC / GA-X38-DQ6 / C2D E6600@3.2GHz
Nero 8 AutoIt script

#74
yadzil

yadzil

    Junior

  • Member
  • Pip
  • 69 posts
Thanks CEoCeo.

I manage to install Nero 8. Seem Nero 8 needs windows update need to be enable.

But I think this methode is the simplest. Even it like the previous version of nero silent install.

But what the different the swicth '/qb' and '/qb!' that been used in nero version 7?

#75
kid1988

kid1988
  • Member
  • 3 posts
I used the script from the first page, then slightly adjusted it it works, also customized...:
@echo off
title Nero 8.1.2.0
echo.
echo Updating DirectX 9c Redistributable...
start /wait Data\Redist\DirectX\dxsetup.exe /silent
echo.
echo VCR...
start /wait Data\Redist\VCRedistSetup.msi /passive /norestart
echo.
echo Nero XML...
start /wait Data\Redist\neroxml.msi /passive /norestart
echo.
echo KB884016 v2...
start /wait Data\Redist\WindowsInstaller-KB884016-v2-x86.exe /passive /norestart
echo.
it works without the first lines, but you do need some of the files in that part
this is the part I edited:
@echo off
title Nero 8.1.2.0
echo Installing Nero Premium 8...
start /wait SetupX.exe /qb! /NORESTART ADDLOCAL="NeroBackItUpCB9D5429,NeroBurningRomBCAFF604,NeroBurnRights72CC518F,NeroStartSmartB035464E" RebootYesNo="No" NERO_SCOUT="FALSE" serialnum_userval="**SERIAL HERE***" AgreeToLicense="Yes" EULA_AGREEMENT=1

as you can see I only installed BackItUp, BurningRom, Burn Rights and SmartStart

full list of avalabel features:
NeroBackItUpCB9D5429
NeroBurningRomBCAFF604
NeroBurnRights72CC518F
NeroCoverDesigner7CE8D626
NeroFastCDDVDBurningPluginC5AB9CFD
NeroHome2FF8B816
NeroMediaHome53BEFA20
NeroPhotoSnapED1EAF52
NeroRecode6035F00C
NeroShowTimeD773A6E2
NeroSoundTrax716FE146
NeroStartSmartB035464E
NeroCDDVDSpeed7DFFCC12
NeroInfoTool7AB7A0CD
NeroVision57D52359
NeroWaveEditorFA3A3F7B
InCDC9AC4AC7
I got these from a NERO 7 installation so they might not all work

to bad smartstart keeps crashing on my pc (vista ultibate x64)

Edited by kid1988, 01 November 2007 - 03:15 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN