Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Photoshop 7.0 & 8.0 silent install

- - - - -

  • Please log in to reply
76 replies to this topic

#51
Astalavista

Astalavista

    MSFN loyalist

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,338 posts
  • Joined 02-December 03
stevenp
We DO NOT allow discussion of CRACKs and WAREZ here.



How to remove advertisement from MSFN

#52
stevenp

stevenp

    Newbie

  • Member
  • 23 posts
  • Joined 07-July 04

stevenp

We DO NOT allow discussion of CRACKs and WAREZ here.

Yehyeh already removed them... But anyway that is my own thing then, but my way still works to skip the activation at the setup, then you'll get that same pop-up when you start it for the first time..

#53
CHANDER

CHANDER

    Junior

  • Member
  • Pip
  • 63 posts
  • Joined 19-January 05
OK I got it working and its doing a totaly silent install with the ISS file :thumbup

but now what if I want to be able to see the progress bar so that I am sure that it is installing and not frozen or stuck somewhere. Is there another switch I can use besides the /s to make it less silent?

And another question...I am making an unattended CD so the user info will be different for each person, is there a way to access the user name variable and put it in the ISS or the abcpy.ini file?

Thanks
Admision free, pay at the door; Pull up a chair and sit on the floor.
One bright morning in the middle of the night; 2 dead boys got up to fight.
Back to back they faced each other; drew there swords and shot eachother.
A deaf policeman who heard all the noise; came to kill those 2 dead boyz.
If you don't believe my lie is true; go ask the blind man he saw it to.

#54
stevenp

stevenp

    Newbie

  • Member
  • 23 posts
  • Joined 07-July 04

OK I got it working and its doing a totaly silent install with the ISS file :thumbup

but now what if I want to be able to see the progress bar so that I am sure that it is installing and not frozen or stuck somewhere. Is there another switch I can use besides the /s to make it less silent?

And another question...I am making an unattended CD so the user info will be different for each person, is there a way to access the user name variable and put it in the ISS or the abcpy.ini file?

Thanks

Change to following value in Abcpy.ini:
DisplayProgressBar=NO
must become
DisplayProgressBar=YES
I think it will work, not shure about it!

#55
TheNewEvil

TheNewEvil
  • Member
  • 1 posts
  • Joined 23-January 05
I've got another Problem, I fixed the "Abcpy.ini" as it is told above, it works fine but at the end of the installation a window pops up and tell me about the registration. Is it possible to fix that ? I know how to fix the registration :-) but not that the window pops up.

#56
CHANDER

CHANDER

    Junior

  • Member
  • Pip
  • 63 posts
  • Joined 19-January 05
@stevenp thanks il try that

@TheNewEvil try looking through the first couple of pages in this topic

Edit: Nope...that wouldnt work because when you run the setup with the -s switch it reads the .iss file and so doesnt show any visable progress....a true silent install
Admision free, pay at the door; Pull up a chair and sit on the floor.
One bright morning in the middle of the night; 2 dead boys got up to fight.
Back to back they faced each other; drew there swords and shot eachother.
A deaf policeman who heard all the noise; came to kill those 2 dead boyz.
If you don't believe my lie is true; go ask the blind man he saw it to.

#57
Niktareum

Niktareum

    Newbie

  • Member
  • 31 posts
  • Joined 11-November 04
I've made a first install to obtain the setup.iss file, i write the Abcpy.ini like Crispy says.

I made this batch :
@ECHO OFF
ECHO.
ECHO Installation de Photoshop CS 8.0
ECHO Veuillez Patienter...
START /WAIT setup.exe /S
ECHO.
ECHO Enregistrement de Photoshop CS 8.0
ECHO Veuillez Patienter...
START /WAIT register.exe
ECHO.
ECHO Patch pour valider les icones vignettes de Photoshop CS 8.0
ECHO Veuillez Patienter...
START /WAIT 1-fix.exe
REGEDIT /S 2-fix.reg
ECHO.
ECHO Re-installation de Photoshop CS 8.0 pour validation du patch
ECHO Veuillez Patienter...
START /WAIT setup.exe /S
ECHO.
ECHO Enregistrement de Photoshop CS 8.0
ECHO Veuillez Patienter...
START /WAIT register.exe

Register.exe is a sfx who contains :
adobelm.dll and tw10122.dat
Path=%programfiles%\Adobe\Photoshop CS
SavePath
Silent=1
Overwrite=1

The patch is for a bug of photoshop 8.0CS.
If you install photoshop 7.0, the psd icons is the picture in the psd file, but it's doesn't work with photoshop8.0, it's a known bug.
To resolve it, you make copy one file and write a key in regedit.
So, 1-fix.exe is a sfx who contains :
psicon.dll (obtain from a photoshop 7 installation)
Path=.\%programfiles%\Fichiers communs\Adobe\Shell
SavePath
Silent=1
Overwrite=1
The 2-fix.reg contains :

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs]"C:\\Program Files\\Fichiers communs\\Adobe\\Shell\\psicon.dll"=dword:00000001

[HKEY_CLASSES_ROOT\.psd\ShellEx]

[HKEY_CLASSES_ROOT\.psd\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
@="{0B6DC6EE-C4FD-11d1-819A-00C04FB69B4D}"

[HKEY_CLASSES_ROOT\CLSID\{0B6DC6EE-C4FD-11d1-819A-00C04FB69B4D}]
@="Photoshop Icon Handler"

[HKEY_CLASSES_ROOT\CLSID\{0B6DC6EE-C4FD-11d1-819A-00C04FB69B4D}\InProcServer
32]
@="C:\\Program Files\\Fichiers communs\\Adobe\\Shell\\psicon.dll"
"ThreadingModel"="Apartment"


The problem is for the activation of this patch (1-fix.exe and 2-fix.reg) is the re-install of photoshop CS 8.0, if you doesn't re-install photoshop the fix doesn't work !!

So, the fourth and fifth section of my batch is the re-install of photoshop and re-install of my registration.

And my batch work perfectly :thumbup huhu !!!
Approx 1min for my batch (barton3000+, nforce2, 2*512Mo ddr @ 333mhz, 7200tpm hdd)

Sorry for my really poor english, but i'm tired :blushing: :D

#58
Worf

Worf

    Worf

  • Member
  • PipPip
  • 189 posts
  • Joined 26-October 04
I have posted this before but instead of being posted in this section it was posted as a new topic by mistake so i have reposted it in here.

Hope it's ok?


Here is how stopped the activation screen comming up after installing PhotoShop CS 8.

I the abcpy.ini file scroll down untill you see the following:

[LauncherApp]
Launch=YES

Just replace the "YES" with "NO"

No activation screen will come up untill you start PhotoShop.

Example:

;--Launch Objects
[Launches]
NumberOfLaunches=0
Launch1Platform=All
Launch1Language=All
Launch1Type=EXE
Launch1Program=Install.exe
Launch1CmdLine=
Launch1ChangeDir=$Source\Disk1
Launch1Wait=YES


[LauncherApp]
Launch=NO


#59
Niktareum

Niktareum

    Newbie

  • Member
  • 31 posts
  • Joined 11-November 04
Tnx for the tips worf, i modify my .ini .

#60
Astalavista

Astalavista

    MSFN loyalist

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,338 posts
  • Joined 02-December 03
Guys a little warning for all of you.

If you are using the Corp Edition which does not require Activation

the command line has changed. Use only setup.exe no need for switches.

setup.exe /s /sms -f2c:\\Photoshop.log ---> Standard Photoshop CS
setup.exe ----> Corp Edition

using the standard Abcpy.ini

#61
davo007

davo007
  • Member
  • 6 posts
  • Joined 08-February 05
I found this method for Photoshop CS works quite well.....and also found that it works very well for premiere pro 1.5....lets you activate on first start of the application...nice work crispy :)

#62
herofryar

herofryar
  • Member
  • 3 posts
  • Joined 15-February 05
I have tried the method for Photoshop 7 and i still see all the dialogs but I don't have to give any input.

I will post my .ini file shortly, if some could have a look and suggest what to change i would be grateful.

Also I am using the RunOnceEx method on my unattended install of XP and the next command after Photoshop is a .cmd file to delete some shortcuts and then reboot the pc after 1 minute, this run half way through the Photoshop installation so the installation of Photoshop fails, anyone any ideas?

#63
patrick_malina

patrick_malina
  • Member
  • 2 posts
  • Joined 24-February 05
I get it. I installed Photoshop 7 with -R switch, then copied setup.iss to the installation folder, and DELETED Abcpy.ini and run silent install with -s switch. No dialogs and program is still working.

Enyone can help me with Corel Draw 10?

#64
Swimming_Bird

Swimming_Bird

    I want the NHL Back

  • Member
  • PipPipPip
  • 378 posts
  • Joined 12-October 04

I have posted this before but instead of being posted in this section it was posted as a new topic by mistake so i have reposted it in here.

Hope it's ok?


Here is how stopped the activation screen comming up after installing PhotoShop CS 8.

I the abcpy.ini file scroll down untill you see the following:

[LauncherApp]
Launch=YES

Just replace the "YES" with "NO"

No activation screen will come up untill you start PhotoShop.

Example:

;--Launch Objects
[Launches]
NumberOfLaunches=0
Launch1Platform=All
Launch1Language=All
Launch1Type=EXE
Launch1Program=Install.exe
Launch1CmdLine=
Launch1ChangeDir=$Source\Disk1
Launch1Wait=YES


[LauncherApp]
Launch=NO

<{POST_SNAPBACK}>

this did not work for me
AIM: laxcmx
MSN: roi_roy@hotmail.com
IRC: Swimming_Bird @ irc.rizon.net

#65
Swimming_Bird

Swimming_Bird

    I want the NHL Back

  • Member
  • PipPipPip
  • 378 posts
  • Joined 12-October 04
I have tried all sorts of things i cant kill the activation

here is how i'm calling it
prog[pn]=['Adobe Photoshop 8 CS']
uid[pn]=['PSCS']
desc[pn]=['Powerful Photo Editor']
cmd1[pn]=['%cdrom%\\$OEM$\\Install\\Adobe.Photoshop.8.CS\\setup.exe /s /sms /f2"%TMP%\\Photoshop.log']
dflt[pn]=['yes']
cat[pn]=['Multimedia Editors']
pn++

here is my ABCPY.ini
[OEM Install]
DisplayWelcomeDlg=NO
DisplayEULA=NO
DisplayXPDialog=NO
DisplayTypeOfInstallDlg=NO
DisplaySelectDestDirDlg=NO
DisplayCustomDlg=NO
DisplayUserInfoDlg=NO
DisplayConfirmRegDlg=NO
DisplayStartCopyDlg=NO
DisplayFinishDlg=NO
DisplayFinalMessage=NO
DisplayRebootDlg=NO
ProgGroupName=
DefaultDestDir=
FName=Tal
LName=Atlas
MI=E
UserCompanyName=Skynet
UserSerialNumber=xxxxxxxxxxxxxxxxxxxxxxxxxx
DisplayBackGround=YES
DisplayProgressBar=YES
ProgressBarStart=YES
ProgressBarEnd=YES
It runs silently untill the activation diologue

i tried removing this part from abcpy.ini but it still ran

;--Launch Objects
;[Launches]
;NumberOfLaunches=0
;Launch1Platform=All
;Launch1Language=All
;Launch1Type=EXE
;Launch1Program=Install.exe
;Launch1CmdLine=
;Launch1ChangeDir=$Source\Disk1
;Launch1Wait=YES


;[LauncherApp]
;Launch=NO

I removed them by placing the ; in front.



If someone could tell me the taskname i could just kill it but i cant figure out what the task's name is.
AIM: laxcmx
MSN: roi_roy@hotmail.com
IRC: Swimming_Bird @ irc.rizon.net

#66
Swimming_Bird

Swimming_Bird

    I want the NHL Back

  • Member
  • PipPipPip
  • 378 posts
  • Joined 12-October 04
when i do /s /sms /f2"%TMP%\\Photoshop.log the setup runs silently (i only know its running cuz it shows up in the prossies) but does nothing. it just closes and doesnt install. but when i just call the setup.exe straight up it does everything silently except it still asks for activation
AIM: laxcmx
MSN: roi_roy@hotmail.com
IRC: Swimming_Bird @ irc.rizon.net

#67
snas

snas
  • Member
  • 1 posts
  • Joined 22-April 05
سسسس

#68
zoobooboozoo

zoobooboozoo

    Junior

  • Member
  • Pip
  • 53 posts
  • Joined 01-October 04
and how can I integrate the install with plugins that i use ?

#69
mr.bo

mr.bo

    Newbie

  • Member
  • 12 posts
  • Joined 24-March 05
Ok, this may be a little off topic. I've got Photoshop all installed but want to have my preferences imported with the install. Does anyone know the file, or keys where the preferences are kept? I haven't had any luck with my searches.

#70
Refund

Refund
  • Member
  • 1 posts
  • Joined 13-June 05
Okay, sorry, but I'm an absolute id*** and I don't get any of this stuff.

I have Photoshop CS, and my 30 day "grace" period has just ended. Now, whenever I open Photoshop CS, the activation window comes up. However, when I try to active, it doesn't work (because the serial was 111-1111-1-1-1-1, just all ones) So I need to find some way of making that window NOT come up, and I can just run CS without any interference.

I tried finding that .ini file but with no luck...

Can anyone help?

And I need clear directions lol. They would be appreciated.

#71
Mojo

Mojo

    Newbie

  • Member
  • 21 posts
  • Joined 23-August 05

I have Photoshop CS, and my 30 day "grace" period has just ended. Now, whenever I open Photoshop CS, the activation window comes up.
So I need to find some way of making that window NOT come up, and I can just run CS without any interference.

Maybe you should try to buy a legitimate copy? :whistle:

The whole idea of this activation popup is that you can't get past it... otherwise people don't pay for the software anymore... B)

#72
Sxyman815

Sxyman815
  • Member
  • 6 posts
  • Joined 08-October 04
There is a way to not show the activation window!

Although you must activate it through a normal install, then copy some files to a certain location before doing a silent install.

This is the way it works.

Do a complete install of Photoshop 8 CS then activate it however you like.

Once you have completed the installation go into %systemdrive%\Program Files\Adobe\Photoshop\

There will be 2 files there and or in activation which are called AdobeLM.dll and Tw10122.dat

Take both of those files and place them in a winRAR SFX file so the file structure looks like this

One folder called activation with both of the files in it. and both of the same files outside of the folder..... confused?

SFX

Attached File  screen.jpg   69.55KB   182 downloads

Ok now that you understand that.....
Select the option to extract to a specific location make it extract to
%systemdrive%\program files\adobe\photoshop\
thats the default location!
Also make it overwrite any existing files just in case.
and make it a silent install!

Also I edited the abcpy.ini so it looks like this

;***************************************************************
;Adobe Installer External Configuration File: Abcpy.ini
;***************************************************************

;***************************************************************
;Main Section
;The (Product) key is a required key
;***************************************************************
[MAIN]
Product=Adobe Photoshop 8.0


;***************************************************************
;OEM Installation Options
;***************************************************************
[OEM Install]
DisplayWelcomeDlg=NO
DisplayEULA=NO
DisplayXPDialog=NO
DisplayTypeOfInstallDlg=NO
DisplaySelectDestDirDlg=NO
DisplayCustomDlg=NO
DisplayUserInfoDlg=NO
DisplayConfirmRegDlg=NO
DisplayStartCopyDlg=NO
DisplayFinishDlg=NO
DisplayFinalMessage=NO
DisplayRebootDlg=NO
ProgGroupName=
DefaultDestDir=C:\Program Files\Adobe\Photoshop
FName=yourname
LName=yourlastname
MI=yourmiddleinitial
UserCompanyName=adobe
UserSerialNumber=xxxxxxxxxxxxxxxxxxxx
DisplayBackGround=NO
DisplayProgressBar=NO
ProgressBarStart=NO
ProgressBarEnd=NO

Plus the rest of it but no editing was done down there

Also I needed no .iss

OH YEAH and on your WPI/RUNONCE
First command line "%CDROM%\Install\Photoshop\winRAR.activation.sfx.exe"
second is just "%CDROM%\Install\Photoshop\setup.exe"

or %systemdrive% instead of %CDROM%

I hope I have helped everyone.

Please leave me some feedback! this is my first time trying to help.

Edited by Sxyman815, 10 September 2005 - 08:33 PM.


#73
bobthenob

bobthenob

    Member

  • Member
  • PipPip
  • 120 posts
  • Joined 25-November 05
hi Sxyman815
ive followed your way of doing a slient install of photoshop
but i still get the activastion screen
the two files are in a self extracting file 2outside folder 2 inside folder activation
ive edited the abcpy.ini
I dont no were im going wrong
I know the files work tryed it after installing?
Thanks bobthenob

#74
BoardBabe

BoardBabe

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,419 posts
  • Joined 04-October 04
@Sxyman815: Is'nt it true that this will only activate on the same computer as you installed and grabbed the activation files from?
BoardBabe

#75
bobthenob

bobthenob

    Member

  • Member
  • PipPip
  • 120 posts
  • Joined 25-November 05
cheers for your reply ill test that out
thats a bit of a pain but thanks for this great site just getting into ua cds
cheers




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users