Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


vegettoxp

Vista Setup Screen Info?

35 posts in this topic

Hey Guys, I hope this is the right place to ask this question. I was wonder when are we gona start a thread on Customizing Vista Setup Screen. If there is a thread already started, they I am sorry and an you point me to that thread. I wanted to Edit my Vista Setup Screen, but I don't know which files to edit. Also what software can I use to edit those DLL files. If you guys can give me a jump start, I might look for those files myself and share my findings with you guys. So if someone can comment to this topic, it would really help me get started.

THX :thumbup

P.S. Fusion :hello:

0

Share this post


Link to post
Share on other sites

w32uiimg.dll and w32uires.dll located at sources folder in Vista DVD

0

Share this post


Link to post
Share on other sites

And which program do I use Neo to edit these DLL Files.

0

Share this post


Link to post
Share on other sites

Use ResHacker, Resource Tunner (Recommeded but available TRAIL)

0

Share this post


Link to post
Share on other sites

First of all Neo, thx for all your help man. Neo I hate to keep bugging you, but I am guessing that the DLL files you gave me are just the starting points right? And I am pretty sure there are more. My question to you Neo is that, What is the best way to find all the DLL Files for the Setup Process? Do I go threw all the DLL or are there any Special Ones for the Setup Process? So if you can comment on this topic, that would REALLY help me out. Once again, thx for all the help man.

P.S. Fusion

0

Share this post


Link to post
Share on other sites
w32uiimg.dll and w32uires.dll located at sources folder in Vista DVD

Not if you removed all files exept boot.wim and install.wim from the sources folder.

Then use the files in the mounted install.wim

0

Share this post


Link to post
Share on other sites

Thats very interesting.... ;) Iwoudlso change my setup screens, but i didnt found the resources, So i play a little animation film during the first time of setup. Is it possible to have sound :whistle: at the vista setup ? In the XP setup process it runs fine at T32...

0

Share this post


Link to post
Share on other sites

Mhhh, i didnt found the setup wallpaper with resource tuner in this files.... Anyone knows more about the setup screens ?

I changed the winpe.bmp, and the setp starts with my new wallpaper, but only a few seconds and "bam" ther was the old style on the screen... :blink:

0

Share this post


Link to post
Share on other sites

:thumbupHi, i had (partially???) success !!! But Im a little bit confused. There are so much files inside and outside of the Wim Files, and i made my work at home and at workplace, so i dont remember, which files i had patched. I believe they had all the text string "img" in the filename, so you should look in this files for Images. Some had bmp,some png files inside. Im still testing...

post-35954-1196264924_thumb.jpg

0

Share this post


Link to post
Share on other sites

bumping...

I have modified spwizimg.dll inside \sources\ folder, it work when I start setup from Windows, but if I run setup from CD (bootable), the default vista background is shown, I mounted install.wim and found spwizimg.dll inside \Windows\system32\ folder, edited it, rebuild ISO test and it still the same...

so any idea how to?

0

Share this post


Link to post
Share on other sites

Its not install.wim,

but boot.wim Image 2

u have to mount boot.wim #2 image and edit required files in sources folder of it.

0

Share this post


Link to post
Share on other sites

ahhh... thanks Innocent Devil for the tips, it's working right now :)

0

Share this post


Link to post
Share on other sites

Can you help me on this please, I followed your instructions but still I cannot change the Autoplay screen of Vista when opened in Windows mode, though the setup in DOS mode is working fine. Thanks.

0

Share this post


Link to post
Share on other sites

Edit spWizImg*.dll in source folder and replace the last bitmap object in the DLL.

0

Share this post


Link to post
Share on other sites

you're welcomed, I just have one last problem, the background image when first entering setup and right before setup restart PC, it still the default image, I've changed anywhere I think the image could be but same...

0

Share this post


Link to post
Share on other sites

I modded all the files which are in sources directory.....but after restarting....the default background image only appearing again in setup......anyone please help me.....by the way....u guys know?...how to change the windows edition name in system properties?.....right now i'm using home premium....but i want to change this edition name to vista ultimate....anyone know where to change this one....? please anyone help me with these two matters...Thank you

0

Share this post


Link to post
Share on other sites
Its not install.wim,

but boot.wim Image 2

u have to mount boot.wim #2 image and edit required files in sources folder of it.

Hey I replaced last image of boot.wim #2 . But I think there is a file protection in vista wim images

because after replacing the image I unmounted boot.wim #2 and again checked it to know whether

It is done or not but I again found an unedited image(default image) there so can you tell me

about this kind of protection please

0

Share this post


Link to post
Share on other sites

Below is a list of all bitmaps that can be modified for setup background.

I'm not sure which were the right ones so I changed them all to black for a completeley black setup.

sources\background_cli.bmp

mounted boot.wim 2 \sources\background.bmp

mounted boot.wim 2 \sources\spwizimg.dll (bitmaps 517,518 ResHacker)

mounted boot.wim 2 \Windows\System32\setup.bmp

mounted boot.wim 2 \Windows\winsxs\x86_microsoft-windows-i..dia-branding-client_31bf3856ad364e35_6.1.7068.0_none_1be5d3d3aff37e82\setup.bmp

mounted boot.wim 2 \Windows\winsxs\x86_microsoft-windows-i..dia-branding-client_31bf3856ad364e35_6.1.7068.0_none_1be5d3d3aff37e82\background.bmp

mounted boot.wim 2 \Windows\winsxs\x86_microsoft-windows-i..dia-branding-client_31bf3856ad364e35_6.1.7068.0_none_1be5d3d3aff37e82\spwizimg.dll (bitmaps 517,518 ResHacker)

mounted install.wim \Windows\system32\spwizimg.dll

post-234383-1239295686_thumb.jpg

The rest of setup looks like this as well as booting from DVD.

I had to edit this post to include windows\system32\spwizimg.dll from mounted install.wim to have the background image of the last part of setup look as you like.

Edited by midnight rambler
0

Share this post


Link to post
Share on other sites

It might be the just the first three in the list you need to modify.

Edited by midnight rambler
0

Share this post


Link to post
Share on other sites

Not work on Vista SP2 .Wim ( boot.wim/spwizimg.dll ) whit Resource Tuner 1.99

error on open file :(

Luckid

0

Share this post


Link to post
Share on other sites

excuse but not understand :(

Im Italian ( google )

Luckid

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.