Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

AVG Anti-Virus Silent

- - - - -

  • Please log in to reply
126 replies to this topic

#1
flattspott

flattspott

    Junior

  • Member
  • Pip
  • 56 posts
This is what you've all be waiting for. How to do a silent install with AVG Anti-Virus.
Change the directories if needed. You should have something similar;

$OEM$\$1\Install\Applications\AVG7\

Inside the AVG7 folder you put extracted AVG setup files.
Then you have to make a file named avgsetup.ini and put the following in it:

HIDE:
DONT_START_APPS:
NO_WELCOME:
LOG: "C:\AVG7INST.LOG" 
NAME: "UserName" 
COMPANY: "Company" 
LICNO: "Serial"

The AVG7 folder should now have the following;

avgsetup.exe
avgsetup.ini
files.dat
setup.dat
setup.lns
license_sk.txt
license_us.txt
license_cz.txt
license_fr.txt
license_ge.txt
readme_ge.txt
readme_cz.txt
readme_fr.txt
readme_sk.txt
readme_us.txt

I tried removing the text files but AVG wouldn't install so just leave them.

Then add this to your app install file;

ECHO.
ECHO Installing AVG Anti-Virus 7.0.197...
SET SETUP="%systemdrive%\Install\Applications\AVG7\avgsetup.exe"
[COLOR=blue]%SETUP% /SCRIPT_FILE "%systemdrive%\Install\Applications\AVG7\avgsetup.ini" %1 %2 %3 %4 %5 %6 %7 %8 %9
[/COLOR]

The part in blue is one line.

If you want to get more technical get the freeware app AVGADMIN 7.0.195

It's how I did it.


How to remove advertisement from MSFN

#2
Bachus

Bachus

    Advanced Member

  • Member
  • PipPipPip
  • 408 posts
Do you know if this (or a similar method) works for the free version? (6.5)

Nevermind, I found documentation on it for AVG6. I'll have to track down the admin tool for it, though. I'll post again when I find a link.

Found it: ftp://ftp.grisoft.cz/pub/softw/60/uk/admin/
There's the admin tool and the documentation. Now to test. :)

#3
DarkBringer

DarkBringer

    Member

  • Member
  • PipPip
  • 219 posts
  • OS:none specified
  • Country: Country Flag
Hey, flattspott,

HIDE:
DONT_START_APPS:
NO_WELCOME:
LOG: "C:\AVG7INST.LOG" <--- Can I use "%systemdrive%\AVG7INST.LOG" instead?
NAME: "UserName"
COMPANY: "Company"
LICNO: "Serial"
If a man speaks in a forest, and no woman is there to hear him, is he still wrong?

#4
flattspott

flattspott

    Junior

  • Member
  • Pip
  • 56 posts
You can put it whereever you want

#5
Shotgun

Shotgun

    Advanced Member

  • Member
  • PipPipPip
  • 462 posts
I'm looking for the same info for AVG Antivirus 6.0 build 282 (which is the one we have at work).

I tried using the AVG_NET.CFG created by the AVG Admin 6, but I can't find what command line option I have to give setup.exe to use it.

Help!!! :/

#6
Bachus

Bachus

    Advanced Member

  • Member
  • PipPipPip
  • 408 posts
Try using setup.exe /HIDE /@ avg_net.cfg

It seems to work for me. :)

#7
thundernetbr

thundernetbr

    Junior

  • Member
  • Pip
  • 67 posts
Hey flattspott,

GREAT job :) ! Works fine even with my FULL installation !

Btw, could you bring us some light regarding to the update file :rolleyes: ? I'll try to copy the most recent .bin to the AVG path, but I think it'll not work, it's different from AVG 6.x, where all we have to do was to d/l the most recent .bin and put it into the \update subfolder (the AVG 6 used to manage all the updates into one folder). But now it doesn't exists anymore...

Thanks !
Gigabyte GA-MA78GM-S2H & Asus K8VSE Deluxe - AMD Athlon X2 7750 Black Edition (2700 MHz, 64-bit, socket AM2+) & AMD Athlon 64 3200+ (2200 MHz, 64-bit, socket 754) - 2x 2GB Kingston DDR2 PC6400 & 2x 512MB Kingston DDR400 - Onboard ATI Radeon HD3200 & GeXCube ATI Radeon 9600Pro 256MB AGP 8X - Windows 7 x64 and XP SP3 Tweaked - and eventually Linux live CDs...

#8
Shotgun

Shotgun

    Advanced Member

  • Member
  • PipPipPip
  • 462 posts

Try using setup.exe /HIDE /@ avg_net.cfg

It seems to work for me. :)


THANK YOU SO MUCH Bachus!!!
You just made my existance easier!!!!
:punk: :afro: :jump:

#9
flattspott

flattspott

    Junior

  • Member
  • Pip
  • 56 posts
You all should do like I did and down load the admin pdfs from grisoft.com

#10
Shotgun

Shotgun

    Advanced Member

  • Member
  • PipPipPip
  • 462 posts
Ok. Now I can install AVG 6.0 silently, but HOW do I make it start up with the virus definition files ALREADY updated. I tried copying the .BIN files directly to the UPDATES directory of AVG, but when I logged on for the first time, the program started as if it did not recognize any updates.

Tried the setup again from scratch (I formatted the target drive) and tried updating by using the Service -> Update -> From folder option in AVG the first time I logged on, but it refuses with "Did not find any updates". The .BINs I'm using are the ones downloaded from the AVG website and the program somehow refuses to update with them. :rolleyes:

It insists on connecting to the Internet to get an update, then it recognizes the other .BIN files I placed in the UPDATES directory. :D :)

Any clues what I'm doing wrong? I want to install it and that when I log the first time it appears already with the latest update.

#11
Bachus

Bachus

    Advanced Member

  • Member
  • PipPipPip
  • 408 posts
Ironically, I'm having trouble getting AVG 6.0 to install, too. :) the setup.log file generated by AVG setup has this to say:
ExePath=C:\INSTALL\AVG\SETUP.EXE
ErrorStop: Serial number not valid for this language version.

The thing is that the serial number works fine when install manually. Odd...

#12
Shotgun

Shotgun

    Advanced Member

  • Member
  • PipPipPip
  • 462 posts
Are you putting the serial in quotes in the AVG_NET.CFG file?

It should be like: SERNO: "XXX-XXX-XXXXXX-XXX"

#13
Bachus

Bachus

    Advanced Member

  • Member
  • PipPipPip
  • 408 posts
Yes, it is. However, the serial only has one character after the first dash, eg: XXX-X-XXXXXX-XXX
I'll just cut to the chase and show you my avg_net.cfg file generated by the admin tool I linked to earlier:
; FILE: AVG_NET.CFG
DIR: "C:\Programs\AVG"
NAME: "#WIN#"
COMPANY: "N/A"
SERNO: "AVG-1-14844019-YNQ"
AUTOEXEC: NO
AVGSYS: YES
NETDIR: ""
NETCOMMENT: ""
FIRSTRUNWIZARD: "NO"
INETUPDATE: "YES"
RESIDENTSHIELD: "YES"
EMAILSCANNER: "NO"
BOOTUPSCANNER: "NO"
ADVANCED: "YES"
COPYFILE: "USER.OUT"
SET CFG [dlg_manazer_test]=Y
SET CFG [dlg_planovac]=Y
SET CFG [dlg_nastaveni]=Y
SET CFG [dlg_aktualizace]=Y
SET CFG [dlg_zachranna_disketa]=Y
SET CFG [dlg_zprava_o_chybe]=Y
SET CFG [dlg_registrace_avg]=Y
SET CFG [dlg_mazani_vysledku=Y
SET CFG [dlg_leceni_infekce]=Y
SET CFG [dlg_mazani_infekce]=Y
SET CFG [dlg_obnova_z_vv]=Y
SET CFG [dlg_control_center]=Y
SET CFG [dlg_system_status]=Y
SET CFG [dlg_test_interrupt]=Y
SET CFG [dlg_password]=0x0
SET CFG [tt_extensions]=COM;DRV;EXE;OV?;PGM;SYS;BIN;CMD;DEV;386;SMM;VXD;DLL;OCX;BOO;SCR;ESL;CLA;CLASS;BAT;VBS;VBE;WSH;HTM;HTML;?HTML;CHM;INI;HTT;INF;JS;JSE;HLP;SHS;PRC;PDB;PIF;PHP;DO?;XL?;VBX;RTF;PP?;POT;
SET CFG [tt_extensionswitch]=3
SET CFG [tt_heuristic]=Y
SET CFG [tt_comparative]=Y
SET CFG [tt_rt_decompress]=2
SET CFG [tt_arc_decompress]=2
SET CFG [tt_test_nonstop]=0
SET CFG [tt_automatic_h]=N
SET CFG [tt_stealth_boot]=N
SET CFG [tt_stealth_file]=N
SET CFG [tt_damaged_warning]=N
SET CFG [tt_macros_warning]=N
SET CFG [tt_changes_warning]=N
SET CFG [tt_clean_mode]=0
SET CFG [tt_backup]=N
SET CFG [tt_clean_all_macros]=N
SET CFG [qt_database_name]=C:\AVGQT.DAT
SET CFG [ct_local_database_name]=?:\AVG6DB_F.DAT
SET CFG [ct_network_database_name]=C:\AVG6DB_N.DAT
SET CFG [ct_removable_database_name]=C:\AVG6DB_R.DAT
SET CFG [ct_action_on_change]=N
SET CFG [gen_cfg_autosave]=Y
SET CFG [gen_logbase_maxitems]=30
SET CFG [gen_logbase_maxdays]=0
SET CFG [start_quick_test]=N
SET CFG [start_memory_test]=1
SET CFG [env_kodovani]=0
SET CFG [env_monitor]=0
SET CFG [mo_incoming]=3
SET CFG [mo_outgoing]=3
SET CFG [mo_postmaster]=
SET CFG [mo_wave]=
SET CFG [mo_notify]=1
SET CFG [vv_sizevaultmaxpercent]=5
SET CFG [vv_sizediskfreemin]=25165824
SET CFG [vv_itemsenable]=1
SET CFG [vv_itemsdaysold]=14
SET CFG [vv_itemsmaxcount]=1000
SET CFG [bootup_enabled]=0
SET CFG [fsh_status]=79
SET CFG [send_log]=N
SET CFG [send_ut]=N
SET CFG [msg_systab]=N
SET CFG [msg_accepted]=N
SET CFG [msg_virus]=N
SET CFG [msg_update]=N
SET CFG [net_check_period]=10
SET CFG [ui_mode_advanced]=Y
SET CFG [net_update_dir]=
SET CFG [enable_send_mail]=0
SET CFG [update_donotaskrestart]=0
SET CFG [update_nodlg]=N
SET CFG [update_forcerestartmode]=N
SET CFG [update_terminateappask]=N
SET CFG [resident_to_admin]=0
SET UT @ut0000.out
SET UT @ut0001.out
COPYFILE: "ut0000.out"
UT_NAME=Main test
UT_PATH=*
UT_COMMENT=Main test
UT_TYP=0
UT_FROM=1
UT_CFG [tt_extensions]=COM;DRV;EXE;OV?;PGM;SYS;BIN;CMD;DEV;386;SMM;VXD;DLL;OCX;BOO;SCR;ESL;CLA;CLASS;BAT;VBS;VBE;WSH;HTM;HTML;?HTML;CHM;INI;HTT;INF;JS;JSE;HLP;SHS;PRC;PDB;PIF;PHP;DO?;XL?;VBX;RTF;PP?;POT;
UT_CFG [tt_extensionswitch]=3
UT_CFG [tt_heuristic]=Y
UT_CFG [tt_comparative]=Y
UT_CFG [tt_rt_decompress]=2
UT_CFG [tt_arc_decompress]=2
UT_CFG [tt_test_nonstop]=0
UT_CFG [tt_automatic_h]=N
UT_CFG [tt_stealth_boot]=N
UT_CFG [tt_stealth_file]=N
UT_CFG [tt_damaged_warning]=N
UT_CFG [tt_macros_warning]=N
UT_CFG [tt_changes_warning]=N
UT_CFG [tt_clean_mode]=0
UT_CFG [tt_backup]=N
UT_CFG [tt_clean_all_macros]=N
UT_CFG [tt_scheduled]=N
UT_CFG [tt_dayofweek_scheduled]=0
UT_CFG [tt_repeat_scheduled]=N
UT_CFG [tt_time_scheduled]=0
UT_CFG [tt_params_scheduled]=0
COPYFILE: "ut0001.out"
UT_NAME=Complete test
UT_PATH=*
UT_COMMENT=Checks throughly the files in the path
UT_TYP=0
UT_FROM=2
UT_CFG [tt_extensions]=COM;DRV;EXE;OV?;PGM;SYS;BIN;CMD;DEV;386;SMM;VXD;DLL;OCX;BOO;SCR;ESL;CLA;CLASS;BAT;VBS;VBE;WSH;HTM;HTML;?HTML;CHM;INI;HTT;INF;JS;JSE;HLP;SHS;PRC;PDB;PIF;PHP;DO?;XL?;VBX;RTF;PP?;POT;
UT_CFG [tt_extensionswitch]=3
UT_CFG [tt_heuristic]=Y
UT_CFG [tt_comparative]=Y
UT_CFG [tt_rt_decompress]=2
UT_CFG [tt_arc_decompress]=2
UT_CFG [tt_test_nonstop]=0
UT_CFG [tt_automatic_h]=N
UT_CFG [tt_stealth_boot]=N
UT_CFG [tt_stealth_file]=N
UT_CFG [tt_damaged_warning]=N
UT_CFG [tt_macros_warning]=N
UT_CFG [tt_changes_warning]=N
UT_CFG [tt_clean_mode]=0
UT_CFG [tt_backup]=N
UT_CFG [tt_clean_all_macros]=N
UT_CFG [tt_scheduled]=Y
UT_CFG [tt_dayofweek_scheduled]=255
UT_CFG [tt_repeat_scheduled]=Y
UT_CFG [tt_time_scheduled]=25200
UT_CFG [tt_params_scheduled]=0


#14
knewman01

knewman01

    Junior

  • Member
  • Pip
  • 50 posts
  • OS:none specified
  • Country: Country Flag
I'm having exactly the same problem with the free version. My cfg file contains the correct serial number.

Tried creating a config file with install.exe...incorrect serial number for this language version.

#15
Bachus

Bachus

    Advanced Member

  • Member
  • PipPipPip
  • 408 posts
I've even tried a couple keys I found elsewhere and those don't even work. Something is very wrong here...

#16
tapnet

tapnet

    Junior

  • Member
  • Pip
  • 50 posts
So whould that be:

ECHO.
ECHO Installing AVG Anti-Virus 7.0.197...
SET SETUP="%systemdrive%\Install\Applications\AVG7\avgsetup.exe"
%SETUP% /SCRIPT_FILE "%systemdrive%\Install\Applications\AVG7\avgsetup.ini" %1 %2 %3 %4 %5 %6 %7 %8 %9
Posted ImagePosted ImagePosted ImagePosted ImagePosted ImagePosted ImagePosted ImagePosted Image
Up and Down and UP and down and Up...

#17
DR.ShadowFusion

DR.ShadowFusion
  • Member
  • 2 posts
How to do a cd unattended, for AVG anti-virus 6 version Free (silent installation)
I would like to do an installation of AVG anti-virus 6 version Free (avg6614fu_free.exe) installing in the silent way (silent installation) in the cd windows xp sp1, somebody knows that command them step-for-step.

If somebody wants this version to test or to try to set up the necessary files:
http://www.grisoft.c...6614fu_free.exe

I created svcpack.inf to install the hotfixes.
I altered dosnet.inf as it should be done.
I created winnt.sif to have an unattended installation.

With the file " admin6_en.pdf " I created the file avg_net.cfg

What should I Do with the file " avg_net.cfg "?
Where should I place this? Where? in OEM? what directory?

I created a directory and I placed extracted AVG in this directory

I place like this: Is that correct?

$OEM$\$1\Install\Applications\AVG6 \

Which command lines should I place in the file winnt.inf, and what directory OEM exactly I should place the antivirus? this correct one as I placed soon above?!
Should I use Winrar to extract the file (avg6614fu_free.exe) before inserting in the directory OEM? Or should I place in the way that came?

Bachus and Rifle, please, they Help me!!

#18
Guest_a1ehouse_*

Guest_a1ehouse_*
  • Guests
Hi I can't seem to get this to work

Every time I run my batch file, I get the following error:

Installer initialization failed due to following error:
Undefined error: Invalid line in the install script file "D:\AutoPatcherXP_Feb\AutoPatcher XP\CustomProgFiles\AVG7\avgsetup.ini" at line 1.

If I remove everything from the ini file:
HIDE:
QUIT_IF_INSTALLED:
LOG: "C:\AVG7INST.LOG"
LANGID: 0x409
NAME: "MyName"
COMPANY: "MyCo"
LICNO: "MyLicNo"

It also fails.

Can anyone get this to run?!?

#19
Schadenfroh

Schadenfroh

    Junior

  • Member
  • Pip
  • 69 posts
bump for silent install of avg free edition
Flash and animated signatures and avatars are not permitted.

#20
Schadenfroh

Schadenfroh

    Junior

  • Member
  • Pip
  • 69 posts
alright, i wrote a VBscript that should autmatically install the free version, asuming you have already extratcted the avg install into a directory. open notepad and save it as avg.vbs and link avg.vbs in your .cmd file to run it, BTW, it will restart your system

Set WshShell = WScript.CreateObject("WScript.Shell")
WshShell.Run ("setup.exe")
WScript.Sleep 4000
WshShell.SendKeys "~"
WScript.Sleep 1000
WshShell.SendKeys "~"
WScript.Sleep 1000
WshShell.SendKeys "AVG-1-17354670-NTZ"
WScript.Sleep 1000
WshShell.SendKeys "~"
WScript.Sleep 1000
WshShell.SendKeys "~"
WScript.Sleep 1000
WshShell.SendKeys "~"
WScript.Sleep 1000
WshShell.SendKeys "~"
WScript.Sleep 18000
WshShell.SendKeys "~"
WScript.Sleep 1000
WshShell.SendKeys "~"
WScript.Sleep 1000
WshShell.SendKeys "~"
WScript.Sleep 1000
WshShell.SendKeys "~"

Flash and animated signatures and avatars are not permitted.

#21
SibTiger

SibTiger

    Computer Geek

  • Member
  • 44 posts
Awesome, Schadenfroh! But I have some newbie questions.
  • I see "sleep" in your script. Do I need to download a freebie for "sleep" to work, or is that built into VB?
  • Does this script go in the AVG6 subdirectory to run properly?
  • Also, how do you call a .vbs file from a batch file?
    avg.vbs
    OR
    call avg.vbs
    OR
    start /w avg.vbs
    OR
    ???
THANKS!!!

#22
KYPUMPER

KYPUMPER

    Newbie

  • Member
  • 19 posts
bump for free edition

#23
KYPUMPER

KYPUMPER

    Newbie

  • Member
  • 19 posts
I found out how to run the vb script inside the folder with the setup.exe for AVG works like a charm. That script was awesome I never had messed with VB script before I ran that and it was like the cartoons where the big lightbulb lights up over your head I will tweak that for other applications Thanks for writing that script man.

#24
Dustinwmew

Dustinwmew

    Member

  • Member
  • PipPip
  • 122 posts
i tryed this but it did not install so I removed the hide: and it told me that DONT_START_APPS:
NO_WELCOME:
NO_AVGW_STARTUP:
are Invalid command line arguments.
No one is ever along. They always have to voices in their heads.

#25
RBCC

RBCC

    Senior Member

  • Member
  • PipPipPipPip
  • 634 posts
How do I install the update file and AVG 7.0 together so it will be updated? John




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN