• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Fernando 1

Integration of Intel's SATA AHCI and RAID drivers

1,534 posts in this topic

There's a popular thread in the XP forum about how to enable AHCI on XP and they have to create a registry entry, etc.:

http://www.msfn.org/board/compiled-faq-gui...tml#entry785969

Just to clarify, they have to go through some extra steps because they're trying to enable AHCI after XP is already installed, right?

Again, just to clarify, since the purpose of this thread is to describe how to integrate the driver during the XP installation, does that mean that you don't have to do anything else after XP is finished being installed?

0

Share this post


Link to post
Share on other sites

@ quaternary:

I don't think, that your problem has something to do with the installation medium USB stick.

The STOP: 0x0000007B error message usually indicates a wrong or broken textmode driver.

Since we do not know exactly the specifications (HardwareID) of your SATA Controller and the SATA Mode (AHCI, RAID or IDE), you probably have to try several different drivers and may check different SATA Controllers during the textmode driver integration.

@ E-66:

If you do a fresh install of Windows XP onto a SATA hdd, which is running in AHCI Mode, and you are booting off an XP CD with integrated suitable AHCI textmode driver, you haven't to do anything regading SATA after XP Setup has been finished.

The procedure you have linked to is only valid for users, who want to enable AHCI after having installed Windows XP in IDE Mode.

Edited by Fernando 1
0

Share this post


Link to post
Share on other sites

Thanks. One more question regarding your reply above. What if I don't use a CD but install off a partition on the HDD instead? That is how I've always installed XP. I've tested many different nLite configurations, tweaking them to try to find one I was happy with. It seemed wasteful to keep burning all those different configs to CD, so I have my nLited XP source on a separate partition on the HDD and install using Winnt.exe. Any issues with doing it that way?

0

Share this post


Link to post
Share on other sites
What if I don't use a CD but install off a partition on the HDD instead?
Although I have never done that, I don't expect any problems due to the installation procedure (by booting off CD/DVD/USB/eSATA or by starting it from within an existing hdd partition.

Much more important is, that you have integrated the correct textmode driver. If yes, Windows Setup will find and use it.

0

Share this post


Link to post
Share on other sites

@Fernando

I thought I posted the relevant data already here. I reposted below. I see product: 82801FB/FW (ICH6/ICH6W) SATA Controller and IDE interface. Is this not the product ID? Does that really not tell us any information about the SATA controller? What kind of hardware ID are you looking for, maybe I can find it.

Also, would IDE not be the SATA mode? I searched through the output of all the hardware, and don't find anything matching RAID or AHCI, but maybe that doesn't mean anything.

My BIOS version (Dell A09) does not include an option to change SATA mode (or to select hard disk boot priority).

*-ide:1

description: IDE interface

product: 82801FB/FW (ICH6/ICH6W) SATA Controller

vendor: Intel Corporation

physical id: 1f.2

bus info: pci@0000:00:1f.2

logical name: scsi2

version: 03

width: 32 bits

clock: 66MHz

capabilities: ide pm bus_master cap_list emulated

configuration: driver=ata_piix latency=0

*-disk:0

description: ATA Disk

product: ST340014AS

vendor: Seagate

physical id: 0.0.0

bus info: scsi@2:0.0.0

logical name: /dev/sda

version: 8.12

serial: 5MQ28YCX

size: 37GiB (40GB)

capabilities: partitioned partitioned:dos

configuration: ansiversion=5 signature=d0f4738c

*-core

description: Motherboard

product: 0M3918

vendor: Dell Inc.

physical id: 0

*-firmware

description: BIOS

vendor: Dell Inc.

physical id: 0

version: A09 (06/22/2005)

size: 64KiB

capacity: 448KiB

capabilities: pci pnp apm upgrade shadowing cdboot bootselect edd int13floppytoshiba int5printscreen int9keyboard int14serial int17printer acpi usb ls120boot biosbootspecification netboot

0

Share this post


Link to post
Share on other sites
What kind of hardware ID are you looking for, maybe I can find it.
The HardwareID consists of the VendorID (VEN_xxxx), the DeviceID (DEV_xxxx) and usually a suffix. A typical HardwareID looks like this:
PCI\VEN_8086&DEV_2822&CC_0104

You can get the HardwareID's of each device, if you have a running Windows OS on the system: Open the Device Manager, do a right-click onto the related device > "Properties" > "Details" > "Property" > "HardwareID's".

All storage Controllers (SATA, AHCI or RAID) are within the "IDE ATA/ATAPI Controllers" or "Storage Controllers" (XP: "SCSI and RAID Controllers") section of the Device Manager.

0

Share this post


Link to post
Share on other sites
The HardwareID consists of the VendorID (VEN_xxxx), the DeviceID (DEV_xxxx) and usually a suffix.

OK! Got it:

00:1f.2 0101: 8086:2651 (rev 03)

00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)

The Vendor ID is 8086 and the Device ID is 2651. Hopefully this can be useful to find the right text driver.

0

Share this post


Link to post
Share on other sites
The Vendor ID is 8086 and the Device ID is 2651. Hopefully this can be useful to find the right text driver.
Thanks for this information.

The exact name of the related device is "Intel® 82801FB Ultra ATA Storage Controllers - 2651". It is an Intel ICH6 chipset SATA device, which is neither supporting AHCI nor RAID.

There is no textmode driver available for this SATA Controller, because the device doesn't need any real driver, but just an INF file. It is supported by the actual Intel chipset "drivers" (wrong name), which you can get >here<.

So you should be able to get Windows XP with integrated SP2 or - even better - SP3 installed without the integration of any textmode driver.

This is what I recommend for you:

  1. Download and unzip the above linked Intel chipset drivers, which I have already prepared for the later integration into a Windows XP CD.
  2. Copy the content of the original (=untouched) Windows XP CD onto a folder of your hdd.
  3. Start nLite and let it do just the following:

    1. integration of the Service Pack 3 (not needed, if your source is already XP SP3)
    2. integration of the Intel chipset "drivers" by pointing onto any of the various INF files (doesn't matter which one you choose)
    3. creation of the ISO file

    4. Burn the ISO file as bootable Image.
    5. Unplug all unneeded extern devices.
    6. Boot off the just created XP CD.


      This way you should succeed with the XP installation. All Intel chipset "drivers" for your Intel ICH6 system should be already installed due to the integration of them.
      Once the OS is up, look into the Device Manager for the missing other drivers (for the Graphics adapter, Network Controller, Soundchip etc.). Search, download and install them.
      Good luck!
      Fernando
Edited by Fernando 1
0

Share this post


Link to post
Share on other sites
The exact name of the related device is "Intel® 82801FB Ultra ATA Storage Controllers - 2651". It is an Intel ICH6 chipset SATA device, which is neither supporting AHCI nor RAID.

There is no textmode driver available for this SATA Controller, because the device doesn't need any real driver, but just an INF file. It is supported by the actual Intel chipset "drivers" (wrong name), which you can get >here<.

No joy.

I tried this twice, once including all of the files from that download, another just using a random .inf file, both times the installation just stops at the blue screen with the same 0x0000007B error.

0

Share this post


Link to post
Share on other sites
No joy.

I tried this twice, once including all of the files from that download, another just using a random .inf file, both times the installation just stops at the blue screen with the same 0x0000007B error.

If you really have integrated nothing else than a Service Pack and the Intel chipset "divers", the BSOD is caused by something else.

Questions:

1. Are you using a clean (=untouched) original MS XP CD as source?

Look into the i386 directory of the CD for a file named WINNT.SIF. If you find it, you can be sure, that the CD has been processed (by you or someone else).

2. When you get the STOP: error message, do you see a name of a file, which may have caused the error?

If you couldn't see the entire error message, because the system rebooted at once, you should repeat the procedure, but hit F8 at (re)boot and choose the option "Don't reboot at System failure". Please give us the complete STOP: error message.

3. How much RAM is within your computer?

If it are more than 3 GB, you should remove 1 RAM stick, before you are going to install Windows XP.

Edited by Fernando 1
0

Share this post


Link to post
Share on other sites

This is not an original CD source, but I know that this ISO has been installed without problems on machines with floppy drives/appropriate drivers. Does this method not apply to any but original versions?

I have 1GB RAM.

The full error is:

STOP: 0x0000007B (0xF78D2524, 0xC0000034, 0x00000000, 0x00000000)

The text is generic and does not give any file information, just that a problem has been detected and windows has been shut down to prevent damage...reboot try again or check for hard drive corruption.

Should it matter if the harddrive I want to install this on is partitioned? One empty 15GB NTFS, and then an ext3 partition.

0

Share this post


Link to post
Share on other sites
This is not an original CD source, but I know that this ISO has been installed without problems on machines with floppy drives/appropriate drivers.
I am sorry. but we must not give any support to users, who are working with an illegal copy of a Windows OS.
0

Share this post


Link to post
Share on other sites

First, this is a great post, THANK YOU.

Second, a suggestion for the first post of this thread, that may help others determine which drivers to integrate (you will know best if this information is useful, I'm still new to integrating these drivers):

If you have WinXP (others?) installed you can find your system's hard drive controller type by:

- Start > Run > devmgmt.msc

- expand the "+" to the left of "IDE ATA/ATAPI controllers"

- controller type will appear in the list.

Cheers,

Bret

0

Share this post


Link to post
Share on other sites

@ bretmaverick999:

Thanks for your suggestion. I will put something like that into my guide, when it's time for the next update.

By the way: Only the Intel SATA AHCI Controllers are listed within the "IDE ATA/ATAPI Controllers" section of the Device Manager. The Intel SATA RAID Controllers are within the section "SCSI and RAID Controllers" (XP) or "Storage Controllers" (Vista and Win7).

Regards

Fernando

0

Share this post


Link to post
Share on other sites

Hey Fernando 1

I followed your instructions and it worked the first time

thank You very much for this

icy

0

Share this post


Link to post
Share on other sites
ive slipstreamed two files i downloaded from the mobo manufacturer, "INF driver ver:9.0.0.1007" (Intel® Chipset Device Software) and "SATA RAID Driver" (iaStor, iaAHCI).
Both drivers are old and replaced by better ones.

If you will ever do a fresh XP installation, you should slipstream the actual Intel ICH10R SATA AHCI driver (as textmode driver) and the Intel Chipset =INF Drivers (as PnP driver). You will find the download links of both drivers (already prepared for the integration) within my guide.

hey, ive just installed xp64 slipstreaming the "Intel ICH10R SATA AHCI driver" found on the first post of this thread and it works, even tho my chipset is the ICH10, without the R.

im posting this just in case some other asrock p45ts owner fails to install the ICH10 driver, and wonders what to try next.

thx and laters.

0

Share this post


Link to post
Share on other sites

Hi Fernando 1,

Thanks for your guide, its really straight forward and clear.

Once I have finished installing XP in AHCI mode, should I install "Intel Matrix Storage Manager"? Or that's only for RAID users?

0

Share this post


Link to post
Share on other sites
Once I have finished installing XP in AHCI mode, should I install "Intel Matrix Storage Manager"? Or that's only for RAID users?
Yes, I do not recommend to install the Intel Matrix Storage Manager Software for AHCI users, because - contrary to RAID users - they cannot really use the Console, but may suffer permanently under a longer boot time.
0

Share this post


Link to post
Share on other sites
Possible updated INF utility (no .zip file as yet):

http://downloadcenter.intel.com/Detail_Des...16〈=eng

Yeah well, you can always extract INF files out of exe (they have some special command line parameter to do that) I think its in read me.

I've a different problem here. It seems, my ICH7 AHCI driver is not inside official or modded version :unsure: But it does exist in the older official release 5.x modded and official 8.x claims to support AHCI... Oddly, VirtualBox always crashed with 8.7 version.

0

Share this post


Link to post
Share on other sites
Possible updated INF utility (no .zip file as yet):

http://downloadcenter.intel.com/Detail_Des...16〈=eng

Thanks for the info.

I will update the download link very soon.

EDIT: Done!

By the way: The version of the "Intel INF Update Utility" (=Intel Chipset Device Software) is much less important than the AHCI/RAID driver version of the Intel Matrix Storage Manager or Intel Rapid Storage Technology.

Reason: The INF "drivers" do not contain any real driver and only a few INF files of the new package have been really updated.

I've a different problem here. It seems, my ICH7 AHCI driver is not inside official or modded version :unsure: But it does exist in the older official release 5.x modded and official 8.x claims to support AHCI... Oddly, VirtualBox always crashed with 8.7 version.
Which is the DeviceID of your Intel ICH7 SATA AHCI Controller? The DeviceID named DEV_xxxx is part of the HardwareID's.

You can get the HardwareID's by doing a right click onto the device within the Device Manager > "Properties" > "Details" > "Property" > "HardwareID's.

Edited by Fernando 1
0

Share this post


Link to post
Share on other sites

This is a godsend, thank you! I have an EP43-UD3L that I'm dual booting XP with OSX with 8 gigs of memory -- this greatly reduces lots of anomalies that occurred when I was not in AHCI mode...

0

Share this post


Link to post
Share on other sites

I integrated both the AHCI and chipset drivers and Windows installed without a hitch, but I'm confused.

When I look at the hard disk controllers in Device Manager, I see Intel® ICH9 Family 4 Port SATA AHCI Controller - 2923,

but I was expecting to see Intel® ICH9 SATA AHCI Controller (added by Fernando).

I checked the file version and date of the IaStore.sys file and it's the same as the one I downloaded from the link on the first page of this topic. Obviously the driver got integrated or I would have never got Windows installed, but why don't I see the controller identified with the "added by Fernando" tag?

To confuse matters more, I did a second install and purposely didn't integrate the driver and used the F6 floppy method instead. Windows again installed without a hitch, and when I look at the controller in Device manager I DO see the "added by Fernando" tag.

Any thoughts?

0

Share this post


Link to post
Share on other sites

@ E-66:

Since you didn't mention the OS you have installed (just "Windows" is not enough) and did not add a screenshot of your Device Manager, it is not easy to answer your questions.

Nevertheless here are some additional informations for you:

  1. The "Intel® ICH9 Family 4 Port SATA AHCI Controller - 2923" is just a system management device and not supported by any real Intel driver. Real drivers have the extension ".SYS". This device is named by the file IBEXAHCI.INF as part of Intel's chipset "drivers".
  2. Contrary to the previous mentioned device the "Intel® ICH9 SATA AHCI Controller (added by Fernando)" is the real Intel mass storage controller device and supported by Intel's textmode driver named IASTOR.SYS.

Please do a right click onto the "Intel® ICH9 Family 4 Port SATA AHCI Controller - 2923" and check the driver name and details, if you find any. After having done that, compare it with the "Driver" > "Details" informations of the "Intel® ICH9 SATA AHCI Controller (added by Fernando)".

Additional questions:

  • Which Windows version did you install?
  • After having installed the OS with integrated Intel AHCI driver and Intel chipset "drivers", have you seen a section named "SCSI and RAID Controllers" or "Storage Controllers" within the Device Manager? If yes, have you done a look into that section?

Regards

Fernando

0

Share this post


Link to post
Share on other sites

Sorry for being sparse on information. I'm installing WinXP Pro SP3 on a Gigabyte GA-P35-DS3L (ICH9 & Intel SATA ports). I've attached 6 screen shots (2 sets of 3) to show what I see in 2 different installs.

The 3 shots on the left are from an install where both the AHCI drivers and chipset inf "drivers" were integrated.

This is the install where the hard disk controller is identified as an Intel® ICH9 Family 4 Port SATA AHCI Controller - 2923. We can call this the "4-port" install.

The 3 shots on the right are from an install where I only integrated the chipset "drivers" and used the F6 method to load the AHCI drivers during the install,

and the hard disk controller is identified as an Intel® ICH9 SATA AHCI Controller (added by Fernando). We can call this the "Fernando" install.

I only see one difference. In the second pair of screen shots on the Driver tab, the 4 Port install shows driver version 7.0.0.1013 for the hard disk controller, while the Fernando install shows driver version 8.9.0.1023.

That's it. On the Driver Details tab, both point to the iaStor.sys file

Your thoughts are appreciated.

post-107588-1262740788_thumb.png post-107588-1262740794_thumb.png

post-107588-1262740826_thumb.png post-107588-1262740833_thumb.png

post-107588-1262740839_thumb.png post-107588-1262740846_thumb.png

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.