Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Fernando 1

Integration of Intel's SATA AHCI and RAID drivers

Recommended Posts

I understand that setup will run on the system so it sounds like to me, you may have a hardware problem ie; hard drive going bad maybe. Upon further reflection on this it may be a memory problem. There are bootable diagnostic cd's to run on your system to check for problems with the hardwarw harddrive, memory, ect..

Edited by cozinbob2

Share this post


Link to post
Share on other sites

After the files had been copied & system restart i get BDOS.
Questions:

1. At which mode (IDE/RAID/AHCI) is the SATA Controller running, where your HDD/SSD is connected to? Open the BIOS and look for the SATA Controller settings.

2. Have you used a clean (=untouched) Windows XP CD, when you got the BSOD? Look into the i386 directory of the CD. Do you see there a file named WINNT.SIF? If yes, the CD is not an original XP CD.

Edited by Fernando 1

Share this post


Link to post
Share on other sites

I'm stuck fighting this setup and would really appreciate some guidance.

The setup is a clean i5 2300 and a Gigabyte B75m-D3H running a 250gb Velociraptor as a workstation that needs to run XP. So I'm stuck with a 10 year old OS on this install. I posted a similar question in another MSFN forum but see this was really the place for it. So sorry to duplicate & elaborate...

My first attempt to install a 32 bit XP/AHCI on this board began with a slipstreamed XP using the 10.8 RST driver with the desktop/workstation controller. But the dreaded 0X00000007b error was the result. This same disk has installed XP on a z68 board

So I went back to basics using the f6 install of the gigabyte sourced f6 SATA AHCI driver v11.1 using external floppy. All was recognized. When it came time to choose the appropriate storage controller the only ones that showed up were the ICH7R/DH, ICH7RMDW, Desktop/Workstation/Server express chipset, and the moble chipset. I started with the Desktop chipset but still couldn't get past the 7b error.

Next I tried a new slipstream of my XP sp3 disk with the newest v11.6 RST . When slipstreaming the driver, I chose the standard 7 series chipset driver that showed up during the nlite procedure. After successfully burning the .iso I thought I had it beat. But still no install and the same 7b error came up. Not sure if it's necessarry, but I've been wiping the drive after each attempt just in case...

And yes, if I set the bios to ide, the XP will install. I took it as far as setting the partitions no problem.

What gives? Is the 7 series chipset driver wrong? As I was researching this I read somewhere that the 7 series chipset will not work with XP in AHCI. Any truth to that?

I've looked for info, there is very little on the B75 so I even checked to see if there were any similar z77 issues, but not much can be found. Sure could use some constructive input. I'm out of patience.

Share this post


Link to post
Share on other sites

@ lioninstreet:

I suspect, that you have chosen the wrong SATA Controller while integrating or loading the Intel AHCI driver. Alternatively your BSOD problem may be caused by using an already modified XP CD as source.

This is what I recommend to do:

  1. Look into your mainboard manual and check, if the SATA Controller of your mainboard belongs to the "Intel® 7 Series/C216 Chipset Family" or to the "Intel® 7 Series Chipset Family".
  2. Download >this< RST driverpack and unzip it.
  3. Restart the creation of an XP SP3 CD with integrated Intel AHCI driver from scratch by copying the content of a clean (untouched) XP CD onto a separate folder of your HDD.
  4. Let nLite integrate the RST driver v11.2.0.1006 as textmode driver. When you get the popup window with the list of all available SATA Controllers, just check the "Intel® 7 Series/C216 Chipset Family SATA AHCI Controller" or the "Intel® 7 Series Chipset Family SATA AHCI Controller" depending on the result of your previous check (point 1).
  5. Let nLite create the ISO file and burn the ISO file as bootable image.
  6. Set the SATA Controller of your system to "AHC mode".
  7. Install Windows XP by booting off the just created CD.

Good luck!

Fernando

P.S.:

Is the 7 series chipset driver wrong?
No, the driver was not wrong, but maybe the chosen Controller.
As I was researching this I read somewhere that the 7 series chipset will not work with XP in AHCI. Any truth to that?
No, that is not true. Edited by Fernando 1

Share this post


Link to post
Share on other sites

Spot on fernando. I have currently 4 custom built PC's. 2 Intel and 2 AMD. I have been useing nlite and driverpacks method for years and have none of these problems being reported like above and by many others in this thread. The driverpacks method does not rely on user knowledge of his/her system hardware to install XP/SP3 with ahci controlers systems. it finds the proper drivers and just installs with zero problems, period. The beauty of the driverpacks method is that one can also install the chipsets, lan, wireless lan, sound, and video and as previously stated it just works period. One might call it drivers integration for dummies.

Share this post


Link to post
Share on other sites

@ cozinbob2:

If you are happy with the driverpacks instead of the nLite integration method, why do you post it into the nLite Forum?

Users may think, that they can integrate the "Mass Storage driverpack" by using nLite and this is absolutely misleading.

This thread has meanwhile more than 1.2 millions of visitors and if you compare this with the numbers of users, who posted about problems, the big majority of them obviously succeeded with the nlite integration method.

Regards

Fernando

Share this post


Link to post
Share on other sites
After the files had been copied & system restart i get BDOS.
Questions:

2. Have you used a clean (=untouched) Windows XP CD, when you got the BSOD? Look into the i386 directory of the CD. Do you see there a file named WINNT.SIF? If yes, the CD is not an original XP CD.

@Fernando 1,

Thank you for watching this board as you do. It looks like you've made alot of friends here!

To your suggestions, I wish I could say I am 100% sure my XP CD is genuine, but I can not. It was an OEM version purchased off ebay a while back. Visually it compares well to a sp2 disk I have and it passes the test above, No WINNT.SIF file. Any other ways to test? If after some research, it actually turns out to be a fake, where does one source a genuine clean untouched sp3 disk these days?

Regarding the controller, I was unable to find anywhere in the boards manual that identified if the controller was the "Intel® 7 Series/C216 Chipset Family" or the "Intel® 7 Series Chipset". On the other hand it makes no reference to the C216 controller either. From what I found the C216 seems to be used with Xeon CPU's. and supports 2 SATA 3.0 and 4 SATA 2.0, My B75 only has 1 SATA 3.0 and 5 SATA 2.0.

@cozinbob2,

Driverpack looks pretty fail safe, although I suppose that is a relative term...

Does it also require a minimum of sp3 as reccomended by @Fernando 1?

Share this post


Link to post
Share on other sites

Look at your Topic - a question was presented regarding this which is obviously your Motherboard's specs (as you state above).

Share this post


Link to post
Share on other sites
To your suggestions, I wish I could say I am 100% sure my XP CD is genuine, but I can not. It was an OEM version purchased off ebay a while back. Visually it compares well to a sp2 disk I have and it passes the test above, No WINNT.SIF file.
If there is no WINNT.SIF file within the i386 directory, your XP CD may work for the driver integration task.
Regarding the controller, I was unable to find anywhere in the boards manual that identified if the controller was the "Intel® 7 Series/C216 Chipset Family" or the "Intel® 7 Series Chipset". On the other hand it makes no reference to the C216 controller either.
If you don't know the exact name of the Intel SATA AHCI Controller (with or without C216), you may integrate them both. If you should know the Controller name you had integrated the last time (with the installation failure), you may take the other one now.

Share this post


Link to post
Share on other sites

@submix8c, I reviewed both the manual and website for a definitive answer to the chipset question and found none. Unless I am blind, it is also not contained on the link you kindly provided.

@Fernando 1, reasonalbly good chance my XP source disk is useable as I was able to slipstream with it to a Gigabyte Z68m-ud2h-b3 board and an M4 SSD a few months ago. However I did have acitvation issues and had to get a key directly from Microsoft. There is another one of those boards here and I was thinking to use it with that disk just to (hopefully) get this terminal up and running.

But if that gets this terminal up an running I still have to revisit the B75 board and will probably make a disk with both chipset drivers. when I intigrate should setup to do it selecting the one driver at a time or multi driver folder?

To all, thanks again for the arrow pointing

Share this post


Link to post
Share on other sites

Interesting,

Now the slipstreamed disk I used a few months ago on the Z68 board with a SSD using the 10.8 driver will not load the OS on the same board with a 250gb Velociraptor.

I'm off to get more blank CD's...

Share this post


Link to post
Share on other sites
But if that gets this terminal up an running I still have to revisit the B75 board and will probably make a disk with both chipset drivers.
Why do you want to create a second disk? And which "both chipet drivers" do you mean?
when I intigrate should setup to do it selecting the one driver at a time or multi driver folder?
I always recommend to use the "one driver" integration method, because it is the safest one to get just the driver you want and nothing else.

Share this post


Link to post
Share on other sites
But if that gets this terminal up an running I still have to revisit the B75 board and will probably make a disk with both chipset drivers.
Why do you want to create a second disk? And which "both chipet drivers" do you mean?
when I intigrate should setup to do it selecting the one driver at a time or multi driver folder?
I always recommend to use the "one driver" integration method, because it is the safest one to get just the driver you want and nothing else.

I am using CD-R as my media, so I assumed I had to make a new disk for each slipstream. By both drivers I was referring to the 7 series with 316 and 7 series without. You are suggesting the one driver method and silipstream them both individually into the same install disk, Yes?

Also I noticed that after the nLite procedeure, the folder that I copied the sp3 disk into now has additional files showing (the slipstreamed files no doubt). Are these the files that are in nLite when I am asked if I want to use the previous session? I usually right click and delete them in nLite but noticed they are still there in the source folder.

I'm not so well versed with nLite so I'm not so certain how should I deal with those files, both in nLite and in the source folder...

Share this post


Link to post
Share on other sites

Also Just discovered my XP sp3 disk is likely a volume licence version, possibly meaning it could be a nock off

This is getting more fun by the minute..

It but it did pass the validation test on another terminal after getting a new key from brother Bill.

How does one source a known legit XP sp3 disk these days?

Edited by lioninstreet

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×