Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Integration of Intel's SATA AHCI and RAID drivers

- - - - -

  • Please log in to reply
1530 replies to this topic

#1501
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

@ misterx7777:

 

Welcome at MSFN Forum!

According to the HardwareIDs and Intel SATA Controller names you have posted, you are running your system drive in IDE and not in AHCI or RAID mode.

As long as you do not switch the Intel SATA Controller within the BIOS to AHCI or RAID mode, you will be able to install Windows XP without loading or having integrated any Intel textmode driver.

 

Regards

Fernando


My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E


How to remove advertisement from MSFN

#1502
GrofLuigi

GrofLuigi

    GroupPolicy Tattoo Artist

  • Member
  • PipPipPipPipPipPip
  • 1,360 posts
  • Joined 21-April 05
  • OS:none specified
  • Country: Country Flag

That's the part I didn't know.  :)



#1503
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,564 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

That's the part I didn't know.  :)

This:

http://www.msfn.org/...-24#entry884409

http://forums.pcper....talling-Windows

may also be of interest to you. ;)

 

jaclaz



#1504
GrofLuigi

GrofLuigi

    GroupPolicy Tattoo Artist

  • Member
  • PipPipPipPipPipPip
  • 1,360 posts
  • Joined 21-April 05
  • OS:none specified
  • Country: Country Flag

I knew that. :) I should have been clearer, I didn't know the HWID of the controller in IDE mode (but I had a fairly good guess with the reference to the BIOS). :)

 

GL



#1505
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,564 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

I see  :), my bad  :blushing: .

 

jaclaz



#1506
misterx7777

misterx7777
  • Member
  • 6 posts
  • Joined 07-March 14
  • OS:XP Pro x86
  • Country: Country Flag

@ misterx7777:

 

Welcome at MSFN Forum!

According to the HardwareIDs and Intel SATA Controller names you have posted, you are running your system drive in IDE and not in AHCI or RAID mode.

As long as you do not switch the Intel SATA Controller within the BIOS to AHCI or RAID mode, you will be able to install Windows XP without loading or having integrated any Intel textmode driver.

 

Regards

Fernando

Thanks Fernando.

The problem is just that: I have the need to enable the ahci because I have a multi-boot system (xp - seven -win8 ).

For seven and win8 all is o.k. in ahci, there are no problems.

This forces me to change the options of the bios when I switch to xp. For this reason I would like to install the correct drivers for xp.

Can you help me?

Is a big problem for me.



#1507
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

The problem is just that: I have the need to enable the ahci because I have a multi-boot system (xp - seven -win8 ).
For seven and win8 all is o.k. in ahci, there are no problems.
This forces me to change the options of the bios when I switch to xp. For this reason I would like to install the correct drivers for xp.

Then you should boot into Win7 or Win8 (in AHCI mode) and post the HardwareIDs of the SATA AHCI Controller, where your system drive is connected.

Edited by Fernando 1, 08 March 2014 - 03:12 PM.

My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#1508
misterx7777

misterx7777
  • Member
  • 6 posts
  • Joined 07-March 14
  • OS:XP Pro x86
  • Country: Country Flag
O.k Fernando.
In windows 8 there is only one value:
 
1)  Intel® 6 Series/c200 Series Chipset Family 6 port SATA AHCI controller - 1c02
 
 
Id hardware:
 
1)   PCI\VEN_8086&DEV_1C02&SUBSYS_76761462&REV_05
      PCI\VEN_8086&DEV_1C02&SUBSYS_76761462
      PCI\VEN_8086&DEV_1C02&CC_010601
      PCI\VEN_8086&DEV_1C02&CC_0106


#1509
misterx7777

misterx7777
  • Member
  • 6 posts
  • Joined 07-March 14
  • OS:XP Pro x86
  • Country: Country Flag
In windows 7 there is also only one value:
 
1) Controller ATA seriale standard AHCI 1.0
 
    Id hardware:
 
1)   PCI\VEN_8086&DEV_1C02&SUBSYS_76761462&REV_05
      PCI\VEN_8086&DEV_1C02&SUBSYS_76761462
      PCI\VEN_8086&DEV_1C02&CC_010601
      PCI\VEN_8086&DEV_1C02&CC_0106
 
 
 
Thank's

Edited by misterx7777, 09 March 2014 - 02:25 PM.


#1510
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64
@ misterx7777:

Thanks for posting the HardwareIDs.
Conclusion:
You can integrate any of the 32bit Intel RST drivers, but I recommend to take the 32bit Intel RST driver v11.2.0.1006 WHQL (you can take the modded version as well).
When nLite is going to integrate it as textmode driver, you should only check the listed "Intel® Desktop/Workstation/Server Express Chipset SATA AHCI Controller".
If you take an original (untouched) XP CD as source, I have no doubt, that you will succeed with the XP installation in AHCI mode.
My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#1511
misterx7777

misterx7777
  • Member
  • 6 posts
  • Joined 07-March 14
  • OS:XP Pro x86
  • Country: Country Flag

Thank you Fernando. I will do as you say and I'll let you know the result.



#1512
misterx7777

misterx7777
  • Member
  • 6 posts
  • Joined 07-March 14
  • OS:XP Pro x86
  • Country: Country Flag

Fernando, I have to thank you:

I'm writing from xp ahci. Everything is o.k.

The drivers are correct for my system. In addition I have also tried to force the same drivers in another hard drive with xp already installed (in device manager), and I had the same result.

So it also works in post installation, the only caution before is to disable the controller  eide already installed.



#1513
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64
@ misterx7777:

It is fine, that you succeeded with the XP installation in AHCI mode.
My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#1514
LeakHunter

LeakHunter

    Nigga

  • Member
  • 29 posts
  • Joined 31-August 13
  • OS:Windows 8.1 x64
  • Country: Country Flag

Somebody can advice where to download ahci driver for windows 2000 for Dell Latitude E4310 and how to integrate?


What is better than a Nigga? more...


#1515
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

Somebody can advice where to download ahci driver for windows 2000 for Dell Latitude E4310 and how to integrate?

If you find out the HardwareIDs of the on-board Intel SATA AHCI Controller, I would try to help you.
This is the way you get them: Install Windows 7, open the "IDE ATA/ATAPI Controllers" section, right click onto the listed AHCI Controller and choose "Oroperties" > "Details" > "Property" > "HardwareIDs".

Edited by Fernando 1, 23 March 2014 - 08:17 AM.

My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#1516
LeakHunter

LeakHunter

    Nigga

  • Member
  • 29 posts
  • Joined 31-August 13
  • OS:Windows 8.1 x64
  • Country: Country Flag

I do not have currently windows 7, but found the driver at the Dell site. I think this what I need for AHCI, however they do not write 2000 support, the XP is the oldest. Will the XP AHCI working with 2000?


What is better than a Nigga? more...


#1517
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

I think this what I need for AHCI, however they do not write 2000 support, the XP is the oldest. Will the XP AHCI working with 2000?

It seems possible, but I am not sure.

Your problem will be anyway, that you obviously do not know the exact name resp. DeviceID of the on-board Intel AHCI Controller. So you may have to guess it while integrating the AHCI driver into the Windows 2000 image or while loading the textmode driver via F6.
My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#1518
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,310 posts
  • Joined 14-September 05
  • OS:none specified
  • Country: Country Flag

Both of the XP Drivers are at that link (see this link to topic and my response).

 

You're welcome, LeakHunter...

http://www.msfn.org/...r-windows-2000/

;)


Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#1519
LeakHunter

LeakHunter

    Nigga

  • Member
  • 29 posts
  • Joined 31-August 13
  • OS:Windows 8.1 x64
  • Country: Country Flag

Thanks guys for the help. So is good if I simply select all the drivers and integrate them? Will the windows 2000 installer able to choose the correct one for my chipset?

 

OA0nw3q.jpg


What is better than a Nigga? more...


#1520
Fernando 1

Fernando 1

    Easy RAIDer

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,021 posts
  • Joined 03-June 05
  • OS:Windows 7 x64

So is good if I simply select all the drivers and integrate them?

The screenshot shows all Intel SATA Controllers, which are supported by the integrated textmode driver. but the Windows 2000/XP Setup at the beginning of the OS installation (before the first reboot) is not able to find out the suitable one for your system (see my last post). That is why it is not a good idea to highlight all listed Controllers.
You can minimize the risk of getting a BSOD while doing the OS installation, when you just highlight the Controllers with the word "AHCI" within their name.
My current system:
ASUS P8Z68-V | Intel Core i5 2500K | 2x4 GB Corsair XMS3 DDR3-1600 | 2x128GB Crucial M4 SSD as RAID0 in SATA3 mode | Seasonic M12II-520 Modular 520W | ATI Radeon HD6850 1 GB GDDR5
My old system:
DFI nF4 Ultra-D (BIOS: 2006/04/06) | AMD Athlon64 4000+ San Diego | 2x512 MB OCZ PC3200 CL2 Rev.2 Platinum | 2x200 GB Samsung S-ATA II as Raid0 | beQuiet!Titan BQT P5-470W-S1.3 | MSI GeForce NX6600GT-TD128E

#1521
LeakHunter

LeakHunter

    Nigga

  • Member
  • 29 posts
  • Joined 31-August 13
  • OS:Windows 8.1 x64
  • Country: Country Flag

Ok, Thanks man, I've got it! I'll put just the AHCI drivers into and if BSOD still comes, I'll install Windows 7 to find out which one is the really proper one. 


What is better than a Nigga? more...


#1522
zhilong

zhilong
  • Member
  • 1 posts
  • Joined 09-May 14
  • OS:Windows 8 x64
  • Country: Country Flag

Hello Fernando,

 

I am using asus zenbook prime ux32la with window 8.1 but i wanted to install window xp on it . but now i am facing problems installation window xp. It always showing blue screen . I have tried to use the driver that was share but am unable to install it. Please assist. I am using window xp sp 3 with nlite.

 

Have check mine is the Intel 8 series sata ahci family controller

 

hardware id

PCI/VEN_8086&DEV_9C03&SUBSYS_15DD1043&REV_04

PCI/VEN_8086&DEV_9C03&SUBSYS_15DD1043

PCI/VEN_8086&DEV_9C03&CC_010601

PCI/VEN_8086&DEV_9C03&CC_0106

 

 

maybe i missout something to include inside



#1523
cdob

cdob

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,000 posts
  • Joined 29-September 05

asus zenbook prime ux32la with window 8.1 but i wanted to install window xp on it

PCI/VEN_8086&DEV_9C03&CC_0106


http://www.win-raid....-C.html#msg4210

The best suitable Intel AHCI driver for the installation of Windows XP onto an Intel 8-Series chipset system is the "Universal 32bit Intel RST AHCI & RAID driver v11.2.0.1006 mod by Fernando" and the correct Controller for your system would have been the "Intel® 8 Series Chipset Family Mobile SATA AHCI Controller DEV_9C03 (added by Fernando)". With this Intel SATA AHCI Controller your Windows XP should run fine.



#1524
samson1701

samson1701
  • Member
  • 3 posts
  • Joined 07-June 14
  • OS:Windows 8 x64
  • Country: Country Flag

Hello Fernando,

 

I found this page by searching for answers to my XP install problem. I've purchased a Dell XPS 8700 with Windows 8 64bit on it. It has an i7- 4770 CPU @3.40GHz in it.  I'm trying to install XP Pro 32bit on a secondary hard drive that I've installed on it. I need XP to run some old software that won't run on anything after XP. I've tried virtual box but it was too sluggish to be useful.

 

Anyway, I enter the BIOS and switch it to Legacy Mode. I restart the PC and boot from my DVD Drive. Everything seems to go alright until the actual install begins. I get a ***STOP: 0x0000007B (0xF78D2524,0xC0000034,0x00000000,0x00000000). 

 

I've tried following your directions using nLite, but I could not even get that to work for me. I've copied my XP install disk to a new folder. I point nLite to that folder but it doesn't "see" anything in the folder. It just tells me, "'Make sure that the selected folder or drive contains the 'i386' or 'AMD64' directory and proper Windows installation files. nLite is for a pre-install environment only, meaning that it connot modify an exisitng Windows installation. An easy way is to insert your Windows installation CD and select your CD drive. Never copy the files directly to a partition root, create an empty folder first..' I'm using my XP Pro install disk. I know it works because I was able to use it on Virtual Box plus I've used it on a few of my machines over the last 4 years.. What could I be doing wrong? 

 

This is the controller info: Intel® 8 Series/C220 Chipset Family SATA AHCI Controller

 
I'm hoping you can help. I'd appreciate any guidance you could give me.
 
Thank you for your time.
 
Best,
Samson


#1525
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,564 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

I've tried following your directions using nLite, but I could not even get that to work for me. I've copied my XP install disk to a new folder. I point nLite to that folder but it doesn't "see" anything in the folder. It just tells me, "[/size]'Make sure that the selected folder or drive contains the 'i386' or 'AMD64' directory and proper Windows installation files. nLite is for a pre-install environment only, meaning that it connot modify an exisitng Windows installation. An easy way is to insert your Windows installation CD and select your CD drive. Never copy the files directly to a partition root, create an empty folder first..' I'm using my XP Pro install disk. I know it works because I was able to use it on Virtual Box plus I've used it on a few of my machines over the last 4 years.. What could I be doing wrong? 

Have you actually copied the WHOLE directry structures from CD (or .iso) to the folder on hard disk?
Like:
copy_cd_hdd.gif

jaclaz




3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users