Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


monohouse

XP Service Pack 3 support

33 posts in this topic

does nLite work with the latest (beta) XP service pack ? did anyone try it

what are those "performance improvements" in it ? did anyone notice them when they tried it ?

0

Share this post


Link to post
Share on other sites

Yes it works with sp3 build 3244, it slipstreamed flawlessly and patches seems to work well (tcp/ip, themes, sfc), unattended, options and tweaks seems to work ok also. Only thing I didn't tried is to play with the hotfixes, drivers and components part.

I didn't noticed any speed improvement since I did test it under a virtual machine.

Hope it helps

Blizz

0

Share this post


Link to post
Share on other sites

My two cents.

Unless you really need to do it, it might be a good idea to wait until the final. Why do I say this. Well, when I tried sp3 build 3205, I had absolutely no problems or issues whatsoever. Period. The computer worked great. However, everytime I tried sp3 rc1, build 3244, it keeps booting me off my Internet connection. I have tried four slightly different setups, but mostly the same as the one I have used for "3205". I was trying different 'addon's and a couple of times I was trying to add some drivers. Net result, I'm back to using "3205", with all the different "addon's" that I was looking for to make work in the first place. Thank goodness for DVD-RW's. LOL. Not to mention the fact I keep seeing posts of folk's having various issues. It is, afterall, still in 'Beta' phase.

That's it. The end.

Good luck in whatever you decide.

Eddie

0

Share this post


Link to post
Share on other sites

XP SP3 Build 3244 RC1 here....no problems.

Explorer seems to be more stable. I'll continue to use SP3 from here on.

0

Share this post


Link to post
Share on other sites

SP3 seems stable to me. The only addons I put on it are DX9c redist, KB888111 (minus portcls.sys/mssap.dll), and MU, none of which modify or overwrite any already present system files. I haven't hacked it with TCP/IP tweaks using out of date DLLs or removed any components.

They decided not to include HDA support, which is why I add KB888111.

0

Share this post


Link to post
Share on other sites

in regard to "you really need it", maybe not "need it" as in I can't live without it, but yes if it gives a 10% improvement in performance for various kinds of software compared to service pack 0, then I think I need it, don't need the rest of the crap it brings in it's 350MB package, but I will take care of that with the deleted edition if it actually does proove to be faster....

but does it ? did anyone run any tests ?

0

Share this post


Link to post
Share on other sites
SP3 seems stable to me. The only addons I put on it are DX9c redist, KB888111 (minus portcls.sys/mssap.dll), and MU, none of which modify or overwrite any already present system files. I haven't hacked it with TCP/IP tweaks using out of date DLLs or removed any components.

They decided not to include HDA support, which is why I add KB888111.

Strange...I couldn't integrate KB888111. It was telling me that it was already part of the package or that it was not compatible. I ended up having to use a new one, KB835221. I have sound, so I'm happy. :)

0

Share this post


Link to post
Share on other sites

what about the serial? did you guys integrated it using the SP2 serial in nlite?

0

Share this post


Link to post
Share on other sites

My gen serial now works fine with the newest SP3 RC1 (it did not work before)

Edited by ricktendo64
0

Share this post


Link to post
Share on other sites
Strange...I couldn't integrate KB888111. It was telling me that it was already part of the package or that it was not compatible. I ended up having to use a new one, KB835221. I have sound, so I'm happy. :)
I created a custom addon for use with RyanVM integrator.

KB835221 is actually older.. the file versions are 5.10.0.5011 where KB888111 is 5.10.1.5013, and it doesn't appear they even have an SP2 package for KB835221.

0

Share this post


Link to post
Share on other sites

Can you do unattended setup through nLite for SP3? I read that it does not require a serial to install anymore. Only activation.

0

Share this post


Link to post
Share on other sites

Unable to run any kb888111.exe on mashine with winxp sp3 installed,because it says higher version of windows is found.

Therefore unable to install HD Realtek driver and as result I haven't sound.

0

Share this post


Link to post
Share on other sites
My gen serial now works fine with the newest SP3 RC1 (it did not work before)

I have integrated v3244 SP3 manual...it doesn't accept gen XP SP2 product key....If nlite is used to integrate for XP SP3...Will XP SP3 accept XP SP2 product key?

0

Share this post


Link to post
Share on other sites
My gen serial now works fine with the newest SP3 RC1 (it did not work before)

I have integrated v3244 SP3 manual...it doesn't accept gen XP SP2 product key....If nlite is used to integrate for XP SP3...Will XP SP3 accept XP SP2 product key?

it works for me ....but it didnt work with previous versions of sp3

0

Share this post


Link to post
Share on other sites

Hopefully all the hotfixes, including those you have to call MSoft for for weird problems, and

those for reliability and added capability i.e. the KB888111 will be fully included in SP3. I hate

to start patching the SP3 with all the missing stuff that didn't get included.

Hopefully, wscript v5.7, media player 10/11, mmc, mdac, msxml software packages are also

integrated so that I don't have to load these too. The reason I say this is that they

are somewhere in the I386 directory cab files and not separately in the other sub directories

of the OS install disk. Support tools/deploy tools and remote desktop along with dot.NET are

addons which will have to be done when creating the OS disk.

Is anyone actually keeping track of every patch to be included, the filename and version to make

sure nothing is missed?

Can one do a diff between the unofficial SP3 patch and the MSoft pre-SP3 patch to see what

may be missing?

:unsure:

0

Share this post


Link to post
Share on other sites
I have integrated v3244 SP3 manual...it doesn't accept gen XP SP2 product key....If nlite is used to integrate for XP SP3...Will XP SP3 accept XP SP2 product key?

Works for me. XP Pro SP2 with SP3 RC1 slipstreamed via nLite.

I tried HFSLIP but that gave me issues.

0

Share this post


Link to post
Share on other sites

On the Bink forum I found there is a MS white paper here.

It gives at least some information from headquarters about what is included, no .Net, WMP11 and IE7 as far as I can see.

0

Share this post


Link to post
Share on other sites
My gen serial now works fine with the newest SP3 RC1 (it did not work before)

I have integrated v3244 SP3 manual...it doesn't accept gen XP SP2 product key....If nlite is used to integrate for XP SP3...Will XP SP3 accept XP SP2 product key?

replace the pidgen.dll with the one from the sp2

0

Share this post


Link to post
Share on other sites
On the Bink forum I found there is a MS white paper here.

It gives at least some information from headquarters about what is included, no .Net, WMP11 and IE7 as far as I can see.

Great! I see they will include msxml and mmc. However, nothing on windows script or MDAC though. :angry:

According to the table "Previous released functionality" it categorizes MDAC as MSXML6. Is this true?

I thought they were entirely different from each other.

Of course they'll include BITS and the Msoft installer.

0

Share this post


Link to post
Share on other sites
From Ryanvm's forums:

An addon to fix the 888111 problem!

integrate this on your SP3 source.

http://red.caek.org/addons/Universal_Audio...io_AddOn_1.0.7z

MD5: 68152827B02DD82D7E685BB25A32393C

Changelog:

- 1.0 Initial release, for SP3 only

Thank you SO MUCH! I've been pulling out my hair trying to figure out why this wasn't working, I finally realized it was the SP3 slipstream that I had w/o 888111, and the 888111 package wouldn't install due to SP3!!! Moronic. The file you linked from Ryanvm saved me a few more hours of frustration. Thanks!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.