• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
puntoMX

Enable Intel AHCI under XP; Case Closed, read second last post

252 posts in this topic

Edit (correct Intel driver + links):

[thank you theshadowrunner for pointing out the confusion :wacko:]

Hi every1,

From what I'm aware the unofficial Intel SATA/AHCI/RAID motherboard-based controller fix for XP is not necessary anymore, because Intel finally enabled that feature natively in their drivers. :thumbup

Note:

To install/test the Intel driver, it is recommended to uninstall/delete the unofficial driver (if any) first and then reboot.

Unofficial driver fix installs its files into the %windir%\IAHCI [%windir% = usually C:\WINDOWS] folder. Just delete all those files and reboot.

Therefore starting with Intel Storage Manager Driver version 9.6.0.1014 all one needs to do is:

1. Reboot.

2. Press Del, Esc, F1, F2, F3, F4 or F8 (see your motherboard documentation for specific key) to enter BIOS setup while your computer's initial POST (Power On Self Test) screen is still on -> change both settings below (if any) to match the values inside square brackets:

SATA RAID/AHCI Mode [AHCI]

SATA Port 0-3 Native Mode [Enabled]

Both these settings must be enabled *before* installing the driver in order for Intel setup to properly recognize AHCI/RAID hardware.

3. Reboot back to Windows.

4. Install current Intel Storage Manager Driver from here [11.2 MB, multilanguage].

This driver installs iastore.sys and enables AHCI/RAID modes if enabled hardware is detected at install time.

5. Reboot 1 last time.

This should (hopefully) work for every mobo based on Intel 9xx/3x/4x/5x chipset series.

Please see Intel ReadMe text for more info.

... And just in case the official Intel driver doesn't work, I'm keeping the unofficial driver fix at my site.

If any1 has problems with the mobo, SATA controllers or hard drives while AHCI is enabled, you can disable it easily:

go back into BIOS setup and disable/change any of those 2 settings [see #2 above].

Could disable both, wont't hurt anything, but this feature requires both enabled, otherwise cannot work.

PS:

I was also getting BSODs and STOP errors in XP [especially with AHCI enabled] with my old mobo [Gigabyte P35-DS3L], took me a while to figure out what was wrong, turned out to be a faulty capacitor. ;-(

I got a replacement [Gigabyte EP43-UD3L], and never looked back. Everything works 100% with or without AHCI enabled, even if overclocked. ;-)

___________________________________________

XP forums (super)mods...

Since this issue has been finally resolved, I propose to close this topic.

Thanks for caring.

HTH

Best wishes,

MDGx

0

Share this post


Link to post
Share on other sites

Nice, it took long enough for this topic to die. :lol:

CASE CLOSED!

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.