• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
EGOvoruhk

Help: I need to Get 2GB installed RAM working in Win98SE

136 posts in this topic

GreyPhound

``````````````````````

Windows 9x and lots of memory: Dotting the i's

@GreyPhound

I have a problem viewing images in the article. I get "403 Forbidden" error.

Please, try this link to the source article.

0

Share this post


Link to post
Share on other sites

You may want to take a look at this for those wanting to use Win98se with 2gigs of RAM:

http://aumha.net/viewtopic.php?t=24516

As for Max Monroe's RAM problem, try out the tips at the site mentioned above. If they work, great. If not, upgrade to Win2k or XP since they can handle large quantities of RAM pretty well.

0

Share this post


Link to post
Share on other sites

"6. AGP cards???? can be directed to use other memory I just forget where to. In most cases you need to tell it in the settings and it can see the extra memory it just has to reach it."

Anyone has a clue on how to do this and if it could be possible to address the memory problem by changing the video card memory usage?

0

Share this post


Link to post
Share on other sites
You may want to take a look at this for those wanting to use Win98se with 2gigs of RAM:

http://aumha.net/viewtopic.php?t=24516

As for Max Monroe's RAM problem, try out the tips at the site mentioned above. If they work, great. If not, upgrade to Win2k or XP since they can handle large quantities of RAM pretty well.

Maybe I'm missing something, but the guy at that forum only says "I have discovered universal solution which is not connected with the values of MaxFileCache and MaxPhysPage. [...] I think the concept could be worth of money for multi boot users." - and that's the end of it; the solution is never revealed, nor pointed to. Thanks for the effort, anyway. :unsure: As for the upgrade, I'm already multibooting XP; the idea was to try to avoid ditching win98 (hint to BenoitRen - I'm not the enemy), of which I'm quite fond, having had it as my main OS over XP. :}

0

Share this post


Link to post
Share on other sites

I've done some tests to find out more about the relationship between XMSDSK, MaxFileCache and the number of simultaneous DOS windows. Here are the results:

Motherboard = Intel D201GLY2

Total system RAM = 1GB

IGD Aperture Size = 128MB Minimum possible (AGP Aperture)

IGD Share Memory Size = 32MB Minimum possible (Video RAM)

OS = Win98SE

Memory map for top 1 GB:

E000 0000 - EFFF FFFF System board extension for ACPI BIOS

FEC0 0000 - FEC0 0FFF System board extension for ACPI BIOS

FEE0 0000 - FEE0 0FFF System board extension for ACPI BIOS

FFF8 0000 - FFFF FFFF Unavailable for use by devices

Minimum XMSDSK = 264192 = 258MB. Windows will not boot with any less

Maximum XMSDSK = 886784 = 866 MB

Minimum MaxFileCache = 2048 = 2MB. Could use 1MB but no advantage

Maximum MaxFileCache = 624640 = 610MB with minimum XMSDSK = 264192 = 258MB

Maximum XMSDSK+MaxFileCache = 888832 = 868 MB. Only 1 DOS window possible

Address space per extra DOS window = 4MB Reduce XMSDSK+MaxFileCache accordingly

Maximum simultaneous DOS windows = 109 Limit, even if more address space available

Notes

MaxFileCache must be defined when using XMSDSK with 1GB system RAM.

ScanDisk should be run with Thorough test to make sure all clusters on RAM drive work.

A different motherboard will produce different results.

MaxPhysPage was undefined throughout.

I did not have 2GB RAM to test.

Edited by diskless
0

Share this post


Link to post
Share on other sites
I've done some tests to find out more about the relationship between XMSDSK, MaxFileCache and the number of simultaneous DOS windows. Here are the results:

[...]

I did not have 2GB RAM to test.

Way to go, diskless, way to go! :thumbup Keep on the great work! :thumbup

0

Share this post


Link to post
Share on other sites

then...somebody has get to install win98 on a 2gb computer? im trying it and i cant... :(

0

Share this post


Link to post
Share on other sites
then...somebody has get to install win98 on a 2gb computer? im trying it and i cant... :(

It is possible to do it. Read this old post of mine. Andy Aronoff's post at techarena seems not to exist anymore, so I reproduce it here. AFAIK, Andy was the first to describe how to do it.

Date: 13 May 2005 02:11 GMT

Re: Can't start up with 2 GB RAM

Hi, Ron.

Thanks for your suggestions.

Try reducing the MaxPhysPage parameter even further, to 30000 (=768mb) or even 20000 (= 512 mb).

As it turns out, what was keeping the PC from booting was the MaxFileCache value. I was able to boot with MaxPhysPage=38000 and MaxFileCache=30000. If MaxFileCache was above 200000, the PC wouldn't boot. Below 200000, it would boot, but running an MS-DOS program would throw the error, "There is not enough memory available to run this program." The error occurred at 40000 but not at 30000.

I'm now able to boot into W98 SE and run MS-DOS programs. That's exactly what I wanted.

regards, Andy

If that's not enough, be sure to read thoroughly all that's been posted about "Win 9x/ME with more than 512MB" (and follow the links therein), including the present thread from the begining and also these others:

http://www.msfn.org/board/index.php?showtopic=105373

http://www.msfn.org/board/index.php?showtopic=99263

http://www.msfn.org/board/index.php?showtopic=79756

http://www.msfn.org/board/index.php?showtopic=59765

Good luck!

Edited by dencorso
0

Share this post


Link to post
Share on other sites
I've got 2 1GB sticks of RAM in my system. I know (or assume rather) I can't use 2GB with 98, but I need them installed because it's a multi-boot system. I installed 98 with just one of my sticks in, and then went about trying to work how to get the second one in. I began my search, and I was directed to this site for help. I finally got my system to boot with MaxPhysPage=38000 and MaxFileCache=30000, but now I have a different problem. Once in Windows, I can't get a command prompt to load without it telling me I have low memory. This also happens when trying load applications, or games

Any help would be appreciated. For now, I'm just going to start messing with the values, hoping to come across some magic, but I'm just shooting in the dark

Thanks in advance :thumbup

Here is the easiest solution to limiting memory with Win98:

1. Run [msconfig].

2. Click on the [Advanced] tab.

3. Put a "check" next to [Limit memory to].

4. Then change memory value to read [512].

5. Reboot.

0

Share this post


Link to post
Share on other sites
then...somebody has get to install win98 on a 2gb computer¿? im trying it and i cant... :(

It is possible to do it. Read this old post of mine. Andy Aronoff's post at techarena seems not to exist anymore, so I reproduce it here. AFAIK, Andy was the first to describe how to do it.

Date: 05/13/2005

Re: Can't start up with 2 GB RAM

Hi, Ron.

Thanks for your suggestions.

Try reducing the MaxPhysPage parameter even further, to 30000 (=768mb) or even 20000 (= 512 mb).

As it turns out, what was keeping the PC from booting was the MaxFileCache value. I was able to boot with MaxPhysPage=38000 and MaxFileCache=30000. If MaxFileCache was above 200000, the PC wouldn't boot. Below 200000, it would boot, but running an MS-DOS program would throw the error, "There is not enough memory available to run this program." The error occurred at 40000 but not at 30000.

I'm now able to boot into W98 SE and run MS-DOS programs. That's exactly what I wanted.

regards, Andy

If that's not enough, be sure to read thoroughly all that's been posted about "Win 9x/ME with more than 512MB" (and follow the links therein), including the present thread from the begining and also these others:

http://www.msfn.org/board/index.php?showtopic=105373

http://www.msfn.org/board/index.php?showtopic=99263

http://www.msfn.org/board/index.php?showtopic=79756

http://www.msfn.org/board/Win9x-512-MB-RAM-t59765.html

Good luck!

The problem is...i can't get install windows98...how I modify system.ini if it was not created yet? :S

0

Share this post


Link to post
Share on other sites

I am a little rusty but I think this is it. Someone please correct me if I'm wrong.

From memory windows starts to install, but on its first restart it crashes right?

So let it start to install as normal, then when it gives you the error about not enough memory to initialise...

You have to use a boot disk to get to a command prompt.

Put in a boot disk, press Ctrl-alt-delete to restart the computer

Then type EDIT

The press "Alt F" to open the file menu. Scroll down and select OPEN

Browse your file system and find system.ini in your WINDOWS folder.

Add the line:

MaxPhysPage=30000

save

Close

press ctrl-alt-delete to reboot again

Windows should continue its setup process.

Edited by galahs
0

Share this post


Link to post
Share on other sites

...

Add the line:

MaxPhysPage=30000

...

MaxPhysPage=30000 has to be under the [386Enh] section of SYSTEM.INI.

You will need to put MaxFileCache=65536 under the [vcache] section in SYSTEM.INI.

If there is no [vcache] section then just add it to the end of the file.

After Windows has installed, you can experiment with these values to find optimal maximums.

You can get to a 98SE command prompt by holding the Ctrl key as Windows starts.

You may need to hold the Ctrl key just after the computer beeps after the POST.

The Microsoft Windows 98 Startup Menu will appear. Select Safe mode command prompt only.

This can also be used when you are testing values of the above and Windows does not start.

From the command prompt, type edit c:\windows\system.ini

Use the Alt key to bring up the Edit menu.

0

Share this post


Link to post
Share on other sites

Does anyone use 2G RAM and Video Card with 256MB RAM can boot win98 successful ?

My Video Card is GeForce 6800Ultra , and I try to edit system.ini with any possible config but I can't find anyway to boot win98 successful........................... :(

0

Share this post


Link to post
Share on other sites
StarRiver said:
Does anyone use 2G RAM and Video Card with 256MB RAM can boot win98 successful ?

My Video Card is GeForce 6800Ultra , and I try to edit system.ini with any possible config but I can't find anyway to boot win98 successful........................... :(

Well, the last resort is to try rloew's RAM Limitation Patch. It's not for free, though. But the demo is, so you can test and see whether it solves your problem. HTH.

0

Share this post


Link to post
Share on other sites

Has anyone in this forum used with success Loewe patch complete version?

Edited by vick1111
0

Share this post


Link to post
Share on other sites
Does anyone use 2G RAM and Video Card with 256MB RAM can boot win98 successful ?

Yes, this is now also my case of troubles:

I still use Win98SE (multiboot with DOS, WXP, Linux) and I just upgraded

RAM from 1GB to 2GB (my system is 945/ICH7 mb & 7600GS PCIE 256M VGA).

I hadn't any problems under 98SE with 1G, as I know about VCACHE issue I

limited it in system.ini:

MaxFileCache=261120

MinFileCache=32768

ChunkSize=4096

...

MaxPhysPage=40000

As this works fine I didn't expected further problems with adding

more mem. I just pull two 1G DIMMs and when 1st booting 98SE it

hangs in text mode screen with blinking cursor. I tried safe mode

but got insufficent memory message during boot. When I tried normal

mode again, it went further but I got only VGA mode 640x480/16

with message "There is a problem with your display settings. The

adapter type is incorrect, or the current settings do not work

with your hardware [OK]". Then display dialog appeared. I tried

to set some higher resolution, reboot but then it hanged again.

I search a lot of topic on web and try adjusting vcache size and

lowering physpage limit, even some patched vcache.vxd but nothing

helped.

I also found Loew's memory limit patch demo. 1st problem was that I

use czech win98se so patch didn't applied. I had to seek some

torrents to get eng. ISO. I backup my system and made clean

win98se-eng installation. I needed to modify system.ini physpage

to complette installation to solve insuficent memory error.

System seemed to work OK with 2GB installed - seeing only 1GB.

But after I installed ForceWare 82.69 drivers for my nVidia

it become unbootable like my CZ version, hanging during boot.

So then I tried Loew's parch 3.2 demo. Now it successfully patched

the english files. I booted safe mode and it booted OK and

even show up all 2GB.

http://rayer.ic.cz/350d/WIN2GBPT.PNG

Well but the problem is that in safe mode VGA drivers are not

loaded so I cannot see if it will works together like in normal

mode. I don't need to use whole 2GB under 98SE (1G is enough) I

just want boot it in normal mode with display driver in usable

resolution.

I also tried to change VGA to my older 6600GT 128MB and same problem.

It seems like VGA LFB memory mapping conflicts with something else.

But I don't understand why. If I'm right, W9x use for this system area

located C0000000-FFFFFFFF. My VGA use LFB at always at D0000000-DFFFFFFF

despite I use 1GB or 2GB RAM it's in system area where it fitted well before.

Do you think that Loew's patch (full) will solve it or is there other way

to use it with limited memory?

Can be size of memory limited at very low HW level? I mean e.g. program

945 MCH chipset to temporary disable one DIMM bank to reach same

effect like when DIMM removed physically?

0

Share this post


Link to post
Share on other sites

Problem (partially) solved!

After some days of messing I finally found HimemX XMS manager freely available here http://japheth.de/Jemm.html

which allows you to limit XMS size by /MAX= option. After I limit XMS to 1GB it boots and seems to work fine!

Of course windows sees then only 1GB but it's acceptable for me, I don't need then any commercial patch.

Here's my lines of system.ini:

[386Enh]

MaxPhysPage=40000

[vcache]

MaxFileCache=261120

MinFileCache=32768

ChunkSize=4096

0

Share this post


Link to post
Share on other sites

Thanks xrayer .

Could you write a quick step to step of how to install and use this Expanded Memory Manager

This will come in handy more and more in the future, no doubt.

Edited by galahs
0

Share this post


Link to post
Share on other sites
Problem (partially) solved!

After some days of messing I finally found HimemX XMS manager freely available here http://japheth.de/Jemm.html

which allows you to limit XMS size by /MAX= option. After I limit XMS to 1GB it boots and seems to work fine!

Of course windows sees then only 1GB but it's acceptable for me, I don't need then any commercial patch.

...

Nice!

xrayer, does this also let you boot into Safe Mode?

This was always a problem with 1.5GB or more of RAM since the SYSTEM.INI memory settings are ignored in Safe Mode.

I wonder if by limiting RAM at the XMS manager level, it might be possible to get more RAM available to Windows than the current maximum 1152MB?

1280MB?

Something to look at!

0

Share this post


Link to post
Share on other sites

Currently, with only replacing the himem.sys its unable to boot safemode coz windoze then load himem.sys on its own. But I found the strings in IO.SYS and patched and then it run also in safemode. I will program some small patch utility to rewrite it.

Installation of himemx.exe is quite esay, just download it, extract himemx.exe to windows directory and replace the line in config.sys to calling this driver. It has regular EXE stub so you can type "himemx.exe" in command line to get help, also there is included documentation and source code :) Thanks to Japheth maintaining it.

Edited by xrayer
0

Share this post


Link to post
Share on other sites

You might want to try patch.exe, from KanastaCorp: it's freeware, very small and very simple to use.

I think you should add Xeno86's fixed VCache.VxD to your system, at least because, when in Safe Mode, as you know, system.ini is ignored, so that your system is at risk of crashing from VCache getting too big. It gives you a default of 393216 (384 MB), which is much safer than 800 MB, and you still can keep your MaxFileCache=261120 entry in system.ini file, for normal mode operation.

And, finally, if you feel like it and have time to do it, I'd much appreciate to know how your system behaves when limited to 1280 MB and to 1536 MB, with a XMSDSK of 262240 and MaxFileCache=114688. Yes, these are the settings that work in my 1.5 GB system, but I use a 32 MB video board with 64 MB AGP aperture... My guess is that your system won't work with 1.5 GB but may possibly do so with 1.25 GB. Since you are the first to discover that windows 9x/ME in fact does not directly detect how much RAM the system has, but relies instead in what the XMS manager tells it, you should also be the first to explore the tweaking possibilities this knowledge opens up to all of us.

You rock! :thumbup

0

Share this post


Link to post
Share on other sites

Hi,

I wrote a small patch yesterday http://www.volny.cz/rayer/os/w98iopat.exe which fix IO.SYS to load himemx.exe instead of himem.sys for safe mode. I don't have problems with crashing in safemode (btw I know about mentioned fixed vcache.vxd). Just copy patch to root dir beside io.sys and run it (make backup before).

I didn't much experimended how can be RAM increased, I just try a few values 1.5G 1.25G (physpage=60000 resp 50000) and it hangs during boot so I gave it up, some additional few megs + are not much important for me, I need stable system. I laso tried to eat excesive RAM with XMSDSK but it didn't work for me.

0

Share this post


Link to post
Share on other sites

Thanks for xrayer :thumbup I also multiboot Win98 and WinXP with 2GB RAM successful while use HimemX.exe :thumbup

Here's my win98's modify steps

1. Download HimemX from http://japheth.de/Jemm.html

2. Copy himemx.exe to win98 directory

3. Add the line in config.sys

DEVICE=C:\WIN98\HIMEMX.EXE

4. Here's my lines of system.ini:

[386Enh]

MaxPhysPage=48000

MinSPs=16

ConservativeSwapfileUsage=1

DMABufferSize=64

[vcache]

MaxFileCache=65535

ChunkSize=1024

After these step, I boot win98 with 2G RAM successful

In winXP, the sysem can detect 2GB RAM

2379680319_e96b98abb8_o.jpg

And in win98, the system can detect 1150MB RAM

2379678421_1f7e0c69e0_o.jpg

0

Share this post


Link to post
Share on other sites

Hi xrayer,

I wrote a small patch yesterday http://www.volny.cz/rayer/os/w98iopat.exe which fix IO.SYS to load himemx.exe instead of himem.sys for safe mode.

I think there might be a little problem with your IO.SYS patch!?

Look at the bytes in the following 2 lines: (o=0x0, d=0xd)

\HIMEM.SYSo/TESTMEM:ONdoo

\HIMEMX.EXEo/MAX=999999do

Since HIMEMX.EXE is one byte longer than HIMEM.SYS, the termination zero-byte 0x0 is moved one byte to the right by your patch. But this is exactly the byte where the HIMEM parameter /TESTMEM starts. So if IO.SYS is using the usual method of addressing strings (with a fixed address table), and I´m quite sure it indeed does it this way, then this address pointer for the parameter now points to this zero-byte (instead of the starting ´/´ of /MAX=...). So this parameter /MAX=999999 isn´t used at all by IO.SYS, I´m afraid! :(

A simple solution would be to just rename HIMEMX.EXE to HIMEM.EXE, so the length would be the same as HIMEM.SYS and the terminating zero-byte doesn´t need to be moved.

Furthermore you could now even use 1 full GB (1048576) instead of 999999, because after the /TESTMEM string there are 2 zero-bytes (but only 1 is needed of course), so you could increase the string length by 1 byte.

Edited by fhub
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.