Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Turn off "File Download - Security Warning"

- - - - -

  • Please log in to reply
4 replies to this topic

#1
ChrL

ChrL
  • Member
  • 2 posts
  • Joined 29-December 07
Each time I try to download any kind of data file (.doc, .mp3 whatever) from my local computer, Internet Explorer 7 on Windows XP presents me with a dialog box, called "File Download - Security Warning".
It is asking whether to Save or Open the file directly, or Cancel the download. The checkbox "Always ask before opening this type of file" has disappeared. There seems to be no way to
get rid of the dialog. The file type available through Folder Options | File Types | Advanced does not provide any way of changing this, only the checkbox "Confirm open after download", which obviously does not help. Oh, boy!

I have tried looking into the post with "Turn off Open File - Security Warning" on this site, but that only seems to work for executables, and does not apply in my case, or maybe I'm doing something wrong.


Can anybody help?


How to remove advertisement from MSFN

#2
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,622 posts
  • Joined 14-September 05
  • OS:none specified
  • Country: Country Flag
"save/open/cancel"... Not sure of that... Should have taken action you specified when you "unchecked" it for that type (I think, ennyhoo, from light search/reading on it).

Checkbox" missing - go here for "how to reset" (IE7 specific) -
http://www.mydigital...ox-in-vista-ie/
It talks about Vista, but probably applies to all IE6/IE7 versions (I have IE6 and that REG key exists but has no values, sincle I always want to be asked). Try looking there, clear them out, and try it again(?)...

edit - another discussion on the subject -
http://www.pcreview....read-693095.php
(would give you MSFN topics/posts on the subject but i'm a kinda google-er...)

oh and here - "unsafe" list -
http://support.micro...kb;EN-US;291369

and here's a tidbit -

1) Open a folder (any folder) on your pc,
2) Tools > Folder Options > File Type tab,
3) Scroll down to the extension,
4) Click "Advanced",
5) Check the "Confirm Open After Download" box,
6) Now go online and try to download a file,
7) IE should now "download" the file instead.

The funny part is that the "Always ask before opening this type of file" check box is not
available for files with the extensions .exe or .com, etc. You will always be asked before
opening this type of file. However, by performing the above mentioned steps, you will get
IE to ask you before opening ANY kind of file, not only ZIP files.


ok!!! - "enhanced security" - read here also -
http://www.microsoft...xp/iesecxp.mspx

just do a search on "file download - security warning"; appears to be a lot of reasons why this is happening...

Edited by submix8c, 29 December 2007 - 02:28 PM.

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image


#3
ChrL

ChrL
  • Member
  • 2 posts
  • Joined 29-December 07
Problem persists!!!

Hey submix8c, thanks for your lengthy reply!
But I need even more help....

I have tried all of the above stuff, including resetting the Windows settings as explained in the links you provided, through flipping the Confirm checkbox.
I have also tried to mimic the Vista solution, just in case something wasn't explained right. All to no avail, it seems.

..
Here is the problem presented again:

I have an html file on my local computer. I links to an .mp3 file, also on my local computer. (So you see, no unsafe files, as of Microsofts list)
and I get this dialog (except of course that it is an .mp3 file, not an executable as shown here.)

http://img.microsoft...xp/iesecx08.gif

Notice how there is no checkbox there which can be used to make this dialog go away.

I want that dialog gone!!!

Please help me.

Edited by ChrL, 30 December 2007 - 07:45 AM.


#4
GrofLuigi

GrofLuigi

    GroupPolicy Tattoo Artist

  • Member
  • PipPipPipPipPipPip
  • 1,367 posts
  • Joined 21-April 05
  • OS:none specified
  • Country: Country Flag
You have been marked by Micro$oft in the name of security. :realmad:

The remedy. :)

GL

#5
submix8c

submix8c

    Inconceivable!

  • Patrons
  • 4,622 posts
  • Joined 14-September 05
  • OS:none specified
  • Country: Country Flag

I have an html file on my local computer. I links to an .mp3 file, also on my local computer. (So you see, no unsafe files, as of Microsofts list) and I get this dialog (except of course that it is an .mp3 file, not an executable as shown here.)

Is this an HTML that you created (including the Link) or one that you "saved" (as GrofLuigi suggests)? I believe that an HTML that contains a valid Link (whether pointing to a website or your HDD) is going to give this due to the "unsafe list" rule regardless of what you want it to do. I have "saved" as "HTML-Only" and downloaded/saved files linked to into the same folder and always get the "Save/Run" dialog (and the HTML link points to the file on the HDD), with the Default IE/Windows Install settings (never changed anything, remember?).

Bottom line (anyone want to correct me, feel free) is you can't stop it from happening as the HTML is "set up / coded". BTW, the "list" is (as the links I provided suggest) doesn't state that it's actually "unsafe", just potentially unsafe, hence the requirement to ask what action you want to take.

If your intent is to play the MP3, don't do it from within an HTML, do it from a Player directly; or execute a Player from within the HTML using correct "coding techniques" (of which I am not knowledgable; look elsewhere for how-to - the "setup / coded" reference above). This is how, e.g. MySpace, does it...

Someday the tyrants will be unthroned... Jason "Jay" Chasteen; RIP, bro!

Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users