Sign in to follow this  
Followers 0
ctpm

[Resolved] Need help for DiskConfiguration

7 posts in this topic

Sorry for my English, I'm from France.

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>fr-fr</UILanguage>
</SetupUILanguage>
<InputLocale>fr-fr</InputLocale>
<SystemLocale>fr-fr</SystemLocale>
<UILanguage>fr-fr</UILanguage>
<UILanguageFallback>fr-fr</UILanguageFallback>
<UserLocale>fr-fr</UserLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
[color="#FF0000"]<DiskConfiguration>
<Disk wcm:action="add">
<CreatePartitions>
<CreatePartition wcm:action="add">
<Extend>true</Extend>
<Order>1</Order>
<Type>Primary</Type>
</CreatePartition>
</CreatePartitions>
<ModifyPartitions>
<ModifyPartition wcm:action="modify">
<Active>true</Active>
<Extend>false</Extend>
<Format>NTFS</Format>
<Label>SYSTEM</Label>
<Letter>C</Letter>
<Order>1</Order>
<PartitionID>1</PartitionID>
</ModifyPartition>
</ModifyPartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
<WillShowUI>OnError</WillShowUI>
</DiskConfiguration>[/color]
<Display>
<ColorDepth>32</ColorDepth>
<VerticalResolution>768</VerticalResolution>
<HorizontalResolution>1024</HorizontalResolution>
</Display>
<WindowsDeploymentServices>
<ImageSelection>
<InstallTo>
<DiskID>0</DiskID>
<PartitionID>1</PartitionID>
</InstallTo>
</ImageSelection>
<Login>
<Credentials>
<Domain>******</Domain>
<Password>*****</Password>
<Username>exp1</Username>
</Credentials>
</Login>
</WindowsDeploymentServices>
</component>
</settings>
<cpi:offlineImage cpi:source="catalog:c:/wiim save/install_windows vista ultimate.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

Here is my unattend file (applicated to the WDS server).

Actually it only works with one partition, but I can't use it for 2 two partitions.

I have a 40 Go disk, so I want to have a system partition (20Go) and a Data partition which use the rest of the space. What configuration shlou have to use on WSIM or directly onto my unattend file?

Another question : is that true that Vista can only be installed in a partition which size is half size of a disk? So if i have a 400 Go sized disk, my system partition should do 200 Go?

Edited by ctpm
0

Share this post


Link to post
Share on other sites

:thumbup

Here you go!

Just add this too your XML file, hopefully this should work.

The Fist partition is called 'System' and is 20Gb, the second partition is extended to the rest of the drive and is called 'Data', so you can modify the name if you wish. As for Vista's main system drive has to be at least half the overall size of the drive ? I don't think so.

I setup the partion so the C: drive is 35Gb and the second partition fills the rest of the drive, and we use a 160Gb drive without a problem.

<DiskConfiguration>
<Disk wcm:action="add">
<ModifyPartitions>
<ModifyPartition wcm:action="add">
<Active>true</Active>
<Extend>false</Extend>
<Format>NTFS</Format>
<Label>System</Label>
<Letter>C</Letter>
<Order>1</Order>
<PartitionID>1</PartitionID>
</ModifyPartition>
<ModifyPartition wcm:action="add">
<Active>false</Active>
<Extend>false</Extend>
<Format>NTFS</Format>
<Label>Data</Label>
<Letter>D</Letter>
<Order>2</Order>
<PartitionID>2</PartitionID>
</ModifyPartition>
</ModifyPartitions>
<CreatePartitions>
<CreatePartition wcm:action="add">
<Order>1</Order>
<Size>20000</Size>
<Type>Primary</Type>
</CreatePartition>
<CreatePartition wcm:action="add">
<Extend>true</Extend>
<Order>3</Order>
<Type>Logical</Type>
</CreatePartition>
<CreatePartition wcm:action="add">
<Order>2</Order>
<Extend>true</Extend>
<Type>Extended</Type>
</CreatePartition>
</CreatePartitions>
<DiskID>0</DiskID>
<WillWipeDisk>true</WillWipeDisk>
</Disk>
</DiskConfiguration>

0

Share this post


Link to post
Share on other sites

<ModifyPartition wcm:action="add">

Shouldn't I specify action="modify" ?

0

Share this post


Link to post
Share on other sites

That was ripped straight out of my working XML file, try it first just to see what happens.

0

Share this post


Link to post
Share on other sites

men you save me !!!

Thanks to you I can do what I want with my partitions now !

thanks a lot :thumbup

et merci à toi ctpm d'avoir poser ta question ^^ yess !

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.