Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

$WinPeDriver$ folder in Vista SP1/W2K8

- - - - -

  • Please log in to reply
1 reply to this topic

#1
midiboy

midiboy

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 703 posts
  • Joined 04-July 04
Hi guys,

has anyone already tried the $WinPeDriver$ folder in Vista SP1 ? From reading the setupact.log file WinPE checks the contents in a folder named $WinPeDriver$ on any accessible drive. I haven´t had a chance to test this on a real machine, just vmware so I can´t say if it really works or not. Has anyone tried it yet ?

Alex


How to remove advertisement from MSFN

#2
midiboy

midiboy

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 703 posts
  • Joined 04-July 04
Well,

i have done some tests with this folder. It does work but there are exceptions. First, if the Intel chipset inf files are in there (tried at least a few 8.x versions) Windows PE will stop the setup with a driver installation error. So you cannot add those drivers.

Second: if the Intel Matrix Storage driver is added to that folder (isastor.sys), Windows will use that driver even inside a vmware virtual machine and after reboot you will receive an error message saying that the driver (iastore.sys) cannot be loaded.

The vmware network drivers are picked up fine, I can´t say much more because I am still testing inside a virtual machine.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users