nuhi

nLite 1.4.9.1 - Honey Turbo 9.1

425 posts in this topic

Bootable CD created with Nlite 1.4.5 say on one computer (from 3 i tested) in boot sequence : Couldn't find NTLDR

0

Share this post


Link to post
Share on other sites
Hm, now that I think about it... Am I supposed to redo all presets from scratch everytime new version is released? Even one would suck more than a pornstar, but damnit, I use three different ones!!!

Did you even try to read my previous post here? No, you don't need to redo your preset when new version is out, you can always use the same!

Hi!

I have a Windows XP HOME sp1 HUN install disc. I integrate sp3 with nlite, but it wont accept the serial. What's wrong?

When i integrate sp2, the serial worked!

Which version of nLite are you using? Try with latest version if don't have it. And if still does not work, I suppose you are doing slipstream under Vista. Although nLite should fix this problem, for someone fix does not work, so you'll have to slipstream under XP as host, or try to run nLite in compatibility mode in Vista.

Bootable CD created with Nlite 1.4.5 say on one computer (from 3 i tested) in boot sequence : Couldn't find NTLDR

First, upgrade your nLite to latest version. Second, upload your preset. Third, try to create ISO with nLite and to burn it with some burning software and use lower speed when burning.

Cheers ;)

Edited by mara-
0

Share this post


Link to post
Share on other sites

@mara-

Never! Not true! You can always use old preset with new version. Only when Nuhi points out that old preset don't work then you should not use it. I always use my same presets with new version and I haven't a single problem. Also there is no "sticky" with this.

Be glad, that it always (!) works for you.

For me and several others, it doesn´t.

I was talking about final versions.

(But even some tweaks in a (silent) update -and you are correct, Nuhi explicitely notifies us- can make an older preset unreliable, not to mention, what happens, if the drivers or addons are not in the same path anymore. ;) )

It was in the "sticky"-thread of an older final.

E.g. there were several problems due to the (german) languagefile-update in the "german-nlite.de"-forum.

(But now everybody is happy about it)

Don´t know, if there have been similar problems in other fora.

Even if we´re talking about "non-localized" english versions of windows, I still doubt, that a preset, built with a former final, is working flawless on an actual one.

So it is "ill-advice" to say :

"It always (!) works, unless we´re notified by Nuhi".

You wouldn´t import an old 1.2.1 preset yourself, won´t you ?

@all

Use the presets, built within the same final-version, unless it´s specifically mentioned othervise (have a look in the changelogs) and you´re on the safe side.

Agi

Edited by AgiHammerklau
0

Share this post


Link to post
Share on other sites

Not sure what is causing this, but I integrated SP3 & IE8 ... everything was perfect until I tried to go to IE8 Tools/Options ... I keep getting a message that it has been disabled by the administrator!!!

Wonder how that happened!

0

Share this post


Link to post
Share on other sites

Hm, I've been using this one preset for quite some time, just adding to it over time. Perhaps I should redo it "just in case", even though everything seems to be perfectly well (how would you tell though...)?..

0

Share this post


Link to post
Share on other sites
Loaded a preset created with some of the previous versions of nLite (but not too old). Made some adjustments and created ISO. Seems to work OK, not burned/installed the ISO yet (don't have enough time), but I noticed some of the options from the old preset were not present in the Last Session.ini. They are:

Boot and Shutdown-Setup Prefetch-Cache-Disabled

Explorer-Disable Accessibility keyboard shortcuts

Explorer-Launch folder windows in a seperate process

Performance-Enable USB Idle Endpoint support

Start Menu-Disable popup on first boot

Visual Effects-Smooth edges of screen fonts-ClearType

Windows Media Player-Disable silent acqusition

While working with nLite, I didn't check specifically for these items, but everything seemed fine, just the way I always do it. Are these tweaks:

a ) removed from nLite?

b ) removed from XP SP3? (the previous preset MIGHT have been from SP2)

c ) moved to another place in nLite? (but there were no new entries similar to them)

d ) a bug in nLite? (forgot them)?

e ) my mistake? (should've started from scratch, but then why have Import Last Session Ini anyway?)

This was checked by doing text compare of the Old Preset.ini and Last Session.ini. When I install the CD, I will know more, but sometimes some of the tweaks don't 'take', so...

Which letter is it? :)

GL

After install, it seems that the tweaks were applied. Can't know for sure because I don't know the exact location for some of them. But I don't understand why were they removed from Last Session.ini.

Again, what I did was:

- Load nLite

- Import Old Session.ini which I work with most of the time

- Adjust some settings (not the ones above, I usually don't touch them; maybe only USB idle)

- make ISO and finish nLite

- binary compare Old Session.ini and Last Session.ini - they are not present

- but they are applied?!

Now I don't understand anything. I guess it isn't a bug, it's a feature - only Nuhi can tell. :)

Off to building New Session.ini. :D

GL

0

Share this post


Link to post
Share on other sites

I guess I will open nLite with my current settings in VirtualPC on 2nd monitor and create new one based on what I see there. lol.

(unless someone tells me how /if/ do I run another instance of nLite on same PC..

0

Share this post


Link to post
Share on other sites

Hi all,

I gave 1.4.6 a try. It comments the nap*.mof in wbemoc.inf, but errors/broken installs are not gone using the winnt.exe method via share.

Currently it is necessary to do the following steps:

Mit nlite 1.4.6

ISO with sp3 integrated (vanilla ms)

Run Nlite and import last.exssion.ini

add addon packs (i take sereby's german ones for fixes, runtimes, wmp11 and ie7), ie7 addon at last

txtsetup.sif:

acadproc.dll doppelte Einträge weg (remove duplicate entry)

napprov.mof, napschem.mof, rsop.mof, wscenter.mof, and rsop.mfl --> remove or comment ;.

unpack wbemoc.in_ and remove/comment above 5 files in [WBEM.CopyMOFs]

replace usetup.exe in the I386 with SMSS.exe from I386\System32

add $$replace file in $oem$/$1/system32:


[\WINDOWS\System32\WBEM]
evtgprov.dll = "CmdEvTgProv.dll"
evtgprov.mof = "CmdEvTgProv.mof"
Napprov.mof = "NapClientProv.mof"
NapSchem.mof = "napclientschema.mof"

[\WINDOWS\System32\]
msjetol1.dll = "msjetoledb40.dll"
class_ss.dll = "shellstyle.dll"

(Optional) recompress with makecab: svcpack.inf und wbemoc.inf, and remove unpacked files.

delete lang und win9xmig dirs

My last session.ini for information:


[Main]
Env = 1.4.6 - 2.0.50727.1433.Microsoft Windows NT 5.1.2600 Service Pack 3
Target = Windows XP Professional SP3 - 5.1.2600.5512 - Deutsch (Deutschland)

[Tasks]
Remove Components
Hotfixes and Update Packs
Tweaks
Options

[Components]
;# Anwendungen #
Ablagemappe
Aktentasche
Bildschirmschoner
Eingabehilfen
Internet-Spiele
Paint
Pinball
Spiele
;# Betriebssystem #
Blaster/Nachi-Entfernungswerkzeug
Desktopbereinigungsassistent
Dokumenten-Templates
DR Watson
Farbschemata
Sicherheitscenter
Suchassistent
Tour
Übertragen von Dateien und Einstellungen
;# Dienste #
Fehlerberichterstattung
Nachrichtendienst
Netzwerkzugriffsschutz (NAP)
Systemwiederherstellung
;# Hardware-Unterstützung #
Brother-Geräte
Gravis Digitaler Spiele-Port
Iomega Zip-Laufwerk
Serielle Multi-Port-Karten
Teletext-Codec
;# Multimedia #
AOL ART-Dateiformat
Bilder und Hintergründe
Luna-Theme
Movie Maker
Musik-Beispiele
;# Netzwerk #
MSN Explorer
Netmeeting
Windows Messenger
;# Treiber #
Grafikkarten (alte)
Logitech WingMan
Sony Jog Dial
Toshiba DVD Decoder-Karte
Treiber für Kamera und Camcorder
;# Zusätzliche Ordner #
DOCS
VALUEADD
;# Kompatibilität #

[KeepFiles]
msconfig.exe

[RemoveFiles]
clock.avi
yahoo.bmp
swtchbrd.bmp

[Options]
ClassicSetup
ProfilesDir = "%SystemDrive%\Dokumente und Einstellungen"
TargetPath = "WINDOWS"
temp_dir = %USERPROFILE%\Lokale Einstellungen\Temp

[Patches]

[Services2]

[Tweaks]
Arbeitsplatz-Entfernt 'Gemeinsame Dokumente'
Arbeitsplatz-Fügt 'Verwaltung' hinzu
Explorer-Erweiterte Suchoptionen voreinstellen
Explorer-Inhalt der Systemordner anzeigen
Explorer-Klassische Systemsteuerung
Explorer-Statusleiste anzeigen
Explorer-Vollständigen Pfad in der Adressleiste anzeigen
Explorer-Vollständigen Pfad in der Titelleiste anzeigen
Explorer-Zeigt die Dateiendung bekannter Dateitypen
Leistung-Herkömmliche Windowsordner verwenden
Leistung-WBEM-Logging deaktivieren
Privatsphäre-Alexa Spyware entfernen
Privatsphäre-Aufforderung zum Treiberupdate via Internet ausschalten
Startmenü-Keine 'Persönlich angepassten Menüs' verwenden
Startmenü-Startmenü ohne Verzögerung öffnen
Visuelle Effekte-Animation der Ein- und Ausblendung von Tasks in der Taskleiste-Deaktivieren
Visuelle Effekte-Combobox-Animation-Deaktivieren
Visuelle Effekte-Durchsichtigen Hintergrund für Symbolunterschriften auf dem Desktop-Deaktivieren
Visuelle Effekte-Durchsichtiges Auswahlrechteck anzeigen-Deaktivieren
Visuelle Effekte-Fade out selection-Deaktivieren
Visuelle Effekte-Individuelles Hintergrundbild für verschiedene Ordnertypen anzeigen-Deaktivieren
Visuelle Effekte-Kanten der Bildschirmschriftarten verfeinern-Deaktiviert
Visuelle Effekte-Menüanimation-Deaktivieren
Visuelle Effekte-Menüschatten-Deaktivieren
Visuelle Effekte-Menü-Style-Normal
Visuelle Effekte-Tooltip-Animation-Deaktivieren

[Unattended]
ComputerType = Automatisch
MaximumDataStorePercentOfDisk = 12
RestorePointLife = 30
DesktopTheme = Standard||
AutoUDay = 5
AutoUHour = 15
ProgFilesPath = "\Programme"

[NetAdapter1]
connname = ""
macaddress = ""
ipaddress = "192.168.0.1"
subnetmask = "255.255.255.0"
defaultgateway = ""
dnsserver1 = ""
dnsserver2 = ""
winsserver = ""
netbiossetting = "0"
ipxnetworknumber = "00000000"
ipxnetworkframetype = "0xFF"

[GuiRunOnce]

[Drivers]

[Hotfixes]
C:\temp\nlite-nt-updatepacks\nlite-juni08\XP-SP3-Updatepack-3.8.6.exe
C:\temp\nlite-nt-updatepacks\nlite-juni08\Runtime-Addon.7z
C:\temp\nlite-nt-updatepacks\nlite-juni08\TweakUI-DE-2.1.cab
C:\temp\nlite-nt-updatepacks\nlite-juni08\WMP11-Addon.7z
C:\temp\nlite-nt-updatepacks\nlite-juni08\IE7-Addon.7z


0

Share this post


Link to post
Share on other sites
See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
Parameter name: index
at System.Char.IsWhiteSpace(String s, Int32 index)
at . .(StringCollection& , String )
at . . ()
at . .()
at . .WndProc(Message& )
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
nlite
Assembly Version: 1.4.6.0
Win32 Version: 1.4.6.0
CodeBase: file:///C:/Program%20Files/nLite/nLite.exe
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
nLite
Assembly Version: 1.4.6.0
Win32 Version: 1.4.6.0
CodeBase: file:///C:/Program%20Files/nLite/nLite.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
nlgw
Assembly Version: 1.1.0.0
Win32 Version: 1.4.6.0
CodeBase: file:///C:/Program%20Files/nLite/nLite.exe
----------------------------------------
MCDBNET2
Assembly Version: 1.32.0.0
Win32 Version: 1.32.0.1302
CodeBase: file:///C:/Program%20Files/nLite/MCDBNET2.DLL
----------------------------------------
msvcm80
Assembly Version: 8.0.50727.1434
Win32 Version: 8.00.50727.1434
CodeBase: file:///C:/Windows/WinSxS/x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.1434_none_d08b6002442c891f/msvcm80.dll
----------------------------------------
cablib
Assembly Version: 8.1.0.0
Win32 Version: 8.1
CodeBase: file:///C:/Program%20Files/nLite/cablib.DLL
----------------------------------------
msvcm90
Assembly Version: 9.0.21022.8
Win32 Version: 9.00.21022.8
CodeBase: file:///C:/Program%20Files/nLite/msvcm90.DLL
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

0

Share this post


Link to post
Share on other sites

I have been struggling ever since Windows XP SP3 came out. I am the network admin at a fairly large company. We roll out new Windows installs on a daily basis. We use Microsoft's Business Desktop Deployment to install via a PE environment. An entire system with updates and applications installed can be finished in about 20 minutes this way. I have always used nLite to facilitate this process. However, we have hit a huge wall now. Microsoft's solution does not provide a simple way to integrate drivers into the Windows source files, so I use nLite. However, as has been confirmed by the numerous posts here, if nLite touches a Windows XP SP3 source any winnt32.exe based installs are severely broken. I have tried the numerous workarounds changing the txtsetup.sif and wbemoc.inf files. I did manage to get a system installed that seemed normal. However, there are still system log entries with WMI errors. And as a perfect example the system can no longer detect if AntiVirus software is installed. Here are a couple of the event log errors:

The Windows Security Center Service was unable to establish event queries with WMI to monitor third party AntiVirus and Firewall.
Source: SecurityCenter Event ID: 1802

Windows couldn't log the RSoP (Resultant Set of Policies) session status. An attempt to connect to WMI failed. No more RSoP logging will be done for this application of policy.
Source: Userenv Event ID: 1090

All that I need to be able to do is integrate a few SATA and RAID drivers into my Windows source files. Does anyone have any suggestions as to something else I could do to integrate drivers?

0

Share this post


Link to post
Share on other sites

Are you aware that utilising nLite within a corporate environment violates the software's licence agreement?

5. nLite is free for personal use only, you cannot use it for any company or business purposes at this time.

James

x

0

Share this post


Link to post
Share on other sites

Sweet m8!!!! Thanks for the heads up on the new version very much appreciated!!!

Stoner81

0

Share this post


Link to post
Share on other sites
Are you aware that utilising nLite within a corporate environment violates the software's licence agreement?

5. nLite is free for personal use only, you cannot use it for any company or business purposes at this time.

James

x

No... I guess that missed that part of the license agreement. Time to find another solution. :(

0

Share this post


Link to post
Share on other sites

I believe quite a few people wouldn't mind paying some bucks for being able to use nLite this way. I actually didn't know until now either, and used this marvelous piece of software to make computers at work MUCH better.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.