• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.

nLite - Honey Turbo 9.1

425 posts in this topic

In fact I have seen, in the Microsoft web site, that we can install (and slipstream) the SP3 only on a XP SP1a or a XP SP2, Not on SP0, SP1.

nLite should show an error in this case

Edited by SuperPat

Share this post

Link to post
Share on other sites

With sfc on I get complaints from Windows sfc that essential files have been replaced. Should I change the option to sfc off?

Security Center cannot start, I think because Windows Management Instrumentation service is missing.

In Tweaks:

Explorer-Remove arrows shortcuts does not work

Speed-Classic Windows maps does not work

I have Windows XP SP3 Dutch with the latest Nlite.

Edited by Breezer

Share this post

Link to post
Share on other sites
jmbattle, long time no read.

A long time indeed - how time flies! ;)

Network Connection - Do you want network support to be removed or it is like your LAN is set by DHCP and you don't need any access to the config?

Well, this system is not connected to a network, hence why I disable the service. All I require is the bare minimum to get online using my cable modem and DHCP (addition components such as file/print sharing etc. are not even installed), thus I am wondering if this service can also be removed?

Shell HW - part of Shell Services, already removable, cant be separated from other 2 in the same component.

Ah, I see, and therefore required for Themes support, yes?

Telephony - I remember removal of this broke down a lot of network dlls so it can go under the same as NetConn

Again, I have disabled this service and am still able to get online, so perhaps it is unnecessary for this system?

App management - aka Add/Remove programs. It is needed, for most

I have disabled this service, yet am still able to open the Add/Remove Programs control panel applet, so perhaps it is not required after all?

Even if the service is required for the applet to run, could the user not use a freeware/shareware alternative?

Crypto - who knows, you never know :)

Yes, I disabled this service and restarted. Everything is fine at bootup, however opening the Hardware Devices list and double clicking on a component sets the service back to Manual and starts it automatically. Disabling and stopping the service, then attempting to double click a hardware component for a second time will still displays the information, yet does not change the service settings. Who knows - perhaps it can be removed too? ;)

HID - usb, mouse, keyboard thingies

Again, disabled here, the service does not appear to have been started, yet my USB mouse is working fine. Unnecessary?

Spooler - Printer Support

Okay, I shall keep it for PDF output.

Sec Acc Mng - Don't know

Okay, well let's try getting rid of it, then seeing what happens. ;)

Installer - needed, for most

Agreed. Third party installer engines such as NSIS appear to be unaffected, however InstallShield and .MSI stuff requires this service.

So only possibility would be Network Support and see what is Crypto and Secc Acc Mng. Not much fun, could be that all 3 are needed.

Well, if you do not have any further components planned for removal in 1.4.6, please consider adding these as 'experimentals' ;)

Keep up the great work!




Edited by jmbattle

Share this post

Link to post
Share on other sites

JM, why not disable the services vi an nlite customization to see what happens.


Share this post

Link to post
Share on other sites

newsposter, actually, with the exception of 'Windows Installer' I have disabled all of the remaining unused services whilst maintaining the required functionality.

After a little research, it would appear that the Human Interface Device Access service is only necessary in order to control additional buttons found on multimedia keyboards and other peripherals such as printers/scanners. The Application Management service, on the other hand, seems to be related to deploying software across a network.

I wonder if perhaps simply disabling a service is different to removing it from the system entirely, due to possible file dependencies?




Edited by jmbattle

Share this post

Link to post
Share on other sites

Yes, disabling a service leaves all the files on your system. Unless you are SURE (100%!) that you will NEVER need a specific service, disable it, DON'T delete it.

The hassles of trying to manuall reinstall a previously deleted service are considerable.


Share this post

Link to post
Share on other sites


I have problem!

I take windows xp pro sp2, I build SP3, IE7, WMP11,

I remove not the components, necessary for me, (without them, built - in IE6, worked), all passes well, but after installation, IE7 does not work: blinks a window and it is more than anything.

Prompt, what's the matter?

Thanks for the answer!

(nlite 1.4.5 b2 on winxpprosp2)


Share this post

Link to post
Share on other sites

If you have problems, always try using the latest (stable) version - nLite 1.4.5 FINAL.

Give more details about how you slipstreamed, in what order you did it and other tasks. I can't figure out what you meant - you removed components or kept all of them?


Share this post

Link to post
Share on other sites

New final build works a treat! many thanks :D


Share this post

Link to post
Share on other sites

The MD5 values for ver 1.4.5 self extracting archives on the download website are wrong!

The sha-1 hash has been put instead of md5.

the correct one (i think) is MD5:77E1A435C5A8DBC75C2E10BCAC0A1F27




Share this post

Link to post
Share on other sites

Yes something's wrong with the hashes? I don't get either of those values! :wacko:


Share this post

Link to post
Share on other sites
The MD5 values for ver 1.4.5 self extracting archives on the download website are wrong!

The sha-1 hash has been put instead of md5.

the correct one (i think) is MD5:77E1A435C5A8DBC75C2E10BCAC0A1F27

You are correct. Forgot to upload the new download page after silently updating the release today.

fix: SP3 issues if you just add an addon without any other component removal, options or tweaks, just addons. That would skip the automatic SP3 adjustments.

You can recognize the new release by the exe version after being installed, it should be

Let me know if something breaks.


Share this post

Link to post
Share on other sites

It still shows version 1.4.5 and not,I have downloaded the latest version ?


Share this post

Link to post
Share on other sites

What exactly was the problem with slipstreaming SP3 in Vista? I added SP3 into XP (English and German versions) using 1.4.5 beta 2 in Vista x64. Both seem to at least boot properly. Will I run into problems using those CDs later?


Share this post

Link to post
Share on other sites

zabardast_1, both have 1.4.5 when you run it but the exe file version is .3

Keelhaul, only problem was that the CDKey from SP2 would not be accepted. If yours works fine you'll be ok.


Share this post

Link to post
Share on other sites

Hmm I haven't gotten to the point where you have to enter the key yet, maybe I should try it out...

Is it ok to re-slip the same folder with the same SP3 using the latest nLite (the one that was already slipstreamed using beta 2)?


Share this post

Link to post
Share on other sites

HI :)

I found a little buggy.

If i select in nLite to remove Security Center.

But after the Windows installation the Security Center ICON is still showing in "Control Panel" -> "Category View" in Classic View it is removed.


Share this post

Link to post
Share on other sites

Keelhaul, if it allows you to do it. Not recommended.

Outbreaker, I think that is hard-coded in XP. In Vista it is a reg entry.


Share this post

Link to post
Share on other sites

there is a new service(s), which was just introduced in SP3, that should not be removed if you use a Wireless LAN card. When I removed this service(s), the Wireless Network Connection window would not show anything, even when the router was a few feet away. Also, Windows did not correctly detect when there was a connection to the router or not. However, you could manually connect to the router via the SSID name.

The services I am looking at:

Health Key and Certificate Management Service

Network Access Protection

Wired AutoConfig

I'm pretty sure it's the NAP service that is causing all the problems when removed, however, I'll need to create one more image to see if I can reproduce the problem....unless if someone's expertise or experience can confirm my suspision :hello:

Edited by Kirby

Share this post

Link to post
Share on other sites

Hi nuhi,

My brother recently killed the .net framework, just when I was going back to windows modding. No .net app works anymore.

I haven't found the alternative runtimes on you website. Where can I have them (I think I read they were not exchangeable) ?

Thanks. :)


Share this post

Link to post
Share on other sites

Kirby, it could be the other two, not the NAP.

Please let me know if you find out for sure and I'll put it into the compat. But actually both of these should be in the Ethernet compat.

Camarade_Tux, don't have a link but this is good for fixing .NET



Share this post

Link to post
Share on other sites

I finally fixed it the way I always did. I just needed to get used to windows again. :P

Basically the installation was completely damaged. No installer would run, uninstallation was impossible and only uninstall/repair was offered to me while a direct force reinstallation would probably have done the trick.

So after a few moments trying to go with microsoft's installers, I opened regmon, found the installers were reading HKEY_CLASSES_ROOT\Installer\Products. I then went there with regedit and deleted all occurences of .net framework. I could at last reinstall the .net framework and two minutes later nlite was running.

When in doubt, use brute force.

(but nlite will wait for tomorrow now ;) )


Share this post

Link to post
Share on other sites

nLite 1.4.5 (.3) Final - Honey Turbo BASIC TESTING

- GOAL: XP PRO SP0 Sliptreamed with SP3 with or without tweaks
(no addons testing yet)

I proceeded by testing after each added task on
Virtual Box 1.6
. I merged them into a single preset ini file for summarizing.

- Tasks Sequences

I] Slipstream SP3
at least an issue
: I noticed that my
dependency tabs
were missing in the service setting boxes

II] Unattended Setup (no added theme)

III] Tweaks

IV] Options


- Presets with detailed failures


Env = 1.4.5 - 2.0.50727.1433.Microsoft Windows NT 5.1.2600 Service Pack 2

Target = Windows XP Professionnel SP0 - 5.1.2600.0 - Français (France)

Service Pack Integration

Remove Components

Unattended Setup


Create a Bootable ISO



;# Applications #

Jeux sur Internet

Options d'accessibilité




;# Claviers #

Afghan clavier

Albanais clavier

Allemand (IBM) clavier

Allemand (Suisse) clavier

Allemand clavier

Anglais étendu (Royaume-Uni) clavier

Arabe (101) clavier

Arabe (102) AZERTY clavier

Arabe (102) clavier

Arménien (Est) clavier

Arménien (Ouest) clavier

Azéri cyrillique clavier

Azéri latin clavier

Belge (point) clavier

Belge (virgule) clavier

Bengali (Inscript) clavier

Bengali clavier

Biélorusse clavier

Bosniaque clavier

Bosniaque cyrillique clavier

Bulgare (latin) clavier

Bulgare clavier

Canadien multilingue standard clavier

Chinois (simplifié) - clavier américain clavier

Chinois (simplifié) - Microsoft Pinyin IME 3.0 clavier

Chinois (simplifié) - NeiMa clavier

Chinois (simplifié) - QuanPin clavier

Chinois (simplifié) - ShuangPin clavier

Chinois (simplifié) - ZhengMa clavier

Chinois (traditionnel) - alphanumérique clavier

Chinois (traditionnel) - ChangJie clavier

Chinois (traditionnel) - clavier américain clavier

Chinois (traditionnel) - code Big5 clavier

Chinois (traditionnel) - DaYi clavier

Chinois (traditionnel) - Matrice clavier

Chinois (traditionnel) - nouveau ChangJie clavier

Chinois (traditionnel) - nouvelle phonétique clavier

Chinois (traditionnel) - phonétique clavier

Chinois (traditionnel) - Rapide clavier

Chinois (traditionnel) - Unicode clavier

Coréen clavier

Croate clavier

Danois clavier

Devanagari - INSCRIPT clavier

Divehi Machine à écrire clavier

Divehi phonétique clavier

Espagnol (variante) clavier

Espagnol clavier

Estonien clavier

États-Unis - Dvorak pour droitier clavier

États-Unis - Dvorak pour gaucher clavier

États-Unis Dvorak clavier

États-Unis International clavier

Farsi clavier

Féroïen clavier

Finnois clavier

Finnois et same clavier

Français (Belgique) clavier

Français (Canada) clavier

Français (Suisse) clavier

Français traditionnel (Canada) clavier

Gaélique clavier

Géorgien clavier

Grec (220) clavier

Grec (220) latin clavier

Grec (319) clavier

Grec (319) latin clavier

Grec clavier

Grec latin clavier

Grec polytonique clavier

Gujarati clavier

Hébreu clavier

Hindi traditionnel clavier

Hongrois 101 touches clavier

Hongrois clavier

IBM Lituanien clavier

Inuktitut latin clavier

Irlandais clavier

Islandais clavier

Italien (142) clavier

Italien clavier

Japonais clavier

Kannada clavier

Kazakh clavier

Kirghyz cyrillique clavier

Latino-américain clavier

Letton (Qwerty) clavier

Letton clavier

Lituanien clavier

Luxembourgeois clavier

Macédonien (Ex Rép. yougoslave de) clavier

Malayalam clavier

Maltais 47 touches clavier

Maltais 48 touches clavier

Maori clavier

Marathi clavier

Mongol cyrillique clavier

Néerlandais clavier

Népalais clavier

Norvégien clavier

Norvégien et same clavier

Ourdou clavier

Ouzbek cyrillique clavier

Pendjabi clavier

Polonais (214) clavier

Polonais (programmeurs) clavier

Portugais (Brésil ABNT2) clavier

Portugais (Brésilien ABNT) clavier

Portugais clavier

Roumain clavier

Royaume-Uni clavier

Russe (machine à écrire) clavier

Russe clavier

Same étendu (Finlande/Suède) clavier

Same étendu (Norvège) clavier

Serbe (cyrillique) clavier

Serbe (latin) clavier

Slovaque (Qwerty) clavier

Slovaque clavier

Slovène clavier

Suédois clavier

Suédois et same clavier

Syrien clavier

Syrien phonétique clavier

Système de saisie coréen (IME 2000) clavier

Système de saisie japonais (MS-IME2002) clavier

Table d'anglais (États-Unis) pour IBM arabe 238_L clavier

Tamoul clavier

Tatar clavier

Tchèque (programmeurs) clavier

Tchèque (Qwerty) clavier

Tchèque clavier

Télougou clavier

Thaï Kedmanee (sans verrouillage majuscule) clavier

Thaï Kedmanee clavier

Thaï Pattachote (sans verrouillage majuscule) clavier

Thaï Pattachote clavier

Turc F clavier

Turc Q clavier

Ukrainien clavier

Vietnamien clavier

;# Multimédia #

Échantillons musicaux

Magnétophone et ancien lecteur CD

Sons Windows

Windows Movie Maker

;# Options du système d'exploitation #

Assistant de recherche

Visite guidée Windows

;# Réseau #

MSN Explorer

Windows Messenger

;# Services #



Pilote du Bip

Registre à distance

Stockage amovible

;# Compatibilité #


























ProfilesDir = "%SystemDrive%\Documents and Settings"

TargetPath = "WINDOWS"

temp_dir = %SystemDrive%\Temp
keep being %USERPROFILE%\Local Settings\Temp



TcpIp = 100



No way to customise them, default is always considered


didn't check all of them
Boot and Shutdown-Auto-End tasks immediately

Boot and Shutdown-Auto-Kill hung applications immediately

Boot and Shutdown-Auto-Kill hung services immediately

Boot and Shutdown-Disable automatic restart on System Failure

Desktop-Internet Explorer icon-Show
Fails even in start menu. After install IE6 is not automatically considered as the default web browser. Don't know if it is normal after a XP SP0 clean install, didn't try.
Desktop-Wrap icon titles-Disable

Explorer-Advanced Search: preconfigure options

Explorer-Associate additional file types with Notepad

Explorer-Change Windows Explorer folder view-Details

Explorer-Classic Control Panel

Explorer-Disable Autorun

Explorer-Disable Beep on errors

Explorer-Disable Prefix: Shortcut to

Explorer-Disable shortcut arrow

Explorer-Disable Web Files and Folders connection

Explorer-Launch folder windows in a separate process

Explorer-Show Drive Letters in front of Drive Names

Explorer-Show extensions of known file-types

Explorer-Show Statusbar in all windows

Explorer-Show the full path in the Address Bar

Explorer-Show the full path in the Title Bar

My Computer-Add Device Manager to Context Menu

My Computer-Add Event Viewer to Context Menu

My Computer-Add Fonts Folder

My Computer-Add Registry Editor to Context Menu
Performance-Processor scheduling-Programs

Performance-Run 16-bit Windows applications in a separate process

Privacy-Remove Alexa

Start Menu-Add Administrative Tools menu

Start Menu-Control Panel-Display as a menu

Start Menu-My Computer-Display as a link

Start Menu-My Documents-Display as a menu

Start Menu-My Music-Display as a menu

Start Menu-My Pictures-Display as a menu

Start Menu-Network Connections-Link to Network Connections folder

Start Menu-Number of programs on Start menu-10

Start Menu-Printers and Faxes-Display as a link

Start Menu-Reduce popup delay

Start Menu-Remove Windows Catalog shortcut

Start Menu-Scroll Programs

Taskbar-Disable Hide inactive icons

Taskbar-Disable Language-Bar

Taskbar-Lock the Taskbar-No

Visual Effects-Keyboard shortcut underline-Enable


ComputerType = Automatic

Resolution = 1280x1024

MaximumDataStorePercentOfDisk = 10

RestorePointLife = 30

DesktopTheme = Default||

AutoUpdates = 4

AutoUDay = 5

AutoUHour = 15

ProgFilesPath = "\Program Files"


connname = ""

macaddress = ""

ipaddress = ""

subnetmask = ""

defaultgateway = ""

dnsserver1 = ""

dnsserver2 = ""

winsserver = ""

netbiossetting = "0"

ipxnetworknumber = "00000000"

ipxnetworkframetype = "0xFF"




I will do other testing later. Hope it helps NUHI

Edit: See new tests here


Edited by fred_gaou

Share this post

Link to post
Share on other sites

2 Questions:

1 : Some years ago i participated in the bugtracker forum for nlite. Is it still active? I can't remember links..

2: Where's the feature suggestion thread?


Share this post

Link to post
Share on other sites


After using Nlite, the WMP Toolbar Shortcut is missing, in taskbar....I dint mean the WMP quick launch shortcuts... hope you understood...

I dont know, whether you or booogy is responsible to do this task..

Edited by dazzlee

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.