Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

USB Hard Drive Auto Letter Assignment

- - - - -

  • Please log in to reply
1 reply to this topic

#1
varney

varney
  • Member
  • 2 posts
Hi

I have been using Server 2003 Datacenter SP2 nLited (by me - not R2) for a while now, and I just nlited my 'non-touched' corporate version of Windows XP Pro SP2.
Normally in windows 2003 when I plug in a USB harddrive, I get the usual taskbar popup that shows me the drive is being installed. When it is complete, I have to go into Disk Management and assign a drive letter to it. When I have added the drive letter, the drive appears in My Computer, but on the properties for the drive it says "File system: RAW". So I turn off the drive, and then back on again, and the Filesystem now says NTFS (or whatever I formatted it as).

However on XP SP2, when I plug in a harddrive for the first time, it is able to assign a drive letter at once, and the filesystem is ok.

The only thing I have done in the nlite of this windows 2003 is I removed a file called volumes.inf. If I didn't remove it, I would get prompted to install a 'generic volume' (e.g. click next to install hardware prompt), but removing the volume.inf solves this 'temporarily'.

I haven't removed the same file from the XP SP2 nlite, as I never had to remove it - it always worked perfectly like this.

Any one have any ideas how I can get the same thing to happen in Windows 2003?

Edited by varney, 01 April 2008 - 07:01 PM.



How to remove advertisement from MSFN

#2
varney

varney
  • Member
  • 2 posts
I found the solution to this.

The process that enables this 'auto drive letter assignment' is called automount. On windows 2003, it is disabled by default (due to possible network share conflicts).

To enable/disable it, do the following:

  • first of all, you need to make sure the Virtual Disk Service is running. Goto Start->Run and type services.msc and make sure it is started.
  • open a command prompt and type diskpart - you will then enter the diskpart prompt.
  • type automount to see the status of automount.
  • to enable/disable automount, type automount enable or automount disable depending on what you need.

That's about it, hope it helps. :)

Edited by varney, 01 April 2008 - 07:09 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN