Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

How to remove "Do you want to move or copy files from this zone?

- - - - -

  • Please log in to reply
5 replies to this topic

#1
oskingen

oskingen

    MSFN Friend

  • Member
  • PipPipPipPip
  • 613 posts
  • Joined 20-January 08
  • OS:none specified
  • Country: Country Flag
Hi, I got a problem that I don't know how to resolve it. Everytime i want to copy files using drag and drop from an other computer (macbook, win 2003 server...) through the network I got this message "do you want to move or copy files from this zone?" I search on google to find some solution but nothing doesn't work. Below the solution i tested but not working:

Open Control Panel -> Internet Options.
Open Security-tab; mark the zone "Local intranet", press the "Sites" button,
UN-tick "Automatically detect intranet network",THEN
tick "Include all local (intranet) sites not listed in other zones" and
tick "Include all network paths (UNCs)".
--------------------------------------------------------------------------------------
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\4]
@=""
"180B"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\4]
@=""
"180B"=dword:00000000
--------------------------------------------------------------------------------------
http://support.microsoft.com/kb/888534

any help?

Edited by hannubys, 24 March 2008 - 12:17 PM.



How to remove advertisement from MSFN

#2
physics2010

physics2010
  • Member
  • 1 posts
  • Joined 24-April 08
You were close. I tried all the above as well, but the final piece was

Tools | Internet Options | Security | Local Intranet | Custom Level | Access data sources across domain = Enable

Not sure if this is the only step, or if the ones you mentioned prior are necessary as well.

#3
Methanoid

Methanoid

    Junior

  • Member
  • Pip
  • 88 posts
  • Joined 21-December 04
  • OS:none specified
I get this in XP too. Is there a REGISTRY fix file for this? I have to apply this process after every install of XP SP3 and I'd like to automate it

#4
coiley

coiley
  • Member
  • 1 posts
  • Joined 11-October 09

I get this in XP too. Is there a REGISTRY fix file for this? I have to apply this process after every install of XP SP3 and I'd like to automate it


For XP Check out the following in your registry. Note that Zone 1 refers to "Local Intranet" (http://support.microsoft.com/kb/182569)

Check in your registry here:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1]
"1406"=dword:00000000
"DisplayName"="Local intranet"
"Description"="This zone contains all Web sites that are on your organization's intranet."

... and here:
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1]
"1406"=dword:00000000
"DisplayName"="Local intranet"
"Description"="This zone contains all Web sites that are on your organization's intranet."

I think XPSP3 adds DEFINITION of the valid sates for CrossDomainData (AKA Tools | Internet Options | Security | Local Intranet | Custom Level | Access data sources across domain) here at:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\SO\MISC\CrossDomainData]
This just defines the states as ALLOW, DENY, QUERY. But it points to the ValueName="1406" as where to go to change the setting in the first two registry entires.
Also, [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\SO\MISC\CrossDomainData] defines the valid corresponding data for the "1406" value. They are: "1406"=dword:00000000 is ALLOW, "1406"=dword:00000001 is QUERY, "1406"=dword:00000003 is DENY. We want to set "1406" to "1406"=dword:00000000 (ALLOW move or copy across local intranet) in both aforementioned keys.

Your registry patch to ALLOW CrossDomainData in YOUR local intranet might look something like this:

-------------------------

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1]
"1406"=dword:00000000

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\1]
"1406"=dword:00000000

-------------------------

Another place to look is [HKCU\Software\Microsoft\CurrentVersion\Internet Settings\SO\MISC\DRAGDROP]
...and [HKLM\Software\Microsoft\CurrentVersion\Internet Settings\SO\MISC\DRAGDROP]

This tree points to value "1802" to ALLOW Drag & Drop across local intranet. Same reg patch methods apply.

Play with it. Give feedback.

The above worked for me in most cases. However, in the end, the only 100% effective solution was to add my local intranet private ip range to the "Trusted sites" list. I added "*://192.168.0.100-209/*". Now everything works - no more "Do you want to move or copy..." warning pop-ups.

The information appears at:
[HKEY_CURRENT_USER\Software\Microsoft\CurrentVersion\Internet Settings\ZoneMap\Ranges\Range1]
"*"=dword:00000002
":Range"="192.168.0.100-209"

... and:
[HKEY_USERS\S-1-5-21-507921405-1563985344-839522115-1003\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Ranges\Range1]
"*"=dword:00000002
":Range"="192.168.0.100-209"

Edited by coiley, 11 October 2009 - 03:48 PM.


#5
Escorpiom

Escorpiom

    Junior

  • Member
  • Pip
  • 89 posts
  • Joined 18-January 09
  • OS:none specified
  • Country: Country Flag

The above worked for me in most cases. However, in the end, the only 100% effective solution was to add my local intranet private ip range to the "Trusted sites" list. I added "*://192.168.0.100-209/*". Now everything works - no more "Do you want to move or copy..." warning pop-ups.

The information appears at:
[HKEY_CURRENT_USER\Software\Microsoft\CurrentVersion\Internet Settings\ZoneMap\Ranges\Range1]
"*"=dword:00000002
":Range"="192.168.0.100-209"

... and:
[HKEY_USERS\S-1-5-21-507921405-1563985344-839522115-1003\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Ranges\Range1]
"*"=dword:00000002
":Range"="192.168.0.100-209"


For the sake of completeness, the first regpath is not correct, below the corrected one :

The information appears at:
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Ranges\Range1]

The second path [HKEY_USERS\S-1-5-21-507921405-1563985344-839522115-1003 is not the same on every system. Also, there is no need to set this second key. It is set automatic when the first one is set.
Other than that, it works fine.

Cheers,
Escorpiom.

#6
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,253 posts
  • Joined 09-September 01
  • OS:Windows 8.1 x64
  • Country: Country Flag
Or you could put it in the same place, but in HKLM, and have it set for all users - far easier than mucking about with the user's registry (or SID registries for each user on the box).
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users