• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
shahed26

BDA (Tv tuner support) on Server 2008/R2

138 posts in this topic

updated with x64 support

Edited by shahed26
0

Share this post


Link to post
Share on other sites

Bad news from me, your guide does not help to me :no:

I follow all steps you wrote, all was installed successfully, but my software for watching TV still does not recognize my device.

When i start program, it shows this error:

post-188025-1209796540_thumb.jpg

when i go to settings to select device this i have:

post-188025-1209796640_thumb.jpg

I dont know what to do now...

0

Share this post


Link to post
Share on other sites

thank you for your solution. however, when i use DVBViewer, in the setting/options, it seems that the "Digital TV" does not work, it said that there is no device found even i have plugged in the USB TV stick to my computer already. can anyone help me, please!

0

Share this post


Link to post
Share on other sites
thank you for your solution. however, when i use DVBViewer, in the setting/options, it seems that the "Digital TV" does not work, it said that there is no device found even i have plugged in the USB TV stick to my computer already. can anyone help me, please!

ok, this is the same problem i had as well. Just run the file bda.inf from "BDAXP.cab" (from latest direcx download)again, and restart (right click on bda.inf and then choose install). if its promting you to install pnp devices that it finds, then just click cancel for all of them if it still does not work, then run bda.inf again, and this time when it finds the pnp devices, just locate and install. when its prompting pnp install make sure you browse to the files extracted from "bdaxp.cab"

Also the guide is sort of confusing, double check everything, and repeat all actions from my guide again if its still not working.

0

Share this post


Link to post
Share on other sites
Bad news from me, your guide does not help to me :no:

I follow all steps you wrote, all was installed successfully, but my software for watching TV still does not recognize my device.

When i start program, it shows this error:

post-188025-1209796540_thumb.jpg

when i go to settings to select device this i have:

post-188025-1209796640_thumb.jpg

I dont know what to do now...

Make sure you have the latest "DIRECTX" installed. also a decent codec pack

run this file from DXSETUP.exe from the latest DX9 Redist download

if it still does not work then do this:

run the file bda.inf from "BDAXP.cab" (from latest direcx download)again, and restart (right click on bda.inf and then choose install). if its promting you to install pnp devices that it finds, then just click cancel for all of them if it still does not work, then run bda.inf again, and this time when it finds the pnp devices, just locate and install. when its prompting pnp install make sure you browse to the files extracted from "bdaxp.cab"

Also the guide is sort of confusing, double check everything, and repeat all actions from my guide again if its still not working.

Edited by shahed26
0

Share this post


Link to post
Share on other sites

Just wanted to let you know that I've been using Server 2008 for the last 24 hours and have recorded several TV Shows with it using Webscheduler and so far it's all good. Thanks again for your Guide. :thumbup

0

Share this post


Link to post
Share on other sites
Make sure you have the latest "DIRECTX" installed. also a decent codec pack

run this file from DXSETUP.exe from the latest DX9 Redist download

if it still does not work then do this:

run the file bda.inf from "BDAXP.cab" (from latest direcx download)again, and restart (right click on bda.inf and then choose install). if its promting you to install pnp devices that it finds, then just click cancel for all of them if it still does not work, then run bda.inf again, and this time when it finds the pnp devices, just locate and install. when its prompting pnp install make sure you browse to the files extracted from "bdaxp.cab"

Also the guide is sort of confusing, double check everything, and repeat all actions from my guide again if its still not working.

Nothings helps to me, trying this steps or full guide again and with no success.

When i ran register.cmd i have these errors:

post-188025-1209822982_thumb.jpg

and

post-188025-1209822988_thumb.jpg

I forgot to mention that i have 64 bit windows server 2008. I use source files from 64 bit Vista, this is ok.

I dont know what to do now...

0

Share this post


Link to post
Share on other sites
Make sure you have the latest "DIRECTX" installed. also a decent codec pack

run this file from DXSETUP.exe from the latest DX9 Redist download

if it still does not work then do this:

run the file bda.inf from "BDAXP.cab" (from latest direcx download)again, and restart (right click on bda.inf and then choose install). if its promting you to install pnp devices that it finds, then just click cancel for all of them if it still does not work, then run bda.inf again, and this time when it finds the pnp devices, just locate and install. when its prompting pnp install make sure you browse to the files extracted from "bdaxp.cab"

Also the guide is sort of confusing, double check everything, and repeat all actions from my guide again if its still not working.

Nothings helps to me, trying this steps or full guide again and with no success.

When i ran register.cmd i have these errors:

post-188025-1209822982_thumb.jpg

and

post-188025-1209822988_thumb.jpg

I forgot to mention that i have 64 bit windows server 2008. I use source files from 64 bit Vista, this is ok.

I dont know what to do now...

thats were it went all wrong. i updated my guide, read it properly again. the errors wont be there anymore. you need to extract ALL THE FILES from bdaxp.cab and run bda.inf from there. read my guide again coz its updated and you wont get no errors.

btw it should work on x64 as well. (did not try it on x64 yet)

0

Share this post


Link to post
Share on other sites

I would like to say a big thanks to shahed26 for the BDA guide. :thumbup

My Terratec DT USB XS Diversity Digital Tuner is now working fine in Windows 2008 server!

Dual tuners working OK, everything looks stable and normal, no errors in the OS logs.

Software : TerraTec Home Cinema 5.73.00 beta

Driver : Cinergy DT USB XS Diversity - BDA Driver 3.12.0.0 (for XP and Vista)

Filters : Vista Codec Package 4.6.4

Hardware (PC) : Lenovo T60 Laptop !

Windows 2008 is now FULLY configured to look and behave like Vista. I'm impressed.

0

Share this post


Link to post
Share on other sites

all working fine after testing.

Edited by shahed26
0

Share this post


Link to post
Share on other sites
Just wanted to let you know that I've been using Server 2008 for the last 24 hours and have recorded several TV Shows with it using Webscheduler and so far it's all good. Thanks again for your Guide. :thumbup

thanks for letting me know. enjoy watching tv on server

0

Share this post


Link to post
Share on other sites
I would like to say a big thanks to shahed26 for the BDA guide. :thumbup

My Terratec DT USB XS Diversity Digital Tuner is now working fine in Windows 2008 server!

Dual tuners working OK, everything looks stable and normal, no errors in the OS logs.

Software : TerraTec Home Cinema 5.73.00 beta

Driver : Cinergy DT USB XS Diversity - BDA Driver 3.12.0.0 (for XP and Vista)

Filters : Vista Codec Package 4.6.4

Hardware (PC) : Lenovo T60 Laptop !

Windows 2008 is now FULLY configured to look and behave like Vista. I'm impressed.

your welcome mate :)

Edited by shahed26
0

Share this post


Link to post
Share on other sites

ok guys, please leave feedback of this bda function solution, and please report any issues, so i can improve bda support on server.

any suggestion on how to improve or anything are most welcome

thanks :)

Edited by shahed26
0

Share this post


Link to post
Share on other sites

This guide does not help to me :o

Does anyone gets bda working on 64 bit windows server 2008?

I do this steps:

1. clean install of windows server 2008 x64

2. install all drivers of my motherboard, vga drivers

3. install tv card drivers (WinFast DTV 2000H) x64

4. use your bda install batch

After restart i got some errors as above:

kstvtune.ax

ksxbar.ax

I give up trying to get working BDA on x64 windows server 2008.

0

Share this post


Link to post
Share on other sites
This guide does not help to me :o

Does anyone gets bda working on 64 bit windows server 2008?

I do this steps:

1. clean install of windows server 2008 x64

2. install all drivers of my motherboard, vga drivers

3. install tv card drivers (WinFast DTV 2000H) x64

4. use your bda install batch

After restart i got some errors as above:

kstvtune.ax

ksxbar.ax

I give up trying to get working BDA on x64 windows server 2008.

x64 support added, and made corrections to x86 installer and added a few more missing filters..

0

Share this post


Link to post
Share on other sites

Hello shahed26,

I have the same error than terrorix with kstvtune.ax and ksxbar.ax by using your manual method. I'm using Win2k8 datacenter X86 on a Dell Latitude C510/C610. What do you advice to me ? Your recently modified automatic method ?

An idea please. My hardware TV tuner : PCTV DVB-T stick solo and PCTV Dual DVB-t Diversity Stick.

Other question : a pack codec like K-Lite codec is really necessary or optional ?

Thanks for your patience.

valorisa

Edited by valorisa
0

Share this post


Link to post
Share on other sites
Hello shahed26,

I have the same error than terrorix with kstvtune.ax and ksxbar.ax by using your manual method. I'm using Win2k8 datacenter X86 on a Dell Latitude C510/C610. What do you advice to me ? Your recently modified automatic method ?

An idea please. My hardware TV tuner : PCTV DVB-T stick solo and PCTV Dual DVB-t Diversity Stick.

Other question : a pack codec like K-Lite codec is really necessary or optional ?

Thanks for your patience.

valorisa

try my new recently modified installers. the errors that you and terrorix had with kstvtune.ax and ksxbar.ax are fixed. these errors were caused by a few "mui" files missing that must be present in the source folder.

just try the new installer and it should work this time.

btw make sure your read the instructions before installing found inside the "bdaforserver"

edit: codec pack is optional. but remember server has no mpeg2 codecs or anything, so viewing live tv picture will require you to install one later. anyways thats a optional so its fine without a codec pack

Edited by shahed26
0

Share this post


Link to post
Share on other sites

Again thanks shahed26. I try this as soon as possible and I will let you know the result.

valorisa

Edited by valorisa
0

Share this post


Link to post
Share on other sites

Updated:

Recent Changes:

03/06/08

-Fixed x64 Directory source file copy error (BDA was not working on x64 systems due to source files not being copied in the right directory)

-Now installer uses x64 version of "regsvr32.exe" to register x64 source files, and x86 version of "regsvr32.exe" to register x86 source files

29/05/08

-Added x64 support

-Made corrections to x86 installer

-Added more filters that were missing from previous installer pack

-Fixed "kxsbar.ax, kstvtune.ax invalid errors

0

Share this post


Link to post
Share on other sites

hello

i'm on win2k8 ent 64bit

downloaded last version.

still getting ksxbar.ax errors

and still can't see tv :(

please help

0

Share this post


Link to post
Share on other sites
hello

i'm on win2k8 ent 64bit

downloaded last version.

still getting ksxbar.ax errors

and still can't see tv :(

please help

Did you follow the instructions properly?

what language version of server your using? (it must be en-US)

Did you grab all the files from vista by running "get bda files.bat"?

0

Share this post


Link to post
Share on other sites
hello

i'm on win2k8 ent 64bit

downloaded last version.

still getting ksxbar.ax errors

and still can't see tv :(

please help

Did you follow the instructions properly?

what language version of server your using? (it must be en-US)

Did you grab all the files from vista by running "get bda files.bat"?

yes

yes

yes

all went good, but the "regsvr32 ksxbar.ax"

can't do this even manually

can you tell me exactly names of files needed to register ksxbar.ax and kswdmcap.ax? (excluding theirselves of course and ksxbar.ax.mui and kswdmcap.ax.mui)

0

Share this post


Link to post
Share on other sites
hello

i'm on win2k8 ent 64bit

downloaded last version.

still getting ksxbar.ax errors

and still can't see tv :(

please help

Did you follow the instructions properly?

what language version of server your using? (it must be en-US)

Did you grab all the files from vista by running "get bda files.bat"?

yes

yes

yes

all went good, but the "regsvr32 ksxbar.ax"

can't do this even manually

can you tell me exactly names of files needed to register ksxbar.ax and kswdmcap.ax? (excluding theirselves of course and ksxbar.ax.mui and kswdmcap.ax.mui)

Hi, after doing a clean install of server 2008 ent x64, i realized that "kstvtune.ax and ksxbar.ax" are not required to register, and it cant be registered as well. The whole point is that them 2 ax files needs to be present in syswow64 and system32 directory, so when you launch any tv applications it uses these 2 files for its purpose. They cant be registered even on vista, i tried registering, but it will not register as the whole point is your tv application to access these 2 files only for your tv app to work.

Just run the "BDA.inf" from bda folder the directX 9 version, and restart to see if your tv card works, if it don't then the only solution i would recommend is do a clean install and run my setup pack.

Hope this helps

0

Share this post


Link to post
Share on other sites

Hi!

Just a little tweack for your bat files If you want them to run no matter the location of bdaforserver folder !

-> So NO NEED FOR

and it will extract as "bdaforserver" to your windows

installation drive,thats were the setup MUST be runned from, otherwise it wont work

IMPORTANT:IN ORDER FOR EVERYTHING TO WORK, RUN THE SETUP FROM WERE YOUR WINDOWS

IS INSTALLED (C:) OTHERWISE IT WONT WORK (THATS WERE IT EXTRACTED)

add

cd /d %0\..
after
@echo off
and replace
%systemdrive%\bdaforserver\
with
"../
(also add quotes " at the end of the line)

For example

@echo off

cd /d %0\..

copy %systemroot%\system32\bdaplgin.ax "../source\x64\System32"

copy %systemroot%\system32\kstvtune.ax "../source\x64\System32"

copy %systemroot%\system32\ksxbar.ax "../source\x64\System32"

copy %systemroot%\system32\Mpeg2Data.ax "../source\x64\System32"

copy %systemroot%\system32\mpg2splt.ax "../source\x64\System32"

copy %systemroot%\system32\MSDvbNP.ax "../source\x64\System32"

copy %systemroot%\system32\MSNP.ax "../source\x64\System32"

copy %systemroot%\system32\MSVidCtl.dll "../source\x64\System32"

copy %systemroot%\system32\en-US\MSVidCtl.dll.mui "../source\x64\System32"

copy %systemroot%\system32\en-US\kstvtune.ax.mui "../source\x64\System32"

copy %systemroot%\system32\en-US\kswdmcap.ax.mui "../source\x64\System32"

copy %systemroot%\system32\en-US\ksxbar.ax.mui "../source\x64\System32"

copy %systemroot%\system32\psisdecd.dll "../source\x64\System32"

copy %systemroot%\system32\psisrndr.ax "../source\x64\System32"

copy %systemroot%\system32\VBICodec.ax "../source\x64\System32"

copy %systemroot%\system32\vbisurf.ax "../source\x64\System32"

copy %systemroot%\system32\WSTPager.ax "../source\x64\System32"

copy %systemroot%\SysWOW64\bdaplgin.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\kstvtune.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\ksxbar.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\Mpeg2Data.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\mpg2splt.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\MSDvbNP.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\MSNP.ax "../source\x64\SysWOW64'

copy %systemroot%\SysWOW64\MSVidCtl.dll "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\en-US\MSVidCtl.dll.mui "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\en-US\kstvtune.ax.mui "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\en-US\kswdmcap.ax.mui "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\en-US\ksxbar.ax.mui "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\psisdecd.dll "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\psisrndr.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\VBICodec.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\vbisurf.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\WSTPager.ax "../source\x64\SysWOW64"

exit

Good luck with your work !

0

Share this post


Link to post
Share on other sites
Hi!

Just a little tweack for your bat files If you want them to run no matter the location of bdaforserver folder !

-> So NO NEED FOR

and it will extract as "bdaforserver" to your windows

installation drive,thats were the setup MUST be runned from, otherwise it wont work

IMPORTANT:IN ORDER FOR EVERYTHING TO WORK, RUN THE SETUP FROM WERE YOUR WINDOWS

IS INSTALLED (C:) OTHERWISE IT WONT WORK (THATS WERE IT EXTRACTED)

add

cd /d %0\..
after
@echo off
and replace
%systemdrive%\bdaforserver\
with
"../
(also add quotes " at the end of the line)

For example

@echo off

cd /d %0\..

copy %systemroot%\system32\bdaplgin.ax "../source\x64\System32"

copy %systemroot%\system32\kstvtune.ax "../source\x64\System32"

copy %systemroot%\system32\ksxbar.ax "../source\x64\System32"

copy %systemroot%\system32\Mpeg2Data.ax "../source\x64\System32"

copy %systemroot%\system32\mpg2splt.ax "../source\x64\System32"

copy %systemroot%\system32\MSDvbNP.ax "../source\x64\System32"

copy %systemroot%\system32\MSNP.ax "../source\x64\System32"

copy %systemroot%\system32\MSVidCtl.dll "../source\x64\System32"

copy %systemroot%\system32\en-US\MSVidCtl.dll.mui "../source\x64\System32"

copy %systemroot%\system32\en-US\kstvtune.ax.mui "../source\x64\System32"

copy %systemroot%\system32\en-US\kswdmcap.ax.mui "../source\x64\System32"

copy %systemroot%\system32\en-US\ksxbar.ax.mui "../source\x64\System32"

copy %systemroot%\system32\psisdecd.dll "../source\x64\System32"

copy %systemroot%\system32\psisrndr.ax "../source\x64\System32"

copy %systemroot%\system32\VBICodec.ax "../source\x64\System32"

copy %systemroot%\system32\vbisurf.ax "../source\x64\System32"

copy %systemroot%\system32\WSTPager.ax "../source\x64\System32"

copy %systemroot%\SysWOW64\bdaplgin.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\kstvtune.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\ksxbar.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\Mpeg2Data.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\mpg2splt.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\MSDvbNP.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\MSNP.ax "../source\x64\SysWOW64'

copy %systemroot%\SysWOW64\MSVidCtl.dll "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\en-US\MSVidCtl.dll.mui "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\en-US\kstvtune.ax.mui "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\en-US\kswdmcap.ax.mui "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\en-US\ksxbar.ax.mui "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\psisdecd.dll "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\psisrndr.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\VBICodec.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\vbisurf.ax "../source\x64\SysWOW64"

copy %systemroot%\SysWOW64\WSTPager.ax "../source\x64\SysWOW64"

exit

Good luck with your work !

Mercury_22, Thank you very much for this tweak. I will update my installer pack, and will have a quick test.

Thank you for this tip :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.