shahed26

BDA (Tv tuner support) on Server 2008/R2

138 posts in this topic

Hello

Has anybody a solution for getting work the analogue tv cards? I have tried with Hauppauge PVR150 and PVR500 and Terratec Cinergy HTC USB XS HD, but it does not work.

Thank you for tips.

Greetings

wima

0

Share this post


Link to post
Share on other sites
Hello

Has anybody a solution for getting work the analogue tv cards? I have tried with Hauppauge PVR150 and PVR500 and Terratec Cinergy HTC USB XS HD, but it does not work.

Thank you for tips.

Greetings

wima

Hey Wima,

unfortunately not. According to Shahed it is possible, and after rereadiing the threads, I found some people who got it working aswel (I think Mister X on the Hauppauge forum", but it never got documented how, as everyone was looking for a DVB solution, not analogue. So it seems it is up to us to find a solution :unsure:

0

Share this post


Link to post
Share on other sites
Hey Wima,

unfortunately not. According to Shahed it is possible, and after rereadiing the threads, I found some people who got it working aswel (I think Mister X on the Hauppauge forum", but it never got documented how, as everyone was looking for a DVB solution, not analogue. So it seems it is up to us to find a solution :unsure:

I tried a little bit with GraphEdit. In Vista I have filters like "WDM Streaming-TV-Empfangsgeräte" and "WDM Streaming-Crossbar-Geräte". I miss these in W2k8. The tuner filter is the file kstvtune.ax, the crossbar is ksxbar.ax. I think there is something wrong with this filters...

Greetings

wima

0

Share this post


Link to post
Share on other sites

still missing

WDM Streaming Crossbar

WDM Streaming TV Audio

WDM Streaming TV Tuner

even with your newest setup.

Whats going wrong?

Thank you

wima

0

Share this post


Link to post
Share on other sites
still missing

WDM Streaming Crossbar

WDM Streaming TV Audio

WDM Streaming TV Tuner

even with your newest setup.

Whats going wrong?

Thank you

wima

I'm afraid I don't have a lot of time to spare the next couple of days. I hope to be looking deeper into this after the weekend. For now, I did find this link that explains clearly how these elements cooperate. Might be helpful: http://msdn.microsoft.com/en-us/library/ms783782(VS.85).aspx

From what I was able to make out of it (and as you mentioned above), the "WDM Streaming Crossbar" relies on the ksxbar.ax file, and the "WDM Streaming TV Tuner" needs KSTVTune.ax. For the audio I dont really know. The 2 files mentioned should be on the Windows 2008 as they are included in the batch-file. I guess it might be a registry issue like Xordos mentioned in one of the above posts.

In the meantime, could you post a screenshot of the graphedit in Vista? thx

Edited by Ekjaker
0

Share this post


Link to post
Share on other sites

Here is the screenshot (vista x64, english):

post-212627-1223060861_thumb.png

Greetings

wima

0

Share this post


Link to post
Share on other sites

The good news: I have now a working MediaPortal TV Server on my W2K8 x64 with my analog tv card (PVR-150).

The bad news: I don't know, if I can reproduce it, because I hacked quite a bit. I made some things from here and I exported many registry keys from my vista x64 and imported them to w2k8. The channel scan in mediaportal worked a little bit better, but there were some exceptions around SetupTeletext(). Then I downloaded the source code of the TvEngine. In the TvCardAnalog.cs of the TVLibrary project I deactivated teletext by returning at the beginning of the FindVBIPin method. Compiled and installed, then the channel scan worked, but I have no channel names. I think they will be getted from teletext. But showing and recording tv works, also with a network client.

If someone is interested in my exported registry keys, I can upload them. There are many keys, I think not all will be used. Next step is to find out which keys are necessary and whats going wrong with teletext.

Greetings

wima

0

Share this post


Link to post
Share on other sites

Wima, great news you got it working. As I dont have a x64 Vista-box available for now, I would definitely love to try out your registry-keys. btw, did it resolve the issue of missing filters?

Concerning the teletext issue, I might be wrong here, but I dont think all versions of the PVR150 support teletext (OEM, MCE,...)

Edited by Ekjaker
0

Share this post


Link to post
Share on other sites

The keys are in the attachment. I don't know, if really all keys are required.

The PVR150 supports teletext, I think there is a problem with WSTPager.ax. Perhaps this file is not registered.

RegHack.zip

0

Share this post


Link to post
Share on other sites
I don't know, if really all keys are required.

Thanks a lot! For me (beholder 407 analog, beholdtv 5.05, server 2008 standard x64) all that was needed:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96460-78F3-11d0-A18C-00A0C9118956}]
@="%Filter_XBar%"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96460-78F3-11d0-A18C-00A0C9118956}\InprocServer32]
@="C:\\Windows\\SysWOW64\\ksxbar.ax"
"ThreadingModel"="Both"

0

Share this post


Link to post
Share on other sites

Couldnt say exactly which registry key from Wima did it, but the I've got the Hauppauge PVR150 working on Windows 2008 x64 with GBPVR. Quality isnt too great, and switching channels is slow, but that might be GBVR.

thx for the keys Wima! Will be trying Mediaportal somewhere in the future, if I run into the Teletext issue, I'l report back here.

0

Share this post


Link to post
Share on other sites
Couldnt say exactly which registry key from Wima did it, but the I've got the Hauppauge PVR150 working on Windows 2008 x64 with GBPVR. Quality isnt too great, and switching channels is slow, but that might be GBVR.

thx for the keys Wima! Will be trying Mediaportal somewhere in the future, if I run into the Teletext issue, I'l report back here.

Does this require the digital BDA patch and all of the Vista files, or does it just require the registry settings posted here? Thanks.

0

Share this post


Link to post
Share on other sites
Couldnt say exactly which registry key from Wima did it, but the I've got the Hauppauge PVR150 working on Windows 2008 x64 with GBPVR. Quality isnt too great, and switching channels is slow, but that might be GBVR.

thx for the keys Wima! Will be trying Mediaportal somewhere in the future, if I run into the Teletext issue, I'l report back here.

Does this require the digital BDA patch and all of the Vista files, or does it just require the registry settings posted here? Thanks.

It requires the BDA digital patch and also this registry settings as well. (Registry settings required only if your using analogue)

@Wima

Great job, you got the analogue to work, and also figured out the registry settings as well :thumbup

Edited by shahed26
0

Share this post


Link to post
Share on other sites

I would never have believed it, but I am using my PVR-150 along with Snapstream BeyondTV in Server 2008 x64. I simply ran the BDA batch files as directed, then followed it up by the reghacks posted above. There are 37 .reg files to import; I was able to import all but the last three or four.

Thanks to all who made this possible! :thumbup

0

Share this post


Link to post
Share on other sites
There are 37 .reg files to import;

there are "only" 30 .reg files, the next after 22.reg ist 30.reg :rolleyes:

wima

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.