shahed26

BDA (Tv tuner support) on Server 2008/R2

138 posts in this topic

There are 37 .reg files to import;

there are "only" 30 .reg files, the next after 22.reg ist 30.reg :rolleyes:

wima

Oops.

:blushing:

At any rate, congratulations.

0

Share this post


Link to post
Share on other sites

About the registry keys, maybe interesting to know: before importing them, I took a full backup of my registry. After importing the keys (and seeing everything worked fine), I reimported the backup. It said it couldnt import everything because some keys were in use. My pvr-150 was still working fine. Basically, I think this way maybe one can filter out the unnessary keys, because the good ones are in use.

Thx Wima for getting this to work!

0

Share this post


Link to post
Share on other sites

As i dont have any Vista 64 machines available, its hard to get the files needed to run the bdaforserver thingie.

Anyone able to help me get hold of the files needed to make this work? I have a PVR-500 card.

\\few

0

Share this post


Link to post
Share on other sites

Now I have only one file for enabling analog tv. Tested on Windows Server 2008 x64 English with a PVR-150.

Windows Registry Editor Version 5.00


[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{a799a801-a46d-11d0-a18c-00a02401dcd4}]
"FriendlyName"="WDM Streaming Crossbars"
"CLSID"="{a799a801-a46d-11d0-a18c-00a02401dcd4}"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{a799a802-a46d-11d0-a18c-00a02401dcd4}]
"FriendlyName"="WDM Streaming TV Audio"
"CLSID"="{a799a802-a46d-11d0-a18c-00a02401dcd4}"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{a799a800-a46d-11d0-a18c-00a02401dcd4}]
"FriendlyName"="WDM Streaming TV Tuners"
"CLSID"="{a799a800-a46d-11d0-a18c-00a02401dcd4}"


[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{07dad660-22f1-11d1-a9f4-00c04fbbde8f}]
"FriendlyName"="WDM Streaming VBI Codec"
"CLSID"="{07dad660-22f1-11d1-a9f4-00c04fbbde8f}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{19689BF6-C384-48FD-AD51-90E58C79F70B}]
"FriendlyName"="WDM Streaming Encoder Devices"
"CLSID"="{19689BF6-C384-48FD-AD51-90E58C79F70B}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{71985F48-1CA1-11d3-9CC8-00C04F7971E0}]
"FriendlyName"="BDA Source Filters"
"CLSID"="{71985F48-1CA1-11d3-9CC8-00C04F7971E0}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{71985F4A-1CA1-11d3-9CC8-00C04F7971E0}]
"FriendlyName"="BDA Rendering Filters"
"CLSID"="{71985F4A-1CA1-11d3-9CC8-00C04F7971E0}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{7A5DE1D3-01A1-452C-B481-4FA2B96271E8}]
"FriendlyName"="WDM Streaming Multiplexer Devices"
"CLSID"="{7A5DE1D3-01A1-452C-B481-4FA2B96271E8}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{C4C4C4FC-0049-4E2B-98FB-9537F6CE516D}]
"FriendlyName"="BDA CP/CA Filters"
"Merit"=dword:00600000
"CLSID"="{C4C4C4FC-0049-4E2B-98FB-9537F6CE516D}"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance\{FD0A5AF4-B41D-11d2-9C95-00C04F7971E0}]
"FriendlyName"="BDA Receiver Components"
"CLSID"="{FD0A5AF4-B41D-11d2-9C95-00C04F7971E0}"






[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{266EEE40-6C63-11cf-8A03-00AA006ECB65}]
@="WDM TV Tuner"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{266EEE40-6C63-11cf-8A03-00AA006ECB65}\InprocServer32]
@="C:\\Windows\\SysWOW64\\kstvtune.ax"
"ThreadingModel"="Both"







[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96460-78F3-11d0-A18C-00A0C9118956}]
@="%Filter_XBar%"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96460-78F3-11d0-A18C-00A0C9118956}\InprocServer32]
@="C:\\Windows\\SysWOW64\\ksxbar.ax"
"ThreadingModel"="Both"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96461-78F3-11d0-A18C-00A0C9118956}]
@="Analog Crossbar Property Page"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96461-78F3-11d0-A18C-00A0C9118956}\InprocServer32]
@="C:\\Windows\\SysWOW64\\ksxbar.ax"
"ThreadingModel"="Both"


[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96462-78F3-11d0-A18C-00A0C9118956}]
@="WDM TV Audio"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96462-78F3-11d0-A18C-00A0C9118956}\InprocServer32]
@="C:\\Windows\\SysWOW64\\ksxbar.ax"
"ThreadingModel"="Both"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96463-78F3-11d0-A18C-00A0C9118956}]
@="TV Audio Property Page"

[HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{71F96463-78F3-11d0-A18C-00A0C9118956}\InprocServer32]
@="C:\\Windows\\SysWOW64\\ksxbar.ax"
"ThreadingModel"="Both"

install.reg

0

Share this post


Link to post
Share on other sites

wima, you have done a great job, with the analogue getting to work. Great stuffs :thumbup

0

Share this post


Link to post
Share on other sites
One problem exists. See here

Greetings

wima

mmmm, the problem seems like a poor signal strength, or signal constantly falling. (just a guess though)

0

Share this post


Link to post
Share on other sites
One problem exists. See here

Try installing a trial version of BeyondTV. At least that might rule out your PVR application. I've had no such issues with a PVR-150 and Live analog TV with my software.

Edited by Bilar Crais
0

Share this post


Link to post
Share on other sites

I just registered into this forum to thank you @shahed26 for this nice script, thanks a lot for the efford creating it and sharing it with us.

You totally saved my day :D, I found this threads after hours of searching. Now I can finally watch TV on my Win2008 Server :D

regards,

0

Share this post


Link to post
Share on other sites

Hi there,

Good news from me. I've already sucessfully setup my TV Card - Leadtek DTV2000H on Windows Server 2008 x32 system.

Steps what did i do:

  1. Install latest Leadtek drivers for Vista x32 (download)
  2. After restart, there was 1 unsucessfull driver installed(later i found it was WinFast DTV2000 H WDM Audio Capture)
  3. Update this unsucessfull driver with driver CX23880.4.0.112.3223_Vista_WHQL (download)
  4. After restart all devices are installed successfull, there are no unknown/unsucessfull drivers in Device Manager
  5. Then i found repack of BDAForServer with included files from Vista (SageTV for Server2003/2008 - search for - Microsoft_BDA_Components_For_Server_2008.
  6. Extract archive to C:\bdaforserver\ and run as administrator c:\bdaforserver\Setup For x86\Setup BDA.bat
  7. Then i follow instructions from file Instructions.txt
  8. After restart i install latest WinFast PVR2 (download)
  9. The hard part is done
  10. Now i run Winfast PVR2 application and program successfully detect and allow me to select capture device WinFast DTV2000 H WDM Video Capture
  11. Rescan channels and i got all channels like in Windows XP, yeah!
  12. But hey, i hear no sound from my speakers!!!
  13. But when i try to record movie and then play this record movie, i found that movie has audio and i hear everything. funny isnt it?
  14. Then i play with volume settings icon in task bar, right click on icon, select Playback Devices, on tab Levels i increase CD Audio to maximum, and now i hear sound while watching channel in WinFast PVR2 program!
  15. Thats it, everything is working!
  16. Thanks a lot shahed26 !

Preview of my settings in Winfast PVR2 program:

winfastpvr2w2k8.jpg

0

Share this post


Link to post
Share on other sites

Does anyone know if this will work for a PVR-350? I'm planning on moving my SageTV Server to W2K8 (and then to W2K8 R2) and would like to know if I should follow these same steps.

Thanks,

Mark.

0

Share this post


Link to post
Share on other sites

Hi guys,

I got Dvico Fusion5Express Link, but it doesnt work for me please help.

I had format my computer a few times, and tired a few times the steps that show on Instructions.

I copied the files from English Windows Vista x64, to test on English Windows server 2008 x64

Please help

Thanks

Eddy

0

Share this post


Link to post
Share on other sites

will this allow me to use a Visiontek Tv Wonder 650 card on server 2008 properly?

just asking because I am about to order one In part I plan to use the card to record vhs tapes so I can make video files from them for my mother, the other part is, i wana beable to watch tv on my puter ofcorse :P

0

Share this post


Link to post
Share on other sites

This worked great to get BDA on Server08 x86 - Cheers!!!!

On x64 Clean Install and using the bdaforserver instructions

I was receiving Access violations on FusionHDTV.exe and CreateKsFilter Failed on starting the tv app.

The Manufacturers website only mentioned that "the driver of the device is not installed properly" thanks dvico.

Only Video in was enabled & the tv tuner(s its dual DVB-T) showed up as unknown devices within the app even though windows drivers installed fine.

With the TV tuner working on Vista64 (Same machine/hardware different partition) & thanks to you guys I used Graphedit (add filter, expand the list, and screen capture) just to check what filters were listed on Vista 64 and on Server 64. Graphedit seems daunting... but just compare the filter lists...

The BDA CP/CA Filters were missing on Server [although the header was there thanks to Wow6432node reg].

On Vista The filter list shows:

#The display name for the missing filters contains the: CLSID {C4C4C4FC-0049-4E2B-98FB-9537F6CE516D}

#The Filename is the file we need... EncDec.dll

1. Open regedit 'find' all 'keys' in HKEY_CLASSES_ROOT\CLSID\ with: 9537F6CE516D and export (theres 10) to "new folder"

2. Do the same for HKEY_CLASSES_ROOT\Wow6432Node\CLSID\ (I just made 1 file and copied it, to do a 'find/replace')

3. Copy EncDec.dll from system32 to "new folder"

On Server x64

4. Copy to and register %systemroot%\system32\EncDec.dll

5. Merge the reg files exported from vista

Open the TV app and scan for channels ...SWEET IT WORKS...

NB.Dual Tunner - if it disables the first tuner (in windows devices - the device cannot start code 10) Just force ESCD in BIOS

Attached is the process (scripts not dlls) - I think its wise to make your own though - IF U DONT UNDERSTAND DONT USE...

Anyway just thought this might help save some time with similar probs, & sorry if its already been posted.

@shahed26 Your a LEGEND

Win Server 2K8 x64 SP1

2x Xeon 3GHz

8GB

Fusion HDTV Dual Digital 4 Rev.1

ATI HD3870

ServeRaid 6M

BDAserver.rar

Edited by nutR
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.