RetroOS

Compilation of Creative Sound Blaster Live! drivers for Windows 9x

99 posts in this topic

Eck,

Thanks a lot for your time and concern.

I managed to d/l your iso from filefront.

I renamed it to SB0100.ISO [was 591 MB] and compressed in RAR format down to 395 MB (200 MB smaller) = new file name SB0100_ISO.RAR:

http://www.mdgx.com/sbdrv/SB0100_ISO.RAR

One needs 7-zip, WinRAR or similar to extract the ISO:

http://www.mdgx.com/toy.htm#ZIP

______________________________________

Everybody,

All files in the SB repository now available at [this is where list.php now redirects to]:

http://www.mdgx.com/sbdrv/

Please update all your bookmarks/favorites/links to this new mirror URL.

And feel free to link to any files.

HTH

0

Share this post


Link to post
Share on other sites
hey where can i find the windows me drivers for the

sound blaster 5.1 SB0680

starcraftmaster, if you have the card installed in your PC, can you please post the PCI ID of the card here.

See the instructions under the card list in the First Post

I'm not able to get the PCI ID information from the latest drivers since Creative now encrypt this information(!) - as if it's really secret!

Anyone can find it if they have the card.

0

Share this post


Link to post
Share on other sites

RetroOS

am getting the card soon lol and if its not going to work on windows me am not sure what i will do

cant you tell from the model name?

0

Share this post


Link to post
Share on other sites
RetroOS

am getting the card soon lol and if its not going to work on windows me am not sure what i will do

cant you tell from the model name?

As mentioned previously, Creative are hiding the information I need related to the model number...

The only way currently is to actually have the card in the PC and read what Windows has got from the card...

Even then, I'm not sure what we can get working with these latest cards.

But we'll try...

0

Share this post


Link to post
Share on other sites

its not new its a 2005 model Lol

so idk

i downloaded the drivers just to see if it will start and it started but said cant find any soundblaster sound card so i dont know if they will install but looks like it will since the installer started.

0

Share this post


Link to post
Share on other sites

ok hes the pci id thing

ven_1102&dev_0006&subsys_10011102&rev_00

what the hell can you tell from that lol

0

Share this post


Link to post
Share on other sites

Well, the first thing I can tell is that it's not part of the Sound Blaster Live! family...

All the Live! cards have a PCI ID starting with PCI\VEN_1102&DEV_0002.

The one you have starts with PCI\VEN_1102&DEV_0006.

I would say at first glance that the Live! drivers will probably never work on this card...

I could be wrong though...

It all depends on whether it has an EMU10K1 chipset...

The Audigy family has an EMU10K2 chipset.

0

Share this post


Link to post
Share on other sites

i dont know justr its a sound blaster 5.1

and live drivers wont work becasue its not a a Live! card

EMU10K1 chipset... how do i tell ?

see the driver wont start at all with windows 98 as it says its not support OS

but with with windows me it install just this error commes when installing the drivers

cannot load a crucial installer component (thk3216.dll) exiting...

???????? gee creative is a** holes make things so hard for us

some one mind giving me windows xp ? lol

0

Share this post


Link to post
Share on other sites

Starcraftmaster, is this what your card looks like?...

http://www.tipidpc.com/viewitem.php?iid=3031311

I've found a few other places calling that model number an "Audigy LS" and it's also possible that it's a Dell or Gateway part.

The only mention of SB0680 that I've been able to find so far on the Creative Labs page is this one where they call it a "Sound Blaster 5.1" (note, no "Live")...

Windows 7 - Driver Availability Chart

If you have the original CD that came with it, maybe you could make an ISO image, then make a RAR archive of this ISO file and upload it somewhere so that RetroOS can take a look at it.

I'm wondering if that model was the bastard child of the flurry of sound chip manufacturer acquisitions that Creative did a while back and was later abandoned.

Edited by krick
0

Share this post


Link to post
Share on other sites

well on the card is says SB0680 and plus in white letter on the top right corner it says SOUND BLASTER

so is my a audigy ls or not ?

0

Share this post


Link to post
Share on other sites

and yes that is my card krick in the pics

also i tryed installing audigy ls drivers but said it could not find any audigy sound card

no i dont have the driver cd i just downloaded them

Edited by starcraftmaster
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.