RetroOS

Compilation of Creative Sound Blaster Live! drivers for Windows 9x

99 posts in this topic

Updated: March 20, 2009

- Added download mirror for dencorso's parametric EQ patch (Thanks again MDGx :hello: )

There are some people having problems with their Creative Sound Blaster Live! in Windows 9x.

Creative CD release drivers and Web Release drivers seem to be in many different revisions for different cards...

Some revisions are good and some are not.

For years I have been collecting and testing newer versions of creative driver files to determine those that worked in 9x with the Live!.

Following is that collection of driver files:

Please note that these are original, freely available Creative files, and the binaries are not modified or patched in any way.

The provided software is useless without a Creative Sound Blaster Live! card installed.

Main Driver Set (4.42 MiB)

mirror 1: http://www.divshare.com/download/6107747-45d

mirror 2: http://www.mdgx.com/sbdrv/sblive2.zip

Creative EMU10K1 sound devices supported:

CT4620 - PCI\VEN_1102&DEV_0002&SUBSYS_00211102 - Sound Blaster Live! (Gen I)

CT4670 - PCI\VEN_1102&DEV_0002&SUBSYS_00201102 - Sound Blaster Live! (Gen I) Value

CT???? -- PCI\VEN_1102&DEV_0002&SUBSYS_002F1102 - Sound Blaster Live! motherboard integrated

CT4760 - PCI\VEN_1102&DEV_0002&SUBSYS_80401102 - Sound Blaster Live! (Gen II)

CT4780 - PCI\VEN_1102&DEV_0002&SUBSYS_80221102 - Sound Blaster Live! Value

CT4790 - PCI\VEN_1102&DEV_0002&SUBSYS_80231102 - Sound Blaster PCI512 (OEM)

CT???? -- PCI\VEN_1102&DEV_0002&SUBSYS_80251102 - Sound Blaster Live! motherboard integrated

CT4830 - PCI\VEN_1102&DEV_0002&SUBSYS_80261102 - Sound Blaster Live! (Gen II OEM) Value

CT4831 - PCI\VEN_1102&DEV_0002&SUBSYS_80311102 - Sound Blaster Live! Value

CT4832 - PCI\VEN_1102&DEV_0002&SUBSYS_80271102 - Sound Blaster Live! Value

CT4850 - PCI\VEN_1102&DEV_0002&SUBSYS_80511102 - Sound Blaster Live! Value

CT4870 - PCI\VEN_1102&DEV_0002&SUBSYS_80281102 - Sound Blaster Live! Value

CT4871 - PCI\VEN_1102&DEV_0002&SUBSYS_80321102 - Sound Blaster Live! Value

SB0060 - PCI\VEN_1102&DEV_0002&SUBSYS_80611102 - Sound Blaster Live! (Gen III) 5.1

SB0100 - PCI\VEN_1102&DEV_0002&SUBSYS_80621102 - Sound Blaster Live! (Gen III) 5.1

SB0102 - PCI\VEN_1102&DEV_0002&SUBSYS_80641102 - Sound Blaster Live! (Gen III) 5.1

SB0100 - PCI\VEN_1102&DEV_0002&SUBSYS_80661102 - Sound Blaster Live! (Gen III) 5.1 (Unofficial)

If you have a Creative Sound Blaster Live! card that is not recognised by these drivers, then please post your PCI ID.

The PCI ID can be found using regedit:

HKEY_LOCAL_MACHINE\Enum\PCI

Look for a key starting with VEN_1102&DEV_0002, and copy the key name.

I have used these drivers in Windows 98SE, but they should support 95 and Me although I have not tested them on these platforms.

There are Creative installers for Windows 95 and for Windows 98/Me.

Windows 9x Pure DOS support drivers

For those wanting Pure DOS (outside of Windows) Sound Blaster 16 Emulation for their Live! and have lost or never had the original CD, or have a newer CD that does not come with these, or simply can't be bothered looking for them:

1999 Release (823 KiB):

mirror 1: http://www.divshare.com/download/6106307-f19

mirror 2: http://www.mdgx.com/sbdrv/sbldos.zip

2000 Release (827 KiB):

mirror 1: http://www.divshare.com/download/6107195-60d

mirror 2: http://www.mdgx.com/sbdrv/sbldos2.zip

There are two releases of DOS Drivers. The 2000 release should work on all Live! cards, but if there is a problem then use the 1999 release.

Note: DOS Emulation may not work on some (newer) motherboards if the BIOS does not map the PCI SERR# signal to the processor NMI (Non-Maskable Interrupt). Look in the BIOS settings for a PCI SERR setting or check with your mobo vendor for a BIOS upgrade, or dump the Mobo for one that works properly!

See here for more technical information:

http://groups.google.com/group/alt.comp.pe...47b2fbdaeff13e6

Creative Applets that are compatible and tested with VxD drivers:

Check your current version of each applet before installing these in case they are actually newer than these...

AudioHQ

To deinstall the original CD installed AudioHQ (and 1.0.185.0):

C:\WINDOWS\IsUninst.exe -f"C:\Program Files\Creative\SBLive\AudioHQ.isu"

Always deinstall old version first!

1.0.185.0 (Oct 1999) - Works (1.98 MiB):

mirror 1: http://www.divshare.com/download/6106308-e10

mirror 2: http://www.mdgx.com/sbdrv/audiohq10185.zip

1.0.193.0 (Sep 2000) - Fails to install (!)

1.0.193.0 (May 2001) - Fails to install (!)

1.10.21 (Jun 2002) - Fails with VxD drivers

1.10.22 (Nov 2002) - Fails with VxD drivers

Surround Mixer

To deinstall the original CD installed Surround Mixer:

C:\WINDOWS\IsUninst.exe -f"C:\Program Files\Creative\SBLive\SurMixer.isu"

To deinstall 1.1.1.0 of Surround Mixer:

C:\WINDOWS\IsUninst.exe -f"C:\Program Files\Creative\SurroundMixer\SurMixer.isu"

Always deinstall old version first!

1.1.1.0 (Nov 2000) - Works (1.68 MiB):

mirror 1: http://www.divshare.com/download/6106309-53b

mirror 2: http://www.mdgx.com/sbdrv/surmix111.zip

2.00.26 (Jun 2002) - Fails with VxD drivers

2.00.29 (Nov 2002) - Fails with VxD drivers

3.00.57 (Feb 2003) - Fails with VxD drivers

More stuff:

dencorso's parametric EQ patch for emu10k1.vxd 4.12.01.0906:

See here: http://www.msfn.org/board/index.php?showto...st&p=771209

mirror 1: http://www.msfn.org/board/index.php?app=core&module=attach&section=attach&attach_id=22430

mirror 2: http://www.mdgx.com/sbdrv/emu0906.zip

aLeXis' patch installer: http://www.msfn.org/board/index.php?showto...st&p=771360

mirror 1: http://qshare.com/get/222538/sblive-eq-pat...1.0906.exe.html

mirror 2: http://www.mdgx.com/sbdrv/sblive-eq-patch-4.12.01.0906.exe

Various Sound Blaster files hosted by MDGx:

http://www.mdgx.com/sbdrv/

Standard disclaimer

These drivers have worked for me but YMMV. I have been using them for years with no problem, however, they may or may not work on your model of Creative sound card, and therefore, I cannot make any guarantee of suitability. In simple terms, you are solely responsible if your audio begins to sound like you're in a concrete bunker some thirty-seven miles from the stage of Disaster Area!

Enjoy! :)

Edited by RetroOS
0

Share this post


Link to post
Share on other sites

I've added the pure DOS Sound Blaster 16 Emulation drivers for the Live!

These are for Windows 95/98, but not Me since Me does not have pure DOS access aside from the EBD.

See first post.

EDIT: Windows Me with the EBD IO.SYS patch could in fact run SB16 DOS Emulation! :sneaky:

Edited by RetroOS
0

Share this post


Link to post
Share on other sites
:hello: Will this help with SB16...as have original cdrom and older SB16 blaster audio card from '95era?...i think. ;It came with Pentium1-133Mhz-66Mhzbus-1.5gbHdd-And a useless(BTC) cdrom :***Will be putting in Via(ShuttleMoBo)Apollo 233Mhz-MMX/Pentium2(acts like a Pentium4)-66Mhzbus-4.7gbHdd,1.5Hdd---LITEON LTN301CdRom-read,audio(player/burner),LITE-ON LH52CIP DVD/CDRW Burner;H-P CD Writer/Burner :whistle: THX...thydreamwalker
0

Share this post


Link to post
Share on other sites
:hello: Will this help with SB16...

No it won't. SBLive! uses the EMU10K1 chipset that is quite different to previous Sound Blasters.

Download the SB16 Windows drivers from Creative.

If it's a SB16 PCI and you want to use it outside of Windows, then you will need the DOS driver.

A bit tricky since Creative dropped DOS support...

Try adapting the SBPCI drivers from here: http://easymamecab.mameworld.net/html/snddosdr.htm

0

Share this post


Link to post
Share on other sites

I've corrected some of the Sound Blaster Live! model names in the first post supported list.

If anyone was wondering, the supported devices do include the SB0060 Live! 5.1 cards (previously incorrectly named).

I would like to confirm the operation of these drivers on various Live! models.

If you have installed these drivers and they are working correctly, then please post your Live! information.

Information as listed in the first post would be good. CT or SB model (on card), descriptive model (on box or manual), and PCI ID would all be useful.

PCI ID can be found using regedit:

HKEY_LOCAL_MACHINE\Enum\PCI

Look for key starting with VEN_1102&DEV_0002, and copy key name.

And the version of Windows 9x (95, 95A, 95B, 95C, 98, 98SP1, 98SE, Me)

Also let me know if the drivers have not worked for you and why.

These drivers do not include the Creative apps like Surround Mixer.

Many of these can be downloaded from Creative.

Thanks. B)

Edited by RetroOS
0

Share this post


Link to post
Share on other sites

I don't know of any PCI SB16 cards. I have an ISA one though, and it works perfectly under DOS with just this line in autoexec.bat, no drivers needed as DOS had native support for the SB:

SET BLASTER=A220 I7 D1 T4 H6 P330

You have to check the jumper settings of the card, they have to match the above line.

Edited by Th3_uN1Qu3
0

Share this post


Link to post
Share on other sites
:thumbup Thanks your driver info helped on older PI ;yet found auto matic driver installs for a lotta Creatives SB Cards?....in Windows 2K ADV SVR...not sure if in CD-ROM or was downloaded in NTSP4 Updates? :blink: thydreamwalker
0

Share this post


Link to post
Share on other sites

Hmm the emu10k1 vxd is actually newer than what i got with liveware 3 full package...how can this be...shame the parametric eq patch doesn't work on it :( Thanks anyway :wacko:

0

Share this post


Link to post
Share on other sites

Yeah, patches tend to be file version specific.

What model Live! card do you have?

0

Share this post


Link to post
Share on other sites

I have model SB0100, which is a SoundBlaster Live! 5.1.

Anyone else gotten the drivers installed and installed properly with the SB0100?

0

Share this post


Link to post
Share on other sites
Hmm the emu10k1 vxd is actually newer than what i got with liveware 3 full package...how can this be...shame the parametric eq patch doesn't work on it :( Thanks anyway :wacko:

I can try to port the patch to the newer version... if you want me to try, do PM me.

0

Share this post


Link to post
Share on other sites
Yeah, patches tend to be file version specific.

What model Live! card do you have?

CT4830

0

Share this post


Link to post
Share on other sites
Hmm the emu10k1 vxd is actually newer than what i got with liveware 3 full package...how can this be...
...What model Live! card do you have?

CT4830

Looks like you have a Generation II Live! card. I've got a Gen II myself.

Generation III was introduced with the Live! 5.1.

There have been driver updates since the Live!Ware 3.0 full package was released.

That's the point of these drivers. ;)

As I noted in a previous post, these are the core drivers and do not include Creative applications like Surround Mixer.

The Creative apps have been updated since Live!Ware 3.0 also, but there are some compatibility issues with some newer versions since they are often designed for the WDM drivers (not recommended in 9x - I tested them, and could never get them working properly...).

0

Share this post


Link to post
Share on other sites
Hmm the emu10k1 vxd is actually newer than what i got with liveware 3 full package...how can this be...
...What model Live! card do you have?

CT4830

Looks like you have a Generation II Live! card. I've got a Gen II myself.

Generation III was introduced with the Live! 5.1.

There have been driver updates since the Live!Ware 3.0 full package was released.

That's the point of these drivers. ;)

As I noted in a previous post, these are the core drivers and do not include Creative applications like Surround Mixer.

The Creative apps have been updated since Live!Ware 3.0 also, but there are some compatibility issues with some newer versions since they are often designed for the WDM drivers (not recommended in 9x - I tested them, and could never get them working properly...).

Yeah i know the point of this post but i hate it when companies dont post updated drivers for their older hardware and only for the newer (obvious reasons) even if they are compatible...i didn't knew there were newer vxd drivers for my card besides the lw3.0 package. What about the apps? Is threr surround mixer update for the vxd drivers ? I would like to try it. Thanks for this nice compilation...would be nice if you could find the updated dos drivers (not preinstalled tho).

0

Share this post


Link to post
Share on other sites
Hi RJARRRPCGP, I don't think the SB0100 is in the installer INF.

Can you post your card's PCI ID.

I, too, own the SB0100...

I've attached a registry file of the SB0100 keys found under:

HKEY_LOCAL_MACHINE\Enum\PCI

Hopefully this will help :).

SB0100.reg

Edited by whatever420
0

Share this post


Link to post
Share on other sites
I have model SB0100, which is a SoundBlaster Live! 5.1.

Anyone else gotten the drivers installed and installed properly with the SB0100?

I, too, own the SB0100...

I've attached a registry file of the SB0100 keys found under...

Thanks for the info whatever420! I've compiled an experimental set of drivers for the SB0100.

See First Post

Let me know how they go.

...What about the apps? Is threr surround mixer update for the vxd drivers ? I would like to try it...

I did some testing some time ago with the new apps - varying success.

I'll re-test all the new apps and post those that work well with the VxD drivers.

I have nearly a gig of Live! drivers and apps (all downloaded from Creative US, Eur, Asia, Aus, over the years)

It'll take some time, so stay tuned! B)

0

Share this post


Link to post
Share on other sites
I have model SB0100, which is a SoundBlaster Live! 5.1.

Anyone else gotten the drivers installed and installed properly with the SB0100?

I, too, own the SB0100...

I've attached a registry file of the SB0100 keys found under...

Thanks for the info whatever420! I've compiled an experimental set of drivers for the SB0100.

See First Post

Let me know how they go.

...What about the apps? Is threr surround mixer update for the vxd drivers ? I would like to try it...

I did some testing some time ago with the new apps - varying success.

I'll re-test all the new apps and post those that work well with the VxD drivers.

I have nearly a gig of Live! drivers and apps (all downloaded from Creative US, Eur, Asia, Aus, over the years)

It'll take some time, so stay tuned! B)

Wow over 1 gb...thats alot...hope you can scrap something for us...can't wait :D

0

Share this post


Link to post
Share on other sites

Well, thanks to aLeXis' help, now I offer you here is the parametric EQ patch for emu10k1.vxd v. 4.12.01.0906... :w00t:

Here's how to proceed:

1) Confirm that you do have emu10k1.vxd v. 4.12.01.0906: go to the folder it is in, right-click on emu10k1.vxd, choose Properties, then Version and confirm that it says "File Version: 4.12.01.0906" (without the inverted double commas). If it does not, this patch is not for you;

2) Download the freeware command-line utils.zip, from KanastaCorp, grab inside it just patch.exe and drop it into the \%windir%\command\ folder;

3) Download the emu0906.zip attached below, grab inside it emu0906.pat and drop it into the folder in which you have emu10k1.vxd v. 4.12.01.0906;

4) Still in that folder, rename emu10k1.vxd to emu10k1.ori

5) Start a DOS box, go to the folder in which you have emu10k1.ori, and run the following command from the DOS prompt:

patch -p emu10k1.ori emu0906.pat emu10k1.vxd

6)If everything went well, when you right-click on emu10k1.vxd, choose Properties, then Version, you'll will see that the copyright line now says "1998-2008", instead of "1998-2000"... That is to help identify the patched file from an unpatched one.

7) Enjoy! :yes:

Of course, as always, the standard disclaimer applies: It works great for me, but YMMV and I can guarantee nothing whatsoever about this patch, and about the use you make of it. So, by deciding to apply it you fully accept that anything you do is of YOUR SOLE RESPONSIBILITY... Hence, if after performing this mod your pc morphs into a purple mushroom and explodes, causing a 10-day worldwide blackout and leaving the whole world's population tone deaf in the process, it's your fault only, you know you can't blame me for it! You have been warned.

emu0906.zip

0

Share this post


Link to post
Share on other sites

what about wdm drivers based on emu10k.sys? i need for my machine wdm drivers - for quad repro it is almost impossible to use VxDs. also your drivers worked as expected. good for stereo, but hard to work with surround settings (set wavedevce instead of directsound may solve that, but it causes other trouble with some sound formats)

also i prefer to use ASIO function for better sound with my sb0100 and that is available only with wdms...

0

Share this post


Link to post
Share on other sites
what about wdm drivers based on emu10k.sys?...

AFAIK, The SB0100 was not supported with VxD drivers. The ones I have compiled are probably the only ones in existence...

I will look into compiling a current WDM driver set for SB0100 Live! 5.1 (EMU10K1) and Audigy (EMU10K2).

I currently use waveOut instead of Direct Sound for some applications like DVD playback to get quad speaker working properly.

It is necessary to have the multichannel Windows 98SE patch (269601/242937) installed to get more than stereo working in most cases.

Auto-Patcher 98 has this patch in the core system updates.

BTW, dencorso, great work on the eq patch!

0

Share this post


Link to post
Share on other sites

i downloaded dozen drivers for sb0100. some of them were vxd (similar to these) and some wdm...

0

Share this post


Link to post
Share on other sites

I've started adding some Creative applets.

So far AudioHQ and Surround Mixer.

Most newer versions only work on WDM drivers.

See first post for VxD compatible versions.

0

Share this post


Link to post
Share on other sites

Cool...ill try the new applets and post back feedback...

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.