damian666

UXTender 1.2

129 posts in this topic

oh, i didnt know that was degrading in your language...

well, i am sorry then, it is just the way i talk in english man, thatys what you get for learning it from TV :D

so no harm intended man, just take it with a grain of salt if i say that man... :D

i cant help it really...

and about the patch, so it is only when you have windows blinds installed huh?

and with the prepatched file its the same?

thanx for reporting man, not sure if i can do anything about it, but i will try :D

Damian666

0

Share this post


Link to post
Share on other sites

You know, when I started working on the machine I saw that she had Windowblinds installed and removed it. When I went back in to get a screen shot to show the themes that weren't showing...hey! That fixed it! So I didn't even try the patch file. I can confirm that this issue is with the patch and Windowblinds installed though. I hate Windowblinds, bloated and useless, and too expensive.

0

Share this post


Link to post
Share on other sites

Just to let you know the patch isn't working for me. I've just got SP3 today through windows update and after applying the patcher when I try to apply a 3rd party msstyles file I get an error "An exception occurred while trying to run <path to theme file>". Maybe I did something wrong...the machine was patched using Uxtheme multi-patcher for SP2 before the update.

Edited by vile
0

Share this post


Link to post
Share on other sites

did you reboot after the install of the SP3?

and then after you patched the file on that next reboot, did you reboot again?

that is really necessary to replace the in-use file.

Let me know if it stil doesnt work, and else email me the uxtheme from your system so i can take a look why it didnt work

:D Damian666

0

Share this post


Link to post
Share on other sites

Yeah, I rebooted after updating to SP3 (windowsupdate asked me to) and after using the patcher. I've emailed you my current dll if you feel like taking a look, thanks :).

0

Share this post


Link to post
Share on other sites

hi man, i have had a looksie at your uxtheme, and man...

see what version it returned: 6.00.2600.0000 (xpclient.010817-1148)

i believe that is a sp0 version man.

so that would explain why it didnt work, but how the hell did you end up with a sp0 file after upgrade with sp3???

any idae what went wrong on your system?

damian666

0

Share this post


Link to post
Share on other sites

That's very weird, I'm not sure. Especially since I upgraded from SP2. I originally installed on here with an SP2 disk so SP0 has never been on this PC. The upgrade went OK as far as I know, nothing else seems to be broken. Guess windows update must have messed something up :/. It might have something to do with the fact that I tried to install the SP2 UXTheme patcher after the upgrade (I wasn't thinking, I was so used to running it on PCs with SP2), but I restored it once I realized it was only for SP2. Unless that somehow restored the wrong version of the file or something.

Edited by vile
0

Share this post


Link to post
Share on other sites

well, just install sp3 again, and then first check the fileversion of the uxtheme.

it should be 5512.

then if thats ok, use the patcher, and let me know man :D

damian666

0

Share this post


Link to post
Share on other sites

After trying to "restore" the SP2 patcher (thinking maybe if I restored the one I did first it would be back to an unaltered state) I got a ton of "bad image" messages and couldn't boot properly. So I used an Ubuntu live CD to boot up and replace uxtheme.dll manually with a patched one from www.withinwindows.com. Now my themes work perfectly. Probably was something I did wrong :P

Thanks for your help :).

0

Share this post


Link to post
Share on other sites

can i modify my UXTheme.dll with your patch (i have sp2)and then restart....?

after that, copy my UXTheme.dll, make a cab (makecab command) to rename it to UXTheme.dl_ ..... and then copy it into my i386 folder windows setup?

my windows ue setup has SP2...i want be able to use any theme with sp2...and then..if the user install sp3..he can use the themes too (with sp3)

sorry for my bad english :P:thumbup

can you understand me?

EDIT: jaja sorry...i searched on my hard disk and i dont have any UXTheme.dll :s

more clearly:

how can i add the patched UXTheme.dll (with support for sp3) to my windows ue SP2 setup?

my windows ue setup (is not mine...) has a UXTheme.dl_ on i386 folder

Edited by cloferba
0

Share this post


Link to post
Share on other sites

First off all, stop that pm bombardement man, thats not cool and very f***ed up :(

not to mention that i wont help you that way man...

and about sp2 versions, if you read the topic, which you clearly didnt, you would see this is tested on sp3 only.

that wont mean it wont work, but its not officialy for now.

sorry if i sound a bit harsh, but i really dont like it if i get bombarded by pm's, just wait till i give a answer man.

damian666

0

Share this post


Link to post
Share on other sites

sorry man, i only sended you one pm..because i saw you was connect on the main forum page..

maybe my mistake was because you didnt put all the information about your patch at the first post...(there are 3 pages) and its easy forget something..

if you see the first post..you didnt put that the patch was only tested on sp3 :rolleyes:

Edited by cloferba
0

Share this post


Link to post
Share on other sites
Hi dudes, marxo from WPC, and myself, have created a UXtheme patcher for the new sp3 version.

this little app can easily patch your file, so you can use unsigned visual styles.

Here is a download link: SP3 UX theme patcher 1.1

Have fun.

new version uploaded.

better detection of patched or unpatched file.

more safety checks

and a "lost hope" hotkey to restore the original file.

I tested it with success on a russian uxtheme file, and all wend well, so i think its language

undependend, but i wont make that claim for sure :D for now...

Damian666

yes, only for sp3, in a few days we will all upgrade so,...

why supply sp2 support? and its also allready there so...

and i hope it works on all language versions, but untill its tested, i cant say for sure...

so let em know dudes.

Damian666

You might want to read the thread. He did state that, it's not his fault it's not all right there in the first post. One could logically surmise that since this is for SP3 as stated, that SP2, SP1. are not included. Research is always good, including reading a small 3 page thread.

Edited by y0himba
0

Share this post


Link to post
Share on other sites

@ y0himba, thank you :D

@cloferba, dude, i had more then 1 pm.

Damian666

0

Share this post


Link to post
Share on other sites

yes! you are right ;):D sorry guys :blushing:

very good job damian! :thumbup

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.