Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Tomcat76

HFSLIP 2.0 in the works

Recommended Posts

Hi Tomcat, you didn't mention you updated the .NET Builder tool! Thank you very much. Will test it soon.

Other patches I have applied are removing all START/WAIT commands from the svcpack hfslip.cmd. In a batch file all commands are processed one after another. This has no side effects!

I have changed the recovery console install command to use the settings as specified in winnt.sif. In that file I specify that dynamic updates are disabled.

IF "%INSTALLRC%"=="1" ECHO>>WORK\HFSLIPCMDP1.TXT IF EXIST %%HFSLIP%%winnt32.exe %%HFSLIP%%winnt32.exe /cmdcons /unattend:%%HFSLIP%%winnt.sif

At line 533 I have replaced the REPLACE script with a script to not copy any hidden or system files or directories starting with a dot (UNIX equivalent of hidden file) to the CD.:

This allows me to use HFSLIP directly in subversion (I know I should use export :P)

FOR /F "DELIMS=" %%i IN ('DIR/B/A-D-H-S/S REPLACE ^| findstr /C:"\\\." /V') DO (
SET FULLREPLACEPATH=%%i
SET REPLACEPATH=!FULLREPLACEPATH:%cd%\REPLACE\=!
SET REPLACEPATH=!REPLACEPATH:%%~nxi=!
XCOPY /RSY "%%i" "SOURCESS\!REPLACEPATH!"
)

I have also added a custom file RunHidden.exe to my CD to hide the SVCPACK hfslip.cmd. This file is placed in the SVCPACK directory (line 3766)

IF EXIST WORK\HFSLIPCMDP1.TXT ECHO>>SVCPACK.INF "runhidden HFSLIP.CMD"
FOR /F "DELIMS=" %%I IN ('DIR/B/ON HFSVCPACK\*.exe') DO ECHO>>SVCPACK.INF %%I
)
ECHO>>SVCPACK.INF "runhidden HFSLIP.CMD"

Runhidden is my own AutoIt written script that simply changes also working directory to the correct folder:

#NoTrayIcon
#include <file.au3>
If $CmdLine[0] = 1 then
;split path
Dim $szDrive, $szDir, $szFName, $szExt
$path = _PathSplit($CmdLine[1], $szDrive, $szDir, $szFName, $szExt)

;If no full path is specified check if file exists
If $path[1] = "" then
$filefullpath = @ScriptDir & "\" & $path[3] & $path[4]
$workdir = @ScriptDir
If Not FileExists($filefullpath) Then Exit
Else
$filefullpath = $path[0]
$workdir = $path[1] & $path[2]
EndIf

;Add commandline arguments
$params = ""
if $CmdLine[0] > 1 Then
;If multiple arguments are added seperate each one with a space
$i = 2
While $i < $CmdLine[0]
$params &= $CmdLine[$i] & ' '
$i += 1
WEnd
$params &= $CmdLine[$CmdLine[0]]
endif
ShellExecuteWait($filefullpath, '"' & $params & '"', $workdir, "", @SW_HIDE)
EndIf

P.S. Can I switch to HFSLIP 2.0 now? Or is it still Alpha?

Edited by Acheron

Share this post


Link to post
Share on other sites

P.S. Can I switch to HFSLIP 2.0 now? Or is it still Alpha?
HFSLIP 2.0 is still pre-alpha, but I don't intend to make big changes to HFSLIP 1.x anymore.

Share this post


Link to post
Share on other sites

Testing plugin for Windows Search 4.0 for Windows XP and for Windows Server 2003.

The plugin is to be extracted into the HFTOOLS folder and the exe goes in HF.

Make sure to use HFSLIP 2.0 build 80508a or newer.

Share this post


Link to post
Share on other sites

Hello,

During some test installations I repeatedly received an error message at the beginning of the text mode copy phase (immediately after formatting the hard disk), see attached screenshot.

After a long and tedious testing phase with several hfslip runs I finally identified the culprit: KB942288 (Windows Installer 4.5), named "WindowsXP-KB942288-v3-x86.exe". Removing just this file from the HF folder makes the installation work again... I'm not sure whether this is a problem of hfslip 2.0.0pa only (tried 80608a, 80605a and xxx) - can someone reproduce the issue with hfslip 1.7.7? I'm not in the mood of running more tests now and already reorganized all my files to support versions 2.x only ;)

Is it possible to support that specific update, Tomcat76, e.g. by another HFTOOLS plugin? And, note to my self: never test the most recent non-standard updates from MS if you don't want to go down the road of desperation :)

Kind regards,

Tomalak

post-86085-1213043383_thumb.png

Share this post


Link to post
Share on other sites

What's "xxx"? :)

Windows Installer 4.5 is not supported by HFSLIP 1.x or HFSLIP 2.0 older than 80605a so you won't notice the problem there.

I'll look into it. I have an idea of the cause, but I must admit I didn't expect it. I only tested WI 4.5 with an English Windows XP source. I'll try with other languages now.

Share this post


Link to post
Share on other sites

I tried a new installation test and i had the same problem Tomalak have. I also put the Installer 4.5 (WindowsXP-KB942288-v3-x86.exe) into HF directory. I was trying 80605a... Is this problem fixed in 80608a?

I'm using Windows XP Italian. I assume that the Installer is multilanguage, as I don't see any "ITA" nor "ENG" nor anything else in the filename... Is it true? :}

Edited by Smiley89

Share this post


Link to post
Share on other sites

The problem is that I was making use of destination folder ID's that apparantly only exist for English XP/2K3 sources. The next version will fix this.

But there's an additional problem. I tested it on a German Windows XP source and it appears the German security catalog file for this update is fubar; you'll get three errors reported in setuperr.log. To work around this, I will have to enforce the use of 7za.exe for Windows XP and Server 2003 host OS's as well in order to get the English CAT file in every circumstance. This is namely a special hotfix that contains INFs and CAT files for all languages Windows XP was released in, but normal extraction will only extract the INF and the CAT in the language of the host OS; eg, if the host OS is German, normal extraction will cause only the German INF and CAT file to be extracted. I can only get the English CAT file for non-English host OS's by using 7za.exe.

Also, by adding support for Windows Installer 4.5 I broke the handling of Windows Installer 3.1 for Windows 2000. In the mean time, you can get around this by placing 7za.exe in the HFTOOLS folder.

Share this post


Link to post
Share on other sites

I really enjoy using HFSLIP to create an XPCD. However to build such an CD costs about 20 minutes on my system. There is some time lost on copying everything from SOURCE to SOURCESS directory and after that some more time is waisted copying everything to the ISO.

I have two harddrives in my system, so I would like for example to have processed C:\HFSLIP\SOURCE to D:\SOURCESS and then copy the ISO back to C:\HFSLIP. This should really speed things up, since reading and writing to the same disc is very slow.

Can you add this feature to the HFSLIP answer file?

Edited by Acheron

Share this post


Link to post
Share on other sites

:hello:

"Changes 80612a:

- cumulative ActiveX KillBits are force-added by HFSLIP so it isn't needed to include the current hotfixes (KB948881 or KB950760); to override this behavior, specify NoKillBits=YES in HFANSWER.INI"

Is there a way to add this into hfslip 2.x?

I made a Testinstall XPSP3 german without IE7 and WMP x, only current Hofixes by hfslip 2.0.0pa build 80611a and added drivers by nlite.

Works great. :thumbup

btw, i don´t include installer 4.5, MS update don´t ask for or offer it.

Edited by wela

Share this post


Link to post
Share on other sites

Tested yesterday, and the problem in text mode setup is vanished. :)

But in installed Windows, I still had an issue with Installer 4.5. The problem seems to be identical to the one I described here, but I used HFSLIP 2.0 80611a this time.

I even put 7za.exe in HFTOOLS... What did I do wrong?

PS I wanted to post the log, but I don't have it anymore...

Share this post


Link to post
Share on other sites

I did a quick test changing the SOURCESS location to my second harddrive. When normally the HFSLIP process takes about 20 minutes to slipstream and create a CD iso, now it was reduced to 15 minutes. A 25% decrease of processing time on my system.

If you can also move location of WORK and TEMP to different drives HFSLIP processing should go even quicker.

Share this post


Link to post
Share on other sites

@Smiley89

Do you still have the SOURCESS folder? If so, ZIP TXTSETUP.SIF and HFSLIPOC.INF from SOURCESS\I386 together and put the ZIP file online (either here or elsewhere).

@Acheron

I need to discuss that with TommyP.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×