• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
Sfor

Opera 9.xx in Windows 98

66 posts in this topic

I found Opera to be a very good internet browser. Still, there is a problem related with opening links using DDE with both Opera 9.2x and the newest 9.5x betas.

While trying to open Opera through running .URL file or clicking on an Internet link in a third party application, Opera displays an error message saying "it can not locate the file or it's component" (translation from Polish), then the browser is starting without the clicked link oppened.

If the Opera is running, the same action works as it should to.

I found, the problem can be corrected through removing DDE from the file associations created by Opera:

REGEDIT4

[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\PROGRAM FILES\\OPERA\\OPERA.EXE\" \"%1\""

[-HKEY_CLASSES_ROOT\http\shell\open\ddeexec]

[HKEY_CLASSES_ROOT\https\shell\open\command]
@="\"C:\\PROGRAM FILES\\OPERA\\OPERA.EXE\" \"%1\""

[-HKEY_CLASSES_ROOT\https\shell\open\ddeexec]

Still, the Opera will renew the bad registry settings every time it is selected as the default browser.

Edited by Sfor
0

Share this post


Link to post
Share on other sites

Works fine for me in WinME, didn't get any of that. But please stay away from the 9.5 betas, they're SLOW.

0

Share this post


Link to post
Share on other sites

It would be good to confirm the problem first, I believe. I hope the problem is not Windows language version related.

0

Share this post


Link to post
Share on other sites

the betas being slow is interesting cause i agree beta 1 is slower then 9.27 but after beta 1 and before beta 2 those snapshots were much faster but then beta 2 seemed about slow again maybe you should look for the lastest snapshot

0

Share this post


Link to post
Share on other sites

I've tested the bug with the newest Opera 9.5 beta build 10024.

I found the bug still present, so I sent a bug report.

0

Share this post


Link to post
Share on other sites

Works OK for me.

My registry entry is slightly different from that quoted, this may by significant, I don't know.

REGEDIT4

[HKEY_CLASSES_ROOT\Opera.HTML\shell\open\command]

@="C:\\PROGRAM FILES\\OPERA\\OPERA.EXE \"%1\""

0

Share this post


Link to post
Share on other sites

In my case the regisrty key you have posted is the same as yours:

REGEDIT4

[HKEY_CLASSES_ROOT\Opera.HTML\shell\open\command]
@="\"C:\\PROGRAM FILES\\OPERA\\OPERA.EXE\" \"%1\""

I found the problem to be depandant on a different registry keys:

HKEY_CLASSES_ROOT\http\shell\open\command

HKEY_CLASSES_ROOT\https\shell\open\command

So, you did compared wrong registry keys, I'm afraid.

0

Share this post


Link to post
Share on other sites

Ah, OK.

My equivalent of those keys look like this -

REGEDIT4


[HKEY_CLASSES_ROOT\http\shell\open]

[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files\\Opera\\Opera.exe\""

[HKEY_CLASSES_ROOT\http\shell\open\ddeexec]
@="\"%1\""
"NoActivateHandler"=""

[HKEY_CLASSES_ROOT\http\shell\open\ddeexec\Application]
@="Opera"

[HKEY_CLASSES_ROOT\http\shell\open\ddeexec\Topic]
@="WWW_OpenURL"

REGEDIT4


[HKEY_CLASSES_ROOT\https\shell\open]

[HKEY_CLASSES_ROOT\https\shell\open\command]
@="\"C:\\Program Files\\Opera\\Opera.exe\""

[HKEY_CLASSES_ROOT\https\shell\open\ddeexec]
@="\"%1\""
"NoActivateHandler"=""

[HKEY_CLASSES_ROOT\https\shell\open\ddeexec\Application]
@="Opera"

[HKEY_CLASSES_ROOT\https\shell\open\ddeexec\Topic]
@="WWW_OpenURL"

It uses the DDE function, which yours doesn't seem to be doing.

:)

0

Share this post


Link to post
Share on other sites

Another misunderstanding happened. My HTTP and HTTPS registry keys are exactly the same as yours. The registry file I've posted was made to remove the problem. So, it remowes the DDE related keys from the registy.

Another problem is, why you do not experience the same effects as I do. Could you explain your testing procedure?

As far as I understand the problem, links oppened through Explorer (system shell) are causing the problem. It's quite possible, other system shells or file managers are not affected.

0

Share this post


Link to post
Share on other sites

Sounds like Windows 98 may be giving an error about a file, because of the DDE file associations.

Messed up registry updates done by Opera is possible.

0

Share this post


Link to post
Share on other sites

Sorry for the misunderstanding(s) Sfor!

:)

If when you click a web link Opera opens but doesn't display the page, it sounds like it's not recognising the "%1" bit of the command.

I have that happen sometimes, but it's usually (I think) because my installation of Opera (9.27 Build 8841) takes a long time to open up when running on Windows 98. It's much faster on Windows 2000 (dual boot).

It's almost as if the fact that Opera is taking so long to load is causing the command to be forgotten somehow!

How long does it take the Opera GUI to appear when you run it?

If it's longer than 5 seconds this could be the problem.

I found it was greatly improved after I emptied the Opera cache (Tools>Preference Settings>Advanced>History>Empty Now).

If that helps, try setting the cache size to no more that 50MB or the problem will quickly come back.

I queried this a lot on the Opera user forums, but never got a satisfactory answer.

:)

Edited by Dave-H
0

Share this post


Link to post
Share on other sites

Please save the following data as a .REG file and import it to the registry:

REGEDIT4

[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\PROGRAM FILES\\OPERA\\OPERA.EXE\" \"%1\""

[-HKEY_CLASSES_ROOT\http\shell\open\ddeexec]

[HKEY_CLASSES_ROOT\https\shell\open\command]
@="\"C:\\PROGRAM FILES\\OPERA\\OPERA.EXE\" \"%1\""

[-HKEY_CLASSES_ROOT\https\shell\open\ddeexec]

It will switch off the DDE by removing the DDE registry entries, and the Opera should start with the proper link opened. According to my experiment results, the situation does not have anything to do with the speed of the Opera application.

0

Share this post


Link to post
Share on other sites

I've tried the latest Opera 9.5 beta build 10048. The problem is still present there.

0

Share this post


Link to post
Share on other sites

I'm wondering Sfor, does your problem happen with .htm files as well as .html and .https files?

I ask because your registry entries don't show any data for .htm files.

I don't have an entry for .https files, but I do for .htm and .html files, and they are both of type "Opera.HTML"

The entry for that, which is generated by Opera of course is -

REGEDIT4


[HKEY_CLASSES_ROOT\Opera.HTML]
@="HTML Document"
"EditFlags"=dword:00000000
"BrowserFlags"=dword:00000008

[HKEY_CLASSES_ROOT\Opera.HTML\ScriptHostEncode]
@="{0CF774D0-F077-11D1-B1BC-00C04F86C324}"

[HKEY_CLASSES_ROOT\Opera.HTML\shell]
@=""

[HKEY_CLASSES_ROOT\Opera.HTML\shell\Edit]
@="&Edit"

[HKEY_CLASSES_ROOT\Opera.HTML\shell\Edit\command]
@="\"C:\\Program Files\\Office XP\\Office10\\msohtmed.exe\" %1"

[HKEY_CLASSES_ROOT\Opera.HTML\shell\open]

[HKEY_CLASSES_ROOT\Opera.HTML\shell\open\command]
@="C:\\Program Files\\OPERA\\OPERA.EXE \"%1\""

[HKEY_CLASSES_ROOT\Opera.HTML\shell\open\ddeexec]
@="\"%1\""

[HKEY_CLASSES_ROOT\Opera.HTML\shell\open\ddeexec\Application]
@="Opera"

[HKEY_CLASSES_ROOT\Opera.HTML\shell\open\ddeexec\Topic]
@="WWW_OpenURL"

[HKEY_CLASSES_ROOT\Opera.HTML\shell\Open in Internet Explorer]
"EditFlags"=hex:01,00,00,00
@="Open in Internet Explorer"

[HKEY_CLASSES_ROOT\Opera.HTML\shell\Open in Internet Explorer\command]
@="C:\\Program Files\\Internet\\IEXPLORE.EXE %1"

[HKEY_CLASSES_ROOT\Opera.HTML\shell\Print]
@="&Print"

[HKEY_CLASSES_ROOT\Opera.HTML\shell\Print\command]
@="\"C:\\Program Files\\Office XP\\Office10\\msohtmed.exe\" /p %1"

[HKEY_CLASSES_ROOT\Opera.HTML\ShellEx]

[HKEY_CLASSES_ROOT\Opera.HTML\ShellEx\IconHandler]
@="{42042206-2D85-11D3-8CFF-005004838597}"

Ignore the entry for Internet Explorer, I just added that manually so I can right click and choose to open the file in IE instead of Opera if I want to. The Office XP entry was put there by Office XP itself!

Apart from the times when Opera is a bit too slow starting up, and opens with a blank page, this always works.

If I double click on an htm or html file in Windows Explorer, or on a link say in an e-mail, Opera opens and displays the page as it should do.

Although it sounds a bit drastic, I would uninstall Opera, and go through and delete manually all registry entries referring to it if any remain.

Then make IE your default browser, assuming that you have it, and make sure that works with the file associations as it should.

Then reinstall Opera and make that the default browser and see if it behaves any better.

:)

Edited by Dave-H
0

Share this post


Link to post
Share on other sites

No, the problem does not happen with the .HTM and .HTML files. But, when I'm trying to open an internet page shortcut from my desktop (Active Desktop - Switched off) without the Opera running, the Opera starts without the link loaded. If Opera is running, the link opens correctly.

When creating a new shortcut on the desktop to an internet page, the Windows 98 creates a .URL file. The file extension is not shown by the windows explorer in any place. In order to confirm the file extension is .URL it is necesary to open properties of the link. The file extension is visible in the MS-DOS file name field, only.

When creating a new shortcut, the explorer does create .LNK or .URL file depending on what is entered in the command line field. Local file path means .LNK. While an internet page address will result in the .URL.

0

Share this post


Link to post
Share on other sites

Ah, so your problem is related to .url files, which are internet shortcuts (as used by IE favorites).

The registry keys you quoted were only relevant to .html and .https files, which are quite different.

Try this, go to Opera Tools>Preferences>Advanced>Programs and select the "Details" button.

Check "URL shortcuts" on the left hand side and see if that does the trick.

:)

0

Share this post


Link to post
Share on other sites

The registry keys I have posted are used, when the Explorer or Outlook Express is opening internet shortcuts. I've proved it, because a change in these keys does change the way the .URL files are opened.

The Opera (while making it the default browser) changes these keys by default. If they would not be selected, other browser would be used to open the shortcuts. So, the check box you are referring to should change nothing. And as a matter of fact it does change nothing, as I have tried all the possible Opera settings long time ago (with this particular setting included).

0

Share this post


Link to post
Share on other sites

If I go to my Internet Explorer favorites folder using Windows Explorer, and double click on one of the files, Opera opens and displays the webpage that it's pointing to.

Those are internet shortcuts, and are actually .url files, although they show no file extension.

Looking at my file types, .url fines are associated with this command "rundll32.exe shdocvw.dll,OpenURL %l" (without the quotes.)

See if this is the case on your system.

:)

0

Share this post


Link to post
Share on other sites

After trying the last beta and the precedent, I've gone back twice to the last stable version until the next stable one is delivered. IMO there's no need to hurry at all, at least for Win9x users.

Edited by cannie
0

Share this post


Link to post
Share on other sites
If I go to my Internet Explorer favorites folder using Windows Explorer, and double click on one of the files, Opera opens and displays the webpage that it's pointing to.

Those are internet shortcuts, and are actually .url files, although they show no file extension.

Looking at my file types, .url fines are associated with this command "rundll32.exe shdocvw.dll,OpenURL %l" (without the quotes.)

See if this is the case on your system.

:)

Yes, there is exaclty the same setting. My shdocvw.dll version is 6.00.2800.1849. It is possible the problem is version or language related. In my case the shdocvw.dll is a Polish language version.

0

Share this post


Link to post
Share on other sites

So if you double click on one of the IE favorites folder files, what happens?

Does Opera open but not display the page?

:)

0

Share this post


Link to post
Share on other sites

Yes, that's exactly the problem.

I've been trying to replace the shdocvw.dll to some older versions. But, I was unable to correct the issue that way. The attempt to replace the shdocvw.dll to some other language version prevented the system from booting correctly. The shdocvw.dll seems to be a wrong trail, I think.

0

Share this post


Link to post
Share on other sites
:unsure: New Opera9.5(latest build) works from USB Cruzer but no go from hdd so use from it as it accomplishes same as a system program and Internet Access is O.K.,too! :thumbup
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.