Petrarca

Logitech Setpoint

18 posts in this topic

THE SOLUTION IS HERE

I signed up to MSFN just to help you guys out. I have had this problem on everything newer than XP with all versions of SetPoint and my G5 Mouse [server 2003, Vista, and Server 2008 all do this].

IT IS SIMPLE. YOU MUST MANUALLY UPDATE THE DRIVER IN DEVICE MANAGER TO "Logitech HID-compliant G5 Laser Mouse". But for some reason the newer versions of SetPoint do not even install the driver to your ProgFiles\Setpoint or %WINDIR%\INF directory, it obviously doesn't detect the USB device when installing and you have to manually unpack the original setup package and browse to the folder with the INF's with the 'Have Disk' method. And even then, because all the files were not installed by the Setup, the image/graphic/picture for your particular mouse will be missing on the 'Set buttons' page, although it still works fine.

The driver/mouse detection during setup issue I managed to solve under Server 2003 by running the Setup under the SetPoint subfolder in the original package [NOT the setup.exe in the root] under Windows XP compat. mode, and it would copy the images too so it worked 100%. However this does not help much with NT6 family [Vista/2K8].

It'd be good if Logitech solve this problem, but i've submitted about three bug reports the the past year or more and never heard back from them, and they never fixed it. I think it might be only with some certain USB controllers or something [which is stupid as my chipset is an old Intel 875P which were as common as anything]. Strange hey. Anyway I hope that helps! Peace

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.