Sign in to follow this  
Followers 0
Dislocated Time

DCOMBobulator

5 posts in this topic

I still don't get it. I can get a program to be called up by AutoIt but I don't get it go thru any menus.

When I use the recorder, I tried using either the tab buttons or mouse clicks but I only get this:

#region --- ScriptWriter generated code Start ---

Opt("WinWaitDelay",100)

Opt("WinTitleMatchMode",4)

Opt("WinDetectHiddenText",1)

Opt("MouseCoordMode",0)

Run('E:\HFSLIPXPENG\SOURCE\WPI\Install\DCOMBobulator\DCOMbob.exe')

#endregion --- ScriptWriter generated code End ---

Why?

I tried using:

send ("{RIGHT}")

I tried using:

send ("!M")

but the program just doesn't react...

what am I doing wrong?

0

Share this post


Link to post
Share on other sites

Not sure but perhaps the installer might be Java based or something. Differcult to know with the small amount of information suppled. The "Dcom Server Process Launcher" service is probably all that program disables and you can just use SC.exe to do that for you.

Untested but I presume it will work for you.

RunWait('sc stop DcomLaunch && sc config DcomLaunch start=disabled', '', @SW_HIDE)

:)

Edited by MHz
0

Share this post


Link to post
Share on other sites

I've just reread their website and found out that they now support a silent install, maybe someone can add it to the list of silent installs... (last time I read it was about 2 years ago, so things have changed even if the program hasn't changed much).

the switches are:

DCOMbob disable

DCOMbob enable

DCOMbob verify

the verification possibility is there to make sure that it has worked.

:thumbup

Edited by Dislocated Time
0

Share this post


Link to post
Share on other sites

you can try this code to see if you can get around the menu...

run ("DCOMbob.exe")
winwaitactive (" DCOMbobulator -- Say no to DCOM to improve your security.","The GRC DCOMbobulator")
sleep (200)
send ("!{V}");Select Am I Vulnerable? Tab
send ("!{R}"); Activate Remote Port 135 Test


sleep (1000)
send ("!{M}"); Select DCOMBobulate Me! Tab
send ("!{E}"); Enable DCOM

0

Share this post


Link to post
Share on other sites

Next...

I assume you are trying to Disable DCOM by default & you are using HFslip. So to install & disabled automatically, you

1) put DCOMbob.exe into the path: ....\HFEXPERT\PROGRAMFILES\DCOMbob\DCOMbob.exe

2) Create a script DCOMbobscript.au3 within HFExpert\autoit folder

with the code

Runwait (@ProgramFilesDir&"\DCOMbob"&"\DCOMbob.exe disable","",@SW_HIDE)

Hope this is what you want

(BTW, I did not test the script. But believe should work)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.