damian666

Vistapack 2.6 released

264 posts in this topic

Damm! I can't believe this don't have portuguese language support! ;(

Which files you need to support it?

0

Share this post


Link to post
Share on other sites

well... , shell32.dll, sysdm.cpl timedate.cpl

i think that are all files i need.

Damian66

0

Share this post


Link to post
Share on other sites
well... , shell32.dll, sysdm.cpl timedate.cpl

i think that are all files i need.

Damian66

Ok, but I installed it and it worked! With the translated content it will translate only the program, or it will allow me custommize it more?

Also I noticed some problems (?)

Where some pictures:

f_Semttulom_263cc20.jpg

This is how looks my outlook express.. It display some images in 16 colors (?). Also there are any way to enable vista theme (the bar for close, minimize, expand the windows) without enable true transparency? (true transparency use my pc to max 100% so I disable it however it's beautiful)

This how my start menu looks..

f_Semttulo2m_8269ee1.jpg

It shouldn't be like this?

http://www.vistapack.org/images/screens/desktop2k.PNG

More. Couldn't you center the load bar here?:

http://www.vistapack.org/images/screens/boot2k.PNG

Thanks, for your amazing work.

0

Share this post


Link to post
Share on other sites

ofcourse it works, but now certain strings in your files will be in english, instead of portuges...

outlook is not able to display more colors then that, sorry :(

vistatheme without true ttransparency? no.

for taskbar, install tclock3 , but be warned... its beta software

and no, it cant be centered. else i would have done it dude :P

thank m$ for those restrictions...

0

Share this post


Link to post
Share on other sites
ofcourse it works, but now certain strings in your files will be in english, instead of portuges...

outlook is not able to display more colors then that, sorry :(

vistatheme without true ttransparency? no.

for taskbar, install tclock3 , but be warned... its beta software

and no, it cant be centered. else i would have done it dude :P

thank m$ for those restrictions...

Ok, the portuguese files are here: (damm I hope them are not patched :S)

http://rapidshare.com/files/143590588/pt.zip.html

@outlook

That's too bad.. I would prefer original ones then..

@vistatheme

Too bad again.. Seems I would need to use Windows Blinds then. :(

Couldn't it use less cpu power?

@taskbar

when I open TClock3Test it closes it auto.. I will ask about that in it's topic.

Edited by Meados
0

Share this post


Link to post
Share on other sites
well, for that i can only say one thing...

go to WPC , and seek out the member Alexnrs, he is making something too, which involves this.

if someone would know, its him...

check it out, and ask him for help, thats my best advice in this matter, i can only call gdi and brushes and dc's in autoit, which wont help you a lot in this matter so :(

good luck man.

Damian666

I took a look but didn't see anything that would help me. I eventually gave up on trying to do custom marshalling of COM objects and built some simple shared-memory classes using CreateFileMapping, MapViewOfFile, etc, and Windows mutexes to synchronize process access. I have that portion working pretty well now, though I can see that I'll have to optimize it at some point with a subclass that supports dirty rectangles.

It's been a long, slow slog getting GDI to play nice, but one GDI message at a time I'm slowly getting there. I have alpha-blended borders and window contents painting on my D3D surface, though the background is still black since I haven't put in any effort yet into getting the window background onto a texture. I've put some thought into it, though, and I don't think that part will be too hard. The real trick is keeping GDI from interfering with my screen painting while letting it route messages to windows. Nailing window dragging down has been a real chore, but once I found that WM_SYSCOMMAND was the culprit, it came into place. At this point I'm concentrating on getting mouse messages working smoothly.

An evil thought has been at the back of my mind...if I can get all this working, I'll have a Direct3D surface for a window background -- I wonder if that will let me make use of Vista .dreams files? I don't know anything about them, but my understanding is that they let you have animated backgrounds. I have no idea if it will be possible, but since the desktop background will be a separate D3D texture, it seems to me that some interesting things should be possible. I don't suppose anyone has any info on what are in .dreams files?

In terms of the non-D3D effort, I've made lots of little improvements, and also added support for some animated elements (start button, window borders (non-alpha-blended), scroll bars, task buttons, and buttons).

Edited by WildBill
0

Share this post


Link to post
Share on other sites

I have fixed the cpu problem with True Trans. I installed it (lateste version 0.9.4.0). And now it work like a charm without burning my cpu. :P

Please update it in your pack.

I am just wondering how to update my start menu, since the Tclock don't work in my system.

0

Share this post


Link to post
Share on other sites

well, to be honest... tahts why i am going to take it out i think...

its unstable for a lot of people

damian666

0

Share this post


Link to post
Share on other sites

Now this is weird: after updating my Avira AntiVir Free Edition, a message pops out when I try to execute Vistapack.exe:

fpgg0.th.jpgthpix.gif

:blink: :blink:

I'm sure this is a False Positive, because I get the same message when I try to unpack the installer. I should send a report to Avira, but I don't know where!

For all those who get the same message, just put C:\Program Files\Vistapack XP\Vistapack.exe in Configure > Scanner > Scan > Exception > "File objects to be omitted for the scanner" and in Configure > Guard > Scan > Exception > "File objects to be omitted for the Guard", and Vistapack.exe in Configure > Guard > Scan > Exception > "Processes to be omitted for the Guard".

This isn't really a bug, but I think it's useful to report.

PS I'm really looking forward to Vistapack 2.6! :)

0

Share this post


Link to post
Share on other sites

yeah... sadly but true...

autoit is flagged as virus by almost all AV's.

so yeah, false positive :D

Damian666

0

Share this post


Link to post
Share on other sites

well, i am in testing stage of my 2000 version, and after that comes the xp version testfase so...

but a timeline? NO

Damian666

0

Share this post


Link to post
Share on other sites

Greetings, Damian666 !

Trying Vistapack on Win 2k SP4. Having a problem :=( unfortunately, on every reboot,

windows wants to run R:\TEMP\refresher.exe and fails (because R: is a ramdisk, duh).

I guess the refresher in question would be the one under : D:\PROGRAMS\Vistapack 2000\Tools,

but... why does the system keep looking for it on R:\TEMP (I couldn't find a registry entry or inifile

with that reference in it !) ?

And more importantly, how do I change it to fetching the refresher from the right location,

assuming it is needed at all of course ?

Thank you very much

0

Share this post


Link to post
Share on other sites

hmm... well it runs the refresher after every reload, so there is a fault to begin with...

something is not patched right, hence the reload, and refresh.

but why is it looking for a ramdrive??? did you install from there???

the registry place i use is a runonce entry, not a simple run on start one, thats why you cant find it.

but a fix?hmm... i need to know more , how come it chooses your ramdrive, i never saw that before...

@squeeto Hi man :D

Damian666

0

Share this post


Link to post
Share on other sites
but why is it looking for a ramdrive??? did you install from there???

Yes indeed. I couldn't imagine the installer would memorise it being run from the Ramdisk and

try to run something from there after a reboot. Admittedly /I/ was shortsighted, let's say fifty-fifty ;=)

the registry place i use is a runonce entry, not a simple run on start one, thats why you cant find it.

I had noticed that runonce thing and deleted it using regedit, do you recreate it on occasions ?

But why do you insist on running the refresher from that temporary path instead of where the software

is installed ? Alright I guess you now have enough information to help me clear the issue.

Thanks again !

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.