Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Access is denied for C:\Windows\system32

- - - - -

  • Please log in to reply
7 replies to this topic

#1
fredharvey

fredharvey
  • Member
  • 3 posts
  • Joined 21-June 08
Hi, I hope I'm in the right place for some help . I'm trying to extract a dll file into the system32 folder but I'm getting access is denied , How can I correct this ? Thanks


How to remove advertisement from MSFN

#2
neo

neo

    Microsoft MVP - Windows Expert Consumer

  • Member
  • PipPipPipPipPipPip
  • 1,251 posts
  • Joined 31-March 06
  • OS:Windows 7 x64
  • Country: Country Flag
First of all.. Welcome to MSFN.
You are going to replace lots of files then....you have to take ownership of those files that are to be replaced.
You can take ownership by executing these commands for each file or you can make a batch file too.

takeown /f <File Name>

icacls /grant <File Name> Administrators:F

NOTE: Commands are to be executed in Administrator Mode.


Then you should rename all the files and then replace....If you have enabled UAC it prompts for Continue...Click Continue to proceed next.

#3
fredharvey

fredharvey
  • Member
  • 3 posts
  • Joined 21-June 08
Hi, Thx for the welcome and suggestion , though I did this before I saw your post

Right click on the Folder
Select Properties
Click on the Security tab
Click on the Advanced button
Click on the Owner tab
Click on the Edit button
In the Change owner to box, highlight your account
Check Replace owner on subcontainers and objects
Click on Apply
Click on Yes to replace all permissions
Continue to click on OK until you

#4
neo

neo

    Microsoft MVP - Windows Expert Consumer

  • Member
  • PipPipPipPipPipPip
  • 1,251 posts
  • Joined 31-March 06
  • OS:Windows 7 x64
  • Country: Country Flag
OK...OK

Now once again: Right click on the Folder >> Select Properties >> Click on the Security tab >> Edit
Select group "Administrators" (YOURPC\Administrators)
and check for Full Control under below permission for administrators container....and Apply or OK.

#5
francisconasicmento

francisconasicmento
  • Member
  • 1 posts
  • Joined 22-December 09
hi , i have the f***ing solutiOn

Go to c: » Windows » and then on System 32 right click on the folder, then properties. then security and in the name of group or user, scrool to ( yourname \ administrador).

then click edit and then total controL, that's it !

#6
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,830 posts
  • Joined 23-July 04
  • OS:none specified
  • Country: Country Flag

hi , i have the f***ing solutiOn


Maybe, though it seems to me very similar to the one already posted before, and a mere 1 1/2 years late. :whistle:

jaclaz

Edited by jaclaz, 22 December 2009 - 09:17 AM.


#7
nitroshift

nitroshift

    Beware of programmers with screwdrivers!

  • Super Moderator
  • 2,908 posts
  • Joined 29-November 05
  • OS:Windows 8.1 x64
  • Country: Country Flag

hi , i have the f***ing solutiOn

Go to c: » Windows » and then on System 32 right click on the folder, then properties. then security and in the name of group or user, scrool to ( yourname \ administrador).

then click edit and then total controL, that's it !

May I take this opportunity to welcome you to THE forums and kindly remind you about our rules, especially this one:

7.a You are expected to be mature when discussing in threads. Racism, pornography, threats, profanity, or excessive vulgarity is not tolerated. You will be promptly banned. No exceptions.


Please read the rules, folks!


#8
ArcDarkSmurf

ArcDarkSmurf
  • Member
  • 1 posts
  • Joined 27-February 12
  • OS:Windows 7 x64
  • Country: Country Flag

First of all.. Welcome to MSFN.
You are going to replace lots of files then....you have to take ownership of those files that are to be replaced.
You can take ownership by executing these commands for each file or you can make a batch file too.

takeown /f <File Name>

icacls /grant <File Name> Administrators:F

NOTE: Commands are to be executed in Administrator Mode.


Then you should rename all the files and then replace....If you have enabled UAC it prompts for Continue...Click Continue to proceed next.


[RESOLVED] I am using Windows 7 64-Bit and this worked perfect for me. The was only one problem with your Command line argument

Instead of

icacls /grant <File Name> Administrators:F

Should be

icacls <File Name> /grant Administrators:F

Note: Assuming that this will work with Windows Vista as well. You must run the (Formerly known as MSDOS) as administrator. Right-Click -> Run As Administrator -> Then input the two command line args. Take ownership and grant permissions.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users