ilko_t

How to install Windows from USB- WinSetupFromUSB with GUI

2,142 posts in this topic

Windows 7 entry is for your Windows 7 install, previous Windows versions is self explanatory as well. You were seeing boot menu because you had 2 entries. Deleting only "earlier Windows versions" from those 2 entries would have been more than enough. Anyway, hopefully you learned something new.

0

Share this post


Link to post
Share on other sites

Windows 7 entry is for your Windows 7 install, previous Windows versions is self explanatory as well. You were seeing boot menu because you had 2 entries. Deleting only "earlier Windows versions" from those 2 entries would have been more than enough. Anyway, hopefully you learned something new.

I deleted first "earlier Windows versions" and the boot manager still prompt me to chose, after that I deleted Windows 7 entry from my Windows 7 install, as you already said and then I cannot boot my OS :P so I insert my USB and repaired the mistake, so I got my Windows 7 install back but the "Windows Boot Manager" still ask me to chose from the only option available "Windows 7 entry" installed by me, after 2 or 3 restarts I formatted the HARD DISK properly and did a fresh install and everything is in order now, NO BOOT MANAGER :D

THE PROBLEM WAS FROM "WINDOWS 7 SYSTEM REVERSED PARTITION", I THINK THERE WAS STORED SOME FILES FROM MY PREVIOUS WIN7 INSTALL, AS I DIDN'T DELETED, FORMATTED AND CREATE IT AGAIN AS I DID THIS TIME.

THANKS

post-362525-0-93816600-1349096182_thumb.

0

Share this post


Link to post
Share on other sites

Hi! First of all, thanks for this great app.

I have a problem with my new ADATA S102 Pro USB 3.0.

When I start the process to put Windows XP and Windows 7 in the flash drive, it hangs in the first file, the DPMS iso. I also tried disabling the DPMS iso in the advanced menu, but after copying 50 files, it hangs again.

WSFU Beta 8 freezes completely, and the only way to quit the program is unplugging the flash drive.

The flash drive works perfectly in any pc including mine. I can copy any file of any size to my flash drive.

I have Windows 7 x64 Ultimate.

I tried using both x86 and x64 executables, running as admin, etc. I don't have Antivirus.

WSFU Beta 7 is working perfect.

This is the log:

2012/10/06 00:11:50- WinSetupFromUSB 1.0 beta8 started
2012/10/06 00:11:50- OS: WIN_7 Architecture type: X64 ServicePack: Service Pack 1 OS Language: 0C0A
2012/10/06 00:11:51- Program directory: D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8
2012/10/06 00:11:51- Getting USB drives information
2012/10/06 00:11:51- Show all drives option is NOT selected, displaying USB drives only
2012/10/06 00:11:51- ADATA USB Flash Drive USB Device
2012/10/06 00:11:52- DeviceID: \\.\PHYSICALDRIVE1
2012/10/06 00:11:52- PNPDeviceID: USBSTOR\DISK&VEN_ADATA&PROD_USB_FLASH_DRIVE&REV_1.00\0000000000000278&0
2012/10/06 00:11:52- DiskSize: 14.7 GB Signature: 796ED485
2012/10/06 00:11:52- Partitions found: 2 MediaType: Removable Media
2012/10/06 00:11:52- Disk--Partition: Disk #1, Partition #0
2012/10/06 00:11:52- Logical Disk:E: File system:FAT32 Primary:True Bootable:True
2012/10/06 00:11:52- FreeSpace: 14.7 GB Partition Size: 14.7 GB
2012/10/06 00:11:52- Partition Starting Offset: 32256
2012/10/06 00:11:52- Disk--Partition: Disk #1, Partition #1
2012/10/06 00:11:53- Drive letter of the selected partition- E:
2012/10/06 00:11:53- Drive letter of the first primary partition in selected disk- E:
2012/10/06 00:11:53- Disk number of the selected disk- 1
2012/10/06 00:11:53- PNPId of the selected disk- USBSTOR\DISK&VEN_ADATA&PROD_USB_FLASH_DRIVE&REV_1.00\0000000000000278&0
2012/10/06 00:11:53- File system type of the selected partition- FAT32
2012/10/06 00:11:53- Disk type of the selected disk- Removable
2012/10/06 00:11:53- Total target space avialable- 14.7 GB
2012/10/06 00:11:53- Checking sizes...
2012/10/06 00:11:53- Total source size- 0 bytes
2012/10/06 00:11:53- Target space available- 14.7 GB
2012/10/06 00:12:05- Checking sizes...
2012/10/06 00:12:05- Total source size- 0 bytes
2012/10/06 00:12:05- Target space available- 14.7 GB
2012/10/06 00:12:15- Checking sizes...
2012/10/06 00:12:16- Total source size- 666 MB
2012/10/06 00:12:16- Target space available- 14.7 GB
2012/10/06 00:12:16- Windows source selected- D:\ISOS\Linux+Windows\Windows.XP.SP3.July.2012.SATA
2012/10/06 00:12:16- Windows version- Windows XP Professional
2012/10/06 00:12:16- Service Pack- Windows XP Professional Service Pack 3
2012/10/06 00:12:16- Windows source- D:\ISOS\Linux+Windows\Windows.XP.SP3.July.2012.SATA
2012/10/06 00:12:16- Windows version- XPpSP3
2012/10/06 00:12:16- Service Pack- SP3
2012/10/06 00:12:16- AMD64 flag- 0
2012/10/06 00:12:16- Boot menu name- Windows XP Professional SP3
2012/10/06 00:12:17- Checking sizes...
2012/10/06 00:12:17- Total source size- 666 MB
2012/10/06 00:12:17- Target space available- 14.7 GB
2012/10/06 00:13:11- Checking sizes...
2012/10/06 00:13:12- Total source size- 4.54 GB
2012/10/06 00:13:12- Target space available- 14.7 GB
2012/10/06 00:13:12- Vista/7/8/Server 2008 source selected- D:\ISOS\Linux+Windows\GRMCULFRER_ES_DVD
2012/10/06 00:13:16- Drive letter of the selected partition- E:
2012/10/06 00:13:17- Drive letter of the first primary partition in selected disk- E:
2012/10/06 00:13:17- Disk number of the selected disk- 1
2012/10/06 00:13:17- PNPId of the selected disk- USBSTOR\DISK&VEN_ADATA&PROD_USB_FLASH_DRIVE&REV_1.00\0000000000000278&0
2012/10/06 00:13:17- File system type of the selected partition- FAT32
2012/10/06 00:13:17- Disk type of the selected disk- Removable
2012/10/06 00:13:17- Total target space avialable- 14.7 GB
2012/10/06 00:13:17- Checking sizes...
2012/10/06 00:13:17- Total source size- 4.54 GB
2012/10/06 00:13:17- Target space available- 14.7 GB
2012/10/06 00:13:17- Flushing disk cache to \\.\E:
2012/10/06 00:13:17- Checking if grub4dos is installed properly
2012/10/06 00:13:17- Grub4dos files are NOT installed properly
2012/10/06 00:13:17- Checking for Grub4dos/Wee/FB MBR on disk #1
2012/10/06 00:13:17- Launching D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8\files\winsetup\grubinst.exe -v --skip-mbr-test -s=mbrdisk1-20121006-001317check.dat -t (hd1)
2012/10/06 00:13:17-
2012/10/06 00:13:17- Start sector: 0x0
Image type: MBR
Num of heads: 255
Sectors per track: 63
Partition table
bt h0 s0 c0 fs h1 s1 c1 base leng
80 01 01 00 0C FE FF FF 3F 1D707C1
00 FE FF FF 21 FE FF FF 1D70800 3F
00 00 00 00 00 00 00 00 0 0
00 00 00 00 00 00 00 00 0 0
Install mode
Read only mode

2012/10/06 00:13:19- Saved MBR of disk #1
2012/10/06 00:13:20- MBR start bytes: 0x33C08E
2012/10/06 00:13:20- Grub4dos/Wee/FB MBR not found
2012/10/06 00:13:20- Installing grub4dos and boot files
2012/10/06 00:13:20- Flushing disk cache to \\.\E:
2012/10/06 00:13:20- Backing up first 63 sectors of disk #1
2012/10/06 00:13:20- Successfully backed up first 63 sectors of disk #1 to D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8\backups\63sect_disk1-20121006-001320.bin
2012/10/06 00:13:21- Installing grub4dos MBR to (hd1)
2012/10/06 00:13:21- Launching grubinst.exe -v -t=0 (hd1)
2012/10/06 00:13:21-
2012/10/06 00:13:21- Start sector: 0x0
Image type: MBR
Num of heads: 255
Sectors per track: 63
Partition table
bt h0 s0 c0 fs h1 s1 c1 base leng
80 01 01 00 0C FE FF FF 3F 1D707C1
00 FE FF FF 21 FE FF FF 1D70800 3F
00 00 00 00 00 00 00 00 0 0
00 00 00 00 00 00 00 00 0 0
Install mode

2012/10/06 00:13:22- Checking for Grub4dos/Wee/FB MBR on disk #1
2012/10/06 00:13:22- Launching D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8\files\winsetup\grubinst.exe -v --skip-mbr-test -s=mbrdisk1-20121006-001322check.dat -t (hd1)
2012/10/06 00:13:23-
2012/10/06 00:13:23- Start sector: 0x0
Image type: MBR
Num of heads: 255
Sectors per track: 63
Partition table
bt h0 s0 c0 fs h1 s1 c1 base leng
80 01 01 00 0C FE FF FF 3F 1D707C1
00 FE FF FF 21 FE FF FF 1D70800 3F
00 00 00 00 00 00 00 00 0 0
00 00 00 00 00 00 00 00 0 0
Install mode
Read only mode

2012/10/06 00:13:25- Saved MBR of disk #1
2012/10/06 00:13:26- MBR start bytes: 0xEB5E80
2012/10/06 00:13:26- Grub4dos/Wee/FB MBR found
2012/10/06 00:13:27- Copying grldr to E:
2012/10/06 00:13:27- Copying usbdrive.tag to E:
2012/10/06 00:13:27- Copying menu.lst to E:
2012/10/06 00:13:27- Copying default to E:
2012/10/06 00:13:27- Copying plpbt.bin to E:
2012/10/06 00:13:27- grub4dos installed
2012/10/06 00:13:27- Preparing Windows setup folder(s)
2012/10/06 00:13:30- Preparing winsetup.lst
2012/10/06 00:13:30- Preparing Vista source
2012/10/06 00:13:30- Copy started
2012/10/06 00:13:30- D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8\files\DPMS\DPMS.ISO---> E:\DPMS\DPMS.ISO
2012/10/06 00:14:21- Func _LargeFileCopy returned an error 5, trying FileCopy
2012/10/06 00:14:21- Func FileCopy returned an error 0, trying copy.exe
2012/10/06 00:14:21- ERROR!!!--- not copied:D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8\files\DPMS\DPMS.ISO 0 file(s) copied.
2012/10/06 00:14:22- D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8\files\DPMS\CREDITS.txt---> E:\DPMS\CREDITS.txt
2012/10/06 00:14:22- Func _LargeFileCopy returned an error 3, trying FileCopy
2012/10/06 00:14:22- Func FileCopy returned an error 0, trying copy.exe
2012/10/06 00:14:22- ERROR!!!--- not copied:D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8\files\DPMS\CREDITS.txt 0 file(s) copied.
2012/10/06 00:14:22- Flushing disk cache to \\.\E:
2012/10/06 00:14:22- Error creating handle to \\.\E: The system cannot find the file specified.

2012/10/06 00:14:22- Copying completed. Took: 52.02 seconds
2012/10/06 00:14:22- Creating boot ISO
2012/10/06 00:14:22- Creating migrate.inf
2012/10/06 00:14:24- ERROR!!!--- Could not create migrate.inf
2012/10/06 00:14:24- Ensuring presetup is launched
2012/10/06 00:14:24- Expanding E:\WINSETUP\XPpSP3\I386\setup.ex_
2012/10/06 00:14:24- Microsoft (R) File Expansion Utility Version 6.1.7600.16385
Copyright (c) Microsoft Corporation. All rights reserved.

Can't open input file: e:\winsetup\xppsp3\i386\setup.ex_.


2012/10/06 00:14:24-
2012/10/06 00:14:24- Compressing E:\WINSETUP\XPpSP3\I386\setupwst.exe
2012/10/06 00:14:25- Cabinet Maker - Lossless Data Compression Tool

ERROR: Could not find file: E:\WINSETUP\XPpSP3\I386\setupwst.exe

2012/10/06 00:14:25-
2012/10/06 00:14:26- Could not replace original Setup.exe, aborting...
2012/10/06 00:14:26- Removing TEMP folder
2012/10/06 00:14:26- ---------------------------------Program quited-----------------------------------------------

Any other information that I can provide just tell me ;)

Thanks.

0

Share this post


Link to post
Share on other sites

Can you try the version attached?

Just copy the two files in D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8\ and launch either of them.

You may also rename D:\ISOS\Linux+Windows\ to D:\ISOS\Linux_Windows\ just in case.

Edited by ilko_t
Attachment removed
0

Share this post


Link to post
Share on other sites

Can you try the version attached?

Just copy the two files in D:\WeissJT\Downloads\Programs\Win Setup_1_0_beta8\ and launch either of them.

You may also rename D:\ISOS\Linux+Windows\ to D:\ISOS\Linux_Windows\ just in case.

Seems to be working now, doesn't hang anymore and I checked the hash of the DPMS iso and is ok. But the log shows errors anyways with all the files now.

Now I'm running directly from Desktop.

Also tried Beta 8 from Desktop and waited 15 minutes, the DPMS iso was automatically skipped with error after that time, and with some other files happen the same. I aborted the process when saw your answer.

Attached Beta 8 log and Beta 9 log. Beta 9 log is incompleted because is currently running, but shows the same error with all files.

WinSetupFromUSB_beta8.zip

WinSetupFromUSB_beta9.zip

0

Share this post


Link to post
Share on other sites

Ok, thanks for the logs and the report. Give me some time and will post another version.

0

Share this post


Link to post
Share on other sites

Is there any documentation on how to add multiple WinPE\XP installations? As i read in the first post you can do alot of them. I have 3 different winxp\pe sources i want to use and one win7pe source. Using the gui app i see theres only one input box for a xp installation path. How do i add mutiples? I use grub for my boot manager currently to successfully call one of my PE installations and the win7pe one as well

0

Share this post


Link to post
Share on other sites

Is there any documentation on how to add multiple WinPE\XP installations? As i read in the first post you can do alot of them. I have 3 different winxp\pe sources i want to use and one win7pe source. Using the gui app i see theres only one input box for a xp installation path. How do i add mutiples? I use grub for my boot manager currently to successfully call one of my PE installations and the win7pe one as well

First post of this thread, as you were told:

http://reboot.pro/17563/#entry161427

Please read the included with the stable versions ReadMe.txt and \Docs\HOW-TOs.txt, it should help you get started. When in doubt hold the mouse over the element, a tooltip should help you with the choice.

HowTo.txt, inside the "stable" release:

Setup Windows XP/2000/2003

==========================

.....

NOTE: Program can add multiple Windows sources to the USB disk (up to 10). Just run the program again and follow the prompts.

NOTE: If you are installing windows different than XP SP2 or SP3, some of the compressed files in ~LS\I386 or AMD64 folder will be deleted during Text mode of setup.

Rerun the program when installation is completed and follow the prompts to syncronise windows source to your USB disk.

jaclaz

Edited by jaclaz
0

Share this post


Link to post
Share on other sites

So it only works with the stable versions then? not the Betas?

Hmmm.

Some documentation is inside the "stable" (and not inside the beta).

Would this mean that in an attempt to better the tool ilko_t removed features form it?

Would this mean more simply that there is no new documentation in the beta's?

Why don't you simply try and see if it works with the Beta? :unsure:

jaclaz

0

Share this post


Link to post
Share on other sites

lol sorry, ive just been messing with this stuff for 3 days until i finally got it working, a little irrated and lazy atm

0

Share this post


Link to post
Share on other sites

Jaclaz,

how about adding multiple WinPE\WinBuilder\UB4Win sources?

The problem is i have multile WinPEv1 sources that i want to multiboot. Not Winxp\2000\2003.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.