• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
ilko_t

How to install Windows from USB- WinSetupFromUSB with GUI

2,139 posts in this topic

Windows 7 would be supported when all other programs used fully support it- AutoIt, grub4dos installer etc. etc.

Fair enough, but I presume that it'd be nearly identical to Vista [behaviour]

As for the VistaPE- can you create an empty folder SOURCES if doesn't exist, next to folder BOOT. Does it accept it now?

Did you use Vista Setup/PE/Recovery ISO field or BartPE/UBCD4Win...? You should use the former one.

Thanks, I created an empty Sources Folder, and it installed it to the USB drive OK. The only problem was that when I booted it, only VistaPE's boot options were shown. This is because menu.lst is used by both the XP and VistaPE packages, and VistaPE had overwritten the previous entry.

Could there be an option to merge both instances of this file into the one, so all menu entries are preserved?

Thx for the help mate; appreciated :)

Edited by jezza333
0

Share this post


Link to post
Share on other sites
Thanks, I created an empty Sources Folder, and it installed it to the USB drive OK. The only problem was that when I booted it, only VistaPE's boot options were shown. This is because menu.lst is used by both the XP and VistaPE packages, and VistaPE had overwritten the previous entry.

Make_USB.exe of U_XP_SET package solves this problem.

It makes use of an Exclude list for FileCopy given in file U_XP_SET\USB_XP_Setup\makebt\NO_xcopy_Vista.txt

http://www.boot-land.net/forums/index.php?showtopic=5306

Support for VistaPE on MultiBoot USB-stick was made, where you can use the Vista Add Extra Source Selector to Select your VistaPE\Target\VistaPE-Core Folder.
Edited by wimb
0

Share this post


Link to post
Share on other sites
The only problem was that when I booted it, only VistaPE's boot options were shown. This is because menu.lst is used by both the XP and VistaPE packages, and VistaPE had overwritten the previous entry.

Could there be an option to merge both instances of this file into the one, so all menu entries are preserved?

Can you post your curren menu.lst please?

Does VistaPE use menu.lst as well?

0

Share this post


Link to post
Share on other sites
Does VistaPE use menu.lst as well?

Yes. :)

It is however trivial to change the menu.lst of the last to be added item to include the entries for the previous ones, or in the case of VistaPE, changing the building Grub4dos .script to generate a "wider" menu.lst with a few TXTADDLINE statrements:

http://www.boot-land.net/forums/index.php?showtopic=6468

Or again, open the §@ç#ing menu.lst with Notepad and add a few entries by hand.

Or again, press "c" and enter a couple of grub4dos commands....:whistle:

jaclaz

0

Share this post


Link to post
Share on other sites

Thanks jaclaz.

I've just excluded menu.lst from the files being copied, no matter from what source. This should fix unexpected problems later on, should more and more items included start using grub4dos.

Entries in menu.lst to start the various items are added by WinSetupFromUSB anyway. May also add merging menu.lst if found, with the one created by the program.

0

Share this post


Link to post
Share on other sites
May also add merging menu.lst if found, with the one created by the program.

Which would create the need to parse each entry to remove possible duplicates....:whistle: or otherwise posiibly create a menu.lst with a couple dozens entries....:unsure:

Are you getting affected by some form of featuritis too? :w00t:

:P

jaclaz

0

Share this post


Link to post
Share on other sites
Are you getting affected by some form of featuritis too? :w00t:
No way, I had been immunized against that form of disease long ago :)
Nj42McOenW.jpg

0gbU449bW0.jpg

wtf?

Do NOT select I386 folder, but the parent one, "Новая папка", which consist I386. To stay on the safe side try NOT to use any spaces in paths.

Read the tooltips, there are plenty of them for each item in the GUI, just hold the mouse over it for a few seconds. In your case the tooltip says "Select a folder, where I386 can be found", not "select I386 folder". If still isn't clear enough- sorry, I am not native english speaker.

0

Share this post


Link to post
Share on other sites

Hi

i downloaded WinSetupFromUSB.exe and installed it on my Windows Vista HP Compaq Laptop

what i did was i chose the destination of WindowsXP. and then, i formated the 2GB Kingston USB Flash Drive using HP Format Tool. then after that i press on Start.

after that i restarted the laptop and the BOOT screen for WindowsXP started. i chose the first option, then it went back to the boot screen again with a second option, here are two things that i did

1. I chose again the first option it went to a blue screen (like the WindowsXP Installation Screen) when i went on the C:\ Drive it only has 1.9GB (which looks like my USB Flash Drive Capacity, and it does not contain my Main Hardisk, so what i did was i chose Drive C:\ but it went into an Error Screen saying that its corrupted.. F3 to Quit. then i restarted the computer. it says that its MISSING OPERATING SYSTEM

2. I chose 2nd option but it says that its missing a file.. (forgot what file it was though)..

anybody can help? thanks a lot. this is for my ACER laptop. it has a defective CDROM Already so im looking for another way to install Windows XP in it. thanks

0

Share this post


Link to post
Share on other sites

Ok, I apologize first for the newbie nature of these questions but I have been unable to find and answer I understand yet.

1) using a 32gb fast patriot drive, during install I get the asms missing notification and have to abort install, but with 4 gb slow as hell drive I can install the same image fully but it takes forever, any ideas how I can get things to work on my faster drives?

2) I have been waiting for the first windows menu, then removing the drive, I got it to work once but never again and think I forgot something, but the problem is, I get a cannot boot message but when I restart with the key, then I can get into windows....what the hell did I miss?

3, where can I get some FAST 4gb thumb drives that are reliably bootable?

0

Share this post


Link to post
Share on other sites
using a 32gb fast patriot drive, during install I get the asms missing notification and have to abort install
Missing ASMS rings a bell.

At CD first reboot there are no cd file system drivers loaded.

Ntldr and BIOS has to find files. First 4 gb of DVD media are available.

Does similar match to USB install?

Did you add XP installation files to a previous filled drive?

Did you start from scratch and format drive?

Can you start from scratch and format drive?

That way installation files are in front of USB drive.

Ntldr may load file system driver for (USB) hard disk boot device only.

I understand, you use FAT32 at USB drive.

Which file system do you use at local hard disk?

Do you use FAT32 too?

Try the same file system for USB drive and local hard disk.

E.g. try both NTFS for USB drive and local hard disk.

0

Share this post


Link to post
Share on other sites

ok, so if I create a 4gb partition in the beginning of the drive it should work?

also, rather than reinstall right now, is there a way to fix the mbr so that it can boot without the usb drive in, what is it I am doing wrong on my install that makes it unable to boot without the usb, when should I remove the usb drive?

as I said, I did it right once, but can't remember what I did

I need the Q1 for a trip in a few days and would like everything to work for a bit, I will resume tinkering later

0

Share this post


Link to post
Share on other sites

To fix boot- allow showing hidden and protected OS files (control panel->folder options->view), open up BOOT.INI in C:\ in Notepad and post it here.

What message do you get when you boot without the USB stick?

0

Share this post


Link to post
Share on other sites

message

Windows could not start because of a computer disk hardware configuration problem.

Could not read from the selected boot disk. Check boot path and disk hardware.

Please check the Windows documentation about hardware disk configuration and your hardware reference manuals for additional information.

boot ini

[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

0

Share this post


Link to post
Share on other sites

nevermind the boot issue, fixed that, no problem

now, can anyone let me in on what I was doing wrong?

0

Share this post


Link to post
Share on other sites

Sorry,but i get this

grubinst.exe could not make a backup of MBR

How do i get a MBR on my sd card?

0

Share this post


Link to post
Share on other sites
Sorry,but i get this

grubinst.exe could not make a backup of MBR

How do i get a MBR on my sd card?

Are you using a SD card through a USB adapter?

Most (read ALL ;)) USB card adapters are set as "Removable".

Thus creating a MBR on them it's not that easy.

I cannot say if the HP USB utility or PEtoUSB can "work" with SD cards through USB. :unsure:, that would be the first thing to try.

You may want to try an indirect approach:

http://www.boot-land.net/forums/index.php?showtopic=5000

not easy, not straightforward, but it should work.

jaclaz

0

Share this post


Link to post
Share on other sites
Sorry,but i get this

grubinst.exe could not make a backup of MBR

How do i get a MBR on my sd card?

WinSetupFromUSB log file would help. You could find the last one in program directory, or the previous ones in \backups\date-time-log.cab.
0

Share this post


Link to post
Share on other sites

Sorry if this question was answered before

I assume this utility can safely be used to install from usb hard drive (and a specific partition on it) ?

0

Share this post


Link to post
Share on other sites

Should be fine, with 2 notes:

- use the first partition, set as active

- USB drive letter won't be U, most likely will be D.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.