ilko_t

How to install Windows from USB- WinSetupFromUSB with GUI

2,139 posts in this topic

Glad you liked it.

how get this file copied to the harddrive
txtsetup.sif in the small ISO.
Can't this setup.cmd not be run directly from the USB stick?

The fake setup.exe which executes setup.cmd in system32 folder should be modified for this purpose. What's your idea, why from USB?
0

Share this post


Link to post
Share on other sites

I have got my USB memory pen with the installing files, it seems it works fine.

When I use it on my new laptop to install XP Pro on the second and third partition, the installing software cannot see the internal HDD at all.

Acer Aspire One, 2GB RAM, 160GB HDD.

HDD partitions:

C 10GB: primary, SO well installed, XP home

D 25GB: Primary, SO not installed

E 17GB: Primary, SO not installed

F 9GB: Logical

G 87GB: Logical

Boot with multi-SO.

Boot.ini with Timeout 5 secs and 3 partions. Boot works fine when installing USB is not plugged in (it shows the 3 SO and run the first one with XP home)

When I start up with the installing USB (setting the BIOS with the USB as first booting device), selecting the first stage of WinSetupFromUSB installation, all works as it is supposed to do (like the installation from CD), until the point that the software should let the user choose the partition where to install the SO. The software does not detect the internal HDD. I get following messages:

"

Setup has recognized the following storage devices in your computer

<none>

"

I press Enter, then F8 and I get as list of existing partitions only my USB memory device (2GB) labeled with unit U (!!!)

I hope somebody can sort out this problem...

Edited by apibiri
0

Share this post


Link to post
Share on other sites

WinSetupFromUSB_1-0-beta6:

XP 32 bit files at second primary partition at USB stick and removable bit set.

txtsetup.sif

[SourceDisksFiles]
...
dmmydisk.sys = 1,,,,,,,4,0,0

[BootBusExtenders.Load]
...
dmmydisk = dmmydisk.sys

[BootBusExtenders]
...
dmmydisk = "USB Fixed Disk filter driver",files.none,dmmydisk

And copy dummydisk.sys I386\dmmydisk.sys

Windows setup complete from second partition at removable USB stick.

Dummydisk is active at installed windows.

0

Share this post


Link to post
Share on other sites

Windows setup complete from second partition at removable USB stick.

Dummydisk is active at installed windows.

:thumbup

jaclaz

0

Share this post


Link to post
Share on other sites

I encountered a problem when try to install XP to an VirtualBox based VM.

I followed this guide to make my usb disk bootable in VirtualBox.

http://agnipulse.com/2009/07/boot-your-usb-drive-in-virtualbox/

I attached the virtual hdd to primary slave slot. Usb disk is primary master.

The very beginning of setup report such information

"The system encountered an I/O error accessing multi(0)disk(0)rdisk(9)partition(1).

Setup cannot continue. Press any key to exit."

What can I do to fix it?

0

Share this post


Link to post
Share on other sites
I encountered a problem when try to install XP to an VirtualBox based VM.

I followed this guide to make my usb disk bootable in VirtualBox.

This is not about bootable USB.

This converts a external USB disk to a internal IDE disk, hence the rdisk(9).

This dosn't match install from USB. Don't use this approach.

0

Share this post


Link to post
Share on other sites
I encountered a problem when try to install XP to an VirtualBox based VM.

I followed this guide to make my usb disk bootable in VirtualBox.

This is not about bootable USB.

This converts a external USB disk to a internal IDE disk, hence the rdisk(9).

This dosn't match install from USB. Don't use this approach.

Thank you. But VirtualBox haven't usb-bootable bios, this is the best way to try usb-boot in it.

0

Share this post


Link to post
Share on other sites

Thank you. But VirtualBox haven't usb-bootable bios, this is the best way to try usb-boot in it.

NO.

As cdob said, mapping something in a Virtual Machine has NOTHING to do with USB booting, it may give some hints about the general bootability of a device, but NOT "Usb-bootability".

Compare with these:

http://www.boot-land.net/forums/index.php?showtopic=8042

http://www.boot-land.net/forums/index.php?showtopic=9688

http://www.boot-land.net/forums/index.php?showtopic=8581

jaclaz

0

Share this post


Link to post
Share on other sites

When I select boot first half of windows xp sp3 setup, nothing happens. It's just a black screen and it stays there forever. Do I have to wait longer?

EDIT: Nevermind. I got it to work. Great program btw!

Edited by ShaolinMilk
0

Share this post


Link to post
Share on other sites

Guys, this looks like exactly what I have been looking for. We use XP, Win 7 64 bit and 32 bit here, and I don't want to lug around a bunch of CD's, but I don't see a way to install both versions of WIN 7, have I missed something here? Everything else is pretty self explanatory.

0

Share this post


Link to post
Share on other sites

Guys, this looks like exactly what I have been looking for. We use XP, Win 7 64 bit and 32 bit here, and I don't want to lug around a bunch of CD's, but I don't see a way to install both versions of WIN 7, have I missed something here? Everything else is pretty self explanatory.

Here are a few links to get you started:

http://www.msfn.org/board/SOLVED-Install-Multiple-XP-USB-t114543.html

http://www.msfn.org/board/topic/139654-install-windows-from-iso-after-booting-to-winpe-30-from-usb-hdd/

http://translate.google.com/translate?prev=hp&hl=ru&js=y&u=http%3A%2F%2Fbbs.wuyou.com%2Fviewthread.php%3Ftid%3D148722%26extra%3Dpage%253D1&sl=zh-CN&tl=en&history_state0=

http://www.boot-land.net/forums/index.php?showtopic=10126

http://www.boot-land.net/forums/index.php?showtopic=10138

OK... I have a read as much as I could and I have spend hrs trying to get this to work but no luck so its time to ask for help lol... I have a a working DVD structure created with RyanVM and Driverpacks. I used a 16G USB and formatted it with a single NTFS partition (using the HDD option gives me a grub error when adding files). Laptop boots, loads initial files, reboots to start windows, then just hangs... what am I doing wrong?

Thanks in advance for your help...

Can you elaborate a bit more on these:

using the HDD option gives me a grub error when adding files
Using what program when formatting? What options?
Laptop boots, loads initial files, reboots to start windows, then just hangs
Does that mean that first part of Setup, the text mode/file copy stage works alright, but for the second part, the GUI mode it hangs at some point? When exactly? What do you see on the screen? What did you see right before that? Please be as detailed as possible in order to understand your issue.
0

Share this post


Link to post
Share on other sites

Hello,

The 1.0 beta6 - 7.March.2010 is this version the last one or Finale one?

0

Share this post


Link to post
Share on other sites

Hi guys,

I have downloaded version 1.0 beta6 but am having problems with a particular error that keeps cropping up.

ErrormessageUSBinstall.png

please dont flame me if this has been mentioned before

thanks

PS I am using Windows 7 Home Premium 64bit

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.