Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

How to install Windows from USB- WinSetupFromUSB with GUI


  • Please log in to reply
2116 replies to this topic

#1026
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,716 posts
  • OS:none specified
  • Country: Country Flag
Thanks cdob :)

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB



How to remove advertisement from MSFN

#1027
Valeron

Valeron

    Newbie

  • Member
  • 13 posts
I encountered a problem when try to install XP to an VirtualBox based VM.
I followed this guide to make my usb disk bootable in VirtualBox.
http://agnipulse.com...-in-virtualbox/
I attached the virtual hdd to primary slave slot. Usb disk is primary master.
The very beginning of setup report such information
"The system encountered an I/O error accessing multi(0)disk(0)rdisk(9)partition(1).
Setup cannot continue. Press any key to exit."
What can I do to fix it?

#1028
cdob

cdob

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 963 posts

I encountered a problem when try to install XP to an VirtualBox based VM.
I followed this guide to make my usb disk bootable in VirtualBox.

This is not about bootable USB.
This converts a external USB disk to a internal IDE disk, hence the rdisk(9).
This dosn't match install from USB. Don't use this approach.

#1029
Valeron

Valeron

    Newbie

  • Member
  • 13 posts

I encountered a problem when try to install XP to an VirtualBox based VM.
I followed this guide to make my usb disk bootable in VirtualBox.

This is not about bootable USB.
This converts a external USB disk to a internal IDE disk, hence the rdisk(9).
This dosn't match install from USB. Don't use this approach.


Thank you. But VirtualBox haven't usb-bootable bios, this is the best way to try usb-boot in it.

#1030
jaclaz

jaclaz

    The Finder

  • Developer
  • 14,086 posts
  • OS:none specified
  • Country: Country Flag

Thank you. But VirtualBox haven't usb-bootable bios, this is the best way to try usb-boot in it.


NO.
As cdob said, mapping something in a Virtual Machine has NOTHING to do with USB booting, it may give some hints about the general bootability of a device, but NOT "Usb-bootability".

Compare with these:
http://www.boot-land...?showtopic=8042
http://www.boot-land...?showtopic=9688
http://www.boot-land...?showtopic=8581

jaclaz

#1031
ShaolinMilk

ShaolinMilk
  • Member
  • 1 posts
  • OS:none specified
  • Country: Country Flag
When I select boot first half of windows xp sp3 setup, nothing happens. It's just a black screen and it stays there forever. Do I have to wait longer?

EDIT: Nevermind. I got it to work. Great program btw!

Edited by ShaolinMilk, 03 August 2010 - 01:21 PM.


#1032
Mikey1969

Mikey1969
  • Member
  • 1 posts
  • OS:Windows 7 x86
  • Country: Country Flag
Guys, this looks like exactly what I have been looking for. We use XP, Win 7 64 bit and 32 bit here, and I don't want to lug around a bunch of CD's, but I don't see a way to install both versions of WIN 7, have I missed something here? Everything else is pretty self explanatory.

#1033
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,716 posts
  • OS:none specified
  • Country: Country Flag

Guys, this looks like exactly what I have been looking for. We use XP, Win 7 64 bit and 32 bit here, and I don't want to lug around a bunch of CD's, but I don't see a way to install both versions of WIN 7, have I missed something here? Everything else is pretty self explanatory.

Here are a few links to get you started:
http://www.msfn.org/...SB-t114543.html
http://www.msfn.org/...0-from-usb-hdd/
http://translate.goo...history_state0=
http://www.boot-land...showtopic=10126
http://www.boot-land...showtopic=10138


OK... I have a read as much as I could and I have spend hrs trying to get this to work but no luck so its time to ask for help lol... I have a a working DVD structure created with RyanVM and Driverpacks. I used a 16G USB and formatted it with a single NTFS partition (using the HDD option gives me a grub error when adding files). Laptop boots, loads initial files, reboots to start windows, then just hangs... what am I doing wrong?

Thanks in advance for your help...


Can you elaborate a bit more on these:

using the HDD option gives me a grub error when adding files

Using what program when formatting? What options?

Laptop boots, loads initial files, reboots to start windows, then just hangs

Does that mean that first part of Setup, the text mode/file copy stage works alright, but for the second part, the GUI mode it hangs at some point? When exactly? What do you see on the screen? What did you see right before that? Please be as detailed as possible in order to understand your issue.

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#1034
brunob

brunob
  • Member
  • 1 posts
  • OS:none specified
  • Country: Country Flag
Hello,

The 1.0 beta6 - 7.March.2010 is this version the last one or Finale one?

#1035
jaseuk

jaseuk
  • Member
  • 3 posts
  • OS:Windows 7 x64
Hi guys,
I have downloaded version 1.0 beta6 but am having problems with a particular error that keeps cropping up.

Posted Image

please dont flame me if this has been mentioned before

thanks

PS I am using Windows 7 Home Premium 64bit

#1036
jaseuk

jaseuk
  • Member
  • 3 posts
  • OS:Windows 7 x64

@jaseuk
Check in Program directory\winsetup\files\PyronSetup\I386 if setup.ex_ exist. Most likely an antivirus program either deleted it or doesn't let copying it. Download fresh copy of the program or turn off your antivirus.
http://www.msfn.org/...-xp-inst-v047z/


thanks I'll look into that

#1037
vinokirk

vinokirk
  • Member
  • 1 posts
  • OS:none specified
  • Country: Country Flag
I am trying to install XP. Ive used the prog to get it on the USB drive. But im getting this error:
'Booting first poart of windows xp profesional sp3 setup from partition 0
address 0x8280: value 0x80
drive 0x81(lba):c/h/s=1024/240/63, sector count/size=156295440/512
partition num:0,active, filesystem type is ntfs, partition type 0x07
geometry (hd1)
Error 15: file not found
press any keyu to continue'

Sorry for spelling....Any ideas anyone?>

#1038
embyq

embyq
  • Member
  • 1 posts
  • OS:Windows 7 x86
  • Country: Country Flag
Hi, first of all, thanks for all your patience and efforts.

I build a USB drive with 1.06 beta, but always I try to install I get BSoD 0x0000007E error.
This errors came up after the first screen, I just select "First Part ..." then when I hit enter, inmediatly I get the error.

The very same configuration and files works flawlessly with 0.2.3. I just use 1.06 beta and everything goes crazy.

I simply doesn´t figure out what is going on!

Before I post this message I tried to search in the forum and the web, but nothing came up.


I hope you guys can help me.

Thanks in advance.

Edited by embyq, 22 August 2010 - 10:31 PM.


#1039
Jaymie1989

Jaymie1989
  • Member
  • 1 posts
  • OS:Windows 7 x64
Hey,

FYI I'm using Microsoft Security Essentials and downloading the new Beta version if popped up as a Virus

Category: Trojan Downloader

Description: This program is dangerous and downloads other programs.

Recommendation: Permit this detected item only if you trust the program or the software publisher.

Microsoft Security Essentials detected programs that may compromise your privacy or damage your computer. You can still access the files that these programs use without removing them (not recommended). To access these files, select the 'Allow' action and click 'Apply actions'. If this option is not available, log on as administrator or ask the local administrator for help.

Items:
containerfile:C:\Users\Jay\Desktop\WinSetup-1-0-beta6.7z
file:C:\Users\Jay\Desktop\WinSetup-1-0-beta6.7z->files/winsetup/PyronSetup/i386/setup.ex_->setup.exe
file:C:\Users\Jay\Desktop\WinSetup-1-0-beta6.7z->files/winsetup/PyronSetup/i386/setup_dbg.ex_->setup_dbg.exe
webfile:C:\ProgramData\Microsoft\Microsoft Antimalware\LocalCopy\{D2FD3E97-44D3-487B-95F3-2A08BE06351E}-WinSetup-1-0-beta6.7z|http://www.datafilehost.com/get.php?file=deec7fdd
webfile:C:\Users\Jay\Desktop\WinSetup-1-0-beta6.7z|http://www.datafilehost.com/get.php?file=deec7fdd



#1040
cdob

cdob

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 963 posts

FYI I'm using Microsoft Security Essentials and downloading the new Beta version if popped up as a Virus

Read Post #1056 http://www.msfn.org/...post__p__935885
http://www.msfn.org/...-xp-inst-v047z/

Write a error report to Security Essentials manufacturer:
ask to fix the broken security application.

#1041
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,716 posts
  • OS:none specified
  • Country: Country Flag

I am trying to install XP. Ive used the prog to get it on the USB drive. But im getting this error:
'Booting first poart of windows xp profesional sp3 setup from partition 0
address 0x8280: value 0x80
drive 0x81(lba):c/h/s=1024/240/63, sector count/size=156295440/512
partition num:0,active, filesystem type is ntfs, partition type 0x07
geometry (hd1)
Error 15: file not found
press any keyu to continue'

Sorry for spelling....Any ideas anyone?>



Hi, first of all, thanks for all your patience and efforts.

I build a USB drive with 1.06 beta, but always I try to install I get BSoD 0x0000007E error.
This errors came up after the first screen, I just select "First Part ..." then when I hit enter, inmediatly I get the error.

The very same configuration and files works flawlessly with 0.2.3. I just use 1.06 beta and everything goes crazy.

I simply doesn´t figure out what is going on!

Before I post this message I tried to search in the forum and the web, but nothing came up.


I hope you guys can help me.

Thanks in advance.


Can you both run the program again with the prepared USB stick attached, select ONLY "Test in QEMU", select "First part of setup" and report if you get to the partitioning screen?
What hardware are you installing on? If laptop- what brand&model, if desktop- motherboard model.

@embyq
What Service Pack is the Windows you are using?

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#1042
NikLok

NikLok

    Newbie

  • Member
  • 18 posts
Many time's ago i create witj your nice tool boot flash!
And it is very good!!!

But time is going, hands waved and etc

After making new XPSP3 with intgrated updates I try update my flash!
First (and very fool) i copy only new files to flash by the explorer!!!

Flash stay work not correct! Her drive letter is D !
But it must be U.

Then i try copy with you tool!
It nice copy all, but letter of flash is D.
How to correct this?


After copy I see that all information duplicated!
In folder WINSETUP I see folders XPSP3 and XPSP31, and files XPpSP3.ISO and XPpSP31.ISO


May bee your make additional buttons "Update contents" ?
After pressing this button files and folders will be replaced changed files and folders to the same place, instead copy to new folders!?

#1043
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,716 posts
  • OS:none specified
  • Country: Country Flag
@ NikLok

That's a lot of extra work and wouldn't save one much time compared to preparing again the stick from a scratch.

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#1044
pmedia

pmedia
  • Member
  • 1 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Thank you for this wonderful tool

One option that I was dreaming about them for a long time its the "prepare windows to be install on usb" i happy to see you include this in your tool but its not work.
I tried with several different sources (sp2,sp3 with all driver pack merged in,2003)and on the copy files proses its say "cannot copy the file UsbBootW.exe.... ITS NOT A VIALED WINDOWS IMAGE......"
I UNPLAGUED THE DRIVE AND COPY THIS FILE ON ANOTHER COMPUTER TO WINDOWS AND TO SYSTEM32 FOLDERS... THEN I CONTINUE WITH THE SETUP BUT AFTER THE SCENED RESTART I GET BLUE SCREEN


What's the problem?
And has anyone was able to install this way?

thanks again!!

#1045
tyriekfv

tyriekfv
  • Member
  • 1 posts
  • OS:Windows 7 x86
  • Country: Country Flag
Ok so I ran this all goes well until it asks what partition to install XP on. Of course I want to format the whole drive and install fresh on one partition. Problem is the only partition it is seeing is U: partition1 on the USB stick. Not showing me any partitions that are on the actual netbook. Help?

#1046
cdob

cdob

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 963 posts

Not showing me any partitions that are on the actual netbook.

Integrate mass storage drivers, relating your netbook, into XP installation files first.

#1047
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,716 posts
  • OS:none specified
  • Country: Country Flag

Thank you for this wonderful tool

One option that I was dreaming about them for a long time its the "prepare windows to be install on usb" i happy to see you include this in your tool but its not work.
I tried with several different sources (sp2,sp3 with all driver pack merged in,2003)and on the copy files proses its say "cannot copy the file UsbBootW.exe.... ITS NOT A VIALED WINDOWS IMAGE......"
I UNPLAGUED THE DRIVE AND COPY THIS FILE ON ANOTHER COMPUTER TO WINDOWS AND TO SYSTEM32 FOLDERS... THEN I CONTINUE WITH THE SETUP BUT AFTER THE SCENED RESTART I GET BLUE SCREEN


What's the problem?
And has anyone was able to install this way?

thanks again!!

The issue why this part has not moved further is because Setup started that way bluescreens 0x7B with only USB disks attached, so USB-->USB setup with no internal disks doesn't work. Need a lot of spare time, which I don't currently have, to test, if it's fixable at all.

It could be used for USB-->IDE/SATA install and then image it to USB disk, to be tested.

As for the error you are getting-

try modifying checksum:
pechecksum -c usbbootw.exe

Get pechecksum.exe:
http://www.ryanvm.ne...opic.php?t=5381

You may want to test the whole setup in QEMU:
Rename test.img to test.img.bak in winsetupfromusb program directory\files\qemu\
Create a new test.img file:
fsutil file createnew test.img 2000000000
Use the program with QEMU option selected and prepared USB stick, now you will have 2GB virtual HD to install onto. Setup completes fine, USB disk is not touched, just be careful on partition screen NOT to select the USB disk.

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#1048
grabben

grabben

    -Grabben

  • Member
  • PipPipPipPip
  • 601 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Good piece of work man:)

XP & Windows 7 works fine copying to the USBdrive, havent tested it yet.. I'll add Win2k and WinXP today if i can and try it:)


Woudnt it be possible to just have diff. folders with the OS? I know other files need to be edited to make the setup etc work but isnt there some small apps to edit those files?

#1049
ilko_t

ilko_t

    MSFN Addict

  • Super Moderator
  • 1,716 posts
  • OS:none specified
  • Country: Country Flag
What version of the program did you use?
1.0 beta6 puts XP/2000/2003 files in own folders in \WINSETUP. For 7/Vista isn't easy to accomplish that, so files&folders go to root.
0.2.3 also puts XP/2000/2003 files in own ~BT and ~LS folders in root.

Install Windows from USB, boot Linux, multiboot and a lot more with WinSetupFromUSB


#1050
Snake7

Snake7

    Newbie

  • Member
  • 16 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Does somebody tried exFAT formatted drive to make bootable? Is it possible at the moment?




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users



How to remove advertisement from MSFN